Overclock.net › Forums › Video Games › PC Gaming › Bad preformance in some games
New Posts  All Forums:Forum Nav:

Bad preformance in some games

post #1 of 8
Thread Starter 
So Hells Highway, Company of Heroes, Black Ops, and Bioshock 2 run like dogs on my comp but i find this strange as Metro2033 at medium runs fine, Bad Company 2 does fine, Stalker COP and CS run fine. Just those games listed run like a dog and I cant figure out why. Res is 1600x900 all but bioshock 2 is maxed with no AA/AF and bioshock2 is setup just how the game choose it would best preform. I can't figure this out. Blackops locks up even with every setting turned off.
post #2 of 8
Are you overclocking? Have you looked at the Nvidia Drivers thread, and are you using one of the recommended drivers?
post #3 of 8
I know for Black Ops, it wont run on anything but a quad core. Anything less than a quad core CPU (even lower end ones) and the game will run poorly.

Not sure about the other games though.
^_^
(13 items)
 
   
CPUMotherboardGraphicsRAM
Intel 2600K ASRock Z68 EXTREME4 GEN3 Gigabyte Windforce 7970 OC Mushkin Enhanced Blackline 8GB (2 x 4GB) 
CoolingMonitorPowerCase
Noctua D14 Asus VG248QE Corsair TX 750 V2 Corsair 650D 
MouseMouse PadAudioAudio
G400, MX518, G500, G5, IMO 1.1, IME 3.0, Deatha... fUnC 1030, QCK+, QCK Heavy, PureTrak Talent Whi... X-Fi Titanium HD Sennheiser HD555 
CPUGraphicsRAMHard Drive
Intel i7 2.4GHz Intel HD 4000 8GB 256GB SSD 
Monitor
2880 x 1800 Retina 
  hide details  
Reply
^_^
(13 items)
 
   
CPUMotherboardGraphicsRAM
Intel 2600K ASRock Z68 EXTREME4 GEN3 Gigabyte Windforce 7970 OC Mushkin Enhanced Blackline 8GB (2 x 4GB) 
CoolingMonitorPowerCase
Noctua D14 Asus VG248QE Corsair TX 750 V2 Corsair 650D 
MouseMouse PadAudioAudio
G400, MX518, G500, G5, IMO 1.1, IME 3.0, Deatha... fUnC 1030, QCK+, QCK Heavy, PureTrak Talent Whi... X-Fi Titanium HD Sennheiser HD555 
CPUGraphicsRAMHard Drive
Intel i7 2.4GHz Intel HD 4000 8GB 256GB SSD 
Monitor
2880 x 1800 Retina 
  hide details  
Reply
post #4 of 8
Thread Starter 
Quote:
Originally Posted by Nick2253 View Post
Are you overclocking? Have you looked at the Nvidia Drivers thread, and are you using one of the recommended drivers?
latest drives and yes its oc'd where its been oced for the last 4 years 3.2ghz this is where my buddy ran it at and i didnt change anything when i got the cpu/mobo/ram from him lol. So its not a stability issue. What makes no sense is games like COH are from 2006, and ran just fine on this rig with an HD3870 which i replaced with a GTS450 2 months ago, and since them these games only run like dogs, and before you ask its a clean windows install of Windows 7 64bit Home, im not an idiot
post #5 of 8
The latest drivers might be part of your problem. I think munaim recommends some driver in the 270 series, though the latest is in the 280 series. People have been reporting problems with the 280 series.
post #6 of 8
Thread Starter 
Quote:
Originally Posted by Nick2253 View Post
The latest drivers might be part of your problem. I think munaim recommends some driver in the 270 series, though the latest is in the 280 series. People have been reporting problems with the 280 series.
well with the 270 series BTTF The game would crash all the time lol
post #7 of 8
Have you tried using driver sweeper to remove all nvidia drivers, and then starting at the 266 series (considered by some to be the gold-standard of stability), and work your way up?

EDIT: read more here http://www.overclock.net/nvidia-driv...vers-incl.html
post #8 of 8
Thread Starter 
well im using the 285 not the 280 and the 285 release are supposed to fix most of the bugs
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Bad preformance in some games