Overclock.net › Forums › Components › Power Supplies › Having problem with a PSU
New Posts  All Forums:Forum Nav:

Having problem with a PSU

post #1 of 5
Thread Starter 
Hello peeps,

So my old SINAN 430w PSU has died out
i have putted a new COBA KING 550w PSU and i cannot turn on my pc.
The only difference between them is the wattage and the new psu doesn't have white -5v cable in pin 20.
As ive read its the v2.2 Power supply and -5v cable is not needed for the newer motherboards.
The Motherboards lcd light is glowing but when i push the on switch i hear a thump in my speakers and the fans spin a little.
This site http://www.extreme.outervision.com/PSUEngine said that i only need 427wats so what could be the problem?

Also my pc specs are :
AMD Phenom 2 X3
Asus M4N78-Pro Motherboard
And Nvidia Geforce 9800Green edition

Thanks in advance Simon

Edit:
Heres a video
Edited by An4rk1 - 11/11/11 at 11:17am
Corsair
(15 items)
 
  
CPUMotherboardGraphicsRAM
amd fx-9370 Sabertooth 990 fx Asus AMD Radeon R9 270  Corsair Vengeance  
Hard DriveOptical DriveCoolingOS
Seagate Baracuda TEAC-w524 Deepcool "Captain 240 Windows 10 
MonitorKeyboardPowerCase
Philips Microsoft CORSAIR HM750 Corsair Carbide 200R 
MouseMouse PadAudio
Steelseries rival 300 Hama Urage Corsair Void 
  hide details  
Reply
Corsair
(15 items)
 
  
CPUMotherboardGraphicsRAM
amd fx-9370 Sabertooth 990 fx Asus AMD Radeon R9 270  Corsair Vengeance  
Hard DriveOptical DriveCoolingOS
Seagate Baracuda TEAC-w524 Deepcool "Captain 240 Windows 10 
MonitorKeyboardPowerCase
Philips Microsoft CORSAIR HM750 Corsair Carbide 200R 
MouseMouse PadAudio
Steelseries rival 300 Hama Urage Corsair Void 
  hide details  
Reply
post #2 of 5
Just a few guesses:

a) pull out everything despite the core components, replug all essential cables and try again (if not done already)

b) see if you can get another psu to test with

c) ditch the old bios battery and replace with a new one. most of the mothersboards won't power up if the battery is empty.

if the worst occurs, could also be a short in the board. report back if you got news for us!
CM690
(15 items)
 
  
CPUMotherboardGraphicsRAM
Core i5-2500K 4,5GHz @ 1,27V ASRock P67 Pro3 B3 Sapphire Radeon R9 270X Dual-X 8GB Corsair Vengeance 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung Spinpoint F3 Crucial BX100 SSD Samsung SH-222AB Alpenföhn Brocken 2 
OSMonitorKeyboardPower
Windows 10 Enterprise x64 BenQ GW2760HM Microsoft Wired 600 Corsair HX520 
CaseMouseMouse Pad
Coolermaster CM 690 Logitech G400s SteelSeries QcK Heavy 
  hide details  
Reply
CM690
(15 items)
 
  
CPUMotherboardGraphicsRAM
Core i5-2500K 4,5GHz @ 1,27V ASRock P67 Pro3 B3 Sapphire Radeon R9 270X Dual-X 8GB Corsair Vengeance 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung Spinpoint F3 Crucial BX100 SSD Samsung SH-222AB Alpenföhn Brocken 2 
OSMonitorKeyboardPower
Windows 10 Enterprise x64 BenQ GW2760HM Microsoft Wired 600 Corsair HX520 
CaseMouseMouse Pad
Coolermaster CM 690 Logitech G400s SteelSeries QcK Heavy 
  hide details  
Reply
post #3 of 5
Thread Starter 
well i now have turned on my computer by turning on my psu with a wire from GND to power on Wire and my pc works, could it be that
my motherboard doesn't send a strong enough "ON" signal to the psu?
Corsair
(15 items)
 
  
CPUMotherboardGraphicsRAM
amd fx-9370 Sabertooth 990 fx Asus AMD Radeon R9 270  Corsair Vengeance  
Hard DriveOptical DriveCoolingOS
Seagate Baracuda TEAC-w524 Deepcool "Captain 240 Windows 10 
MonitorKeyboardPowerCase
Philips Microsoft CORSAIR HM750 Corsair Carbide 200R 
MouseMouse PadAudio
Steelseries rival 300 Hama Urage Corsair Void 
  hide details  
Reply
Corsair
(15 items)
 
  
CPUMotherboardGraphicsRAM
amd fx-9370 Sabertooth 990 fx Asus AMD Radeon R9 270  Corsair Vengeance  
Hard DriveOptical DriveCoolingOS
Seagate Baracuda TEAC-w524 Deepcool "Captain 240 Windows 10 
MonitorKeyboardPowerCase
Philips Microsoft CORSAIR HM750 Corsair Carbide 200R 
MouseMouse PadAudio
Steelseries rival 300 Hama Urage Corsair Void 
  hide details  
Reply
post #4 of 5
that happen to me once where the motherboard would turn on for few seconds then turn off. it turns out that my motherboard died on me.
i fixed the motherboard by putting it in the oven for 10 min and that fixed the problem. biggrin.gif
    
CPUMotherboardGraphicsRAM
Intel 3930K 5040MHz @ 1.48 - 1.53v @ VTT/VCCSA ... Asus rampage extreme IV Gigabyte GTX 970 G1 @ 1580/4050MHz @ 1.325V Corsair Vengeance 64GB (8 x 8GB) DDR3 2400MHz. ... 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 Pro 256GB Seagate Barracuda ST3000DM001 3TB WD Black 1TB 64Mb Cache  WD Blue 500GB 16mb Cache 
Hard DriveOptical DriveCoolingCooling
WD Black 4TB 64mb Cache LG DVD EK-FB KIT RE4 - Acetal EK-FC970 GTX WF3 Backplate - Black 
CoolingCoolingCoolingCooling
Laing D5 Vario 12V DC Pump (MCP 655)  EK-BAY SPIN Reservoir - Plexi EK-CoolStream RAD XT (240) EK-CoolStream RAD XTX (120) 
CoolingCoolingCoolingCooling
EK-CoolStream XE 120 (Single) 8x Corsair Air SP120 PWM High Performance Edition 3x Corsair Air AF120 High Performance Edition EK-Supremacy EVO CPU Water Block (Nickel Acetal) 
CoolingOSMonitorMonitor
EK-FC970 GTX WF3 - Acetal+Nickel Windows 10 64-bit v1511 build 10586.14 BenQ RL2755HM LG W2261 
MonitorKeyboardPowerCase
Samsung S23C350 Razer BlackWidow Ultimate Cooler Master Silent Pro Gold 1000W Thermaltake Level 10 GT 
Mouse
Razer Lachesis 5600DPI 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel 3930K 5040MHz @ 1.48 - 1.53v @ VTT/VCCSA ... Asus rampage extreme IV Gigabyte GTX 970 G1 @ 1580/4050MHz @ 1.325V Corsair Vengeance 64GB (8 x 8GB) DDR3 2400MHz. ... 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 Pro 256GB Seagate Barracuda ST3000DM001 3TB WD Black 1TB 64Mb Cache  WD Blue 500GB 16mb Cache 
Hard DriveOptical DriveCoolingCooling
WD Black 4TB 64mb Cache LG DVD EK-FB KIT RE4 - Acetal EK-FC970 GTX WF3 Backplate - Black 
CoolingCoolingCoolingCooling
Laing D5 Vario 12V DC Pump (MCP 655)  EK-BAY SPIN Reservoir - Plexi EK-CoolStream RAD XT (240) EK-CoolStream RAD XTX (120) 
CoolingCoolingCoolingCooling
EK-CoolStream XE 120 (Single) 8x Corsair Air SP120 PWM High Performance Edition 3x Corsair Air AF120 High Performance Edition EK-Supremacy EVO CPU Water Block (Nickel Acetal) 
CoolingOSMonitorMonitor
EK-FC970 GTX WF3 - Acetal+Nickel Windows 10 64-bit v1511 build 10586.14 BenQ RL2755HM LG W2261 
MonitorKeyboardPowerCase
Samsung S23C350 Razer BlackWidow Ultimate Cooler Master Silent Pro Gold 1000W Thermaltake Level 10 GT 
Mouse
Razer Lachesis 5600DPI 
  hide details  
Reply
post #5 of 5
Seems like you mobo is somehow the problem. I guess your best bet is just to test with another psu. If that also fails, it should be your mobo.
CM690
(15 items)
 
  
CPUMotherboardGraphicsRAM
Core i5-2500K 4,5GHz @ 1,27V ASRock P67 Pro3 B3 Sapphire Radeon R9 270X Dual-X 8GB Corsair Vengeance 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung Spinpoint F3 Crucial BX100 SSD Samsung SH-222AB Alpenföhn Brocken 2 
OSMonitorKeyboardPower
Windows 10 Enterprise x64 BenQ GW2760HM Microsoft Wired 600 Corsair HX520 
CaseMouseMouse Pad
Coolermaster CM 690 Logitech G400s SteelSeries QcK Heavy 
  hide details  
Reply
CM690
(15 items)
 
  
CPUMotherboardGraphicsRAM
Core i5-2500K 4,5GHz @ 1,27V ASRock P67 Pro3 B3 Sapphire Radeon R9 270X Dual-X 8GB Corsair Vengeance 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung Spinpoint F3 Crucial BX100 SSD Samsung SH-222AB Alpenföhn Brocken 2 
OSMonitorKeyboardPower
Windows 10 Enterprise x64 BenQ GW2760HM Microsoft Wired 600 Corsair HX520 
CaseMouseMouse Pad
Coolermaster CM 690 Logitech G400s SteelSeries QcK Heavy 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Having problem with a PSU