Overclock.net › Forums › Graphics Cards › NVIDIA › Smells like burning/Anyone dealt with EVGA Europe RMA?
New Posts  All Forums:Forum Nav:

Smells like burning/Anyone dealt with EVGA Europe RMA?

post #1 of 3
Thread Starter 
So... long story short, my EVGA GTX 570 SC has been great for 3 months, but now my PC will not turn on with it plugged in. If I take it out and use my i7 2600k graphics, PC boots fine. I stuck my nose in the back of the card and I can clearly smell a burning smell. Card was on stock cooler, stock volts and clocks. I can see no visible damage to the card! Is this a common issue/a known issue/anyone else had it before?

With that, has anyone experienced the EVGA EU RMA service. I paid £256 deposit for cross shipment, so the new card should be here soon, but i'm scared they are going to take my reference 570 and replace it with the rubbish middle fan 2nd revision 570. Any experiences of it on OCN? Useful people?
post #2 of 3
Have you ruled out the possibility that it is your power supply generating the burning smell? You could have a capacitor there going bad.

For some reason signatures aren't working for me, what power supply are you using?

I've never dealt with an EVGA RMA, but from what I hear about it state-side, it's very good.
post #3 of 3
Thread Starter 
Quote:
Originally Posted by mingqi53 View Post

Have you ruled out the possibility that it is your power supply generating the burning smell? You could have a capacitor there going bad.
For some reason signatures aren't working for me, what power supply are you using?
I've never dealt with an EVGA RMA, but from what I hear about it state-side, it's very good.

Woops, nah, I took the card out and smelt it, definite burning. The PC boots and works absolutely fine on my i7 2600k integrated GPU. So PSU seems fine, it's a Antec TP 650W. When 570 is plugged in, no boot. My PC is:

Intel i7 2600k @ 4.7ghz
Asus P8Z68V Pro
8GB Corsair Vengeance LP 1600mhz
EVGA GTX 570
Asus Xonar Essence ST
Antec TruePower 650W
Corsair Obsidian 800D
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Smells like burning/Anyone dealt with EVGA Europe RMA?