Overclock.net › Forums › Components › Keyboards › Help Razer Blackwidow problem
New Posts  All Forums:Forum Nav:

Help Razer Blackwidow problem

post #1 of 2
Thread Starter 
Hi all. I have a Razer Blackwidow mechanical keyboard that is acting up on me. While on my PC (Windows 7) yesterday, my backspace key stopped working. I rebooted and every time I try to backspace, it will backspace once and then throw up a "\1" and then a bunch of random characters if I keep pressing it. I plugged it into my linux box and it works just fine. I'm using another USB keyboard on my Windows box and it works just fine. Virus scan comes up clean.

I have no idea what the problem is and would appreciate any help/suggestions. Thanks.
post #2 of 2
I don't know what could cause that, maybe try to RMA it.
Murderface
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600k MSI Z68A-GD65 EVGA GTX 680 Mushkin Redline 
Hard DriveHard DriveHard DriveHard Drive
Mushkin Chronos WD Caviar Black WD Caviar Black Hitachi Deskstar 
Optical DriveOptical DriveCoolingOS
Lite-On BD burner Samsung DVD burner Thermalright Silver Arrow Win 7 64bit 
MonitorKeyboardPowerCase
LG IPS236 KBT Race Enermax RV920 Lian Li T60B 
MouseMouse PadAudio
CM Storm Xornet PureTrak Talent Creative Sound Blaster X-Fi Titanium HD 
  hide details  
Reply
Murderface
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600k MSI Z68A-GD65 EVGA GTX 680 Mushkin Redline 
Hard DriveHard DriveHard DriveHard Drive
Mushkin Chronos WD Caviar Black WD Caviar Black Hitachi Deskstar 
Optical DriveOptical DriveCoolingOS
Lite-On BD burner Samsung DVD burner Thermalright Silver Arrow Win 7 64bit 
MonitorKeyboardPowerCase
LG IPS236 KBT Race Enermax RV920 Lian Li T60B 
MouseMouse PadAudio
CM Storm Xornet PureTrak Talent Creative Sound Blaster X-Fi Titanium HD 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Keyboards
Overclock.net › Forums › Components › Keyboards › Help Razer Blackwidow problem