Overclock.net › Forums › Graphics Cards › NVIDIA › NVIDIA Drivers and Overclocking Software › Constant "Nvidai Drivers have stopped working" when playing games
New Posts  All Forums:Forum Nav:

Constant "Nvidai Drivers have stopped working" when playing games

post #1 of 11
Thread Starter 
Operating System
MS Windows 7 Ultimate 64-bit SP1
CPU
Intel Core i7 930 @ 2.80GHz 55 °C
Bloomfield 45nm Technology
RAM
6.0GB Triple-Channel DDR3 @ 539MHz (8-8-8-20)
Motherboard
Gigabyte Technology Co., Ltd. X58A-UD5 (Socket 1366)
Graphics
VX2235wm-EU @ 1680x1050
NVIDIA GeForce GTX 460
Hard Drives
977GB Western Digital WDC WD1002FAEX-00Z3A0 ATA Device (Unknown) 36 °C
Optical Drives
HGXSHIH 52VGH6RCP SCSI CdRom Device
HGXSHIH 52VGH6RCP SCSI CdRom Device
Optiarc DVD RW AD-7260S ATA Device
Audio
Realtek High Definition Audio

My Gtx 460 is overclocked (All the temps are nice). Whenever I am playing a game (Most notably shogun 2 and Skyrim), my monitor would suddenly stop receiving input from the GTX 460 for 4-6 seconds. Then it would get it's input back, but anything rendered needs to be re-started, and on the bottom right, I get message saying the graphics driver has stopped working. I have the latest nvidia drivers, which I double checked to be the correct ones. Any game running would have a black screen, I would have to alt tab and kill it using task manager. If youtube was playing, the video just shows green. I have watched the temperature and checked temp logs while this has happened, and nothing was high at all and the temp logs showed no abnormalities whatsoever.

What is the problem? I have no clue what it is. Updating the graphics driver didn't fix it. Reverting the overclock did not fix it too.
post #2 of 11
recent Nvidia drivers have been unstable for many people. Best thing you could do right now is rollback your drivers to an older one, or a last known working version. It happens sometimes.
Yeyo
(16 items)
 
Scarface PC pics
(47 photos)
 
CPUMotherboardGraphicsRAM
i7 3770k ASRock Extreme 4 Gen 3 EVGA 670FTW Gskill Sniper Low Voltage Series 1.25v 16GB 
Hard DriveOptical DriveCoolingOS
Intel 80GB G2- OCZ 60GB- 1TB Asus BD combo Megashadow Deluxe Edition  Win7 
MonitorPowerCaseAudio
40" Insignia  Seasonic X750w Sleeved red Corsair 500r White Asus Xonar DGX 
  hide details  
Reply
Yeyo
(16 items)
 
Scarface PC pics
(47 photos)
 
CPUMotherboardGraphicsRAM
i7 3770k ASRock Extreme 4 Gen 3 EVGA 670FTW Gskill Sniper Low Voltage Series 1.25v 16GB 
Hard DriveOptical DriveCoolingOS
Intel 80GB G2- OCZ 60GB- 1TB Asus BD combo Megashadow Deluxe Edition  Win7 
MonitorPowerCaseAudio
40" Insignia  Seasonic X750w Sleeved red Corsair 500r White Asus Xonar DGX 
  hide details  
Reply
post #3 of 11
Yup I have had a 560 TI for 2 weeks and until Monday had tons of driver crashes on the 285.xx drivers. I think I might have fixed it by using a higher voltage setting (1.125v) and I've gone a few days without a driver crash. I don't know if i recommend that much voltage but it worked for me. I made a post about my problems, most people suggested reverting to 275.33 drivers, but I had a huge performance loss in Skyrim.
post #4 of 11
The most stable I've been able to run Skyrim is with the Windows Update installed Nvidia drivers. I'll pass on the latest drivers until one becomes known as completely solid...relatively at least.
    
CPUMotherboardGraphicsRAM
3570k@4.5ghz 1.21v Gigabyte Sniper M3 Sapphire 6950 Samsung 8g1866 
Hard DriveHard DriveHard DriveCooling
Samsung 830 Samsung F1 500 Crucial M4 64 (SRC) cpu:Noc NF-F12 / case:4x TY-141/gpu: 2x NB-Multi 
CoolingOSMonitorKeyboard
Venomous X, Accelero TT Win 7 64 Acer X213H Saitek Eclipse 
PowerCaseMouse
Superflower 650 plat Fractal Arc Midi G500 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
3570k@4.5ghz 1.21v Gigabyte Sniper M3 Sapphire 6950 Samsung 8g1866 
Hard DriveHard DriveHard DriveCooling
Samsung 830 Samsung F1 500 Crucial M4 64 (SRC) cpu:Noc NF-F12 / case:4x TY-141/gpu: 2x NB-Multi 
CoolingOSMonitorKeyboard
Venomous X, Accelero TT Win 7 64 Acer X213H Saitek Eclipse 
PowerCaseMouse
Superflower 650 plat Fractal Arc Midi G500 
  hide details  
Reply
post #5 of 11
I have had the same problem with my 2x285 sli setup. constant headache.

I did get rid of it at the end, but i dont know what really helped. I did a little reading online and people have been mentioning to play with TDR setting on registry..It didnt work well for me, than i found out that with the normal drivers the fan speeds wouldnt adjust itself to the temp. they would just stay at 40% with full load. yet the temps were fine ~80oC or so. these were with 285.xx driver. so i installed afterburner and use it to control my fan speeds. It started to crash less. and when it did it changed the error massege about to TDR settings.. unfortunately i didnt have my registry backed up so i did format the computer and got fresh install. With the fresh install it crashed little less often smile.gif and error messege changed to something about Directx.. i dont remember the exact messege..So i reinstalled the Directx even thou it was current. but this time i used the file that came with my Anno 2070 disk. i was still using 285.xx driver. than i was getting crappy FPS on BF3 and Anno 2070, my GPU usage was about 60% on my both cards. i did little resarch and found out that 285.xx didnt come with SLI profiles for these games. so i went ahead and installed 290.xx drivers. instantly my both card usage went up to %95. and i started to get 60~ fps on BF3 with ultra profile with AA and BlurMotion turned off. which is awesome with my cards being 3 years old. but anno 2070 wouldnt work properly it would drop to 2 fps after about 5 minutes in the game, i checked the SLI profile settings for specific application and the anno wasnt on the list.when i created a shortcut fo the . exe file on the desktop (advice from this forum) it appeared on the list. and finally it ran smooth with highest setting and made me really happy...


So my suggestion is that you try to lower temps.. try to clean your GPU and give them good air/water to cool them

than check the drivers try old ones as well as the new ones.. try testing them with MSI Kombuster with directx.it uses opengl as default. check usage % and core clock freq.

What is your Power supply rating? try to unplug unneccesary drives / fans/ lights etc.

if you have overclocked your GPU than revert back to stock.


these are all the suggestion that i can remember right now. but let me know if you have more question.
post #6 of 11
it is possibly a resolution issue. make sure your in-game settings and desktop resolution match your monitor's native resolution.

also are you using more than one monitor? if you have 2 or more monitors that arent the same resolution or refresh rate this could also cause your issues.

also if you are using a 768mb gtx 460 on BF3 or other intensive games and trying to push max settings on 1080p that could cause it as well. too much vram requirements and not enough that your card has.
Chimera
(17 items)
 
  
CPUMotherboardGraphicsGraphics
i5 2500k 4.8Ghz ASUS P8Z68-v PRO GEN3 Evga gtx 580 3gb Evga gtx 580 3gb 
RAMHard DriveCoolingOS
8Gb Veangence ocz agility 3 watercooled Windows 7 Ultimate 64bit 
MonitorKeyboardPowerCase
d3 - 23" acer led monitors Logitech G15 1050W modular custom built from scratch case 
MouseAudioAudio
CM Inferno afterglow wireless 7.1 headphones w/ mic x-fi titanium soundcard 
  hide details  
Reply
Chimera
(17 items)
 
  
CPUMotherboardGraphicsGraphics
i5 2500k 4.8Ghz ASUS P8Z68-v PRO GEN3 Evga gtx 580 3gb Evga gtx 580 3gb 
RAMHard DriveCoolingOS
8Gb Veangence ocz agility 3 watercooled Windows 7 Ultimate 64bit 
MonitorKeyboardPowerCase
d3 - 23" acer led monitors Logitech G15 1050W modular custom built from scratch case 
MouseAudioAudio
CM Inferno afterglow wireless 7.1 headphones w/ mic x-fi titanium soundcard 
  hide details  
Reply
post #7 of 11
Hey bud, if you check it out in Event Viewer and locate the crash, or when it crashes you click the more info thing in the "X Stopped Working" popup and it reads AppHang B1 (or even App Crash) with "nvlddmkm.sys" or "nvlddmkm.dll" as the Faulting Module, I can GUARANTEE you almost 100% that it's an under-volted GPU. Even if you've reverted to stock, try keeping the voltage a bit higher than it was set out of the box.

Had this issue for months until I upped the voltage one or two notches in Afterburner (without upping the clock speed!) and it hasn't occured since. Recommended it to another guy on the forum when his nvidia card was doing the same thing and it solved his issue too. It's really my only suggestion I can think of.
Edited by lowfiwhiteguy - 12/9/11 at 2:09pm
Óðinn
(15 items)
 
Methuselah
(15 items)
 
 
CPUMotherboardGraphicsRAM
| Intel Core i7 | 2600K | 4.2GHz @ 1.33v | | ASUS | Maximus IV Extreme | | ASUS | ENGTX 580 | 933MHz @ 1.138v | 2-way SLI | | G.Skill | RipjawsX | 2133MHz | 8GB | 
Hard DriveHard DriveCoolingCooling
| Intel | 510 SSD | 120GB | | Western Digital | Caviar Black | 1TB | | XSPC | Raystorm | | XSPC | Razor 580 | Dual SLI | 
CoolingCoolingCoolingOS
| XSPC | Dual RX360 | | Dual MCP-655 | Variable-Speed | | Koolance | RP-452x2 | Windows 7 Professional 64-bit 
MonitorPowerCase
| Acer | P243W | 1920 x 1200 | | Enermax | MODU87+ | 900W | | CaseLabs | M8 + Pedestal | 
CPUMotherboardGraphicsRAM
| Intel Core i7 | 2600K | 4.2GHz @ 1.33v | | ASUS | Maximus IV Extreme | | ASUS | ENGTX 580 | 933MHz @ 1.138v | 2-way SLI | | G.Skill | RipjawsX | 2133MHz | 8GB | 
Hard DriveHard DriveCoolingCooling
| Intel | 510 SSD | 120GB | | Western Digital | Caviar Black | 1TB | | XSPC | Raystorm | | XSPC | Razer 580 | 2-way SLI | 
CoolingCoolingCoolingOS
| XSPC | RX360 | | Phobya | Xtreme 200| | MCP 655 | Variable-Speed | Windows 7 Professional 64-bit 
MonitorPowerCase
| Acer | P243W | 1920 x 1200 | | Enermax | MODU87+ | 900W | | CoolerMaster | HAF X | 
  hide details  
Reply
Óðinn
(15 items)
 
Methuselah
(15 items)
 
 
CPUMotherboardGraphicsRAM
| Intel Core i7 | 2600K | 4.2GHz @ 1.33v | | ASUS | Maximus IV Extreme | | ASUS | ENGTX 580 | 933MHz @ 1.138v | 2-way SLI | | G.Skill | RipjawsX | 2133MHz | 8GB | 
Hard DriveHard DriveCoolingCooling
| Intel | 510 SSD | 120GB | | Western Digital | Caviar Black | 1TB | | XSPC | Raystorm | | XSPC | Razor 580 | Dual SLI | 
CoolingCoolingCoolingOS
| XSPC | Dual RX360 | | Dual MCP-655 | Variable-Speed | | Koolance | RP-452x2 | Windows 7 Professional 64-bit 
MonitorPowerCase
| Acer | P243W | 1920 x 1200 | | Enermax | MODU87+ | 900W | | CaseLabs | M8 + Pedestal | 
CPUMotherboardGraphicsRAM
| Intel Core i7 | 2600K | 4.2GHz @ 1.33v | | ASUS | Maximus IV Extreme | | ASUS | ENGTX 580 | 933MHz @ 1.138v | 2-way SLI | | G.Skill | RipjawsX | 2133MHz | 8GB | 
Hard DriveHard DriveCoolingCooling
| Intel | 510 SSD | 120GB | | Western Digital | Caviar Black | 1TB | | XSPC | Raystorm | | XSPC | Razer 580 | 2-way SLI | 
CoolingCoolingCoolingOS
| XSPC | RX360 | | Phobya | Xtreme 200| | MCP 655 | Variable-Speed | Windows 7 Professional 64-bit 
MonitorPowerCase
| Acer | P243W | 1920 x 1200 | | Enermax | MODU87+ | 900W | | CoolerMaster | HAF X | 
  hide details  
Reply
post #8 of 11
Quote:
Originally Posted by lowfiwhiteguy View Post

Hey bud, if you check it out in Event Viewer and locate the crash, or when it crashes you click the more info thing in the "X Stopped Working" popup and it reads AppHang B1 (or even App Crash) with "nvlddmkm.sys" or "nvlddmkm.dll" as the Faulting Module, I can GUARANTEE you almost 100% that it's an under-volted GPU. Even if you've reverted to stock, try keeping the voltage a bit higher than it was set out of the box.
Had this issue for months until I upped the voltage one or two notches in Afterburner (without upping the clock speed!) and it hasn't occured since. Recommended it to another guy on the forum when his nvidia card was doing the same thing and it solved his issue too. It's really my only suggestion I can think of.

+1 on this and possibly what i said as well. i have seen several cards need more voltage out of the box.
Chimera
(17 items)
 
  
CPUMotherboardGraphicsGraphics
i5 2500k 4.8Ghz ASUS P8Z68-v PRO GEN3 Evga gtx 580 3gb Evga gtx 580 3gb 
RAMHard DriveCoolingOS
8Gb Veangence ocz agility 3 watercooled Windows 7 Ultimate 64bit 
MonitorKeyboardPowerCase
d3 - 23" acer led monitors Logitech G15 1050W modular custom built from scratch case 
MouseAudioAudio
CM Inferno afterglow wireless 7.1 headphones w/ mic x-fi titanium soundcard 
  hide details  
Reply
Chimera
(17 items)
 
  
CPUMotherboardGraphicsGraphics
i5 2500k 4.8Ghz ASUS P8Z68-v PRO GEN3 Evga gtx 580 3gb Evga gtx 580 3gb 
RAMHard DriveCoolingOS
8Gb Veangence ocz agility 3 watercooled Windows 7 Ultimate 64bit 
MonitorKeyboardPowerCase
d3 - 23" acer led monitors Logitech G15 1050W modular custom built from scratch case 
MouseAudioAudio
CM Inferno afterglow wireless 7.1 headphones w/ mic x-fi titanium soundcard 
  hide details  
Reply
post #9 of 11
Yes the last stable ones for me are the 277.xx drivers.
Gaming Rig
(18 items)
 
   
CPUMotherboardGraphicsRAM
Intel i5-2500k @ 4.6 GHZ ASUS P8Z77-V PRO XFX AMD 6970 2GB CORSAIR VENGENCE DDR3 16 GB 1600mhz 9 9 9 24-2R 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital 7200 rpm 500 gb (Storage)  CRUCIAL M4 64 GB SSD SATA III (Boot Drive) External 1 TB Western Digital HDD ASUS DVD-RW 
CoolingOSMonitorKeyboard
ZALMAN CNPS9900MAX Windows 7 Ultimate 64 Bit Acer 1920 x 1080 23 inch Razer BlackWidow 2013 Ultimate Mechanical keybo... 
PowerCaseMouseMouse Pad
CORSAIR 650 Watt ANTEC 900 Razer NAGA Razer Kabuto 
AudioOther
Logitech G930 and some speakers. USB Drives Oh and a surge protector to prevent ... 
CPUMotherboardGraphicsRAM
Intel Celeron Dual Core G530 @ 2423 MHZ ASUS P8Z68-V PRO EVGA 550 Ti G.SKILL Ripjaws Series 4GB DDR3 1600 MHZ 9-9-9-24 
Hard DriveOptical DriveCoolingOS
250 GB 7200 RPM Western Digital LG DVD RW You don't wanna know. Win 7 64 
Monitor
19 inch dell 1280 x 1024  
  hide details  
Reply
Gaming Rig
(18 items)
 
   
CPUMotherboardGraphicsRAM
Intel i5-2500k @ 4.6 GHZ ASUS P8Z77-V PRO XFX AMD 6970 2GB CORSAIR VENGENCE DDR3 16 GB 1600mhz 9 9 9 24-2R 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital 7200 rpm 500 gb (Storage)  CRUCIAL M4 64 GB SSD SATA III (Boot Drive) External 1 TB Western Digital HDD ASUS DVD-RW 
CoolingOSMonitorKeyboard
ZALMAN CNPS9900MAX Windows 7 Ultimate 64 Bit Acer 1920 x 1080 23 inch Razer BlackWidow 2013 Ultimate Mechanical keybo... 
PowerCaseMouseMouse Pad
CORSAIR 650 Watt ANTEC 900 Razer NAGA Razer Kabuto 
AudioOther
Logitech G930 and some speakers. USB Drives Oh and a surge protector to prevent ... 
CPUMotherboardGraphicsRAM
Intel Celeron Dual Core G530 @ 2423 MHZ ASUS P8Z68-V PRO EVGA 550 Ti G.SKILL Ripjaws Series 4GB DDR3 1600 MHZ 9-9-9-24 
Hard DriveOptical DriveCoolingOS
250 GB 7200 RPM Western Digital LG DVD RW You don't wanna know. Win 7 64 
Monitor
19 inch dell 1280 x 1024  
  hide details  
Reply
post #10 of 11
Sorry to hear about your driver issues,it sucks i know. Couple of questions for you have u tried to do a fresh install of the drivers by using driver sweeper.Personally i would try that before i would start changing voltages.Also make sure your card is seated all the way,sometimes they will work themselves loose just by heating and cooling off.
Primo
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7-7700k Asus Maximus Hero ix Evga GTX 1080 ACX 3.0 G-Skill F-43200C15D-16GTZKW 
Hard DriveHard DriveCoolingCooling
Samsung 850 Evo Corsair Neutron  Ek Supremacy CSQ clean OCOOL 360mm radiator 
CoolingCoolingOSKeyboard
OCOOL 360mm radiator Ek -FC1080 GTX  Windows 10 CM Storm 
PowerCaseMouse
Evga 750 watt Phanteks Enthoo Primo Roccat Kone Optical 
  hide details  
Reply
Primo
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7-7700k Asus Maximus Hero ix Evga GTX 1080 ACX 3.0 G-Skill F-43200C15D-16GTZKW 
Hard DriveHard DriveCoolingCooling
Samsung 850 Evo Corsair Neutron  Ek Supremacy CSQ clean OCOOL 360mm radiator 
CoolingCoolingOSKeyboard
OCOOL 360mm radiator Ek -FC1080 GTX  Windows 10 CM Storm 
PowerCaseMouse
Evga 750 watt Phanteks Enthoo Primo Roccat Kone Optical 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › NVIDIA › NVIDIA Drivers and Overclocking Software › Constant "Nvidai Drivers have stopped working" when playing games