Overclock.net › Forums › Graphics Cards › NVIDIA › Is my GTX 580 failing? Or is it drivers?
New Posts  All Forums:Forum Nav:

Is my GTX 580 failing? Or is it drivers?

post #1 of 12
Thread Starter 
I have a Zotac GTX 580 AMP!, and lately it's been causing a lot of issues, I'm not sure if it's the drivers or the video card, or something else.

Flash in Firefox causes drivers to either crash or simply flash videos become nearly pitch black with some red and blue

Playing League of Legends sometimes starts to have stretched textures/glitches (especially with the beta drivers), all go away when I alt-tab though.

Battlefield 3 runs like a champ on max, no problems

Occasionally after a driver crash random pixels or small patches start to flash on the screen irregardless of the application running

I've tried changing drivers to the current beta ones 285.79 (I get a lot more problems with these though), or the current 285.62
I've also tried the 275.33, they caused me significantly less problems, but Battlefield 3 crashes a lot on them.

Temperatures are stable, usually runs at 50-70c when gaming, but rarely above, even during BF3
Otherwise runs 35-40c normally.

I use MSI afterburner, I've also tried not using it, but I still get problems
I've tried changing the voltage and underclocking, but nothing helped.

I've only had a BSOD once when I tried to restart, it was a 0x124

Running the card through a load of benchmarks doesn't cause it to crash or anything, its just random stuff like watching videos

The only thing that DID help was when I took out the video card to clean the connectors a little and replugged it, that fixed everything for a day or two. Or it was simply pure coincidence.


Any ideas if the card is dying or not?
post #2 of 12
Do you have DirectX and everything else updated? Have you tried re-installing flash?

If I had to venture a guess, you may need to RMA the card, but I do find it odd that BF3 works perfectly fine
post #3 of 12
Thread Starter 
Yes, everything is up to date, its a relatively new installation of Win 7 too, three weeks old.
post #4 of 12
Do you have Flash running as hardware acceleration? Do you have your CPU overclocked? Try watching an HTML5 video on YouTube see if it does it.

Only asking if Flash is running as hardware acceleration because when I had my ATI 5870 and was using Chrome, I had Hardware acceleration (Chrome: About:Flags) selected and it caused BSODs and the like.

http://www.youtube.com/html5
post #5 of 12
Could you be more specific about changing the voltages and underclocking? How much did you experiment?

If voltages/clock speeds can't get you stable then I would RMA.
Audio E-peen
(24 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-5960X ASRock X99E-ITX/ac Unobtainium GPU 32GB Corsair Vengeance LPX DDR4-2666 
Hard DriveCoolingCoolingCooling
Samsung 950 Pro M.2 512GB Corsair H100i Corsair SP120 High-Performance PWM x2 Noctua NF-F12 iPPC-2000 PWM x2 
CoolingOSMonitorKeyboard
Noctua NF-A9x14 Windows 10 Pro x64 Dell U2715H Logitech G710+ 
PowerCaseMouseMouse Pad
Silverstone SX600-G NCASE M1 v4 Logitech G700s eVGA GTX 590 Mouse Mat 
AudioAudioAudioAudio
Schiit Yggdrasil Unobtainium Amplifier Unobtainium Headphones Cambridge Audio Azur 851A 
AudioAudioOther
Anthony Gallo Acoustics Reference Strada JH Audio JH13 Pro (Custom Silver Cables) Herman Miller Embody 
  hide details  
Reply
Audio E-peen
(24 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-5960X ASRock X99E-ITX/ac Unobtainium GPU 32GB Corsair Vengeance LPX DDR4-2666 
Hard DriveCoolingCoolingCooling
Samsung 950 Pro M.2 512GB Corsair H100i Corsair SP120 High-Performance PWM x2 Noctua NF-F12 iPPC-2000 PWM x2 
CoolingOSMonitorKeyboard
Noctua NF-A9x14 Windows 10 Pro x64 Dell U2715H Logitech G710+ 
PowerCaseMouseMouse Pad
Silverstone SX600-G NCASE M1 v4 Logitech G700s eVGA GTX 590 Mouse Mat 
AudioAudioAudioAudio
Schiit Yggdrasil Unobtainium Amplifier Unobtainium Headphones Cambridge Audio Azur 851A 
AudioAudioOther
Anthony Gallo Acoustics Reference Strada JH Audio JH13 Pro (Custom Silver Cables) Herman Miller Embody 
  hide details  
Reply
post #6 of 12
Thread Starter 
I've been running Firefox with and without hardware acceleration and it still caused problems.

Running a 2500k at stock


I haven't experimented very thoroughly
I've only tried underclocking about 10-20% on the Core and Shader clocks from the default 815 and 1630, didn't help though.

Currently I've forced the voltage to 1.025 at stock clocks, since I was reading it improved stability for Zotac 580's, I tried going up to 1.050 but it didn't make any difference.
Edited by kohrak - 11/20/11 at 2:10pm
post #7 of 12
Yeah the fact that it's giving you trouble out of the box isn't a good sign.. either RMA or get a refund IMO.

If you have any spare graphics cards laying around, plug those in and see if you can replicate the problems.
post #8 of 12
Quote:
Originally Posted by kohrak View Post

I've been running Firefox with and without hardware acceleration and it still caused problems.
Running a 2500k at stock
I haven't experimented very thoroughly
I've only tried underclocking about 10-20% on the Core and Shader clocks from the default 815 and 1630, didn't help though.
Currently I've forced the voltage to 1.025 at stock clocks, since I was reading it improved stability for Zotac 580's, I tried going up to 1.050 but it didn't make any difference.

What are the stock clocks? If it is above ~830MHz it is actually possible it might need 1.075v or 1.088v. Regardless of what voltage you'd need, it really is unacceptable for there to be instability or artifacting at stock so RMA is the way to go.
Audio E-peen
(24 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-5960X ASRock X99E-ITX/ac Unobtainium GPU 32GB Corsair Vengeance LPX DDR4-2666 
Hard DriveCoolingCoolingCooling
Samsung 950 Pro M.2 512GB Corsair H100i Corsair SP120 High-Performance PWM x2 Noctua NF-F12 iPPC-2000 PWM x2 
CoolingOSMonitorKeyboard
Noctua NF-A9x14 Windows 10 Pro x64 Dell U2715H Logitech G710+ 
PowerCaseMouseMouse Pad
Silverstone SX600-G NCASE M1 v4 Logitech G700s eVGA GTX 590 Mouse Mat 
AudioAudioAudioAudio
Schiit Yggdrasil Unobtainium Amplifier Unobtainium Headphones Cambridge Audio Azur 851A 
AudioAudioOther
Anthony Gallo Acoustics Reference Strada JH Audio JH13 Pro (Custom Silver Cables) Herman Miller Embody 
  hide details  
Reply
Audio E-peen
(24 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-5960X ASRock X99E-ITX/ac Unobtainium GPU 32GB Corsair Vengeance LPX DDR4-2666 
Hard DriveCoolingCoolingCooling
Samsung 950 Pro M.2 512GB Corsair H100i Corsair SP120 High-Performance PWM x2 Noctua NF-F12 iPPC-2000 PWM x2 
CoolingOSMonitorKeyboard
Noctua NF-A9x14 Windows 10 Pro x64 Dell U2715H Logitech G710+ 
PowerCaseMouseMouse Pad
Silverstone SX600-G NCASE M1 v4 Logitech G700s eVGA GTX 590 Mouse Mat 
AudioAudioAudioAudio
Schiit Yggdrasil Unobtainium Amplifier Unobtainium Headphones Cambridge Audio Azur 851A 
AudioAudioOther
Anthony Gallo Acoustics Reference Strada JH Audio JH13 Pro (Custom Silver Cables) Herman Miller Embody 
  hide details  
Reply
post #9 of 12
Try adjusting your settings for 772MHz at the core and 2004MHz for memory with 1.025V. That pretty much matches up with my stock EVGA cards, which helped to stabilize my Zotac AMP! during the short time I owned it. I eventually flashed that card to the stock EVGA BIOS as it was just easier to manage three cards with the same settings, but that is a more extreme approach if you're OK with just using MSI Afterburner for all your tweaking.
     
CPUGraphicsRAMHard Drive
Intel Core i5 4258U 2.4 GHz Intel Iris HD 5100 8GB Samsung 256GB SSD 
OS
OSX 10.9 Mavericks 
  hide details  
Reply
     
CPUGraphicsRAMHard Drive
Intel Core i5 4258U 2.4 GHz Intel Iris HD 5100 8GB Samsung 256GB SSD 
OS
OSX 10.9 Mavericks 
  hide details  
Reply
post #10 of 12
Try re-seeding ( again ) your 580 or doing a cold restart ( unplug ), there is a common problem that I experienced and it fixed this. I had weird coloring and graphical issues in some of my games, even little lines. Worth a shot.

I think if it is this problem it will randomly come back occasionally, though it only happened to me 2-3 times total in 1+ year of ownership.
1440P Extreme.
(17 items)
 
Now the wifes PC.
(14 items)
 
 
CPUMotherboardGraphicsGraphics
I7 3930K @ 4.4ghz Asus Rampage IV Extreme 2011 EVGA GTX 980 Ti 6GB FTW EVGA GTX 980 Ti 6GB FTW 
RAMHard DriveHard DriveHard Drive
G,skill Ripjaw Z series 2400 32gb Samsung 840 Pro Seagate 3TB 7200 RPM  Western Digital mainstream 3TB  
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro LG Bluray Burner Noctua NH-D14 SE2011 Windows 10 x64 
MonitorKeyboardPowerCase
Monoprice 27" 2560x1440 IPS LED Razer Black Widow Tournament Edition Corsair RM1000 CoolerMaster Storm Trooper 
Other
EVGA SLI Bridge 
CPUMotherboardGraphicsGraphics
Intel I7 870 @ 3.6 ghz ASUS P7P55D-E Pro EVGA 680 GTX 4gb EVGA 680 GTX 4gb 
RAMHard DriveOptical DriveOS
G.SKILL Ripjaws Series 16GB (4x 4GB) DDR3 Samsung 830 128 GB SSD, WD 2TB 7200 RPM LG Black 10X Blu-ray Burner Windows 7 64 bit 
MonitorKeyboardPowerCase
Acer G24, 24" 1920x1200 Razer Blackwidow Ultimate Antec TruePower 750 COOLER MASTER Storm Scout 
MouseMouse Pad
Rat7 Razer eXactMat 
  hide details  
Reply
1440P Extreme.
(17 items)
 
Now the wifes PC.
(14 items)
 
 
CPUMotherboardGraphicsGraphics
I7 3930K @ 4.4ghz Asus Rampage IV Extreme 2011 EVGA GTX 980 Ti 6GB FTW EVGA GTX 980 Ti 6GB FTW 
RAMHard DriveHard DriveHard Drive
G,skill Ripjaw Z series 2400 32gb Samsung 840 Pro Seagate 3TB 7200 RPM  Western Digital mainstream 3TB  
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro LG Bluray Burner Noctua NH-D14 SE2011 Windows 10 x64 
MonitorKeyboardPowerCase
Monoprice 27" 2560x1440 IPS LED Razer Black Widow Tournament Edition Corsair RM1000 CoolerMaster Storm Trooper 
Other
EVGA SLI Bridge 
CPUMotherboardGraphicsGraphics
Intel I7 870 @ 3.6 ghz ASUS P7P55D-E Pro EVGA 680 GTX 4gb EVGA 680 GTX 4gb 
RAMHard DriveOptical DriveOS
G.SKILL Ripjaws Series 16GB (4x 4GB) DDR3 Samsung 830 128 GB SSD, WD 2TB 7200 RPM LG Black 10X Blu-ray Burner Windows 7 64 bit 
MonitorKeyboardPowerCase
Acer G24, 24" 1920x1200 Razer Blackwidow Ultimate Antec TruePower 750 COOLER MASTER Storm Scout 
MouseMouse Pad
Rat7 Razer eXactMat 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Is my GTX 580 failing? Or is it drivers?