Overclock.net › Forums › Video Games › PC Gaming › GTA IV problem with FPS...
New Posts  All Forums:Forum Nav:

GTA IV problem with FPS...

post #1 of 7
Thread Starter 
Hey guys, well I wanted to ask you whats going on with GTA IV. You see, I have an i7 2600K and a 590 and the game runs like **** (at 1280x1024, my monitor resolution ¬¬). When I move the camera a bit sharply, the game lags like ****, the fps decreases to 20 or so and the game starts to get laggy for a minute till it stabilizes and the fps rises to 55 - 60. I'm running the game on the max settings.

What is happening there?
My Console Killer
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K EVGA P67 NVIDIA GeForce GTX 590 G-Skill Ripjaws+ 4GB + Trubulence II Fan 
RAMHard DriveOSMonitor
G. Samsung F3 1TB Windows 7 Ultimate 64 Bits Samsung 17' 
KeyboardPowerCaseMouse
Wireless Microsoft Keyboard OCZ 750W Modular Cooler Master HAF 932 Advanced Wireless Microsoft Mouse 
Audio
Creative SB Titanium 
  hide details  
Reply
My Console Killer
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K EVGA P67 NVIDIA GeForce GTX 590 G-Skill Ripjaws+ 4GB + Trubulence II Fan 
RAMHard DriveOSMonitor
G. Samsung F3 1TB Windows 7 Ultimate 64 Bits Samsung 17' 
KeyboardPowerCaseMouse
Wireless Microsoft Keyboard OCZ 750W Modular Cooler Master HAF 932 Advanced Wireless Microsoft Mouse 
Audio
Creative SB Titanium 
  hide details  
Reply
post #2 of 7
GTA IV is coded like crap, steam or disc copy?
Edited by driftingforlife - 12/6/11 at 11:43am
Main Rig
(15 items)
 
Work Rig
(9 items)
 
 
CPUMotherboardGraphicsRAM
5820k Asus X99 Deluxe MSI GTX980 Ti Gaming/EK GPU Block Corsair 16GB 
Hard DriveCoolingOSMonitor
M4 128GB,C300 128GB, F3 1TB  480mm RAD, 655/top, 250mm RES, EK LX CPU Block windows 7 PRO 64bit Asus PB278Q 
PowerCase
Enermax Platimax 1500W Cosmos S 
CPUMotherboardGraphicsRAM
Core i7 2600k ASUS P8Z77-V MSI GT 610 1GB Corsair 1333mhz 16GB 
Hard DriveCoolingOSPower
Intel 330 60GB Cooler Master Hyper 212 EVO W7 Corsair CX500M 
Case
Cooler Master Elite 334U 
  hide details  
Reply
Main Rig
(15 items)
 
Work Rig
(9 items)
 
 
CPUMotherboardGraphicsRAM
5820k Asus X99 Deluxe MSI GTX980 Ti Gaming/EK GPU Block Corsair 16GB 
Hard DriveCoolingOSMonitor
M4 128GB,C300 128GB, F3 1TB  480mm RAD, 655/top, 250mm RES, EK LX CPU Block windows 7 PRO 64bit Asus PB278Q 
PowerCase
Enermax Platimax 1500W Cosmos S 
CPUMotherboardGraphicsRAM
Core i7 2600k ASUS P8Z77-V MSI GT 610 1GB Corsair 1333mhz 16GB 
Hard DriveCoolingOSPower
Intel 330 60GB Cooler Master Hyper 212 EVO W7 Corsair CX500M 
Case
Cooler Master Elite 334U 
  hide details  
Reply
post #3 of 7
Well this works for BF3 so why not try it for this.

Turn off hyperthreading.
post #4 of 7
You have a GTX590 but only a 1280x1024 monitor..? headscratch.gif
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 5820K @4.4ghz Asus X99-S EVGA GTX680 2GB 32GB Crucial 2133MHz DDR4 
Hard DriveCoolingOSMonitor
120GB Samsung 830 | 120GB Samsung 840 EVO | 6TB... Noctua NH-D14 Windows 8.1 Achieva Shimian 27" 1440p 
MonitorPowerCaseAudio
Dell U2311h (Portrait) Corsair HX520 NZXT Phantom White Asus Xonar D2X -> Samson SR850 or HiFi 
  hide details  
Reply
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 5820K @4.4ghz Asus X99-S EVGA GTX680 2GB 32GB Crucial 2133MHz DDR4 
Hard DriveCoolingOSMonitor
120GB Samsung 830 | 120GB Samsung 840 EVO | 6TB... Noctua NH-D14 Windows 8.1 Achieva Shimian 27" 1440p 
MonitorPowerCaseAudio
Dell U2311h (Portrait) Corsair HX520 NZXT Phantom White Asus Xonar D2X -> Samson SR850 or HiFi 
  hide details  
Reply
post #5 of 7
Thread Starter 
Guys I fixed it, I installed the 1.0.1 patch and voila, 50 - 60 stable fps, hell yeah! No lag at all.

I have HT off, btw, as well as turbo boost xD.
My Console Killer
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K EVGA P67 NVIDIA GeForce GTX 590 G-Skill Ripjaws+ 4GB + Trubulence II Fan 
RAMHard DriveOSMonitor
G. Samsung F3 1TB Windows 7 Ultimate 64 Bits Samsung 17' 
KeyboardPowerCaseMouse
Wireless Microsoft Keyboard OCZ 750W Modular Cooler Master HAF 932 Advanced Wireless Microsoft Mouse 
Audio
Creative SB Titanium 
  hide details  
Reply
My Console Killer
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K EVGA P67 NVIDIA GeForce GTX 590 G-Skill Ripjaws+ 4GB + Trubulence II Fan 
RAMHard DriveOSMonitor
G. Samsung F3 1TB Windows 7 Ultimate 64 Bits Samsung 17' 
KeyboardPowerCaseMouse
Wireless Microsoft Keyboard OCZ 750W Modular Cooler Master HAF 932 Advanced Wireless Microsoft Mouse 
Audio
Creative SB Titanium 
  hide details  
Reply
post #6 of 7
Oh well you still fixed your problem so have fun. biggrin.gif
post #7 of 7
Thread Starter 
In fact I may turn HT on, according to this site I got a 50% of improvement... http://www.pcgameshardware.com/aid,694495/Intel-Core-i5-and-Core-i7-Lynnfield-CPUs-reviewed/Reviews/
My Console Killer
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K EVGA P67 NVIDIA GeForce GTX 590 G-Skill Ripjaws+ 4GB + Trubulence II Fan 
RAMHard DriveOSMonitor
G. Samsung F3 1TB Windows 7 Ultimate 64 Bits Samsung 17' 
KeyboardPowerCaseMouse
Wireless Microsoft Keyboard OCZ 750W Modular Cooler Master HAF 932 Advanced Wireless Microsoft Mouse 
Audio
Creative SB Titanium 
  hide details  
Reply
My Console Killer
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K EVGA P67 NVIDIA GeForce GTX 590 G-Skill Ripjaws+ 4GB + Trubulence II Fan 
RAMHard DriveOSMonitor
G. Samsung F3 1TB Windows 7 Ultimate 64 Bits Samsung 17' 
KeyboardPowerCaseMouse
Wireless Microsoft Keyboard OCZ 750W Modular Cooler Master HAF 932 Advanced Wireless Microsoft Mouse 
Audio
Creative SB Titanium 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › GTA IV problem with FPS...