Overclock.net › Forums › Cooling › Water Cooling › swifttech MCP655 Broken??
New Posts  All Forums:Forum Nav:

swifttech MCP655 Broken??

post #1 of 3
Thread Starter 

I think my pump is broken, I have the swifttech MCP655. I have the water almost completely filled through my loops and it never fired up. I don't know why it doesn't make any sounds and nothing spinning.

 

What should I do?

Switch 810 Proof
(48 photos)
  
Reply
Switch 810 Proof
(48 photos)
  
Reply
post #2 of 3
Check your plug in for pushed out pins I had this happen before and i hate molex lol
My System
(27 items)
 
  
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1100T Crosshair V Formula NVIDIA GeForce GTX 580 NVIDIA GeForce GTX 580 
RAMRAMRAMRAM
G.Skill G.Skill G.Skill G.Skill 
Hard DriveHard DriveOptical DriveOS
Crucial M4 2.5" 256GB SATA III MLC Internal Sol... Western Digital Caviar Black WD1002FAEX 1TB 720... SONY Black 12X BD-R 2X BD-RE 8X DVD+R 5X DVD-RA... Microsoft Windows 7 Ultimate SP1 64-bit 
MonitorKeyboardPowerCase
HP LED Black 27" 5ms HDMI Widescreen LED BackLi... Logitech G510 Black 18 Function Keys USB Wired ... SILVERSTONE ST1500 1500W ATX 12V 2.3 & EPS 12V ... XSPC H1 Hive Series Cube Enthusiast Water Cooli... 
MouseMouse PadAudioOther
Logitech G500 10 Buttons Dual-mode Scroll Wheel... Ozone Gaming Gear GROUND LEVEL L Gaming Mouse Pad Cooler Master Circumaural Storm Sirus Headset -... XSPC Dual 5.25" Bay Reservoir - w/ Alphacool VP... 
OtherOtherOtherOther
XSPC Dual 5.25" Bay Reservoir - w/ Alphacool VP... XSPC EX360 Triple 120mm Low Profile Split Fin R... XSPC EX360 Triple 120mm Low Profile Split Fin R... XSPC EX360 Triple 120mm Low Profile Split Fin R... 
OtherOtherOther
XSPC EX360 Triple 120mm Low Profile Split Fin R... EK ASUS Crosshair V Full Board Cooling Block Ki... EK Supreme HF Universal CPU Liquid Cooling Bloc... 
  hide details  
Reply
My System
(27 items)
 
  
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1100T Crosshair V Formula NVIDIA GeForce GTX 580 NVIDIA GeForce GTX 580 
RAMRAMRAMRAM
G.Skill G.Skill G.Skill G.Skill 
Hard DriveHard DriveOptical DriveOS
Crucial M4 2.5" 256GB SATA III MLC Internal Sol... Western Digital Caviar Black WD1002FAEX 1TB 720... SONY Black 12X BD-R 2X BD-RE 8X DVD+R 5X DVD-RA... Microsoft Windows 7 Ultimate SP1 64-bit 
MonitorKeyboardPowerCase
HP LED Black 27" 5ms HDMI Widescreen LED BackLi... Logitech G510 Black 18 Function Keys USB Wired ... SILVERSTONE ST1500 1500W ATX 12V 2.3 & EPS 12V ... XSPC H1 Hive Series Cube Enthusiast Water Cooli... 
MouseMouse PadAudioOther
Logitech G500 10 Buttons Dual-mode Scroll Wheel... Ozone Gaming Gear GROUND LEVEL L Gaming Mouse Pad Cooler Master Circumaural Storm Sirus Headset -... XSPC Dual 5.25" Bay Reservoir - w/ Alphacool VP... 
OtherOtherOtherOther
XSPC Dual 5.25" Bay Reservoir - w/ Alphacool VP... XSPC EX360 Triple 120mm Low Profile Split Fin R... XSPC EX360 Triple 120mm Low Profile Split Fin R... XSPC EX360 Triple 120mm Low Profile Split Fin R... 
OtherOtherOther
XSPC EX360 Triple 120mm Low Profile Split Fin R... EK ASUS Crosshair V Full Board Cooling Block Ki... EK Supreme HF Universal CPU Liquid Cooling Bloc... 
  hide details  
Reply
post #3 of 3
Thread Starter 

Sorry guys,

 

Wows, I got totally saved by forgetting to swap the wires. I forgot that when I sleeved them, I must have messed up the wires. Whats worse I ran the pump dry and it didn't turn or nothing. Lucky it didn't cos it would of been a done for.

Switch 810 Proof
(48 photos)
  
Reply
Switch 810 Proof
(48 photos)
  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › swifttech MCP655 Broken??