Overclock.net › Forums › Software, Programming and Coding › Other Software › How can I restore Java and all of its settings to default?
New Posts  All Forums:Forum Nav:

How can I restore Java and all of its settings to default?

post #1 of 6
Thread Starter 
I did something a while back in an attempt to get Minecraft to perform differently, and now I can't seem to undo it. I cannot remember what exactly I did, so I'm asking for help.

Every time I launch a Java Console I get the following message
Picked up _JAVA_OPTIONS: -Xmx256m -Xms256m


Here is one I get now, and a great example of how this is causing a problem. It automatically launches with 256mb of RAM no matter what I do.

Picked up _JAVA_OPTIONS: -Xmx256m -Xms256m
174 recipes
27 achievements
05:58:24 [INFO] Starting minecraft server version 1.0.1
05:58:24 [WARNING] **** NOT ENOUGH RAM!
05:58:24 [WARNING] To start the server with more ram, launch it as "java -Xmx102
4M -Xms1024M -jar minecraft_server.jar"
05:58:24 [INFO] Loading properties
05:58:24 [INFO] Starting Minecraft server on *:11377
05:58:24 [INFO] This server is running Craftbukkit version git-Bukkit-1.0.1-R1-b
1597jnks (MC: 1.0.1) (Implementing API version 1.0.1-R1)
05:58:24 [INFO] Preparing level "world"
05:58:24 [INFO] Default game type: 0
05:58:24 [INFO] Preparing start region for level 0 (Seed: -8377849845446463568)
05:58:24 [INFO] Preparing start region for level 1 (Seed: -8377849845446463568)
05:58:25 [INFO] Preparing start region for level 2 (Seed: -8377849845446463568)
05:58:25 [INFO] Preparing spawn area: 20%
05:58:25 [INFO] Server permissions file permissions.yml is empty, ignoring it
05:58:25 [INFO] Done (0.132s)! For help, type "help" or "?"
>



I need to know how to completely remove whatever it is that java is getting these _JAVA_OPTIONS: -Xmx256m -Xms256m from, because countless uninstalls and reboots have not done so. I'm sure it something simple but it is frustrating. I want this to be over with and I really don't want to spend all day in order to do so, please help smile.gif

I've tried googling but found nothing helpful.
i7 Sandy
(8 items)
 
Skylake Pentium
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7-2600K ASRock Z75 Pro3 GTX 970 16GB 
Hard DriveOSMonitorPower
250GB Samsung 850 Evo WinXP Pro / Win7 Pro 1080p 60Hz Thermaltake Smart M850W 
CPUMotherboardGraphicsRAM
Pentium G4400 ASRock H110M-HDV GTX 550 Ti 8GB (2x4) 
Hard DriveOSPowerOther
250GB SSD Windows 7 500W 300Mbps WLAN 
  hide details  
Reply
i7 Sandy
(8 items)
 
Skylake Pentium
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7-2600K ASRock Z75 Pro3 GTX 970 16GB 
Hard DriveOSMonitorPower
250GB Samsung 850 Evo WinXP Pro / Win7 Pro 1080p 60Hz Thermaltake Smart M850W 
CPUMotherboardGraphicsRAM
Pentium G4400 ASRock H110M-HDV GTX 550 Ti 8GB (2x4) 
Hard DriveOSPowerOther
250GB SSD Windows 7 500W 300Mbps WLAN 
  hide details  
Reply
post #2 of 6

There's no option to restore to default. I uninstalled from Control Panel then download and re-installed. Go to Minecraft and undo the changes made.

 

Capture.JPG

ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
post #3 of 6
Thread Starter 
If it were as simple as that I would not be posting here. What did you mean by "Go to Minecraft and undo changes made" anyway? It's not a Minecraft problem, it's a JAVA Problem and it's affecting my Server.

I've tried all of the following with no success. It STILL says "Picked up _JAVA_OPTIONS"
-Uninstall, Reinstall
-Uninstall, Reboot, Reinstall
-Uninstall, Delete "Sun" AppData folder, Reboot, Reinstall

Desperately awaiting some good help :\
i7 Sandy
(8 items)
 
Skylake Pentium
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7-2600K ASRock Z75 Pro3 GTX 970 16GB 
Hard DriveOSMonitorPower
250GB Samsung 850 Evo WinXP Pro / Win7 Pro 1080p 60Hz Thermaltake Smart M850W 
CPUMotherboardGraphicsRAM
Pentium G4400 ASRock H110M-HDV GTX 550 Ti 8GB (2x4) 
Hard DriveOSPowerOther
250GB SSD Windows 7 500W 300Mbps WLAN 
  hide details  
Reply
i7 Sandy
(8 items)
 
Skylake Pentium
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7-2600K ASRock Z75 Pro3 GTX 970 16GB 
Hard DriveOSMonitorPower
250GB Samsung 850 Evo WinXP Pro / Win7 Pro 1080p 60Hz Thermaltake Smart M850W 
CPUMotherboardGraphicsRAM
Pentium G4400 ASRock H110M-HDV GTX 550 Ti 8GB (2x4) 
Hard DriveOSPowerOther
250GB SSD Windows 7 500W 300Mbps WLAN 
  hide details  
Reply
post #4 of 6

Bump it for more replies thumb.gif

ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
post #5 of 6
Thread Starter 
Found the solution.
-> Windows Key + Pause/Break
-> Advanced Tab
-> Environment Variables
-> _JAVA_OPTIONS entry was in there


I knew it was simple! mad.gif



Reply to below (So my post isn't bumped)
Quote:
Originally Posted by Ken1649 View Post

I didn't find anything there.

Yeah, because that is what I added and that was being kept through uninstalls of Java. I found the solution to my problem, don't know what you were looking for.
Edited by Shadow11377 - 12/14/11 at 6:04am
i7 Sandy
(8 items)
 
Skylake Pentium
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7-2600K ASRock Z75 Pro3 GTX 970 16GB 
Hard DriveOSMonitorPower
250GB Samsung 850 Evo WinXP Pro / Win7 Pro 1080p 60Hz Thermaltake Smart M850W 
CPUMotherboardGraphicsRAM
Pentium G4400 ASRock H110M-HDV GTX 550 Ti 8GB (2x4) 
Hard DriveOSPowerOther
250GB SSD Windows 7 500W 300Mbps WLAN 
  hide details  
Reply
i7 Sandy
(8 items)
 
Skylake Pentium
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7-2600K ASRock Z75 Pro3 GTX 970 16GB 
Hard DriveOSMonitorPower
250GB Samsung 850 Evo WinXP Pro / Win7 Pro 1080p 60Hz Thermaltake Smart M850W 
CPUMotherboardGraphicsRAM
Pentium G4400 ASRock H110M-HDV GTX 550 Ti 8GB (2x4) 
Hard DriveOSPowerOther
250GB SSD Windows 7 500W 300Mbps WLAN 
  hide details  
Reply
post #6 of 6

I didn't find anything there.

ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › How can I restore Java and all of its settings to default?