Overclock.net › Forums › AMD › AMD - General › New build is finally done.
New Posts  All Forums:Forum Nav:

New build is finally done. - Page 2

post #11 of 14
Thread Starter 
Quote:
Originally Posted by Defunctronin View Post

PSUcalc developed by Phaedrus here at OCN. Should tell you what you need to know. thumb.gif

Hey thanks alot I used that and it said I need 865w so yep I would need a new PSU as well maybe I will just stick one for now with it overclocked it rapes anything I can throw at it.
post #12 of 14
Thread Starter 
Quote:
Originally Posted by Dt_Freak1 View Post

too clean dude! so hawtness.
Quote:
Originally Posted by icy22 View Post

Very nice.thumb.gif
Quote:
Originally Posted by Cryptic20 View Post

Very Nice setup!



Hey thanks alot guys.thumb.gif
post #13 of 14
Quote:
Originally Posted by Leo_Da_vinci View Post

Yep as soon as I get the cash that's my next upgrade.
EDIT
Do you think I would have to up my power supply or 750 is just cutting it?

750 watts is just enough to run 2 in sli. I'm using 760 watts to power 2 560 ti so it's all good thumb.gif

Edit: Nvm, those 570 was more power hungry than i thought it was lol. Yepp you definitely need to upgrade your psu if you want sli
Edited by Jonsu - 12/15/11 at 3:54pm
post #14 of 14
Thread Starter 
Quote:
Originally Posted by Jonsu View Post

750 watts is just enough to run 2 in sli. I'm using 760 watts to power 2 560 ti so it's all good thumb.gif
Edit: Nvm, those 570 was more power hungry than i thought it was lol. Yepp you definitely need to upgrade your psu if you want sli

Yea I used the PSUcalc and I need 865w to run sli.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD - General
Overclock.net › Forums › AMD › AMD - General › New build is finally done.