post #1 of 1
Thread Starter 
So i recently put my loop back together and have noticed a clicking noise coming from the pump which occurs 1-2 times a second.
I'm thinking it might be cavatation caused by the almost 90 tube routing before the pump but I'n not sure. It only occurs when the PWM is set at 40%+ so I currently have it set at 30% to prevent any possible damage.

Does anyone have any idea what could be causing this clicking noise.

Loop: MCP35X pump -to- Black Ice SR1 560 Rad -to- EK Supreme HF -to- Phobya Dual Bay Res
pc160789.jpg
AMD Extreme
(16 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090t Black Edition Crosshair IV Extreme Sapphire Radeon HD6970 Corsair Dominator GT 2000MHZ CL8 
Hard DriveOptical DriveCoolingCooling
Western Digital 1TB Caviar Black Hardrive Liteon ihas-324 DVD Drive Ek Supreme HF Acetal+ EN Nickel MCP35X Pump and Heatsink 
CoolingCoolingCoolingCooling
EK-Multioption RES X2 - 250 Advanced Hardware Labs Black Ice SR1-560 Radiator EK-FC6970 Acetal + EN (Nickel) Bitspower Crosshair IV Extreme full cover water... 
OSMonitorPowerCase
Microsoft Windows 7 Ultimate 64 Bit Acer G245H 24inch Monitor Coolermaster Silent Pro 1000W Cooler Master Haf 932 
  hide details  
Reply
AMD Extreme
(16 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090t Black Edition Crosshair IV Extreme Sapphire Radeon HD6970 Corsair Dominator GT 2000MHZ CL8 
Hard DriveOptical DriveCoolingCooling
Western Digital 1TB Caviar Black Hardrive Liteon ihas-324 DVD Drive Ek Supreme HF Acetal+ EN Nickel MCP35X Pump and Heatsink 
CoolingCoolingCoolingCooling
EK-Multioption RES X2 - 250 Advanced Hardware Labs Black Ice SR1-560 Radiator EK-FC6970 Acetal + EN (Nickel) Bitspower Crosshair IV Extreme full cover water... 
OSMonitorPowerCase
Microsoft Windows 7 Ultimate 64 Bit Acer G245H 24inch Monitor Coolermaster Silent Pro 1000W Cooler Master Haf 932 
  hide details  
Reply