post #11 of 11
I don't know if it helps, but I'm running the Audigy 4 Pro on x64. I didn't go native disc with the drivers when I decided to install drivers, as I had many of the same problems. Try going to the website for the X-Fi Platinum, using auto-update for the basic drivers, and just downloading those in order to have basic sound. The other way that worked was 1. download the drivers and install, 2. full install of 32-bit drivers and programs, then 3. going back to update the card's drivers with the update installers on autoupdate.

Mind you, that was for the Audigy 4 Pro. I don't know how they'd differ with an X-Fi, other than my breakout box was the external, not the internal.

Good luck
The Outrider
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 Extreme 990X P6T6 WS REVOLUTION Radeon HD 7970 G. Skill 24GB Kit 
Hard DriveHard DriveOptical DriveCooling
Western Digital 2TB Caviar Black 1TB SSD BluRay Burner Corsair H100 
OSMonitorPowerCase
Windows 7 Ultimate 24" ASUS HDMI Corsair 1200w Gold Cooler Master CSX Green Dragon XXLE (6 of 300 -... 
MouseMouse PadAudioAudio
Razer Tron Razer Goliathus Auzentech X-Fi Home Theater HD Logitech Z-5450 
AudioOther
4.1 Trash Set tuned crispy Blackmagic Intensity Pro 
  hide details  
Reply
The Outrider
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 Extreme 990X P6T6 WS REVOLUTION Radeon HD 7970 G. Skill 24GB Kit 
Hard DriveHard DriveOptical DriveCooling
Western Digital 2TB Caviar Black 1TB SSD BluRay Burner Corsair H100 
OSMonitorPowerCase
Windows 7 Ultimate 24" ASUS HDMI Corsair 1200w Gold Cooler Master CSX Green Dragon XXLE (6 of 300 -... 
MouseMouse PadAudioAudio
Razer Tron Razer Goliathus Auzentech X-Fi Home Theater HD Logitech Z-5450 
AudioOther
4.1 Trash Set tuned crispy Blackmagic Intensity Pro 
  hide details  
Reply