Overclock.net › Forums › Components › Sound Cards and Computer Audio › Creative Xtremegamer Dead?
New Posts  All Forums:Forum Nav:

Creative Xtremegamer Dead?

post #1 of 2
Thread Starter 
I'm trying to install the Xtremegamer sound card. However, nothing is happening. All it does is prompt up a window saying "Updating window drivers. This will take a few minutes” and then it'll ask me to restart. Nothing is getting installed the window pop up for about a second before asking me to restart.

I'm trying to reinstall the driver because all of the sudden the card became undetected. This has happen MANY times before. But all I had to do is reseat the sound card, uninstall driver, driversweep creative driver, and then reinstall the driver. I’ve tried the same procedure for the last 30min and nothing is happening

Is this the end for this crappy card?
READY
(17 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1045T 78LMT-S2P HIS 6870 ADATA 8GB 1333mhz 
Hard DriveHard DriveHard DriveCooling
Samsung 830 128GB WD Caviar Black 2TB Seagate 2TB Corsair A70 
OSMonitorPowerCase
Windows 7 2x Acer 23" Antec NEO ECO 620W Antec 300 
Audio
M-Audio Mobilepre II 
  hide details  
Reply
READY
(17 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1045T 78LMT-S2P HIS 6870 ADATA 8GB 1333mhz 
Hard DriveHard DriveHard DriveCooling
Samsung 830 128GB WD Caviar Black 2TB Seagate 2TB Corsair A70 
OSMonitorPowerCase
Windows 7 2x Acer 23" Antec NEO ECO 620W Antec 300 
Audio
M-Audio Mobilepre II 
  hide details  
Reply
post #2 of 2
Might not be the card, it can possible just be Creative's garbage drivers. Have you tried the PAX drivers and see if that gives the same issue? (PAX drivers are just a standalone version of Creative's drivers that remove a lot of the garbage and bloatware, and basically give you your moneys worth).
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Creative Xtremegamer Dead?