Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI 5870 BIOS flash help needed, cold start boot
New Posts  All Forums:Forum Nav:

ATI 5870 BIOS flash help needed, cold start boot

post #1 of 7
Thread Starter 
My friend gave me a 5870 ref Diamond card that has never been gamed on, or hardly used. It was not used since it has a cold boot issue. About 1/2 of the time on boot you get no video. You either unplug the cord or restart the computer to fix it. Unpluggin the cable works about 1/2 of the time. It does not matter if you use DVI port 1 or 2 or HDMI.

The card works perfect otherwise, furmark stable at 900mhz (may slider in CCC). I tested it and once started works great. I figured I my try changing the bios.

I AM NOT A PROGRAMER and I have never flashed bios, I have not used DOS in over 10 yearrs. It took me about 1 hour to get my USB drive to take a DOS startup file. Every set of dirrections I find skip steps they must assume are common knowledge.

I now have a bootable USB drive, ati flash on it, and asus bios labeled under asus5870.bin

I changed my BIOS to boot from the USB, it did, went to DOS, I can enter atiflash and it shows me the programs. I then enter "atiflash -f -p 0 asus5870.bin" some sites say to enter .rom but that wont work.

After about 5 minutes I get a message that c drive failed to read. Any idea what I am doing wrong?

+rep for anyone who can help. I will be out a lot today and tonight for a party if I dont respond. Thanks
Mini Might
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500k ASUS Maximus 4 Gene-z  7970 REF 16GB Sam LP 30nm 
Hard DriveOptical DriveCoolingOS
Samsung 830 LG BR  HP212+ W7 64B 
MonitorPowerCase
27" Corsair 750HX Silverstone PS07 
  hide details  
Reply
Mini Might
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500k ASUS Maximus 4 Gene-z  7970 REF 16GB Sam LP 30nm 
Hard DriveOptical DriveCoolingOS
Samsung 830 LG BR  HP212+ W7 64B 
MonitorPowerCase
27" Corsair 750HX Silverstone PS07 
  hide details  
Reply
post #2 of 7
Try using winflash thumb.gif, great little utility with a easy to use GUI smile.gif. I've flashed multiple ATi cards BIOSes with this tool.
Swag box m8
(13 items)
 
7 x BL460c
(6 items)
 
 
CPUMotherboardGraphicsRAM
2500K Asus P8P67 Sapphire HD 5770 2x8GB Corsair 1333MHz 
Hard DriveMonitorMonitorPower
Corsair Force 3 120GB Aoc F22S+ Aoc F22S+ Powercool 850W 80+ 
Case
NZXT Phantom 
CPUCPUMotherboardRAM
Xeon E5520  Xeon E5520  BL460c G6 12GB ECC DDR3 
Hard DriveOS
1TB of SAN Server 2008 R2 
  hide details  
Reply
Swag box m8
(13 items)
 
7 x BL460c
(6 items)
 
 
CPUMotherboardGraphicsRAM
2500K Asus P8P67 Sapphire HD 5770 2x8GB Corsair 1333MHz 
Hard DriveMonitorMonitorPower
Corsair Force 3 120GB Aoc F22S+ Aoc F22S+ Powercool 850W 80+ 
Case
NZXT Phantom 
CPUCPUMotherboardRAM
Xeon E5520  Xeon E5520  BL460c G6 12GB ECC DDR3 
Hard DriveOS
1TB of SAN Server 2008 R2 
  hide details  
Reply
post #3 of 7
Subbed.

I plan on giving you a hand when I get a chance. I've got some parties of my own to get ready for and attend! wheee.gif

I'll be sure to check back later... hang tight!

Happy New Years Eve btw! thumb.gif
Pwnz0r Radley IV
(15 items)
 
   
CPUMotherboardGraphicsRAM
Q9550 Gigabyte X38-DS4 Asus GTX 480 2x2gb Corsair XMS2 
Hard DriveMonitorPower
2 x 500GB WD Caviar Black (RAID-0) 22" AOC 1080P Enermax Ininity 720W 
  hide details  
Reply
Pwnz0r Radley IV
(15 items)
 
   
CPUMotherboardGraphicsRAM
Q9550 Gigabyte X38-DS4 Asus GTX 480 2x2gb Corsair XMS2 
Hard DriveMonitorPower
2 x 500GB WD Caviar Black (RAID-0) 22" AOC 1080P Enermax Ininity 720W 
  hide details  
Reply
post #4 of 7
Thread Starter 
Thanks!

EDIT

Update, I used ATIWinflash to flash my bios from windows, that was way too easy compared to DOS. It says it worked. I screewed up and did not look in CCC to see what BIOS (did not realize I could) I had so now I just need to wait and see if the boot issue is fixed.

I tried to flash ASUS bios but winflash wont let me since the vendor id is different? Any thoughts? I wanted to do this just to see if I can see my bios version change, plus you can OC more. Since the card is free I want to test everything I always wanted to do.
Edited by Gabe63 - 12/31/11 at 2:46pm
Mini Might
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500k ASUS Maximus 4 Gene-z  7970 REF 16GB Sam LP 30nm 
Hard DriveOptical DriveCoolingOS
Samsung 830 LG BR  HP212+ W7 64B 
MonitorPowerCase
27" Corsair 750HX Silverstone PS07 
  hide details  
Reply
Mini Might
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500k ASUS Maximus 4 Gene-z  7970 REF 16GB Sam LP 30nm 
Hard DriveOptical DriveCoolingOS
Samsung 830 LG BR  HP212+ W7 64B 
MonitorPowerCase
27" Corsair 750HX Silverstone PS07 
  hide details  
Reply
post #5 of 7
Use RBE to modify the Vendor to whatever your card is, it should let you flash it then thumb.gif
Swag box m8
(13 items)
 
7 x BL460c
(6 items)
 
 
CPUMotherboardGraphicsRAM
2500K Asus P8P67 Sapphire HD 5770 2x8GB Corsair 1333MHz 
Hard DriveMonitorMonitorPower
Corsair Force 3 120GB Aoc F22S+ Aoc F22S+ Powercool 850W 80+ 
Case
NZXT Phantom 
CPUCPUMotherboardRAM
Xeon E5520  Xeon E5520  BL460c G6 12GB ECC DDR3 
Hard DriveOS
1TB of SAN Server 2008 R2 
  hide details  
Reply
Swag box m8
(13 items)
 
7 x BL460c
(6 items)
 
 
CPUMotherboardGraphicsRAM
2500K Asus P8P67 Sapphire HD 5770 2x8GB Corsair 1333MHz 
Hard DriveMonitorMonitorPower
Corsair Force 3 120GB Aoc F22S+ Aoc F22S+ Powercool 850W 80+ 
Case
NZXT Phantom 
CPUCPUMotherboardRAM
Xeon E5520  Xeon E5520  BL460c G6 12GB ECC DDR3 
Hard DriveOS
1TB of SAN Server 2008 R2 
  hide details  
Reply
post #6 of 7
Thread Starter 
I changed the vendor id with RBE but it would still not work, probably missing something.

However, I decided to mod the bios I did put in by opening the maximum clocks to 1125. After loading the new BIOS CCC now shows 11.25 max where it was locked at 900!

Also I have not has a start up or restart issue in 5 times. It was happening everytime so I may have fixed the issue! It was 100% on power savings mode and now it seems fine. That is nice since I now have a free 5870 ref cards with almost no use ever! I need to use it for a while to determine if everything is ok.

Thnaks +rep udated!

Any tips on RBE would be great! For one how to I make a new custom stock clock. I thought I did but then my card still defaults to 850.
Mini Might
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500k ASUS Maximus 4 Gene-z  7970 REF 16GB Sam LP 30nm 
Hard DriveOptical DriveCoolingOS
Samsung 830 LG BR  HP212+ W7 64B 
MonitorPowerCase
27" Corsair 750HX Silverstone PS07 
  hide details  
Reply
Mini Might
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500k ASUS Maximus 4 Gene-z  7970 REF 16GB Sam LP 30nm 
Hard DriveOptical DriveCoolingOS
Samsung 830 LG BR  HP212+ W7 64B 
MonitorPowerCase
27" Corsair 750HX Silverstone PS07 
  hide details  
Reply
post #7 of 7
Damn, I'm not even done with making the food and it seems you've already solved your problem! thumb.gif

The other thing I wanted to mention is that you technically didn't need to mod the BIOS for higher clocks. That's what "EnableUnofficialOverclocking" in the MSIAfterburner.cfg is for. biggrin.gif

Glad you got it sorted though. Happy New Years! drunken.gif
Pwnz0r Radley IV
(15 items)
 
   
CPUMotherboardGraphicsRAM
Q9550 Gigabyte X38-DS4 Asus GTX 480 2x2gb Corsair XMS2 
Hard DriveMonitorPower
2 x 500GB WD Caviar Black (RAID-0) 22" AOC 1080P Enermax Ininity 720W 
  hide details  
Reply
Pwnz0r Radley IV
(15 items)
 
   
CPUMotherboardGraphicsRAM
Q9550 Gigabyte X38-DS4 Asus GTX 480 2x2gb Corsair XMS2 
Hard DriveMonitorPower
2 x 500GB WD Caviar Black (RAID-0) 22" AOC 1080P Enermax Ininity 720W 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI 5870 BIOS flash help needed, cold start boot