Overclock.net › Forums › Graphics Cards › AMD/ATI › [Official] AMD Radeon HD 7950/7970/7990 Owners Thread
New Posts  All Forums:Forum Nav:

[Official] AMD Radeon HD 7950/7970/7990 Owners Thread - Page 3272

post #32711 of 38704
Quote:
Originally Posted by jezzer View Post

Since price dropped so much for 7990 cards, is there a turnside? I mean, will it loose driver support or whatever soon? No clue how that goes with AMD drivers. I am building a mITX system and what to as much graphic power as possible in one card

It's kind of a gamble with the coilwhine issue, as well as heat. Seems like a very large majority have at least some coilwhine. Mine has absolutely none, and I know of a few others that got lucky right off the bat. They also pretty much require a custom fan profile and when they start spinning up they are loud.

I'm abdolutely loving mine, but others have had bad experiences. If you can get one for $600-$650 I'd definitely say go for it.
post #32712 of 38704
Quote:
Originally Posted by pcoutu17 View Post

It's kind of a gamble with the coilwhine issue, as well as heat. Seems like a very large majority have at least some coilwhine. Mine has absolutely none, and I know of a few others that got lucky right off the bat. They also pretty much require a custom fan profile and when they start spinning up they are loud.

I'm abdolutely loving mine, but others have had bad experiences. If you can get one for $600-$650 I'd definitely say go for it.

Heat and fan noise would not be a problem as i would put a waterblock on it but coil whine would not be so cool i guess, especially if its louds.

But driver wise its all good? CF issues are mostly resolved i hear? And AMD brings driver optimizations also for older cards?

And yes its a good price, a bit cheaper then the 290x
Andromeda
(12 items)
 
  
CPUMotherboardGraphicsRAM
7700K Asus Z270G Strix GTX 1080 Strix Triden Z RGB 3600 CL16 
Hard DriveCoolingOSMonitor
M.2 Samsung Evo 960 Kraken X62 Win 10 Acer XB270HU 144hz IPS GSYNC 
KeyboardPowerCaseMouse
Razer Black Widow Tournament Corsair 860i NZXT S340 Elite Corsair Sabre Optical 
  hide details  
Reply
Andromeda
(12 items)
 
  
CPUMotherboardGraphicsRAM
7700K Asus Z270G Strix GTX 1080 Strix Triden Z RGB 3600 CL16 
Hard DriveCoolingOSMonitor
M.2 Samsung Evo 960 Kraken X62 Win 10 Acer XB270HU 144hz IPS GSYNC 
KeyboardPowerCaseMouse
Razer Black Widow Tournament Corsair 860i NZXT S340 Elite Corsair Sabre Optical 
  hide details  
Reply
post #32713 of 38704
Quote:
Originally Posted by jezzer View Post

Heat and fan noise would not be a problem as i would put a waterblock on it but coil whine would not be so cool i guess, especially if its louds.

But driver wise its all good? CF issues are mostly resolved i hear? And AMD brings driver optimizations also for older cards?

And yes its a good price, a bit cheaper then the 290x

If you're going under water then you're set. I'd say it's a no brainer at that point.

As far as drivers, CF is fixed for all the newer games that support it. Eyefinity setups and DirectX9 games are still a little iffy, but quickly being improved. I'm fairly positive that AMD drivers keep up with older cards, but I'm not entirely sure. I would assume so though.

If it does have coil whine it qualifies for an RMA but that's just an annoying process.
post #32714 of 38704
How come cheaper than 290x when it costs 550?

I'm waiting for the 290 non x personally...how good do you think it will perform guys?
post #32715 of 38704
Quote:
Originally Posted by DaClownie View Post

Quote:
Originally Posted by Paul17041993 View Post

Quote:
Originally Posted by DaClownie View Post

Hey guys... having a bit of an issue, hoping someone can lend me a hand...

I had the issue where I used the AMD uninstall utility in Windows 8 and it jacked up my install. So, I figured... why not just reinstall, update to win8.1, and get the latest drivers while I'm at it.

I'm now running Windows 8.1, my processor is overclocked to 4.6GHz, my video card is clocked at 1200/1600. Everything is stable, running fine as they're not even my max overclocks on either. I'm running Catalyst 13.9, and I'm getting weird issues in ALL games.

So when I first start up the computer, it works fine. It lets me game just fine, no issues with BF4 or Path of Exile, Fallout, etc. However, It's now 5 hours later, I sit back down to game, and BF4 keeps crashing with a DirectX crash, and Path of exile gets 2-4 second stutters where I have a line on he screen like it was mid drawing of a frame, FPS drops to 0, etc.

Any idea what I can do to get this to work correctly again? these are the same clocks/volts/temps that I ran on Windows8, and now with 8.1 and Catalyst 13.9 instead of 13.6 I can't get everything to play nice anymore. :/

have you run burn tests to make sure its still stable? quite possible that it could have changed in the time you upgraded, but if tests find it stable then I guess its a driver issue, or its only unstable for the shader code that BF4 uses...

Actually, that's the weird part of the issue. The crash isn't just BF4. Something is happening in other games as well. Path of exile gets 2-4 second skips, then all of a sudden clicks back in, etc. The other strange thing is right after the computer starts up it seems to be perfect. If it's sat idle for a bit then it doesn't work. Almost seems like something to do with how power is being reapplied when switching from 2D to 3D clocks or maybe after the monitors have gone to sleep or something.

Card idles at 500/1600. 3D clocks are 1200/1600. 20% power, 1.3v core, 1.7v mem.

Guess I'll back my overclocks out and see if that improves the issue. Going to be rather upset if I can't run an overclock. Will kill my FPS and defeat the purpose of the WC lol

I'll post back once I get a chance to test. It won't be until this weekend unfortunately as I'm going to be working until Sunday morning :/

Just to bring this back for any others with issues, here's my scenario. Running a 3770k @ 4.6GHz. Running a single 7970 @ 1200/1600. Overclocks are all stable.

When the computer first starts up, the games all play PERFECT. No 2-4 stutters in PoE. No DirectX crashes in BF4. After the monitors have gone to sleep, and I wake them back up, the games no longer work. I need to go into MSI Afterburner and reapply my overclock for it to work. It seems to be an issue with my MSI Afterburner. However, for reference... it appears I reinstalled an old version and am still using version 2.3.1 and the beta of 3.0.6 just released.

Anyone overclocking with the latest versions of Afterburner and experiencing zero issues? If so, I'll simply update Afterburner and see if that provides better 8.1 compatability. The game runs like absolute silk with my OC on and everything working though. 90+ FPS all settings on high @ 1440p
Beast of Burden
(19 items)
 
Cool story, bro!
(16 items)
 
 
CPUMotherboardGraphicsRAM
i7 3770k Gigabyte Z77X-UD5H Gigabyte HD 7970 Reference Ripjaws Z 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 Caviar Black ASUS DVD XSPC Raystorm 
CoolingCoolingCoolingOS
EK FC-7970 w/ Backplate Copper/Acetal RX360 w/ 3x Yate Loon High Speed in Push XSPC Dual Bay Res w/ D5 Pump Windows 7 
MonitorMonitorKeyboardPower
ASUS VE226H ASUS VE226H Cooler Master Quickfire Rapid Corsair HX850 
CaseMouseMouse Pad
HAF 932 Advanced Razer Deathadder QcK Mini 
CPUMotherboardGraphicsRAM
Q9550@ 3.5GHz w/ 1.191v Gigabyte GA-EP45-UD3P Sapphire Reference 5850 @ 775/1100 G.SKILL 4GB (2 x 2GB) DDR2 1066 
Hard DriveHard DriveHard DriveOptical Drive
Crucial C300 Spinpoint F3 Caviar Black ASUS DVD-RW 
CoolingOSMonitorKeyboard
Arctic Cooling Freezer 7 Pro Windows 7 Home Premium 64-bit Samsung 23" Saitek Eclipse III 
PowerCaseMouse
Corsair 430W NZXT Source 210 Wolf King 
  hide details  
Reply
Beast of Burden
(19 items)
 
Cool story, bro!
(16 items)
 
 
CPUMotherboardGraphicsRAM
i7 3770k Gigabyte Z77X-UD5H Gigabyte HD 7970 Reference Ripjaws Z 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 Caviar Black ASUS DVD XSPC Raystorm 
CoolingCoolingCoolingOS
EK FC-7970 w/ Backplate Copper/Acetal RX360 w/ 3x Yate Loon High Speed in Push XSPC Dual Bay Res w/ D5 Pump Windows 7 
MonitorMonitorKeyboardPower
ASUS VE226H ASUS VE226H Cooler Master Quickfire Rapid Corsair HX850 
CaseMouseMouse Pad
HAF 932 Advanced Razer Deathadder QcK Mini 
CPUMotherboardGraphicsRAM
Q9550@ 3.5GHz w/ 1.191v Gigabyte GA-EP45-UD3P Sapphire Reference 5850 @ 775/1100 G.SKILL 4GB (2 x 2GB) DDR2 1066 
Hard DriveHard DriveHard DriveOptical Drive
Crucial C300 Spinpoint F3 Caviar Black ASUS DVD-RW 
CoolingOSMonitorKeyboard
Arctic Cooling Freezer 7 Pro Windows 7 Home Premium 64-bit Samsung 23" Saitek Eclipse III 
PowerCaseMouse
Corsair 430W NZXT Source 210 Wolf King 
  hide details  
Reply
post #32716 of 38704
Quote:
Originally Posted by istudy92 View Post

Ohhh=p im excited with this crossfire even though I am sad that im being bottlenecked by my cpu i see a double improvement in Folding=p
went from ~4500 points a day to ~8900 points a day=p contributing to science like this is sorta fascinating =p

8900ppd, with two 7950s? Are you running Core 16? You should use Core 17; it's ~10-20x faster. Add the "client-type" flag to your GPU slots and set it to "beta".
SPEAR
(22 items)
 
Laptop #3
(7 items)
 
 
CPUMotherboardGraphicsRAM
i5 2500k @ 4.2ghz ASRock Z68 Extreme3 Gen3 Gigabyte WF3 Radeon R9 270X x2 G.Skill Ripjaws X 4x4gb @ 1600 
Hard DriveHard DriveHard DriveHard Drive
OCZ Agility 3 120gb (Linux) OCZ Agility 3 120gb (Windows) WD Caviar Black 2tb Hitachi 500gb 
Optical DriveOptical DriveCoolingOS
Sony Optiarc LightScribe LaCie external BluRay writer Antec Kühler H2O 920 + Corsair SP120 P/P Arch Linux + radeonsi + E20 
OSMonitorKeyboardPower
Windows 10 Pro (Insider release) ASUS VS238H-V @ 70hz Corsair K90 Corsair TX750 V2 
CaseMouseAudioAudio
None CM Storm Recon Altec Lansing ATP3 Creative Aurvana Live! 
OtherOther
Masscool Shin-Etsu G751 ASUS PCE-N10 
CPUGraphicsGraphicsRAM
Intel i7 4980HQ @ 2.8/4.0GHz Intel Iris Pro 5200 AMD Radeon R9 M370X 2x8GB DDR3 @ 1600MHz 
Hard DriveOSMonitor
1TB PCIe SSD OS X 10.11.2 El Capitan 15" @ 2880x1800 
  hide details  
Reply
SPEAR
(22 items)
 
Laptop #3
(7 items)
 
 
CPUMotherboardGraphicsRAM
i5 2500k @ 4.2ghz ASRock Z68 Extreme3 Gen3 Gigabyte WF3 Radeon R9 270X x2 G.Skill Ripjaws X 4x4gb @ 1600 
Hard DriveHard DriveHard DriveHard Drive
OCZ Agility 3 120gb (Linux) OCZ Agility 3 120gb (Windows) WD Caviar Black 2tb Hitachi 500gb 
Optical DriveOptical DriveCoolingOS
Sony Optiarc LightScribe LaCie external BluRay writer Antec Kühler H2O 920 + Corsair SP120 P/P Arch Linux + radeonsi + E20 
OSMonitorKeyboardPower
Windows 10 Pro (Insider release) ASUS VS238H-V @ 70hz Corsair K90 Corsair TX750 V2 
CaseMouseAudioAudio
None CM Storm Recon Altec Lansing ATP3 Creative Aurvana Live! 
OtherOther
Masscool Shin-Etsu G751 ASUS PCE-N10 
CPUGraphicsGraphicsRAM
Intel i7 4980HQ @ 2.8/4.0GHz Intel Iris Pro 5200 AMD Radeon R9 M370X 2x8GB DDR3 @ 1600MHz 
Hard DriveOSMonitor
1TB PCIe SSD OS X 10.11.2 El Capitan 15" @ 2880x1800 
  hide details  
Reply
post #32717 of 38704
I had coil whine on 3 cards in a row. Finally got this hawk and its silent. Not sure if its the gpu reactor but im much happier now.
Intel Overclocker
(12 items)
 
Media PC
(8 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 4790k Delidded + Lapped ASRock Z97 Extreme4 MSI Twin Frozr GTX 660  Corsair Vengeance Pro 2400mhz DDR3 
Hard DriveHard DriveOptical DriveCooling
OCZ Deneva 2 R series 400GB SSD WD Green 4TB HDD Asus DRW-24B1ST Phanteks PH-TC14PE_RD 
OSPowerCaseMouse
Windows 10 Seasonic 650w M12II Phanteks Enthoo Pro M with Acrylic side Cobra e-blue 
CPUMotherboardRAMHard Drive
intel core 2 quad q8200 Dell studio stock Dell studio Stock Corsair Force 3 SSD 
Hard DriveOptical DriveCoolingOS
External powered Seagate expansion desk Dell studio stock Stock Windows 10 
CPUMotherboardGraphicsRAM
FX-8350 GA-990FXA-UD5 MSI 7870 Hawk Edition Gskill 1600 2x4 GB 
Hard DriveOptical DriveCoolingOS
Corsair Force Series 3 22x Samsung w/ lightscribe dvd/cd burner Noctua NH-D14 Win 7 pro x64 
MonitorPowerCase
Acer x173w Seasonic M12II 650watt Semi-Modular PSU Apevia x-dreamer4 (with side window and red) 
  hide details  
Reply
Intel Overclocker
(12 items)
 
Media PC
(8 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 4790k Delidded + Lapped ASRock Z97 Extreme4 MSI Twin Frozr GTX 660  Corsair Vengeance Pro 2400mhz DDR3 
Hard DriveHard DriveOptical DriveCooling
OCZ Deneva 2 R series 400GB SSD WD Green 4TB HDD Asus DRW-24B1ST Phanteks PH-TC14PE_RD 
OSPowerCaseMouse
Windows 10 Seasonic 650w M12II Phanteks Enthoo Pro M with Acrylic side Cobra e-blue 
CPUMotherboardRAMHard Drive
intel core 2 quad q8200 Dell studio stock Dell studio Stock Corsair Force 3 SSD 
Hard DriveOptical DriveCoolingOS
External powered Seagate expansion desk Dell studio stock Stock Windows 10 
CPUMotherboardGraphicsRAM
FX-8350 GA-990FXA-UD5 MSI 7870 Hawk Edition Gskill 1600 2x4 GB 
Hard DriveOptical DriveCoolingOS
Corsair Force Series 3 22x Samsung w/ lightscribe dvd/cd burner Noctua NH-D14 Win 7 pro x64 
MonitorPowerCase
Acer x173w Seasonic M12II 650watt Semi-Modular PSU Apevia x-dreamer4 (with side window and red) 
  hide details  
Reply
post #32718 of 38704
Isin't it possible to get rid of coil whine through overclocking and/or running Valley Benchmarks for awhile?
post #32719 of 38704
Quote:
Originally Posted by King PWNinater View Post

Isin't it possible to get rid of coil whine through overclocking and/or running Valley Benchmarks for awhile?

I had a bad case of coil-whine on my 7970 when I first got it. I lock frame rates at 60, and the whine disappeared after a couple weeks. I still get it pretty bad when I run a bench that pushes massive frames(3d mark "Ice Storm gets 2k FPS and the whine is louder than the fans). But at 60fps, it seems to have worked itself out after extended usage. I don't think there is a conclusive answer to this, but someone else might have a better understanding than I do.
Blue540
(14 items)
 
x99
(18 items)
 
B.M.O.
(10 items)
 
CPUMotherboardGraphicsGraphics
6800k ASUS X99-A EVGA 980 FTW ACX 2.0 EVGA 980 FTW ACX2.0 
RAMHard DriveHard DriveCooling
Corsair Vengeance CMK32GX4M4B3200C16W Crucial MX100 WD Blue 1TB EK Supremacy EVO 
CoolingCoolingCoolingOS
EK 480 PE EK 240 PE EK D5 Vario Windows 10 
MonitorKeyboardPowerCase
Samsung 49KU7500 (curved 4k) Corsair K65 NZXT Hale 90 V2 1000W Thermaltake X9 
MouseMouse Pad
Logitch G100S X-Trac Ripper 
CPUMotherboardGraphicsRAM
6400k msi A75MA-P33 Sapphire 6670 passive hynix 2 GB dual channel 
Hard DriveOSMonitorKeyboard
WD  windows 8.1 e-machine wireless 
PowerCase
king win 600w custom built 
  hide details  
Reply
Blue540
(14 items)
 
x99
(18 items)
 
B.M.O.
(10 items)
 
CPUMotherboardGraphicsGraphics
6800k ASUS X99-A EVGA 980 FTW ACX 2.0 EVGA 980 FTW ACX2.0 
RAMHard DriveHard DriveCooling
Corsair Vengeance CMK32GX4M4B3200C16W Crucial MX100 WD Blue 1TB EK Supremacy EVO 
CoolingCoolingCoolingOS
EK 480 PE EK 240 PE EK D5 Vario Windows 10 
MonitorKeyboardPowerCase
Samsung 49KU7500 (curved 4k) Corsair K65 NZXT Hale 90 V2 1000W Thermaltake X9 
MouseMouse Pad
Logitch G100S X-Trac Ripper 
CPUMotherboardGraphicsRAM
6400k msi A75MA-P33 Sapphire 6670 passive hynix 2 GB dual channel 
Hard DriveOSMonitorKeyboard
WD  windows 8.1 e-machine wireless 
PowerCase
king win 600w custom built 
  hide details  
Reply
post #32720 of 38704
Quote:
Originally Posted by DaClownie View Post

Quote:
Originally Posted by DaClownie View Post

Quote:
Originally Posted by Paul17041993 View Post

Quote:
Originally Posted by DaClownie View Post

Hey guys... having a bit of an issue, hoping someone can lend me a hand...

I had the issue where I used the AMD uninstall utility in Windows 8 and it jacked up my install. So, I figured... why not just reinstall, update to win8.1, and get the latest drivers while I'm at it.

I'm now running Windows 8.1, my processor is overclocked to 4.6GHz, my video card is clocked at 1200/1600. Everything is stable, running fine as they're not even my max overclocks on either. I'm running Catalyst 13.9, and I'm getting weird issues in ALL games.

So when I first start up the computer, it works fine. It lets me game just fine, no issues with BF4 or Path of Exile, Fallout, etc. However, It's now 5 hours later, I sit back down to game, and BF4 keeps crashing with a DirectX crash, and Path of exile gets 2-4 second stutters where I have a line on he screen like it was mid drawing of a frame, FPS drops to 0, etc.

Any idea what I can do to get this to work correctly again? these are the same clocks/volts/temps that I ran on Windows8, and now with 8.1 and Catalyst 13.9 instead of 13.6 I can't get everything to play nice anymore. :/

have you run burn tests to make sure its still stable? quite possible that it could have changed in the time you upgraded, but if tests find it stable then I guess its a driver issue, or its only unstable for the shader code that BF4 uses...

Actually, that's the weird part of the issue. The crash isn't just BF4. Something is happening in other games as well. Path of exile gets 2-4 second skips, then all of a sudden clicks back in, etc. The other strange thing is right after the computer starts up it seems to be perfect. If it's sat idle for a bit then it doesn't work. Almost seems like something to do with how power is being reapplied when switching from 2D to 3D clocks or maybe after the monitors have gone to sleep or something.

Card idles at 500/1600. 3D clocks are 1200/1600. 20% power, 1.3v core, 1.7v mem.

Guess I'll back my overclocks out and see if that improves the issue. Going to be rather upset if I can't run an overclock. Will kill my FPS and defeat the purpose of the WC lol

I'll post back once I get a chance to test. It won't be until this weekend unfortunately as I'm going to be working until Sunday morning :/

Just to bring this back for any others with issues, here's my scenario. Running a 3770k @ 4.6GHz. Running a single 7970 @ 1200/1600. Overclocks are all stable.

When the computer first starts up, the games all play PERFECT. No 2-4 stutters in PoE. No DirectX crashes in BF4. After the monitors have gone to sleep, and I wake them back up, the games no longer work. I need to go into MSI Afterburner and reapply my overclock for it to work. It seems to be an issue with my MSI Afterburner. However, for reference... it appears I reinstalled an old version and am still using version 2.3.1 and the beta of 3.0.6 just released.

Anyone overclocking with the latest versions of Afterburner and experiencing zero issues? If so, I'll simply update Afterburner and see if that provides better 8.1 compatability. The game runs like absolute silk with my OC on and everything working though. 90+ FPS all settings on high @ 1440p

Newest version of Afterburner did not fix the issue. It's an issue when waking the monitors from sleep... it doesn't apply the overclock correctly, or maybe jump the voltage up. I'll have to continue to test to get the full information but hope I can find a fix soon. if I forget to reapply my overclock when waking monitors from sleep it's a guaranteed crash within 10 seconds in BF4. It's not game related though, it's something to do with this update to Windows 8.1 or update to 13.9/13.11 Catalyst drivers
Beast of Burden
(19 items)
 
Cool story, bro!
(16 items)
 
 
CPUMotherboardGraphicsRAM
i7 3770k Gigabyte Z77X-UD5H Gigabyte HD 7970 Reference Ripjaws Z 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 Caviar Black ASUS DVD XSPC Raystorm 
CoolingCoolingCoolingOS
EK FC-7970 w/ Backplate Copper/Acetal RX360 w/ 3x Yate Loon High Speed in Push XSPC Dual Bay Res w/ D5 Pump Windows 7 
MonitorMonitorKeyboardPower
ASUS VE226H ASUS VE226H Cooler Master Quickfire Rapid Corsair HX850 
CaseMouseMouse Pad
HAF 932 Advanced Razer Deathadder QcK Mini 
CPUMotherboardGraphicsRAM
Q9550@ 3.5GHz w/ 1.191v Gigabyte GA-EP45-UD3P Sapphire Reference 5850 @ 775/1100 G.SKILL 4GB (2 x 2GB) DDR2 1066 
Hard DriveHard DriveHard DriveOptical Drive
Crucial C300 Spinpoint F3 Caviar Black ASUS DVD-RW 
CoolingOSMonitorKeyboard
Arctic Cooling Freezer 7 Pro Windows 7 Home Premium 64-bit Samsung 23" Saitek Eclipse III 
PowerCaseMouse
Corsair 430W NZXT Source 210 Wolf King 
  hide details  
Reply
Beast of Burden
(19 items)
 
Cool story, bro!
(16 items)
 
 
CPUMotherboardGraphicsRAM
i7 3770k Gigabyte Z77X-UD5H Gigabyte HD 7970 Reference Ripjaws Z 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 Caviar Black ASUS DVD XSPC Raystorm 
CoolingCoolingCoolingOS
EK FC-7970 w/ Backplate Copper/Acetal RX360 w/ 3x Yate Loon High Speed in Push XSPC Dual Bay Res w/ D5 Pump Windows 7 
MonitorMonitorKeyboardPower
ASUS VE226H ASUS VE226H Cooler Master Quickfire Rapid Corsair HX850 
CaseMouseMouse Pad
HAF 932 Advanced Razer Deathadder QcK Mini 
CPUMotherboardGraphicsRAM
Q9550@ 3.5GHz w/ 1.191v Gigabyte GA-EP45-UD3P Sapphire Reference 5850 @ 775/1100 G.SKILL 4GB (2 x 2GB) DDR2 1066 
Hard DriveHard DriveHard DriveOptical Drive
Crucial C300 Spinpoint F3 Caviar Black ASUS DVD-RW 
CoolingOSMonitorKeyboard
Arctic Cooling Freezer 7 Pro Windows 7 Home Premium 64-bit Samsung 23" Saitek Eclipse III 
PowerCaseMouse
Corsair 430W NZXT Source 210 Wolf King 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › [Official] AMD Radeon HD 7950/7970/7990 Owners Thread