Overclock.net › Forums › Graphics Cards › AMD/ATI › [Official] AMD Radeon HD 7950/7970/7990 Owners Thread
New Posts  All Forums:Forum Nav:

[Official] AMD Radeon HD 7950/7970/7990 Owners Thread - Page 574

post #5731 of 38704
Quote:
Originally Posted by Hambone07si View Post

Not sure. What program are you using to see your VRM temps?

Program from the first post - HWiNFO64
My Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @ 4,5GHz, 1.33v Asus P8Z68-V Pro Gen3 Sapphire HD7950 OC Edition @ 1130 / 1550, 1.150v 8GB Corsair CML8GX3M2A1600C9 @ DDR3-1600, 9-9-9... 
Hard DriveOptical DriveCoolingCooling
1x Samsung 830 Series Desktop Upgrade Kit Sony Optiarc 24x DVDRW AD-7280S Scythe Mugen 2 Rev. B 2x Front intake fans 
CoolingCoolingOSMonitor
1x Large intake side fan 1x Back exhaust fan Windows 7 Enterprise x64 SP1 Samsung SyncMaster 2494hm 
KeyboardPowerCaseMouse
Logitech Media Keyboard 600 Corsair Enthusiast TX850M Corsair Carbide 500R Black Logitech G5 Laser Mouse 
AudioAudio
Realtek High Definition Audio AMD High Definition Audio Device 
  hide details  
Reply
My Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @ 4,5GHz, 1.33v Asus P8Z68-V Pro Gen3 Sapphire HD7950 OC Edition @ 1130 / 1550, 1.150v 8GB Corsair CML8GX3M2A1600C9 @ DDR3-1600, 9-9-9... 
Hard DriveOptical DriveCoolingCooling
1x Samsung 830 Series Desktop Upgrade Kit Sony Optiarc 24x DVDRW AD-7280S Scythe Mugen 2 Rev. B 2x Front intake fans 
CoolingCoolingOSMonitor
1x Large intake side fan 1x Back exhaust fan Windows 7 Enterprise x64 SP1 Samsung SyncMaster 2494hm 
KeyboardPowerCaseMouse
Logitech Media Keyboard 600 Corsair Enthusiast TX850M Corsair Carbide 500R Black Logitech G5 Laser Mouse 
AudioAudio
Realtek High Definition Audio AMD High Definition Audio Device 
  hide details  
Reply
post #5732 of 38704
Quote:
Originally Posted by svthomas View Post

In regard to the voltages and ASIC quality, this is how I understand it:
up to 2F90 (up to 75% quality) - 1.1750V
up to 34D0 (up to 80% quality) - 1.1125V
up to 3820 (up to 85% quality) - 1.0500V
up to 3A90 (up to 90% quality) - 1.0250V

Is this for 7970 only or does this also apply to 7950 cards?
Thanks in advance!
My Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @ 4,5GHz, 1.33v Asus P8Z68-V Pro Gen3 Sapphire HD7950 OC Edition @ 1130 / 1550, 1.150v 8GB Corsair CML8GX3M2A1600C9 @ DDR3-1600, 9-9-9... 
Hard DriveOptical DriveCoolingCooling
1x Samsung 830 Series Desktop Upgrade Kit Sony Optiarc 24x DVDRW AD-7280S Scythe Mugen 2 Rev. B 2x Front intake fans 
CoolingCoolingOSMonitor
1x Large intake side fan 1x Back exhaust fan Windows 7 Enterprise x64 SP1 Samsung SyncMaster 2494hm 
KeyboardPowerCaseMouse
Logitech Media Keyboard 600 Corsair Enthusiast TX850M Corsair Carbide 500R Black Logitech G5 Laser Mouse 
AudioAudio
Realtek High Definition Audio AMD High Definition Audio Device 
  hide details  
Reply
My Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @ 4,5GHz, 1.33v Asus P8Z68-V Pro Gen3 Sapphire HD7950 OC Edition @ 1130 / 1550, 1.150v 8GB Corsair CML8GX3M2A1600C9 @ DDR3-1600, 9-9-9... 
Hard DriveOptical DriveCoolingCooling
1x Samsung 830 Series Desktop Upgrade Kit Sony Optiarc 24x DVDRW AD-7280S Scythe Mugen 2 Rev. B 2x Front intake fans 
CoolingCoolingOSMonitor
1x Large intake side fan 1x Back exhaust fan Windows 7 Enterprise x64 SP1 Samsung SyncMaster 2494hm 
KeyboardPowerCaseMouse
Logitech Media Keyboard 600 Corsair Enthusiast TX850M Corsair Carbide 500R Black Logitech G5 Laser Mouse 
AudioAudio
Realtek High Definition Audio AMD High Definition Audio Device 
  hide details  
Reply
post #5733 of 38704
Quote:
Originally Posted by Hambone07si View Post

What popped? A cap?

I don't know, I presume something around the VRMs because they were getting so hot. I can't see without taking the heatsink off and I'm not game to do that since I'm returning it. It's definitely stuffed and I could smell the card burning.
Quote:
Originally Posted by Daffie82 View Post

What is a safe temp of the VRM of my HD7950 Sapphire OC edition ?
I am running on air and my GPU temps are in the low 70's (degrees) when extreme testing (Furmark). So that looks OK to me, but I want to know what should be considered safe as max VRM temp when overclocking.
Thanks for the replies !

My VRMs got to ~95C in Heaven, which IMO was too high, but I'd read about high VRM temps on the DCUII. I let them cool down, then ran 2mins of 3DMark11 and the card died. I don't know what temp it was at but just take that on board.
Quote:
Originally Posted by pfunkmort View Post

I know this was a few pages back...but is it even possible for a card to artifact during POST? I was under the impression that POST was just the motherboard doing its thing and that the peripherals and cards didn't even do anything until after that was done.

I suppose so, you have to get display from somewhere and the card was so stuffed that it artifacted from POST all the way through to login.
MiniCaptein
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 7700K MSI Z270I Gaming Pro Carbon AC mITX EVGA GTX980Ti SC+ 2x8GB G.Skill Ripjaws V 3200MHz 16-16-16-36 
Hard DriveHard DriveHard DriveCooling
120GB Samsung 840 EVO 500GB Samsung Spinpoint F3 (Storage) 2TB WD Caviar Black (Games) Corsair H80i 
OSMonitorKeyboardPower
Win7 Home Premium 64bit Dell U2711 2560x1440 60Hz Das Keyboard 4 Cherry Brown Seasonic X-Series 750W 
CaseMouseMouse Pad
Corsair Obsidian 250D Razer Taipan Razer Goliathus Fragged Extended Speed Edition 
  hide details  
Reply
MiniCaptein
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 7700K MSI Z270I Gaming Pro Carbon AC mITX EVGA GTX980Ti SC+ 2x8GB G.Skill Ripjaws V 3200MHz 16-16-16-36 
Hard DriveHard DriveHard DriveCooling
120GB Samsung 840 EVO 500GB Samsung Spinpoint F3 (Storage) 2TB WD Caviar Black (Games) Corsair H80i 
OSMonitorKeyboardPower
Win7 Home Premium 64bit Dell U2711 2560x1440 60Hz Das Keyboard 4 Cherry Brown Seasonic X-Series 750W 
CaseMouseMouse Pad
Corsair Obsidian 250D Razer Taipan Razer Goliathus Fragged Extended Speed Edition 
  hide details  
Reply
post #5734 of 38704
Thanks for the reply LAF, my VRM temps are not that high, according to HWiNFO64 (latest beta) it only gets to around 63 degrees when overclocked (after about 80sec in Furmark) while the thermal Diode gets to 72 degrees with the same test. So I guess that makes my VRM temps totally fine.

I got another strange thing though, look at the info from HWinfo :

Stock speeds and voltage (1090 V):

521

Overclock at 1100 core / 1500 memory (1175 V):

635

Overclock at 1175 core / 1580 memory (1175 V):

593

Why does it say 0% GPU Utilization in the highest overclock ??
I noticed this in Furmark also but thought it was some bug in Furmark. As you can see this does NOT happen at stock and does NOT happen at the lower overclock.
Does this mean my overclock of 1175 / 1580 is too high??

Any feedback is very much appreciated !
My Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @ 4,5GHz, 1.33v Asus P8Z68-V Pro Gen3 Sapphire HD7950 OC Edition @ 1130 / 1550, 1.150v 8GB Corsair CML8GX3M2A1600C9 @ DDR3-1600, 9-9-9... 
Hard DriveOptical DriveCoolingCooling
1x Samsung 830 Series Desktop Upgrade Kit Sony Optiarc 24x DVDRW AD-7280S Scythe Mugen 2 Rev. B 2x Front intake fans 
CoolingCoolingOSMonitor
1x Large intake side fan 1x Back exhaust fan Windows 7 Enterprise x64 SP1 Samsung SyncMaster 2494hm 
KeyboardPowerCaseMouse
Logitech Media Keyboard 600 Corsair Enthusiast TX850M Corsair Carbide 500R Black Logitech G5 Laser Mouse 
AudioAudio
Realtek High Definition Audio AMD High Definition Audio Device 
  hide details  
Reply
My Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @ 4,5GHz, 1.33v Asus P8Z68-V Pro Gen3 Sapphire HD7950 OC Edition @ 1130 / 1550, 1.150v 8GB Corsair CML8GX3M2A1600C9 @ DDR3-1600, 9-9-9... 
Hard DriveOptical DriveCoolingCooling
1x Samsung 830 Series Desktop Upgrade Kit Sony Optiarc 24x DVDRW AD-7280S Scythe Mugen 2 Rev. B 2x Front intake fans 
CoolingCoolingOSMonitor
1x Large intake side fan 1x Back exhaust fan Windows 7 Enterprise x64 SP1 Samsung SyncMaster 2494hm 
KeyboardPowerCaseMouse
Logitech Media Keyboard 600 Corsair Enthusiast TX850M Corsair Carbide 500R Black Logitech G5 Laser Mouse 
AudioAudio
Realtek High Definition Audio AMD High Definition Audio Device 
  hide details  
Reply
post #5735 of 38704
Quote:
Originally Posted by Daffie82 View Post

Thanks for the reply LAF, my VRM temps are not that high, according to HWiNFO64 (latest beta) it only gets to around 63 degrees when overclocked (after about 80sec in Furmark) while the thermal Diode gets to 72 degrees with the same test. So I guess that makes my VRM temps totally fine.
I got another strange thing though, look at the info from HWinfo :
*snip*
Why does it say 0% GPU Utilization in the highest overclock ??
I noticed this in Furmark also but thought it was some bug in Furmark. As you can see this does NOT happen at stock and does NOT happen at the lower overclock.
Does this mean my overclock of 1175 / 1580 is too high??
Any feedback is very much appreciated !

Did you have load on it when it took that reading? If you scroll across you can see the "Max" tab, which is what we're interested in.
MiniCaptein
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 7700K MSI Z270I Gaming Pro Carbon AC mITX EVGA GTX980Ti SC+ 2x8GB G.Skill Ripjaws V 3200MHz 16-16-16-36 
Hard DriveHard DriveHard DriveCooling
120GB Samsung 840 EVO 500GB Samsung Spinpoint F3 (Storage) 2TB WD Caviar Black (Games) Corsair H80i 
OSMonitorKeyboardPower
Win7 Home Premium 64bit Dell U2711 2560x1440 60Hz Das Keyboard 4 Cherry Brown Seasonic X-Series 750W 
CaseMouseMouse Pad
Corsair Obsidian 250D Razer Taipan Razer Goliathus Fragged Extended Speed Edition 
  hide details  
Reply
MiniCaptein
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 7700K MSI Z270I Gaming Pro Carbon AC mITX EVGA GTX980Ti SC+ 2x8GB G.Skill Ripjaws V 3200MHz 16-16-16-36 
Hard DriveHard DriveHard DriveCooling
120GB Samsung 840 EVO 500GB Samsung Spinpoint F3 (Storage) 2TB WD Caviar Black (Games) Corsair H80i 
OSMonitorKeyboardPower
Win7 Home Premium 64bit Dell U2711 2560x1440 60Hz Das Keyboard 4 Cherry Brown Seasonic X-Series 750W 
CaseMouseMouse Pad
Corsair Obsidian 250D Razer Taipan Razer Goliathus Fragged Extended Speed Edition 
  hide details  
Reply
post #5736 of 38704
Quote:
Originally Posted by LAF View Post

Did you have load on it when it took that reading? If you scroll across you can see the "Max" tab, which is what we're interested in.

Did the same test and made the same screenshot now with max tab included...

588

But The current tab has always stayed zero during the test as far as I could see... Which was not the case with the 2 other tests (lower overclock + stock).
Also as you can see I made the screenshot while the test was still going (you can see the temps), and for Furmark the load should always be 99%.
Also when I do the 1080p Benchmark preset in Furmark I can see the load constantly going from 99% to 0%.
It does not do this on the lower overclock.
What does this mean?
Feedback again MUCH appreciated!
My Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @ 4,5GHz, 1.33v Asus P8Z68-V Pro Gen3 Sapphire HD7950 OC Edition @ 1130 / 1550, 1.150v 8GB Corsair CML8GX3M2A1600C9 @ DDR3-1600, 9-9-9... 
Hard DriveOptical DriveCoolingCooling
1x Samsung 830 Series Desktop Upgrade Kit Sony Optiarc 24x DVDRW AD-7280S Scythe Mugen 2 Rev. B 2x Front intake fans 
CoolingCoolingOSMonitor
1x Large intake side fan 1x Back exhaust fan Windows 7 Enterprise x64 SP1 Samsung SyncMaster 2494hm 
KeyboardPowerCaseMouse
Logitech Media Keyboard 600 Corsair Enthusiast TX850M Corsair Carbide 500R Black Logitech G5 Laser Mouse 
AudioAudio
Realtek High Definition Audio AMD High Definition Audio Device 
  hide details  
Reply
My Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @ 4,5GHz, 1.33v Asus P8Z68-V Pro Gen3 Sapphire HD7950 OC Edition @ 1130 / 1550, 1.150v 8GB Corsair CML8GX3M2A1600C9 @ DDR3-1600, 9-9-9... 
Hard DriveOptical DriveCoolingCooling
1x Samsung 830 Series Desktop Upgrade Kit Sony Optiarc 24x DVDRW AD-7280S Scythe Mugen 2 Rev. B 2x Front intake fans 
CoolingCoolingOSMonitor
1x Large intake side fan 1x Back exhaust fan Windows 7 Enterprise x64 SP1 Samsung SyncMaster 2494hm 
KeyboardPowerCaseMouse
Logitech Media Keyboard 600 Corsair Enthusiast TX850M Corsair Carbide 500R Black Logitech G5 Laser Mouse 
AudioAudio
Realtek High Definition Audio AMD High Definition Audio Device 
  hide details  
Reply
post #5737 of 38704
Does anyone else have crossfire issues with Mass Effect 3? I've had to disable it for the moment as the screen flickers black constantly otherwise.

Optimization is awful too - with the game maxed out on one 7970 clocked at 1100/1600 I'm getting ~30-40fps.

This is with driver set 12.3 and cap 12.2 1.
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
[i7 2600k - 5.XGHz @ X.XXv] [ASUS P8P67 Pro B3] [2x MSI 7970s in Crossfire @ 1125/1650] [8GB G.Skill Ripjaws X 2x4GB] 
Hard DriveHard DriveCoolingCooling
[2TB Hitachi] [Crucial M4 SSD 64GB] [Antec Kuhler H20 920] [Lian-Li BZ BZ-502B] 
CoolingOSMonitorKeyboard
[G.Skill Turbulence II RAM Cooler] [Windows 7 Ultimate 64bit] [2x BenQ XL2410T @ 120Hz] [Razer Lycosa] 
PowerCaseMouseMouse Pad
[Corsair AX1200] [Silverstone Raven RV02-EW] [Razer DeathAdder] [Razer Goliathus] 
  hide details  
Reply
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
[i7 2600k - 5.XGHz @ X.XXv] [ASUS P8P67 Pro B3] [2x MSI 7970s in Crossfire @ 1125/1650] [8GB G.Skill Ripjaws X 2x4GB] 
Hard DriveHard DriveCoolingCooling
[2TB Hitachi] [Crucial M4 SSD 64GB] [Antec Kuhler H20 920] [Lian-Li BZ BZ-502B] 
CoolingOSMonitorKeyboard
[G.Skill Turbulence II RAM Cooler] [Windows 7 Ultimate 64bit] [2x BenQ XL2410T @ 120Hz] [Razer Lycosa] 
PowerCaseMouseMouse Pad
[Corsair AX1200] [Silverstone Raven RV02-EW] [Razer DeathAdder] [Razer Goliathus] 
  hide details  
Reply
post #5738 of 38704
Quote:
Originally Posted by Smo View Post

Does anyone else have crossfire issues with Mass Effect 3? I've had to disable it for the moment as the screen flickers black constantly otherwise.
Optimization is awful too - with the game maxed out on one 7970 clocked at 1100/1600 I'm getting ~30-40fps.
This is with driver set 12.3 and cap 12.2 1.

I'm on a 7950 at 1200/1600 and I never drop under 60fps. Mainly flying around 30% GPU usage as well with VSync.

Also, does anyone ever have a problem where their clocks in game are at 501/1250, or 900/1600? Sometimes when I game, my clock speeds are at 501/1250, and my GPU usage is at a constant 100%. This results in absolutely horrible frames as well. A simple restart fixes it. But the problem has started happening quite often with the release of ME3 for some reason, not sure if this is what is causing it to happen again now. Not sure what I did to fix it last time.

I also have a little issue for whenever my PC first boots up, my clock speeds are at 900/1600 until I play a game and then exit, and then they idle at the normal 300/150. Anyone have these issues?
Literally da bes
(16 items)
 
  
CPUMotherboardGraphicsRAM
|Intel| i5-2500K @ 4.5GHz - 1.345v |ASRock| P67 Extreme4 Gen3 |MSI| GTX 970 Gaming 4GB |GSkill| Sniper Low Voltage 8GB DDR3 @ 1600 
Hard DriveHard DriveOptical DriveCooling
|Samsung| Spinpoint F3 1TB |Kingston| HyperX 3K 128GB BD-ROM |Cooler Master| Hyper 212+ 
OSMonitorPowerCase
|Microsoft| Win7 Professional 64-bit |ASUS| VH236H |Corsair| TX650 v2 |Corsair| Carbide 400R 
MouseMouse PadAudio
|Cooler Master| Storm Spawn |RAZER| Goliathus Speed |Creative| Insprire T10 
  hide details  
Reply
Literally da bes
(16 items)
 
  
CPUMotherboardGraphicsRAM
|Intel| i5-2500K @ 4.5GHz - 1.345v |ASRock| P67 Extreme4 Gen3 |MSI| GTX 970 Gaming 4GB |GSkill| Sniper Low Voltage 8GB DDR3 @ 1600 
Hard DriveHard DriveOptical DriveCooling
|Samsung| Spinpoint F3 1TB |Kingston| HyperX 3K 128GB BD-ROM |Cooler Master| Hyper 212+ 
OSMonitorPowerCase
|Microsoft| Win7 Professional 64-bit |ASUS| VH236H |Corsair| TX650 v2 |Corsair| Carbide 400R 
MouseMouse PadAudio
|Cooler Master| Storm Spawn |RAZER| Goliathus Speed |Creative| Insprire T10 
  hide details  
Reply
post #5739 of 38704
Quote:
Originally Posted by Invisible View Post

I'm on a 7950 at 1200/1600 and I never drop under 60fps. Mainly flying around 30% GPU usage as well with VSync.
Also, does anyone ever have a problem where their clocks in game are at 501/1250, or 900/1600? Sometimes when I game, my clock speeds are at 501/1250, and my GPU usage is at a constant 100%. This results in absolutely horrible frames as well. A simple restart fixes it. But the problem has started happening quite often with the release of ME3 for some reason, not sure if this is what is causing it to happen again now. Not sure what I did to fix it last time.
I also have a little issue for whenever my PC first boots up, my clock speeds are at 900/1600 until I play a game and then exit, and then they idle at the normal 300/150. Anyone have these issues?

In all honesty your issue sounds like an unstable overclock.

Can I ask which driver set/cap you're using? Is it the same as mine?
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
[i7 2600k - 5.XGHz @ X.XXv] [ASUS P8P67 Pro B3] [2x MSI 7970s in Crossfire @ 1125/1650] [8GB G.Skill Ripjaws X 2x4GB] 
Hard DriveHard DriveCoolingCooling
[2TB Hitachi] [Crucial M4 SSD 64GB] [Antec Kuhler H20 920] [Lian-Li BZ BZ-502B] 
CoolingOSMonitorKeyboard
[G.Skill Turbulence II RAM Cooler] [Windows 7 Ultimate 64bit] [2x BenQ XL2410T @ 120Hz] [Razer Lycosa] 
PowerCaseMouseMouse Pad
[Corsair AX1200] [Silverstone Raven RV02-EW] [Razer DeathAdder] [Razer Goliathus] 
  hide details  
Reply
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
[i7 2600k - 5.XGHz @ X.XXv] [ASUS P8P67 Pro B3] [2x MSI 7970s in Crossfire @ 1125/1650] [8GB G.Skill Ripjaws X 2x4GB] 
Hard DriveHard DriveCoolingCooling
[2TB Hitachi] [Crucial M4 SSD 64GB] [Antec Kuhler H20 920] [Lian-Li BZ BZ-502B] 
CoolingOSMonitorKeyboard
[G.Skill Turbulence II RAM Cooler] [Windows 7 Ultimate 64bit] [2x BenQ XL2410T @ 120Hz] [Razer Lycosa] 
PowerCaseMouseMouse Pad
[Corsair AX1200] [Silverstone Raven RV02-EW] [Razer DeathAdder] [Razer Goliathus] 
  hide details  
Reply
post #5740 of 38704
Quote:
Originally Posted by Smo View Post

In all honesty your issue sounds like an unstable overclock.
Can I ask which driver set/cap you're using? Is it the same as mine?

It's definitely most stable. Can play BF3 maxed and never drop under 60fps for hours, and same for other games, no problems at all. It's just this issue comes up very rarely at times.

And I'm pretty sure I'm at 12.3 (driver packaging version or what not says 8.96-120214a-133521E-ATI). I dont have crossfire so no CAP.
Literally da bes
(16 items)
 
  
CPUMotherboardGraphicsRAM
|Intel| i5-2500K @ 4.5GHz - 1.345v |ASRock| P67 Extreme4 Gen3 |MSI| GTX 970 Gaming 4GB |GSkill| Sniper Low Voltage 8GB DDR3 @ 1600 
Hard DriveHard DriveOptical DriveCooling
|Samsung| Spinpoint F3 1TB |Kingston| HyperX 3K 128GB BD-ROM |Cooler Master| Hyper 212+ 
OSMonitorPowerCase
|Microsoft| Win7 Professional 64-bit |ASUS| VH236H |Corsair| TX650 v2 |Corsair| Carbide 400R 
MouseMouse PadAudio
|Cooler Master| Storm Spawn |RAZER| Goliathus Speed |Creative| Insprire T10 
  hide details  
Reply
Literally da bes
(16 items)
 
  
CPUMotherboardGraphicsRAM
|Intel| i5-2500K @ 4.5GHz - 1.345v |ASRock| P67 Extreme4 Gen3 |MSI| GTX 970 Gaming 4GB |GSkill| Sniper Low Voltage 8GB DDR3 @ 1600 
Hard DriveHard DriveOptical DriveCooling
|Samsung| Spinpoint F3 1TB |Kingston| HyperX 3K 128GB BD-ROM |Cooler Master| Hyper 212+ 
OSMonitorPowerCase
|Microsoft| Win7 Professional 64-bit |ASUS| VH236H |Corsair| TX650 v2 |Corsair| Carbide 400R 
MouseMouse PadAudio
|Cooler Master| Storm Spawn |RAZER| Goliathus Speed |Creative| Insprire T10 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › [Official] AMD Radeon HD 7950/7970/7990 Owners Thread