Overclock.net › Forums › Intel › Intel Motherboards › No video output on z68 ASRock extreme3 - bad PCIE controller?`
New Posts  All Forums:Forum Nav:

No video output on z68 ASRock extreme3 - bad PCIE controller?`

post #1 of 6
Thread Starter 
I am building an ASRock z68 extreme 3 gen 3 on a 2600k. Everything boots up and I have windows 7 64 bit loaded on a samsung SSD drive. I get video output and can get into windows when I have the analog monitor output connected to the onboard analog output. However, I get no video output when I put the AMD 7900 video card into either PCIe slot. I have tried all monitor output plugs and both PCIe ports. I tried an additional video card I know to be working and I still have no video output. I haven't received any BSOD's. Let me know if anyone has any ideas. thanks.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.4GHz ASRock Z68 Extreme 4 Dual GTS 450 8GB GSkill Sniper 1866 
Hard DriveOSMonitorPower
64GB Crucial SSD and 500 GB storage Windows 7 64bit 3 Viewsonic LCD's Corsair 750W 
Case
Coolermaster HAF 942 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.4GHz ASRock Z68 Extreme 4 Dual GTS 450 8GB GSkill Sniper 1866 
Hard DriveOSMonitorPower
64GB Crucial SSD and 500 GB storage Windows 7 64bit 3 Viewsonic LCD's Corsair 750W 
Case
Coolermaster HAF 942 
  hide details  
Reply
post #2 of 6
Same thing happened to me..

I cleared CMOS a couple of times, and just shutdown/reboot with monitor plugged into video card.

Try changing the default video output to onboard in bios.

It eventually just started working for me.
post #3 of 6
I don't know tons about this, but you did attempt to install the driver right?
post #4 of 6
Thread Starter 
it should at least show some video output without drivers installed just to get you through the install and to windows so that you can install the drivers.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.4GHz ASRock Z68 Extreme 4 Dual GTS 450 8GB GSkill Sniper 1866 
Hard DriveOSMonitorPower
64GB Crucial SSD and 500 GB storage Windows 7 64bit 3 Viewsonic LCD's Corsair 750W 
Case
Coolermaster HAF 942 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.4GHz ASRock Z68 Extreme 4 Dual GTS 450 8GB GSkill Sniper 1866 
Hard DriveOSMonitorPower
64GB Crucial SSD and 500 GB storage Windows 7 64bit 3 Viewsonic LCD's Corsair 750W 
Case
Coolermaster HAF 942 
  hide details  
Reply
post #5 of 6
Thread Starter 
alright I feel like an idiot....spent about 3 hours now trouble shooting this thing, tried different motherboards, video cards, ram, pretty much everything....found the problem. cord was loose on the back of the monitor...
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.4GHz ASRock Z68 Extreme 4 Dual GTS 450 8GB GSkill Sniper 1866 
Hard DriveOSMonitorPower
64GB Crucial SSD and 500 GB storage Windows 7 64bit 3 Viewsonic LCD's Corsair 750W 
Case
Coolermaster HAF 942 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.4GHz ASRock Z68 Extreme 4 Dual GTS 450 8GB GSkill Sniper 1866 
Hard DriveOSMonitorPower
64GB Crucial SSD and 500 GB storage Windows 7 64bit 3 Viewsonic LCD's Corsair 750W 
Case
Coolermaster HAF 942 
  hide details  
Reply
post #6 of 6
Quote:
Originally Posted by saintpcr View Post

alright I feel like an idiot....spent about 3 hours now trouble shooting this thing, tried different motherboards, video cards, ram, pretty much everything....found the problem. cord was loose on the back of the monitor...

No worries, at least you found and fixed the problem. We are human therefore, we make mistakes.
My CM sniper
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8ghz @ 1.4v. ASRock Z68 EXTREME4 GEN3 EVGA gtx470 SC GSKILL SNIPER DDR3 1600 2X4 9.9.9.24 
Hard DriveOptical DriveOSMonitor
CRUCIAL 64GB SSD 1-VR300 4X F3 1TB SAMSUNG 22X SATA DVD BURNER WINDOWZ 7 64BIT 23'' ACER P235H WS 
KeyboardPowerCaseMouse
LOGITECH G15 V 2007 CORSAIR TX750 CM STORM SNIPER/ MODDED OCZ DOMINATRIX 
Mouse PadAudio
ALL OVER THE TABLE ON BOARD 
  hide details  
Reply
My CM sniper
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8ghz @ 1.4v. ASRock Z68 EXTREME4 GEN3 EVGA gtx470 SC GSKILL SNIPER DDR3 1600 2X4 9.9.9.24 
Hard DriveOptical DriveOSMonitor
CRUCIAL 64GB SSD 1-VR300 4X F3 1TB SAMSUNG 22X SATA DVD BURNER WINDOWZ 7 64BIT 23'' ACER P235H WS 
KeyboardPowerCaseMouse
LOGITECH G15 V 2007 CORSAIR TX750 CM STORM SNIPER/ MODDED OCZ DOMINATRIX 
Mouse PadAudio
ALL OVER THE TABLE ON BOARD 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › No video output on z68 ASRock extreme3 - bad PCIE controller?`