Overclock.net › Forums › Graphics Cards › AMD/ATI › Just installed 7970, no display... HELP!
New Posts  All Forums:Forum Nav:

Just installed 7970, no display... HELP! - Page 2

post #11 of 15
Oh man this thread is giving me horrible flashbacks of when I tried to upgradefrom an 8800GT to an HD4870 and spent hours and hours and hours trying to get video out before having to RMA the card. Same exact thing, black screen but Windows was definitely running. Tried different monitors, cables, everything, just couldn't get it going. Really hope you get this sorted out!
sugs
(13 items)
 
hdplex h3 htpc
(7 items)
 
 
CPUMotherboardGraphicsRAM
Intel 3570K ASRock Z77E-ITX MSI GTX660ti Samsung Green 2x4GB DDR3 
Hard DriveOptical DriveCoolingOS
Vertex 4 nope Thermalright AXP-140 Windows 7 Pro x64 
MonitorKeyboardPowerCase
HP ZR24w K800 SG08 PSU SilverstoneSG08 
Mouse
G700 
CPUMotherboardGraphicsRAM
i3-2125 Asus H61 mini-itx integrated intel hd3000 2x2gb g.skill eco ram 
Hard DriveOSCase
intel X-25m 80gb ssd Windows 7 x64 hdplex h3 
  hide details  
Reply
sugs
(13 items)
 
hdplex h3 htpc
(7 items)
 
 
CPUMotherboardGraphicsRAM
Intel 3570K ASRock Z77E-ITX MSI GTX660ti Samsung Green 2x4GB DDR3 
Hard DriveOptical DriveCoolingOS
Vertex 4 nope Thermalright AXP-140 Windows 7 Pro x64 
MonitorKeyboardPowerCase
HP ZR24w K800 SG08 PSU SilverstoneSG08 
Mouse
G700 
CPUMotherboardGraphicsRAM
i3-2125 Asus H61 mini-itx integrated intel hd3000 2x2gb g.skill eco ram 
Hard DriveOSCase
intel X-25m 80gb ssd Windows 7 x64 hdplex h3 
  hide details  
Reply
post #12 of 15
Thread Starter 
Fixed, I took out the 8 and 6 pin power adapter cables in the computer, and plugged power in straight from the PSU... Really annoying...

For the person who said too powerful for 775, waiting for Ivy Bridge + 7990 for tri-fire.. smile.gif
     
CPUMotherboardGraphicsRAM
i7 3820 WC'd ASRock Fatal1ty X79 Professional Sapphire + Gigabyte R9 290X CF WC'd 16GB G. Skill Ripjaws Z 
Hard DriveHard DriveOptical DriveCooling
2x 3TB Seagate Barracuda 7200.14 RAID 1 2x 250GB Samsung 840 Series SSD RAID 1 Samsung Burner w/ Lightscribe Custom Watercooling 
OSMonitorKeyboardPower
Windows 10 Professional 64-bit 55" 4K Samsung Curved TV Roccat Sova Mechanical Cooler Master Silent Pro 1200W Gold 
CaseMouseMouse PadAudio
Cooler Master HAF 922 w/ Dust Filters Roccat Kone XTD 2x XFX Warpad ODAC > Glow Amp One > K702/65 
AudioOther
Yamaha Receiver + 5.1 Xbox One Wireless Controller 
CPUMotherboardGraphicsRAM
Intel Core i5 540M @ 3.33Ghz DC 3.65Ghz SC Acer Intel HD 3000 + ATi Radeon HD 5650M Switchable 4GB 
Hard DriveOSMonitorMouse
OCZ Vertex 2 SSD Windows 10 Pro 64 bit 13.3" 1366x768 G403 
Audio
iBasso D-Zero Headphone AMP + DAC 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
i7 3820 WC'd ASRock Fatal1ty X79 Professional Sapphire + Gigabyte R9 290X CF WC'd 16GB G. Skill Ripjaws Z 
Hard DriveHard DriveOptical DriveCooling
2x 3TB Seagate Barracuda 7200.14 RAID 1 2x 250GB Samsung 840 Series SSD RAID 1 Samsung Burner w/ Lightscribe Custom Watercooling 
OSMonitorKeyboardPower
Windows 10 Professional 64-bit 55" 4K Samsung Curved TV Roccat Sova Mechanical Cooler Master Silent Pro 1200W Gold 
CaseMouseMouse PadAudio
Cooler Master HAF 922 w/ Dust Filters Roccat Kone XTD 2x XFX Warpad ODAC > Glow Amp One > K702/65 
AudioOther
Yamaha Receiver + 5.1 Xbox One Wireless Controller 
CPUMotherboardGraphicsRAM
Intel Core i5 540M @ 3.33Ghz DC 3.65Ghz SC Acer Intel HD 3000 + ATi Radeon HD 5650M Switchable 4GB 
Hard DriveOSMonitorMouse
OCZ Vertex 2 SSD Windows 10 Pro 64 bit 13.3" 1366x768 G403 
Audio
iBasso D-Zero Headphone AMP + DAC 
  hide details  
Reply
post #13 of 15
Make sure that your monitor is plugged into the FIRST slot on the card, otherwise it'll be read as the 2nd monitor and nothing will show up!
    
CPUMotherboardGraphicsRAM
i5-2500k  MSI z68ma-EP55 4870 1GB 8GB Kingston Hyper X DDR3 1333 (7-7-7-20) 
Hard DriveOptical DriveOSMonitor
60GB OCZ V2 SSD and lots of mech drives DVD-ROM Windows 7 chronic edition BENQ 1680X1050 
KeyboardPowerCaseMouse
Kinesis Freestyle PC Power and Cooling 610watt Lian Li PC-A04B wowpen joy 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2500k  MSI z68ma-EP55 4870 1GB 8GB Kingston Hyper X DDR3 1333 (7-7-7-20) 
Hard DriveOptical DriveOSMonitor
60GB OCZ V2 SSD and lots of mech drives DVD-ROM Windows 7 chronic edition BENQ 1680X1050 
KeyboardPowerCaseMouse
Kinesis Freestyle PC Power and Cooling 610watt Lian Li PC-A04B wowpen joy 
  hide details  
Reply
post #14 of 15
Quote:
Originally Posted by xxicrimsonixx View Post

Fixed, I took out the 8 and 6 pin power adapter cables in the computer, and plugged power in straight from the PSU... Really annoying...
For the person who said too powerful for 775, waiting for Ivy Bridge + 7990 for tri-fire.. smile.gif

Um, "straight from the psu"?

Isn't that how it's always supposed to be?
     
CPUMotherboardGraphicsGraphics
[Intel] Core i7 2630QM [Lenovo] 4239CTO [Intel](R) HD Graphics Family [NVIDIA] NVS 4200M  
RAMRAMHard DriveHard Drive
[Samsung] 4GB 1333MHz  [Corsair] 4GB 1333MHz [Patriot] Pyro 60GB Sata III  [Western Digital] Scorpio Black 500GB 7200rpm 1... 
Optical DriveOSOSMonitor
[Lenovo] DL-DT Drive [Microsoft] Windows 7 64-bit SP1 Professional Kubuntu 64bit 11.10 [LG] 15.6in 1600x900  
PowerCaseMouseMouse Pad
[Lenovo] Power Brick 130w [Lenovo] ThinkPad T520 [Logitech] G500 [Razr] Goliathus Medium 
  hide details  
Reply
     
CPUMotherboardGraphicsGraphics
[Intel] Core i7 2630QM [Lenovo] 4239CTO [Intel](R) HD Graphics Family [NVIDIA] NVS 4200M  
RAMRAMHard DriveHard Drive
[Samsung] 4GB 1333MHz  [Corsair] 4GB 1333MHz [Patriot] Pyro 60GB Sata III  [Western Digital] Scorpio Black 500GB 7200rpm 1... 
Optical DriveOSOSMonitor
[Lenovo] DL-DT Drive [Microsoft] Windows 7 64-bit SP1 Professional Kubuntu 64bit 11.10 [LG] 15.6in 1600x900  
PowerCaseMouseMouse Pad
[Lenovo] Power Brick 130w [Lenovo] ThinkPad T520 [Logitech] G500 [Razr] Goliathus Medium 
  hide details  
Reply
post #15 of 15
Quote:
Originally Posted by xxicrimsonixx View Post

Fixed, I took out the 8 and 6 pin power adapter cables in the computer, and plugged power in straight from the PSU... Really annoying...
For the person who said too powerful for 775, waiting for Ivy Bridge + 7990 for tri-fire.. smile.gif

Never use those cheesy power chord adapters that they send with the card. Just plug it in directly from your psu pci power cable. tongue.gif
Voodoo Omen x79
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel I7 4930k  Asus Rampage IV Black Edition  EVGA GTX Titan 16gb Corsair Dominator Platinum ddr3 2400mhz 
Hard DriveHard DriveOptical DriveCooling
WD RE3 1TB 7200rpm  Samsung 840 Pro SSD 256gb Boot OS LG BluRay Player All disc reader/burner Corsair H80i 
OSMonitorKeyboardPower
Windows 7 Home Premium 64bit Samsung Syncmaster 26'' LCD 5ms 1920x1200 Razer Lycossa Thermaltake Toughpower 1200watt 
CaseMouse
Voodoo Omen Razer Mamba Wireless 
  hide details  
Reply
Voodoo Omen x79
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel I7 4930k  Asus Rampage IV Black Edition  EVGA GTX Titan 16gb Corsair Dominator Platinum ddr3 2400mhz 
Hard DriveHard DriveOptical DriveCooling
WD RE3 1TB 7200rpm  Samsung 840 Pro SSD 256gb Boot OS LG BluRay Player All disc reader/burner Corsair H80i 
OSMonitorKeyboardPower
Windows 7 Home Premium 64bit Samsung Syncmaster 26'' LCD 5ms 1920x1200 Razer Lycossa Thermaltake Toughpower 1200watt 
CaseMouse
Voodoo Omen Razer Mamba Wireless 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Just installed 7970, no display... HELP!