Overclock.net › Forums › Graphics Cards › AMD/ATI › Weird Eyefinity stuttering issues. Please help!
New Posts  All Forums:Forum Nav:

Weird Eyefinity stuttering issues. Please help!

post #1 of 53
Thread Starter 
Hey guys,

So I just upgraded to 2x7970s, but this issue has been driving me completely nuts since a long time ago. I've had 6990+6970 and it was the same.

So here's the problem - when I game in eyefinity even though my average fps is high (50-60 fps), the game feels and looks like I'm playing at like 30 fps or lower. If I use some sort of a frame clipping program to cap my fps at just below the average frame rate (say 49), everything is silky smooth. It happens in all the games I play pretty much (BF3, pCARS, etc.) and only in eyefinity. Single screen it's just fine.

Now, here's the kicker. I wanted to record a video of this problem using BF3 and clipping the fps using the console command in that game. So I recorded it, but when I watched it - the video looked perfectly smooth all the way through, even though in-game it was choppy even at 50fps, until I clipped the fps at 45, at which point the game became smooth. So this left me scratching my head...

I have a central monitor which is a 120Hz Samsung sa950d and two side Acer s231 hls. The main monitor is connected through a Dual-Link DVI cable, and the other two are connected to hdmi and minidisplay ports on the card, however the cables going to the monitors are DVI - I'm using an active dvi to minidisplay converter cable for one, and a dvi to hdmi converter cable for the other.

So I really don't know what my problem is, but it appears that it's not my video cards or motherboard but something to do with connection to my monitors maybe?

Any help would be greatly appreciated.

This has been driving me nuts for months now!!
MyRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 3960x Gigabyte GA-X79-UD3 3 x EVGA GTX 680 Corsair XMS3 16Gb @ 1600Mhz 
Hard DriveHard DriveHard DriveOS
WD Caviar Black 7200 RPM 500 Gb + Intel 311 SSD... WD Caviar Green 500 Gb (Data)  Crucial m4 SSD 128GB Windows 7 64-bit 
MonitorPowerCaseMouse
3 x Samsung 23" SA950D Corsair HX1050 Thermaltake Chaser MK-1 Logitech G5 
Audio
Logitech Wireless Gaming Headset G930 with 7.1 ... 
  hide details  
Reply
MyRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 3960x Gigabyte GA-X79-UD3 3 x EVGA GTX 680 Corsair XMS3 16Gb @ 1600Mhz 
Hard DriveHard DriveHard DriveOS
WD Caviar Black 7200 RPM 500 Gb + Intel 311 SSD... WD Caviar Green 500 Gb (Data)  Crucial m4 SSD 128GB Windows 7 64-bit 
MonitorPowerCaseMouse
3 x Samsung 23" SA950D Corsair HX1050 Thermaltake Chaser MK-1 Logitech G5 
Audio
Logitech Wireless Gaming Headset G930 with 7.1 ... 
  hide details  
Reply
post #2 of 53
I'm not sure if you have aware of the micro-stuttering issues when using cross fire or SLI? If you don't experience problems while using one single card, then I would discard an adapter/monitor issue and focus on the micro-stutter issue which is common as far as I know
My System
(20 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus WS Revolution P67 Nvidia 460 EVGA Superclocked Nvidia 460 EVGA Superclocked 
GraphicsRAMHard DriveHard Drive
Nvidia 240GT Dedicated Physx 16GB DDR3 1333 Mushkin 4x4gb Corsair SSD Seagate 2TB HDD 
Hard DriveOptical DriveCoolingOS
Seagate 2TB HDD None :D Megahalem Windows 7 Ultimate 64-bit 
MonitorMonitorMonitorKeyboard
Dell 2407WFP  Dell 2407WFPb  Dell 2407WFP Old Genius Kb -_- 
PowerCaseMouseMouse Pad
Corsair 1000w Chieftec Server modded Razer Mamba Rainbow Six Collector Edition Mouse pad 
  hide details  
Reply
My System
(20 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus WS Revolution P67 Nvidia 460 EVGA Superclocked Nvidia 460 EVGA Superclocked 
GraphicsRAMHard DriveHard Drive
Nvidia 240GT Dedicated Physx 16GB DDR3 1333 Mushkin 4x4gb Corsair SSD Seagate 2TB HDD 
Hard DriveOptical DriveCoolingOS
Seagate 2TB HDD None :D Megahalem Windows 7 Ultimate 64-bit 
MonitorMonitorMonitorKeyboard
Dell 2407WFP  Dell 2407WFPb  Dell 2407WFP Old Genius Kb -_- 
PowerCaseMouseMouse Pad
Corsair 1000w Chieftec Server modded Razer Mamba Rainbow Six Collector Edition Mouse pad 
  hide details  
Reply
post #3 of 53
Thread Starter 
Quote:
Originally Posted by Razorstorm View Post

I'm not sure if you have aware of the micro-stuttering issues when using cross fire or SLI? If you don't experience problems while using one single card, then I would discard an adapter/monitor issue and focus on the micro-stutter issue which is common as far as I know

Yeah, as far as I know microstuttering is an issue when you get a sudden jerk in the frames, but for me it feels like the game runs at lower fps, even though average fps reported by the game or AB is high.

Again, when I recorded the video using Afterburner's video recording and replayed it back - video was silky smooth at all times, so I'm not sure what the deal is here.
MyRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 3960x Gigabyte GA-X79-UD3 3 x EVGA GTX 680 Corsair XMS3 16Gb @ 1600Mhz 
Hard DriveHard DriveHard DriveOS
WD Caviar Black 7200 RPM 500 Gb + Intel 311 SSD... WD Caviar Green 500 Gb (Data)  Crucial m4 SSD 128GB Windows 7 64-bit 
MonitorPowerCaseMouse
3 x Samsung 23" SA950D Corsair HX1050 Thermaltake Chaser MK-1 Logitech G5 
Audio
Logitech Wireless Gaming Headset G930 with 7.1 ... 
  hide details  
Reply
MyRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 3960x Gigabyte GA-X79-UD3 3 x EVGA GTX 680 Corsair XMS3 16Gb @ 1600Mhz 
Hard DriveHard DriveHard DriveOS
WD Caviar Black 7200 RPM 500 Gb + Intel 311 SSD... WD Caviar Green 500 Gb (Data)  Crucial m4 SSD 128GB Windows 7 64-bit 
MonitorPowerCaseMouse
3 x Samsung 23" SA950D Corsair HX1050 Thermaltake Chaser MK-1 Logitech G5 
Audio
Logitech Wireless Gaming Headset G930 with 7.1 ... 
  hide details  
Reply
post #4 of 53

Mixed and mismatched monitors in the group? What refresh rate set for each monitor? 

ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
post #5 of 53
Thread Starter 
60 hz for each, 1080p res for each.

I think that it happens with a single card too but to a lesser extent, since my fps is a lot lower anyway.
Edited by FcZenitFan - 1/25/12 at 5:52pm
MyRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 3960x Gigabyte GA-X79-UD3 3 x EVGA GTX 680 Corsair XMS3 16Gb @ 1600Mhz 
Hard DriveHard DriveHard DriveOS
WD Caviar Black 7200 RPM 500 Gb + Intel 311 SSD... WD Caviar Green 500 Gb (Data)  Crucial m4 SSD 128GB Windows 7 64-bit 
MonitorPowerCaseMouse
3 x Samsung 23" SA950D Corsair HX1050 Thermaltake Chaser MK-1 Logitech G5 
Audio
Logitech Wireless Gaming Headset G930 with 7.1 ... 
  hide details  
Reply
MyRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 3960x Gigabyte GA-X79-UD3 3 x EVGA GTX 680 Corsair XMS3 16Gb @ 1600Mhz 
Hard DriveHard DriveHard DriveOS
WD Caviar Black 7200 RPM 500 Gb + Intel 311 SSD... WD Caviar Green 500 Gb (Data)  Crucial m4 SSD 128GB Windows 7 64-bit 
MonitorPowerCaseMouse
3 x Samsung 23" SA950D Corsair HX1050 Thermaltake Chaser MK-1 Logitech G5 
Audio
Logitech Wireless Gaming Headset G930 with 7.1 ... 
  hide details  
Reply
post #6 of 53
does it happen if you use a single monitor? or just eyefinity? If happens only in eyefinity, have you tried with other games? and if issue persists with other games, have you tried Softth to test if issue disappear? ( i know its not compatible with BF3, but could help see if issue persists wheter or not eyefinity is present
My System
(20 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus WS Revolution P67 Nvidia 460 EVGA Superclocked Nvidia 460 EVGA Superclocked 
GraphicsRAMHard DriveHard Drive
Nvidia 240GT Dedicated Physx 16GB DDR3 1333 Mushkin 4x4gb Corsair SSD Seagate 2TB HDD 
Hard DriveOptical DriveCoolingOS
Seagate 2TB HDD None :D Megahalem Windows 7 Ultimate 64-bit 
MonitorMonitorMonitorKeyboard
Dell 2407WFP  Dell 2407WFPb  Dell 2407WFP Old Genius Kb -_- 
PowerCaseMouseMouse Pad
Corsair 1000w Chieftec Server modded Razer Mamba Rainbow Six Collector Edition Mouse pad 
  hide details  
Reply
My System
(20 items)
 
  
CPUMotherboardGraphicsGraphics
i7 2600k Asus WS Revolution P67 Nvidia 460 EVGA Superclocked Nvidia 460 EVGA Superclocked 
GraphicsRAMHard DriveHard Drive
Nvidia 240GT Dedicated Physx 16GB DDR3 1333 Mushkin 4x4gb Corsair SSD Seagate 2TB HDD 
Hard DriveOptical DriveCoolingOS
Seagate 2TB HDD None :D Megahalem Windows 7 Ultimate 64-bit 
MonitorMonitorMonitorKeyboard
Dell 2407WFP  Dell 2407WFPb  Dell 2407WFP Old Genius Kb -_- 
PowerCaseMouseMouse Pad
Corsair 1000w Chieftec Server modded Razer Mamba Rainbow Six Collector Edition Mouse pad 
  hide details  
Reply
post #7 of 53

Try this;

 

SA950D,  DVI > DVI > 7970

S231HLS, DVI > DVI to Mini DP Active Adapter > 7970

S231HLS, DVI > DVI to Mini DP Active Adapter > 7970

 

You must have the Active adapter from previous setup.

ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
post #8 of 53
Thread Starter 
Quote:
Originally Posted by Razorstorm View Post

does it happen if you use a single monitor? or just eyefinity? If happens only in eyefinity, have you tried with other games? and if issue persists with other games, have you tried Softth to test if issue disappear? ( i know its not compatible with BF3, but could help see if issue persists wheter or not eyefinity is present

Single monitor is fine, no problems there. Only in eyefinity at 5760x1080 or higher. Single card seems to have issues too like I said, but hard to tell since fps is not that high. Happens in other games two, at least 2 that I know of. Haven't tried softth.
MyRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 3960x Gigabyte GA-X79-UD3 3 x EVGA GTX 680 Corsair XMS3 16Gb @ 1600Mhz 
Hard DriveHard DriveHard DriveOS
WD Caviar Black 7200 RPM 500 Gb + Intel 311 SSD... WD Caviar Green 500 Gb (Data)  Crucial m4 SSD 128GB Windows 7 64-bit 
MonitorPowerCaseMouse
3 x Samsung 23" SA950D Corsair HX1050 Thermaltake Chaser MK-1 Logitech G5 
Audio
Logitech Wireless Gaming Headset G930 with 7.1 ... 
  hide details  
Reply
MyRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 3960x Gigabyte GA-X79-UD3 3 x EVGA GTX 680 Corsair XMS3 16Gb @ 1600Mhz 
Hard DriveHard DriveHard DriveOS
WD Caviar Black 7200 RPM 500 Gb + Intel 311 SSD... WD Caviar Green 500 Gb (Data)  Crucial m4 SSD 128GB Windows 7 64-bit 
MonitorPowerCaseMouse
3 x Samsung 23" SA950D Corsair HX1050 Thermaltake Chaser MK-1 Logitech G5 
Audio
Logitech Wireless Gaming Headset G930 with 7.1 ... 
  hide details  
Reply
post #9 of 53
Thread Starter 
Quote:
Originally Posted by Ken1649 View Post

Try this;

SA950D,  DVI > DVI > 7970
S231HLS, DVI > DVI to Mini DP Active Adapter > 7970
S231HLS, DVI > DVI to Mini DP Active Adapter > 7970

You must have the Active adapter from previous setup.

Tried that. Actually got worse. The new one I connected with started sorta flickering from time to time in-game. The stuttering still there.
MyRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 3960x Gigabyte GA-X79-UD3 3 x EVGA GTX 680 Corsair XMS3 16Gb @ 1600Mhz 
Hard DriveHard DriveHard DriveOS
WD Caviar Black 7200 RPM 500 Gb + Intel 311 SSD... WD Caviar Green 500 Gb (Data)  Crucial m4 SSD 128GB Windows 7 64-bit 
MonitorPowerCaseMouse
3 x Samsung 23" SA950D Corsair HX1050 Thermaltake Chaser MK-1 Logitech G5 
Audio
Logitech Wireless Gaming Headset G930 with 7.1 ... 
  hide details  
Reply
MyRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 3960x Gigabyte GA-X79-UD3 3 x EVGA GTX 680 Corsair XMS3 16Gb @ 1600Mhz 
Hard DriveHard DriveHard DriveOS
WD Caviar Black 7200 RPM 500 Gb + Intel 311 SSD... WD Caviar Green 500 Gb (Data)  Crucial m4 SSD 128GB Windows 7 64-bit 
MonitorPowerCaseMouse
3 x Samsung 23" SA950D Corsair HX1050 Thermaltake Chaser MK-1 Logitech G5 
Audio
Logitech Wireless Gaming Headset G930 with 7.1 ... 
  hide details  
Reply
post #10 of 53
Sorry to hi-jack this thread with my somewhat long post, but I have had a similar experience with BF3 (note, I only play BF3 and nothing else at the moment. All other games I've recently played with CFX/Eyefinity have pretty much been perfect and smooth):

The problem you are describing happens to me to in BF3 on a 6990 in Eyefinity (5760x1080) I have literally spent hours and hours over the last few days trying to fix this. Yesterday alone, I probably spent 4 hours testing different things. At one point, I had BF3 playing as smooth as silk at 5760x1080 -- it almost felt like I was playing an old, less demanding game like CoD2 or something it was that fluid-- but of course, when I rebooted/changed servers it was back to stuttering. I achieved that by making a custom profile for bf3.exe in CCC with everything set to 'Use Application Settings' and all sliders set to 'Performance' and by forcing the game to use the Dirt3 profile for the Crossfire mode.

I've tried countless drivers, both AMD official and the weekly unofficial drivers that most have never heard of from the Guru3D forums (8.94, 8.945, 8.95 etc), I put together my own "hybrid" driver using the .dll's, application packages, and other files from several different driver sets, and I even converted the binary .blb file that houses the application profiles to XML and back to edit it and make my own app profile for BF3. I always perform a very thorough (~15 minutes) uninstallation -- probably WAY more thorough than most people -- using multiple tools, manual registry editing, and manual file deletion when testing new drivers. Not much has worked.

Sometimes the game is pretty smooth but most of the time it has the effect that you describe (pretty high fps but feels a lot lower). I only play B2K maps and I get about 50-80 fps depending on the map/area of the map. I've also tried various in-game options and user.cfg edits and different values for the RenderDevice. settings in BF3 as well as making multiple brand-new PROF_SAVE_profile config files with different settings.

In short, I've spent a ridiculous amount of time trying to make BF3 run butter smooth. But I know it can be done on multi-GPU setups without stutter, I experienced it first-hand for a game or two when I used the Dirt3 profile...It was so smooth/fast/fluid that it felt like I had speed hacks enabled or something, compared to what it usually plays like. At this point, I'm convinced that the problem lies somewhere in the game itself and it is unlikely to be fixed, since people who shell out the premium bucks for multi-GPU and multi-monitor setups are so few and far between.

Sorry for the long post, but I am at my wit's end and just about done with tweaking anything else to get this thing to run nicely. During this process, I have learned a lot about how AMD's drivers work, and I've discovered that they are absolutely horrible. This experience alone has converted me into a Day-1 nVidia Kepler purchaser. Good luck getting this resolved. Let me know if you ever find a solution.
Edited by xartion - 1/25/12 at 6:34pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Weird Eyefinity stuttering issues. Please help!