Overclock.net › Forums › Components › Hard Drives & Storage › SSD › OCZ Agility 3; random disconnection causing BSOD
New Posts  All Forums:Forum Nav:

OCZ Agility 3; random disconnection causing BSOD

post #1 of 5
Thread Starter 
Hello,

I recently bought a OCZ agility 3 60 gigs version and find that there is a very annoying problem with it. The SSD would randomly stop working causing a BSOD. Then when i restart my computer would tell me that there is no Hard drive detected. I then have to manually go in to the BIOS and change my hard drive priority from my HDD back to SSD.

I have updated the firmware of the SSD, it decrease the problem by alot but i still get the same problem about once a week.
I was wondering any of you guys also have this problem with the SSD and if so are there any solutions?


Thanks
-Martin biggrin.gif
post #2 of 5
Uninstall any SATA drivers you may have installed or if you have none installed then install the latest.

If that doesn't work I suggest you Secure erase and reinstall.

All info and guides are here. www.overclock.net/ssd/1156654-seans-windows-7-install-guide-optimization.html

Then if that doesn't work then RMA or return and get a Crucial M4 or Samsung 830.
post #3 of 5
Martin, are you running firmware 2.15 on the drive?

If so, are you running the latest bios for your motherboard? A lot of board makers released bios updates with Sata 6gb/s bugfixes in the last few months.

And are you running the latest version of Intel rapid storage technology for your board?

Also, OCZ recommends when the firmware is updated to remove the battery or use the jumper to reset the cmos to fresh on your board.

My Vertex 3 seemed to be stable on firmware 2.09 but lost speed. When they came out with 2.11, the speed was returned and so was the bsod. At that point, I gave up on OCZ and started using my Vertex 3 as a Steam only drive.
Upstairs Rig
(11 items)
 
  
CPUMotherboardGraphicsRAM
4770k Asus Maximus VI Hero evga 1080 Ti with Hybrid mod Corsair Vengeance Pro 2133 mhz 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500gb WD Caviar Black Corsair h100i GTX Windows 8.1 64bit 
MonitorPowerCase
xb280hk EVGA Supernova 1000 G2 Corsair Carbide Air 540 
  hide details  
Reply
Upstairs Rig
(11 items)
 
  
CPUMotherboardGraphicsRAM
4770k Asus Maximus VI Hero evga 1080 Ti with Hybrid mod Corsair Vengeance Pro 2133 mhz 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 500gb WD Caviar Black Corsair h100i GTX Windows 8.1 64bit 
MonitorPowerCase
xb280hk EVGA Supernova 1000 G2 Corsair Carbide Air 540 
  hide details  
Reply
post #4 of 5
Thread Starter 
Thanks for the advice,

I just finished updating my firmware to 2.15 and also install the newest Intel rapid storage technology. So hopefully that will make it more stable.

Thanks
post #5 of 5
My OCZ Agility 3 drives didn't respond well at all to the Intel rst drivers. Works perfectly with the MS AHCI drivers.
However the OS was loaded with the ms ahci drivers and then I switched to Intel months later. Fwiw.
Mild Mod
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-5930k 4.5Ghz @1.331v Asus X99-A EVGA GTX1070 SC 16Gb Gskill DDR4-2400 
Hard DriveOptical DriveCoolingCooling
850 Pro SSD, 2 Cav Blacks Asus HWLabs 280mm SR-1 and GTX120 mm radiators EK GPU waterblock and backplate 
CoolingOSMonitorKeyboard
EK Supremacy EVO cpu block W7 64 Pro Dell U3011  Razer BlackWidow Ultimate 
PowerCaseMouseAudio
Corsair AX850 Corsair 650d Modded SteelSeries Sensei Raw (heat orange) Creative 5.1 setup 
Audio
Creative Soundblaster Z 
  hide details  
Reply
Mild Mod
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-5930k 4.5Ghz @1.331v Asus X99-A EVGA GTX1070 SC 16Gb Gskill DDR4-2400 
Hard DriveOptical DriveCoolingCooling
850 Pro SSD, 2 Cav Blacks Asus HWLabs 280mm SR-1 and GTX120 mm radiators EK GPU waterblock and backplate 
CoolingOSMonitorKeyboard
EK Supremacy EVO cpu block W7 64 Pro Dell U3011  Razer BlackWidow Ultimate 
PowerCaseMouseAudio
Corsair AX850 Corsair 650d Modded SteelSeries Sensei Raw (heat orange) Creative 5.1 setup 
Audio
Creative Soundblaster Z 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › OCZ Agility 3; random disconnection causing BSOD