Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › RAID issues, can't install unsigned drivers
New Posts  All Forums:Forum Nav:

RAID issues, can't install unsigned drivers

post #1 of 22
Thread Starter 
Hi all,

Thought I'd finally set up a raid on my new build, but that turned out to be much harder than I expected.

I've been struggeling for hours now with various issues in regards to this.

To see the specs for the build in question, please look at the Extreme Vengeance tab for my builds.

It started up with the RAID0 volume not showing up, after poking thru the manual it turned out I had to install the drivers from a USB disc while installing Windows in order to solve this - so went on creating an USB drive based on the Motherboards support DVD to use.
During the regular install I get told that in my own interperation "**** you for trying to install unsigned drivers, love Microsoft". So then I tried going thru the "backway" by chosing Repair and do load drives from there. There I am able to install the x32 bit drivers, but the x64's always fails. Might be that it doesnt like it given that the windows instal enviroment is 32 bit or something? Anyhow..
Once I have installed the x32 bit drivers, the volume shows up. I go back, preform a run for a clean install - everything seems to work perfectly I and were finally happy. But no, after it's first restart I end up with the Windows Boot Manager whining about the file iaStorA.sys missing or being corrupted.

I am this -> || close to giving up RAID and just go for a regular disk, if I'm not able to get a solution to this pretty soon as it's annoying the hell out of me!

Any help, suggestions or inputs would be great!
     
CPUMotherboardGraphicsRAM
Intel® Core i7-3930K Processor OC@4.25Ghz ASUS RAMPAGE IV EXTREME/BF3, Socket-2011 HIS Radeon HD 7970 3GB GDDR5 x2 in CrossX Corsair XMS3 1866MHz 8GB Vengeance CL9 x2 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Caviar® Black 250GB Western Digital Caviar® Green 250GB Seagate FreeAgent® GoFlex Desk 2TB ASUS BW-12B1LT, Blu-Ray Writer 
CoolingOSKeyboardPower
Corsair H100 Hydro Series Windows 7 Ultimate x64 Corsair Vengeance K60 Performance Corsair AX 1200W PSU 
CaseMouseMouse Pad
Lian Li PC-V2120B Big Tower Razer Mamba 4G Gaming Mouse SteelSeries QCK 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel® Core i7-3930K Processor OC@4.25Ghz ASUS RAMPAGE IV EXTREME/BF3, Socket-2011 HIS Radeon HD 7970 3GB GDDR5 x2 in CrossX Corsair XMS3 1866MHz 8GB Vengeance CL9 x2 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Caviar® Black 250GB Western Digital Caviar® Green 250GB Seagate FreeAgent® GoFlex Desk 2TB ASUS BW-12B1LT, Blu-Ray Writer 
CoolingOSKeyboardPower
Corsair H100 Hydro Series Windows 7 Ultimate x64 Corsair Vengeance K60 Performance Corsair AX 1200W PSU 
CaseMouseMouse Pad
Lian Li PC-V2120B Big Tower Razer Mamba 4G Gaming Mouse SteelSeries QCK 
  hide details  
Reply
post #2 of 22
Are you just trying to add raid drives, like backup drives. Or you trying to enable raid and then install a os. Or enable raid and restore a backup copy of windows to it? Are you using the intel raid or the marvel/micron raid? As the intel you will not need a drive installing the os from a fresh install. The marvel/micron you will need a driver. Thanks

Try this and see what it gets you.
Quote:
Go into the registry using regedit and change each of the "start" values in the registry keys below from 3 to 0 and this will allow you to change between the different modes by just changing the option in your bios each time you reboot.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\servic es\pciide

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\servic es\msahci

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\servic es\iaStorV

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\servic es\iaStor

You might not have the last registry key (iastor) as this is installed in the registry with the intel raid drivers, the default windows 7 raid driver uses the iastorV key.
post #3 of 22
Thread Starter 
Forgot to spesify it directly, but as this is a completely new build - this is in order to install the OS. And yes, I am using the Intel chipset, no it is not showing the volume without a driver installed. I've tried the most now, just aint working.

Not sure when it goes wrong, but installing the 32 bit driver from the repair menues and load drives from there seems to be working all the way up until the first restart.
Edited by Ghostscript - 1/31/12 at 4:31pm
     
CPUMotherboardGraphicsRAM
Intel® Core i7-3930K Processor OC@4.25Ghz ASUS RAMPAGE IV EXTREME/BF3, Socket-2011 HIS Radeon HD 7970 3GB GDDR5 x2 in CrossX Corsair XMS3 1866MHz 8GB Vengeance CL9 x2 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Caviar® Black 250GB Western Digital Caviar® Green 250GB Seagate FreeAgent® GoFlex Desk 2TB ASUS BW-12B1LT, Blu-Ray Writer 
CoolingOSKeyboardPower
Corsair H100 Hydro Series Windows 7 Ultimate x64 Corsair Vengeance K60 Performance Corsair AX 1200W PSU 
CaseMouseMouse Pad
Lian Li PC-V2120B Big Tower Razer Mamba 4G Gaming Mouse SteelSeries QCK 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel® Core i7-3930K Processor OC@4.25Ghz ASUS RAMPAGE IV EXTREME/BF3, Socket-2011 HIS Radeon HD 7970 3GB GDDR5 x2 in CrossX Corsair XMS3 1866MHz 8GB Vengeance CL9 x2 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Caviar® Black 250GB Western Digital Caviar® Green 250GB Seagate FreeAgent® GoFlex Desk 2TB ASUS BW-12B1LT, Blu-Ray Writer 
CoolingOSKeyboardPower
Corsair H100 Hydro Series Windows 7 Ultimate x64 Corsair Vengeance K60 Performance Corsair AX 1200W PSU 
CaseMouseMouse Pad
Lian Li PC-V2120B Big Tower Razer Mamba 4G Gaming Mouse SteelSeries QCK 
  hide details  
Reply
post #4 of 22
Have you tried using your mobo disk directly and not through the USB?
post #5 of 22
Thread Starter 
Tried that too, but ironically enough the way it's suppose to be done thru that one - as long as I haven't missed out on anything, might have quick look at it again, is to make a USB stick to then load it from. So yeah, so far thats been a dead end too. But I'll look up on the manual on it, in case I've missed something there.
     
CPUMotherboardGraphicsRAM
Intel® Core i7-3930K Processor OC@4.25Ghz ASUS RAMPAGE IV EXTREME/BF3, Socket-2011 HIS Radeon HD 7970 3GB GDDR5 x2 in CrossX Corsair XMS3 1866MHz 8GB Vengeance CL9 x2 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Caviar® Black 250GB Western Digital Caviar® Green 250GB Seagate FreeAgent® GoFlex Desk 2TB ASUS BW-12B1LT, Blu-Ray Writer 
CoolingOSKeyboardPower
Corsair H100 Hydro Series Windows 7 Ultimate x64 Corsair Vengeance K60 Performance Corsair AX 1200W PSU 
CaseMouseMouse Pad
Lian Li PC-V2120B Big Tower Razer Mamba 4G Gaming Mouse SteelSeries QCK 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel® Core i7-3930K Processor OC@4.25Ghz ASUS RAMPAGE IV EXTREME/BF3, Socket-2011 HIS Radeon HD 7970 3GB GDDR5 x2 in CrossX Corsair XMS3 1866MHz 8GB Vengeance CL9 x2 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Caviar® Black 250GB Western Digital Caviar® Green 250GB Seagate FreeAgent® GoFlex Desk 2TB ASUS BW-12B1LT, Blu-Ray Writer 
CoolingOSKeyboardPower
Corsair H100 Hydro Series Windows 7 Ultimate x64 Corsair Vengeance K60 Performance Corsair AX 1200W PSU 
CaseMouseMouse Pad
Lian Li PC-V2120B Big Tower Razer Mamba 4G Gaming Mouse SteelSeries QCK 
  hide details  
Reply
post #6 of 22
did you have your usb configuration set right?
get the intel drivers..and put them in the root of your usb
maybe your bios isn't set right for the usb...
 
Thuban Powah!
(14 items)
 
 
CPUMotherboardGraphicsRAM
Xeon X5650 Asus P6X58D-E Sapphire HD 7950 G.Skill Trident-X 2600 CL10 
Hard DriveCoolingPowerCase
Samsung 840 pro Bong cooler / RASA waterblock Rosewill Capstone Gold 750 None 
MouseMouse PadAudio
cheap! Newegg box panel ibeats with onboard. 
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1075T w/2 cores locked @ 4.2+ M4a89GTD-Pro XFX Radeon HD 5870 8gb Samsung ddr3 1600 11-11-11-28@ 8-8-8-24 
Hard DriveHard DriveOptical DriveCooling
OCZ Agility2 40gb WD Blue 500GB Lite-On RASA waterblock 
OSMonitorKeyboardPower
Windows & Linux Samsung 1080p 2 ms Dell Thermaltake TR2-800 
CaseMouse
Cooler Master Elite 330 (was) cheap 
  hide details  
Reply
 
Thuban Powah!
(14 items)
 
 
CPUMotherboardGraphicsRAM
Xeon X5650 Asus P6X58D-E Sapphire HD 7950 G.Skill Trident-X 2600 CL10 
Hard DriveCoolingPowerCase
Samsung 840 pro Bong cooler / RASA waterblock Rosewill Capstone Gold 750 None 
MouseMouse PadAudio
cheap! Newegg box panel ibeats with onboard. 
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1075T w/2 cores locked @ 4.2+ M4a89GTD-Pro XFX Radeon HD 5870 8gb Samsung ddr3 1600 11-11-11-28@ 8-8-8-24 
Hard DriveHard DriveOptical DriveCooling
OCZ Agility2 40gb WD Blue 500GB Lite-On RASA waterblock 
OSMonitorKeyboardPower
Windows & Linux Samsung 1080p 2 ms Dell Thermaltake TR2-800 
CaseMouse
Cooler Master Elite 330 (was) cheap 
  hide details  
Reply
post #7 of 22
Thread Starter 
Trying a new run here now. I got the signed error when trying to install from the Install menue, but for somewhat reason the disks acutally showed up this time. Half way thru now, but I suppose I will end on the missing/corrupted error this time arround as well. I'll give myself 1 hour 20 mins more to solve it, if not I'll just go with a regular disk tongue.gif

Update:

Yes, same **** again... doesn't seem to be working no matter what.. this time I tried with the files downloaded from the ASUS site...
Edited by Ghostscript - 1/31/12 at 4:45pm
     
CPUMotherboardGraphicsRAM
Intel® Core i7-3930K Processor OC@4.25Ghz ASUS RAMPAGE IV EXTREME/BF3, Socket-2011 HIS Radeon HD 7970 3GB GDDR5 x2 in CrossX Corsair XMS3 1866MHz 8GB Vengeance CL9 x2 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Caviar® Black 250GB Western Digital Caviar® Green 250GB Seagate FreeAgent® GoFlex Desk 2TB ASUS BW-12B1LT, Blu-Ray Writer 
CoolingOSKeyboardPower
Corsair H100 Hydro Series Windows 7 Ultimate x64 Corsair Vengeance K60 Performance Corsair AX 1200W PSU 
CaseMouseMouse Pad
Lian Li PC-V2120B Big Tower Razer Mamba 4G Gaming Mouse SteelSeries QCK 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel® Core i7-3930K Processor OC@4.25Ghz ASUS RAMPAGE IV EXTREME/BF3, Socket-2011 HIS Radeon HD 7970 3GB GDDR5 x2 in CrossX Corsair XMS3 1866MHz 8GB Vengeance CL9 x2 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Caviar® Black 250GB Western Digital Caviar® Green 250GB Seagate FreeAgent® GoFlex Desk 2TB ASUS BW-12B1LT, Blu-Ray Writer 
CoolingOSKeyboardPower
Corsair H100 Hydro Series Windows 7 Ultimate x64 Corsair Vengeance K60 Performance Corsair AX 1200W PSU 
CaseMouseMouse Pad
Lian Li PC-V2120B Big Tower Razer Mamba 4G Gaming Mouse SteelSeries QCK 
  hide details  
Reply
post #8 of 22
Quote:
Originally Posted by ChristianEx View Post

Trying a new run here now. I got the signed error when trying to install from the Install menue, but for somewhat reason the disks acutally showed up this time. Half way thru now, but I suppose I will end on the missing/corrupted error this time arround as well. I'll give myself 1 hour 20 mins more to solve it, if not I'll just go with a regular disk tongue.gif
Update:
Yes, same **** again... doesn't seem to be working no matter what.. this time I tried with the files downloaded from the ASUS site...


Turn off UAC?

 

Control Panel > User Accounts > change User Account Control Settings > slider to bottom > restart PC
 

 

 

ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
post #9 of 22
Thread Starter 
Quote:
Originally Posted by Ken1649 View Post



Turn off UAC?

Control Panel > User Accounts > change User Account Control Settings > slider to bottom > restart PC

 


As mentioned, this is a 100% clean install. No OS on it yet.
     
CPUMotherboardGraphicsRAM
Intel® Core i7-3930K Processor OC@4.25Ghz ASUS RAMPAGE IV EXTREME/BF3, Socket-2011 HIS Radeon HD 7970 3GB GDDR5 x2 in CrossX Corsair XMS3 1866MHz 8GB Vengeance CL9 x2 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Caviar® Black 250GB Western Digital Caviar® Green 250GB Seagate FreeAgent® GoFlex Desk 2TB ASUS BW-12B1LT, Blu-Ray Writer 
CoolingOSKeyboardPower
Corsair H100 Hydro Series Windows 7 Ultimate x64 Corsair Vengeance K60 Performance Corsair AX 1200W PSU 
CaseMouseMouse Pad
Lian Li PC-V2120B Big Tower Razer Mamba 4G Gaming Mouse SteelSeries QCK 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel® Core i7-3930K Processor OC@4.25Ghz ASUS RAMPAGE IV EXTREME/BF3, Socket-2011 HIS Radeon HD 7970 3GB GDDR5 x2 in CrossX Corsair XMS3 1866MHz 8GB Vengeance CL9 x2 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Caviar® Black 250GB Western Digital Caviar® Green 250GB Seagate FreeAgent® GoFlex Desk 2TB ASUS BW-12B1LT, Blu-Ray Writer 
CoolingOSKeyboardPower
Corsair H100 Hydro Series Windows 7 Ultimate x64 Corsair Vengeance K60 Performance Corsair AX 1200W PSU 
CaseMouseMouse Pad
Lian Li PC-V2120B Big Tower Razer Mamba 4G Gaming Mouse SteelSeries QCK 
  hide details  
Reply
post #10 of 22
You may need to try these:

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20792&keyword=enterprise&lang=eng
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › RAID issues, can't install unsigned drivers