Overclock.net › Forums › Graphics Cards › AMD/ATI › 7970 or Monitor Issue?
New Posts  All Forums:Forum Nav:

7970 or Monitor Issue?

post #1 of 22
Thread Starter 
I believe this is a monitor issue but let me pick your brains.

I have 3 displays hooked up to the 7970. Only one seems to be having problems. When hooked up through a mini DP -> DVI - the monitor will have odd flickers when effects are used. One time this flicker can be seen is when I change frequency of clock speeds in Trixx and hit apply. Other times I will see green dots on my screen. These are quickly fixed by turning the monitor off and on (another reason I believe it's monitor related). When booting up (before windows) the monitor will artifact, stretch text vertically, and distort colors. The flickering has been seen DVI->DVI, miniDP->DVI HDMI->DVI. The green dots have been observed when it's miniDP -> DVI and HDMI->DVI (not directly through DVI). I've used multiple cables to rule that issue out.

I want to note I have hooked the monitor up to the onboard iGPU. It does not flicker and I have yet to see the green dots, but it does have the odd artifacting (odd colors on boot up sequence and windows shut down).

My hunch is that this is monitor related.
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
post #2 of 22
May I ask as to what resolution you are trying to run? The adapter may not support anything higher than 1920 x 1200.
post #3 of 22
Thread Starter 
1900X1200. I have issues occurring regardless of whether an adapter is used or a direct connection is used. The issues tend to be the most pronounced with miniDP-DVI followed by HDMI-DVI and least pronounced as a direct dvi connection. Additionally I still have some odd issues with a direct DVI connection to the onboard sandy bridge gpu.
Edited by Faksnima - 1/31/12 at 6:45pm
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
post #4 of 22
Does it still flicker if you lower the resolution?

Oh and to add, it might be a driver related issue (just putting it out there)
post #5 of 22
Thread Starter 
Driver related when there are issues during boot up regardless video adapter?
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
post #6 of 22
I have had this happen to me before. It sounds like a monitor issue. There are a number of reasons for this to happen: monitor issue, driver issue, heat issue and even motherboard bios issue.

Does the monitor still display artifacts when it is the only one plug into the DVI slot?
post #7 of 22
Thread Starter 
Quote:
Originally Posted by S1L3Nt View Post

I have had this happen to me before. It sounds like a monitor issue. There are a number of reasons for this to happen: monitor issue, driver issue, heat issue and even motherboard bios issue.
Does the monitor still display artifacts when it is the only one plug into the DVI slot?

I'm not sure. Are you referring to only plugged into the 7970 or on the iGPU? I don't recall having this issue prior to the 7970.

Let me ask you a question - the green dots issue I was having before....if it was video card related, turning the monitor off and on wouldn't necessarily solve the issue, correct?
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
post #8 of 22
Thread Starter 
Here is a video. The monitor is plugged into the dvi port of the IGPU (NOT THE 7970) noticed the odd discoloration during boot/restart.
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
post #9 of 22
Thread Starter 
Any ideas?
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
Desktop
(18 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 2600K Gigabyte Z77-UD5H-WB XFX R9 290 DD XFX R9 290 DD 
RAMHard DriveHard DriveOptical Drive
G. Skill Seagate 750 GB Crucial SSD LG Blu-Ray Burner 
CoolingMonitorMonitorMonitor
Corsair H60 Push/Pull Potalion 27" Spectre 24" Panasonic 55" Plazma HDTV 
KeyboardPowerCaseMouse
Logitech 710+ EVGA SuperNOVA 1000 G2 Corsair Carbide Air 540 Logtech GS700s 
Mouse Pad
Rocketfish Steel Mouse Pad 
  hide details  
Reply
post #10 of 22
Quote:
Originally Posted by Faksnima View Post

I believe this is a monitor issue but let me pick your brains.
I have 3 displays hooked up to the 7970. Only one seems to be having problems. When hooked up through a mini DP -> DVI - the monitor will have odd flickers when effects are used. One time this flicker can be seen is when I change frequency of clock speeds in Trixx and hit apply. Other times I will see green dots on my screen. These are quickly fixed by turning the monitor off and on (another reason I believe it's monitor related). When booting up (before windows) the monitor will artifact, stretch text vertically, and distort colors. The flickering has been seen DVI->DVI, miniDP->DVI HDMI->DVI. The green dots have been observed when it's miniDP -> DVI and HDMI->DVI (not directly through DVI). I've used multiple cables to rule that issue out.
I want to note I have hooked the monitor up to the onboard iGPU. It does not flicker and I have yet to see the green dots, but it does have the odd artifacting (odd colors on boot up sequence and windows shut down).
My hunch is that this is monitor related.


One of the monitor is out of snyc. It's not the monitor or the card. 

 

Solution; post #21
 

 

 

ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › 7970 or Monitor Issue?