Overclock.net › Forums › Components › Power Supplies › Omg...
New Posts  All Forums:Forum Nav:

Omg... - Page 2

post #11 of 13
Quote:
Originally Posted by DanNEBTD
I have a neo power 480 on my rig below and it has failed on me only twice while folding and running both optical drives and three HD's, and (transfering files/installing and) i love this PSU . . . though its time for a new one. . . a/w back on topic . . . mine also has one wire missing. . .goes one black then three reds from my lower left hand corner. . . ill try to get a pic.
Thats definately two more failures then any PSU should give.

I say bring the rig in and have them look at it. If they break it they buy it anyways, and make sure you state that.

pink
post #12 of 13
most likely the psu is busted...take your rig to them and show them that it doesnt work and use your old 350watt one to show them that the old one boots the pc up....what else can it be?..im sure theyll give you a new one
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
4790K delidded @4.9ghz Asus Z97 Deluxe Wifi EVGA GTX 980 SC 2 x 8GB Corsair Vengence 2400 
Hard DriveOptical DriveCoolingOS
Crucial MX200 250gb + 1tb Lg Bluray EK Supreme, TC PA120.3, D5 Vario, San Ace Windows 7 Ultimate  
MonitorKeyboardPowerCase
32" LG7000 1920x1080 Logitech S510 XFX 650Watt XXX Modular Edition Custom Modded 
MouseAudio
Logitech S510 Mission M74 Denon PMA 355 
  hide details  
Reply
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
4790K delidded @4.9ghz Asus Z97 Deluxe Wifi EVGA GTX 980 SC 2 x 8GB Corsair Vengence 2400 
Hard DriveOptical DriveCoolingOS
Crucial MX200 250gb + 1tb Lg Bluray EK Supreme, TC PA120.3, D5 Vario, San Ace Windows 7 Ultimate  
MonitorKeyboardPowerCase
32" LG7000 1920x1080 Logitech S510 XFX 650Watt XXX Modular Edition Custom Modded 
MouseAudio
Logitech S510 Mission M74 Denon PMA 355 
  hide details  
Reply
post #13 of 13
Thread Starter 
Yes the PSU seems to work but I guess it ain't compatible from what i've read somewhere (sorry can't find the link) it seems to have a lot of incompatibilty issues especially with A8N mobos tho nothing for mine eh. So far would resetting the CMOS really help? And also i'll be getting an Asus P5B deluxe for my conroe build next week and I wonder if 480W would be enough for it. And by the way thanks for your help folks.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Pentium D 820 2.8Ghz Asus P5N-E SLI Ati Radeon X1900XTX 2GB OCZ Gold DDR2 800 
Hard DriveOSMonitorKeyboard
250GB SATA Win XP SP2 Samsung syncmaster 920NX Logitech G15 
PowerCaseMouse
Antec Neopower 480W NZXT Zero Logitech G5 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Pentium D 820 2.8Ghz Asus P5N-E SLI Ati Radeon X1900XTX 2GB OCZ Gold DDR2 800 
Hard DriveOSMonitorKeyboard
250GB SATA Win XP SP2 Samsung syncmaster 920NX Logitech G15 
PowerCaseMouse
Antec Neopower 480W NZXT Zero Logitech G5 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Omg...