Overclock.net › Forums › Graphics Cards › AMD/ATI › XFX 5870 possible problem
New Posts  All Forums:Forum Nav:

XFX 5870 possible problem

post #1 of 8
Thread Starter 
I have been running a Sapphire 5870 with an XFX 5870 for several months now (I know name doesn't really matter, just a FYI). I started to get some screen flicker on one of my monitors. I had the three monitors plugged into the sapp in the first gpu slot. I tried uninstalling drivers and re-installing them but the flicker was still there. Can't remember if I used any older drivers but I know I used the most recent ones. So to further trouble shoot the issue, I took both video cards out and tested one at a time. Absolutely nothing wrong with the sapph gpu (currently running it now). When I put the XFX card in alone, and hooked up just one monitor, there was a black box around each side. I believe this could have been fixed by making some adjustments on the monitor itself but nothing I did software related would fix this. Also, none of the other display ports would work. I tried hooking up one monitor at a time using each display and only the DVI port would work. If I hooked up all three to this card, only the DVI would show up. Am I doing something wrong here or has this card gone bad is same way? Thanks in advance for your answers.
Work in progress
(17 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5-3570K Ivy Bridge 3.4GHz ASRock Z77 Extreme4 Sapphire Radeon 7970 3GB G.SKILL Ares Series 16GB (2 x 8GB) 240-Pin SDRA... 
Hard DriveHard DriveHard DriveHard Drive
Kingston HyperX 3K 240G SSD Seagate Barracuda 7200 3 TB Seagate Barracuda 7200 3 TB WD Black 1TB 
Optical DriveCoolingOSMonitor
Lite-ON DVD burner Cooler Master 212+ Win 7 Hanns·G 25" LCD Monitor x3 
KeyboardPowerCaseMouse
Logitech Wireless Illuminated Keyboard K800 COOLER MASTER Silent Pro Gold Series 1000W COOLER MASTER HAF X Logitech G700 
Audio
Logitech G930 Wireless Gaming Headset 
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1055T Thuban 2.8GHz OC'ed to 3.4 MSI 870A Fuzion Radeon 5870 Radeon 5870 
RAMHard DriveOSKeyboard
Patriot G 'Sector 5' 2x4Gb DDR3 1600 (PC3 12800) WD 150GB VelociRaptor, WD Black 1TB Win 7 64 Logitech G-15 
PowerCaseMouse
CORSAIR HX Series 620W Unsure Logitech G518 
  hide details  
Reply
Work in progress
(17 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5-3570K Ivy Bridge 3.4GHz ASRock Z77 Extreme4 Sapphire Radeon 7970 3GB G.SKILL Ares Series 16GB (2 x 8GB) 240-Pin SDRA... 
Hard DriveHard DriveHard DriveHard Drive
Kingston HyperX 3K 240G SSD Seagate Barracuda 7200 3 TB Seagate Barracuda 7200 3 TB WD Black 1TB 
Optical DriveCoolingOSMonitor
Lite-ON DVD burner Cooler Master 212+ Win 7 Hanns·G 25" LCD Monitor x3 
KeyboardPowerCaseMouse
Logitech Wireless Illuminated Keyboard K800 COOLER MASTER Silent Pro Gold Series 1000W COOLER MASTER HAF X Logitech G700 
Audio
Logitech G930 Wireless Gaming Headset 
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1055T Thuban 2.8GHz OC'ed to 3.4 MSI 870A Fuzion Radeon 5870 Radeon 5870 
RAMHard DriveOSKeyboard
Patriot G 'Sector 5' 2x4Gb DDR3 1600 (PC3 12800) WD 150GB VelociRaptor, WD Black 1TB Win 7 64 Logitech G-15 
PowerCaseMouse
CORSAIR HX Series 620W Unsure Logitech G518 
  hide details  
Reply
post #2 of 8
Thread Starter 
Guessing by the lack of response that this is going to be an XFX support question?
Work in progress
(17 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5-3570K Ivy Bridge 3.4GHz ASRock Z77 Extreme4 Sapphire Radeon 7970 3GB G.SKILL Ares Series 16GB (2 x 8GB) 240-Pin SDRA... 
Hard DriveHard DriveHard DriveHard Drive
Kingston HyperX 3K 240G SSD Seagate Barracuda 7200 3 TB Seagate Barracuda 7200 3 TB WD Black 1TB 
Optical DriveCoolingOSMonitor
Lite-ON DVD burner Cooler Master 212+ Win 7 Hanns·G 25" LCD Monitor x3 
KeyboardPowerCaseMouse
Logitech Wireless Illuminated Keyboard K800 COOLER MASTER Silent Pro Gold Series 1000W COOLER MASTER HAF X Logitech G700 
Audio
Logitech G930 Wireless Gaming Headset 
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1055T Thuban 2.8GHz OC'ed to 3.4 MSI 870A Fuzion Radeon 5870 Radeon 5870 
RAMHard DriveOSKeyboard
Patriot G 'Sector 5' 2x4Gb DDR3 1600 (PC3 12800) WD 150GB VelociRaptor, WD Black 1TB Win 7 64 Logitech G-15 
PowerCaseMouse
CORSAIR HX Series 620W Unsure Logitech G518 
  hide details  
Reply
Work in progress
(17 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5-3570K Ivy Bridge 3.4GHz ASRock Z77 Extreme4 Sapphire Radeon 7970 3GB G.SKILL Ares Series 16GB (2 x 8GB) 240-Pin SDRA... 
Hard DriveHard DriveHard DriveHard Drive
Kingston HyperX 3K 240G SSD Seagate Barracuda 7200 3 TB Seagate Barracuda 7200 3 TB WD Black 1TB 
Optical DriveCoolingOSMonitor
Lite-ON DVD burner Cooler Master 212+ Win 7 Hanns·G 25" LCD Monitor x3 
KeyboardPowerCaseMouse
Logitech Wireless Illuminated Keyboard K800 COOLER MASTER Silent Pro Gold Series 1000W COOLER MASTER HAF X Logitech G700 
Audio
Logitech G930 Wireless Gaming Headset 
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1055T Thuban 2.8GHz OC'ed to 3.4 MSI 870A Fuzion Radeon 5870 Radeon 5870 
RAMHard DriveOSKeyboard
Patriot G 'Sector 5' 2x4Gb DDR3 1600 (PC3 12800) WD 150GB VelociRaptor, WD Black 1TB Win 7 64 Logitech G-15 
PowerCaseMouse
CORSAIR HX Series 620W Unsure Logitech G518 
  hide details  
Reply
post #3 of 8
Well, each time I switch between my XFX and MSI 5870 I would need to disable drivers before actually getting the system to resume normal function with the drivers. Otherwise doing a hot swap with my cards would actually cause the drivers to crash and I would need to reboot and then all would be fine. Have you tried multiple boots with the same card a couple times to see if that would get your screen back to normal and then try the troubleshooting. I hop that will get you somewhere.

Also going off of what you said.....

Getting a screen to show on the DVI and not the DP, Try using the Sapphire DP's and using the DVI on the XFX and sounds like that will stop the flickering if you really do have dead DP's on the XFX. But I somewhere remember that the DisplayPorts actually run off the DVI ports(shared usage) Like you cannot run your dedicated #2 DVI and # 2 DP at the same time. Someone with an actual X-fire system with some better experience could actually help you here.
Edited by DeadLink - 2/10/12 at 7:19pm
Defenstrate V 2.0
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 4790K Gigabyte Z97MX 5 780 Ti Classified TXD316G2400HC10QDC01 
Hard DriveCoolingOSMonitor
Samsung 240 Evo H80i Microsoft Windows 7 Professional Asus VG Series VG248QE 
KeyboardPowerCaseMouse
Corsair K70 EVGA 1300 Case Labs S5 Steel Series Sensei 
  hide details  
Reply
Defenstrate V 2.0
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 4790K Gigabyte Z97MX 5 780 Ti Classified TXD316G2400HC10QDC01 
Hard DriveCoolingOSMonitor
Samsung 240 Evo H80i Microsoft Windows 7 Professional Asus VG Series VG248QE 
KeyboardPowerCaseMouse
Corsair K70 EVGA 1300 Case Labs S5 Steel Series Sensei 
  hide details  
Reply
post #4 of 8
Quote:
Originally Posted by bhardy1185 View Post

I have been running a Sapphire 5870 with an XFX 5870 for several months now (I know name doesn't really matter, just a FYI).
I started to get some screen flicker on one of my monitors. I had the three monitors plugged into the sapp in the first gpu slot.
I tried uninstalling drivers and re-installing them but the flicker was still there. Can't remember if I used any older drivers but I know I used the most recent ones.
So to further trouble shoot the issue, I took both video cards out and tested one at a time. Absolutely nothing wrong with the sapph gpu (currently running it now).
When I put the XFX card in alone, and hooked up just one monitor, there was a black box around each side. I believe this could have been fixed by making some adjustments on the monitor itself but nothing I did software related would fix this. Also, none of the other display ports would work.
I tried hooking up one monitor at a time using each display and only the DVI port would work. If I hooked up all three to this card, only the DVI would show up. Am I doing something wrong here or has this card gone bad is same way? Thanks in advance for your answers.
 


With multi-monitor setup, that's very common with 58xx series. The 2D idle clocks should be something like 400/1200 MHz to avoid flickering.

 

I tried to read OP many times but don't get the picture. If your monitors have no native DisplayPort, you must be using one active adapter. If so, it could be the adapter or not the correct one.

ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
post #5 of 8
Thread Starter 
Quote:
Originally Posted by Ken1649 View Post



With multi-monitor setup, that's very common with 58xx series. The 2D idle clocks should be something like 400/1200 MHz to avoid flickering.

I tried to read OP many times but don't get the picture. If your monitors have no native DisplayPort, you must be using one active adapter. If so, it could be the adapter or not the correct one.

Ok I knew after I posted that I should have explained it a little better. I will try to make it a little more clear and go step by step of what I have encountered(I hope). Sorry for the confusion.

I started out with the Sapph 5870. Everything was running fine. Decided to get a XFX 5870 after about three months of running a single card. Installed the new card and everything was gravy for 4-5 months. One day out of the blue while playing SWTOR my right monitor (running 3 exact same monitors,see sig) started flicking. I uninstalled the drivers using driver sweeper blushsmiley.gif before I released this wasn't the best way to do it. Anyways, uninstalled drivers, re-installed the drivers and the flicker was still there. It was more noticeable if I was in game or if I was moving windows around but would still flicker if nothing was happening.

So I started to trouble shoot each card to see if it was card related. I took the XFX card out and ran with just the Sapph 5870. Nothing wrong at all, no flicker on any screen.

Took the Sapph card out and put the XFX card in. This is where the problems started. Only one display would work (DVI) and even then it had the 2.5 in black boarders around all sides. That is an easy fix with the amd control center. I unplugged all the monitors and tested each individually. Only the DVI slot would work. I even switched the cables on each monitor and same thing happened.

Now, during this process, I did not change anything driver wise which could be one of my mistakes. I thought the cards would work just fine with the same drivers if I swapped them in and out???weirdsmiley.gif but I could be wrong.

Again, I am sorry for making the OP so confusing. I had a lot going through my head and wanted to make sure that I got everything out right without checking to make sure it made since. I'm hoping both cards are ok and it is just user error because I just bought a 7970 yessir.gif and wanted to give these two cards to my dad (who is running a 9800gtx+ thumbsdownsmileyanim.gif .

I just did a fresh install on my computer and everything seems to be running smoothly. I am thinking about grabbing a spare HD and doing another install with the XFX card with fresh drivers and all just to see if I am doing something wrong.

If you think that any of this will net better results please let me know or if you think I should try something else, I am willing to give anything a shot.
Work in progress
(17 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5-3570K Ivy Bridge 3.4GHz ASRock Z77 Extreme4 Sapphire Radeon 7970 3GB G.SKILL Ares Series 16GB (2 x 8GB) 240-Pin SDRA... 
Hard DriveHard DriveHard DriveHard Drive
Kingston HyperX 3K 240G SSD Seagate Barracuda 7200 3 TB Seagate Barracuda 7200 3 TB WD Black 1TB 
Optical DriveCoolingOSMonitor
Lite-ON DVD burner Cooler Master 212+ Win 7 Hanns·G 25" LCD Monitor x3 
KeyboardPowerCaseMouse
Logitech Wireless Illuminated Keyboard K800 COOLER MASTER Silent Pro Gold Series 1000W COOLER MASTER HAF X Logitech G700 
Audio
Logitech G930 Wireless Gaming Headset 
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1055T Thuban 2.8GHz OC'ed to 3.4 MSI 870A Fuzion Radeon 5870 Radeon 5870 
RAMHard DriveOSKeyboard
Patriot G 'Sector 5' 2x4Gb DDR3 1600 (PC3 12800) WD 150GB VelociRaptor, WD Black 1TB Win 7 64 Logitech G-15 
PowerCaseMouse
CORSAIR HX Series 620W Unsure Logitech G518 
  hide details  
Reply
Work in progress
(17 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5-3570K Ivy Bridge 3.4GHz ASRock Z77 Extreme4 Sapphire Radeon 7970 3GB G.SKILL Ares Series 16GB (2 x 8GB) 240-Pin SDRA... 
Hard DriveHard DriveHard DriveHard Drive
Kingston HyperX 3K 240G SSD Seagate Barracuda 7200 3 TB Seagate Barracuda 7200 3 TB WD Black 1TB 
Optical DriveCoolingOSMonitor
Lite-ON DVD burner Cooler Master 212+ Win 7 Hanns·G 25" LCD Monitor x3 
KeyboardPowerCaseMouse
Logitech Wireless Illuminated Keyboard K800 COOLER MASTER Silent Pro Gold Series 1000W COOLER MASTER HAF X Logitech G700 
Audio
Logitech G930 Wireless Gaming Headset 
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1055T Thuban 2.8GHz OC'ed to 3.4 MSI 870A Fuzion Radeon 5870 Radeon 5870 
RAMHard DriveOSKeyboard
Patriot G 'Sector 5' 2x4Gb DDR3 1600 (PC3 12800) WD 150GB VelociRaptor, WD Black 1TB Win 7 64 Logitech G-15 
PowerCaseMouse
CORSAIR HX Series 620W Unsure Logitech G518 
  hide details  
Reply
post #6 of 8

Check these:

 

1. All 3 Hanns-G 25" HD 1080p available input D-Sub, DVI, HDMI. So you must be using one DP-To-DVI-Single Link Active Adapter. Link of the adapter used? This could be the culprit for flickering or on it's way out. Make sure the active adapter is listed and supported by AMD here AMD Eyefinity Validated Dongles

 

2. Disable Hardware Acceleration everywhere, Youtube, FlashPlayer, WMP, VLC, IE, Chrome, etc. or whatever hardware accelerated affinity set to GPU(s). This will get rid of compatibility issues such as flickering or crashes.

 

3. Check or replace Crossfire bridge and make sure to mount it firmly or wiggle it see if makes a difference.

 

4. If you want to check the XFX 5870 alone, move it to the first PCIe slot and using the first card PCIe power cable from PSU. This will rule out many things. You do not have to uninstall/reinstall swapping the cards around the PCIe slots. But you will need to "reset" third party softwares such as Trixx, Afterburner and "Restore Factory Defaults" in CCC then restart PC after the swap.

 

5. Install Official WHQL Catalyst + CAP (no Preview/Beta) Download Catalyst drivers

 

6. Avoid Driver Sweeper. Use Atiman Uninstaller v.6.3.1 to uninstall and clean Catalyst + CAP. Turn off UAC to install this file. The UI is self-explanatory.


Edited by Ken1649 - 2/11/12 at 9:26am
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
post #7 of 8
Quote:
Originally Posted by bhardy1185 View Post

Guessing by the lack of response that this is going to be an XFX support question?

RAMDAC is goin' out on the XFX. Card just needs to be RMA'd.
Edit System
(15 items)
 
  
CPUMotherboardGraphicsRAM
830x4 ASUS blah blah blah PRO/USB3 FiveEightFiveZer0 2x4 AMD entertainment edition memory lolwut 
Hard DriveHard DriveOptical DriveCooling
Seagate Barracuda >:] WD Scorpio >:] idk lol 212 
OSMonitorKeyboardPower
xx64en_client_en-us_Retail_Ultimate-_EN_DVD LED 23'' 1080P 5MS no dead pixels :D Goodwill 500w PCP+C 80+<3 
CaseMouseMouse Pad
Antec 300 Was a G500 :*( Steel Series 
  hide details  
Reply
Edit System
(15 items)
 
  
CPUMotherboardGraphicsRAM
830x4 ASUS blah blah blah PRO/USB3 FiveEightFiveZer0 2x4 AMD entertainment edition memory lolwut 
Hard DriveHard DriveOptical DriveCooling
Seagate Barracuda >:] WD Scorpio >:] idk lol 212 
OSMonitorKeyboardPower
xx64en_client_en-us_Retail_Ultimate-_EN_DVD LED 23'' 1080P 5MS no dead pixels :D Goodwill 500w PCP+C 80+<3 
CaseMouseMouse Pad
Antec 300 Was a G500 :*( Steel Series 
  hide details  
Reply
post #8 of 8
Thread Starter 
Quote:
Originally Posted by Ken1649 View Post

Check these:

1. All 3 Hanns-G 25" HD 1080p available input D-Sub, DVI, HDMI. So you must be using one DP-To-DVI-Single Link Active Adapter. Link of the adapter used? This could be the culprit for flickering or on it's way out. Make sure the active adapter is listed and supported by AMD here AMD Eyefinity Validated Dongles

2. Disable Hardware Acceleration everywhere, Youtube, FlashPlayer, WMP, VLC, IE, Chrome, etc. or whatever hardware accelerated affinity set to GPU(s). This will get rid of compatibility issues such as flickering or crashes.

3. Check or replace Crossfire bridge and make sure to mount it firmly or wiggle it see if makes a difference.

4. If you want to check the XFX 5870 alone, move it to the first PCIe slot and using the first card PCIe power cable from PSU. This will rule out many things. You do not have to uninstall/reinstall swapping the cards around the PCIe slots. But you will need to "reset" third party softwares such as Trixx, Afterburner and "Restore Factory Defaults" in CCC then restart PC after the swap.

5. Install Official WHQL Catalyst + CAP (no Preview/Beta) Download Catalyst drivers

6. Avoid Driver Sweeper. Use Atiman Uninstaller v.6.3.1 to uninstall and clean Catalyst + CAP. Turn off UAC to install this file. The UI is self-explanatory.

Thank you for the info. +rep. I will give these a shot. I releaseed the mistake I made after reading for a while on these forums about drive sweeper. I have been using atiman since I did the initial sweep.

http://www.newegg.com/Product/Product.aspx?Item=N82E16814998051

That is the adapter I was using. Some of the comments seem familiar tongue.gif. I just got another adapter with the 7970 so I will test it out with that one as well. Only thing that makes me not think it is the adapter is that it runs fine on the sapph 5870 thinking.gif

But I will get the other stuff tested and let you know my findings. Thank you for your help again.
Work in progress
(17 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5-3570K Ivy Bridge 3.4GHz ASRock Z77 Extreme4 Sapphire Radeon 7970 3GB G.SKILL Ares Series 16GB (2 x 8GB) 240-Pin SDRA... 
Hard DriveHard DriveHard DriveHard Drive
Kingston HyperX 3K 240G SSD Seagate Barracuda 7200 3 TB Seagate Barracuda 7200 3 TB WD Black 1TB 
Optical DriveCoolingOSMonitor
Lite-ON DVD burner Cooler Master 212+ Win 7 Hanns·G 25" LCD Monitor x3 
KeyboardPowerCaseMouse
Logitech Wireless Illuminated Keyboard K800 COOLER MASTER Silent Pro Gold Series 1000W COOLER MASTER HAF X Logitech G700 
Audio
Logitech G930 Wireless Gaming Headset 
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1055T Thuban 2.8GHz OC'ed to 3.4 MSI 870A Fuzion Radeon 5870 Radeon 5870 
RAMHard DriveOSKeyboard
Patriot G 'Sector 5' 2x4Gb DDR3 1600 (PC3 12800) WD 150GB VelociRaptor, WD Black 1TB Win 7 64 Logitech G-15 
PowerCaseMouse
CORSAIR HX Series 620W Unsure Logitech G518 
  hide details  
Reply
Work in progress
(17 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5-3570K Ivy Bridge 3.4GHz ASRock Z77 Extreme4 Sapphire Radeon 7970 3GB G.SKILL Ares Series 16GB (2 x 8GB) 240-Pin SDRA... 
Hard DriveHard DriveHard DriveHard Drive
Kingston HyperX 3K 240G SSD Seagate Barracuda 7200 3 TB Seagate Barracuda 7200 3 TB WD Black 1TB 
Optical DriveCoolingOSMonitor
Lite-ON DVD burner Cooler Master 212+ Win 7 Hanns·G 25" LCD Monitor x3 
KeyboardPowerCaseMouse
Logitech Wireless Illuminated Keyboard K800 COOLER MASTER Silent Pro Gold Series 1000W COOLER MASTER HAF X Logitech G700 
Audio
Logitech G930 Wireless Gaming Headset 
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1055T Thuban 2.8GHz OC'ed to 3.4 MSI 870A Fuzion Radeon 5870 Radeon 5870 
RAMHard DriveOSKeyboard
Patriot G 'Sector 5' 2x4Gb DDR3 1600 (PC3 12800) WD 150GB VelociRaptor, WD Black 1TB Win 7 64 Logitech G-15 
PowerCaseMouse
CORSAIR HX Series 620W Unsure Logitech G518 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › XFX 5870 possible problem