Overclock.net › Forums › Components › Monitors and Displays › (Reviewed) $400 2560x1440 IPS no-AG 90hz+ Achieva Shimian QH270 and Catleap Q270
New Posts  All Forums:Forum Nav:

(Reviewed) $400 2560x1440 IPS no-AG 90hz+ Achieva Shimian QH270 and Catleap Q270 - Page 270

Poll Results: Vote when your Achieva/Catleap monitor comes in.

 
  • 41% (222)
    Achieva QH270
  • 2% (12)
    Achieva QH270 (DOA / didn't recieve)
  • 8% (44)
    Achieva QH270 (Dead pixel(s) / flawed panel)
  • 40% (221)
    Catleap Q270
  • 1% (8)
    Catleap Q270 (DOA / didn't recieve)
  • 6% (33)
    Catleap Q270 (Dead pixel(s) / flawed panel)
540 Total Votes  
post #2691 of 4772
Quote:
Originally Posted by 87dtna View Post

Oh and I also forgot, it started blinking red before I ever even hooked a DVI cable to it. Just plugged in the power, started blinking. Stays blinking no matter what you do.

Could it perhaps be the PSU? I wonder if it's not delivering enough current to be completely powered.
post #2692 of 4772
Good news, everyone!

Assuming the settings from Nvidia control panel are actually applying, I've gotten my Achieva to 95Hz. Tried 99 and now its just a black screen. Any idea how to bring it back to default? Im typing on a second monitor ATM, which would not exceed 60Hz at all.. so I believe it is truly capable of 95Hz+
post #2693 of 4772
Quote:
Originally Posted by lionelhuts View Post

Could it perhaps be the PSU? I wonder if it's not delivering enough current to be completely powered.



You mean the monitor's PSU/converter? I thought about that, but where the heck would I get another one of these! lol it converts it to 24v DC, which is just weird.
post #2694 of 4772
Wow - completely floored. I had a very nice 24" and this thing just decimates it.

Ordered Thursday from dcsamsungmall, was in my town Saturday and arrived Monday. Catleap Q270. This monitor is glorious. I used the included, rather cheap feeling DVI cable and it works just fine. I saw the blinking red light as well but after a few moments it flipped green.

Mine was packaged in about 2" of bubble wrap which took forever to open.

003bgi.jpg

Not sure what this sticker says:

004um.jpg

Contents:

005brt.jpg

POST:

009dkq.jpg

Only one place to go from unboxing - BF3:

011jc.jpg

Incidentally it does say 'This display supports HDCP'
post #2695 of 4772
Quote:
Originally Posted by Derpinheimer View Post

Good news, everyone!
Assuming the settings from Nvidia control panel are actually applying, I've gotten my Achieva to 95Hz. Tried 99 and now its just a black screen. Any idea how to bring it back to default? Im typing on a second monitor ATM, which would not exceed 60Hz at all.. so I believe it is truly capable of 95Hz+
If all else fails, safe mode
Main Rig
(12 items)
 
  
CPUMotherboardGraphicsRAM
I7 2600k @ 4.6 Asus P8Z68-V Pro AMD Sapphire R9 290 Tri-X 16gb G-skill Sniper DDR3 1600 
Hard DriveOptical DriveCoolingOS
Samsung 830 SSD, WD Caviar Black HDD's ASUS DVD-RW XSPC Water cooling Win7 
MonitorPowerCaseAudio
Catleap Q270 27" 2560x1440 Corsair HX850 COOLER MASTER HAF X Blue Edition Asus Xonar DG 
  hide details  
Reply
Main Rig
(12 items)
 
  
CPUMotherboardGraphicsRAM
I7 2600k @ 4.6 Asus P8Z68-V Pro AMD Sapphire R9 290 Tri-X 16gb G-skill Sniper DDR3 1600 
Hard DriveOptical DriveCoolingOS
Samsung 830 SSD, WD Caviar Black HDD's ASUS DVD-RW XSPC Water cooling Win7 
MonitorPowerCaseAudio
Catleap Q270 27" 2560x1440 Corsair HX850 COOLER MASTER HAF X Blue Edition Asus Xonar DG 
  hide details  
Reply
post #2696 of 4772
Quote:
Originally Posted by THX152 View Post

I saw the blinking red light as well but after a few moments it flipped green.

Was that before you turned on your PC that it turned green? Or, it turned green once you powered up your PC?

If you shut your PC down, does it start blinking red again?
post #2697 of 4772
Video card is a GTX 260.

The monitor light shows solid red when off.

When I created a custom resolution > 66 hz I got a static pattern of colored bands on the display and the light stayed green.
post #2698 of 4772
OK thanks.

Well, I did hook up another monitor to the supplied DVI cable just to rule it out and it works fine.


I have a friend thats fairly close that ordered a catleap. Once he confirms his works, I'm going to ship him my power supply/DC converter to rule that out as well.
Edited by 87dtna - 3/19/12 at 3:52pm
post #2699 of 4772
Quote:
Originally Posted by jradic View Post

17:37 19-Mar-2012 Handed over to Customs GBCVTA
Customs retention reason : Invoice missing
anyone have experience with dealing with customs biggrin.gif. I'm cool with paying for it now that I'm busted but I don't want to have to wait over a week for it!
Damn UK customs.

If they won't find an invoice in the package they'll try to contact the seller or the buyer for one.
post #2700 of 4772
Update on the Achieva. Got it running again.. Nvidia control panel is funky.

The back seems to be VERY hot, so im turning it down to 60Hz again.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › (Reviewed) $400 2560x1440 IPS no-AG 90hz+ Achieva Shimian QH270 and Catleap Q270