Overclock.net › Forums › Components › Monitors and Displays › (Reviewed) $400 2560x1440 IPS no-AG 90hz+ Achieva Shimian QH270 and Catleap Q270
New Posts  All Forums:Forum Nav:

(Reviewed) $400 2560x1440 IPS no-AG 90hz+ Achieva Shimian QH270 and Catleap Q270 - Page 416

Poll Results: Vote when your Achieva/Catleap monitor comes in.

 
  • 41% (232)
    Achieva QH270
  • 2% (12)
    Achieva QH270 (DOA / didn't recieve)
  • 8% (46)
    Achieva QH270 (Dead pixel(s) / flawed panel)
  • 40% (224)
    Catleap Q270
  • 1% (8)
    Catleap Q270 (DOA / didn't recieve)
  • 5% (33)
    Catleap Q270 (Dead pixel(s) / flawed panel)
555 Total Votes  
post #4151 of 4784
Model: ACHIEVA Shimian QH270-Lite
Seller: dream-seller
Price: $297.90

Order Placed: June 14th
Order Shipped: June 18th
Order Delivered: June 20th (fast!) Portland, OR

I want to thank all previous individuals that contributed in crafting this encyclopedia of affordable ips's! Have yourself a beer! Here's my 2 cents... I have a 27inch imac at work and can recognize the similarities it shares with the Shimian. Everything is very crisp and readable. Your able to crank the brightness up to some very good levels. However my Shimian has it's faults (out of box yellow tint, backlight bleed, 10+ dead/stuck pixels, top of panel housing is bent which slightly covers the top row of pixels-not flush).

450

For some reason they used the tempered glass boxing (I got the LITE which is no glass)
450

450450

They probably just check if it's doa. I didn't do the pixel perfect one, just the cheapest base model
450640

Minimum brightness
450

Maximum brightness
450

Dead/Stuck pixels on middle right side of panel
640450450

All in all I'm fine with it's defects. I wasn't expecting much going into this gamble and I came out pleasantly surprised. I honestly can't see the dead pixels unless I'm within a foot from the screen. (my viewing distance is a little over 2 feet away so it's a non-issue for me.) The pixels are small enough that they disappear into surrounding ones. Backlight bleed is probably my biggest gripe as some blacks don't get as black as they should. I plan to do some tweaking within the nvidia panel to fix the slight yellow tint. My main goal was to step up to 2560x1440 in an affordable manner and this was the ticket. Chime in!
post #4152 of 4784
I Fixed the yellow back light bleed by adding screws on the frame of the panel and back light , worked perfectly.
post #4153 of 4784
Hi all,


I'm going to be crazy about this issue!!!


I've bought 6 different brands of dvd-i dual link cables from 1.5m to 3m and impossible to have a display frown.gif monitor detected/blue led/back light on .


When i put the original 1.20m cable, all going ok smile.gif



Please users,

What type/brand of cables do you use on your monitor?

Regards.
post #4154 of 4784
Quote:
Originally Posted by Dazog View Post

I Fixed the yellow back light bleed by adding screws on the frame of the panel and back light , worked perfectly.

Can you explain that in more detail?
post #4155 of 4784
Quote:
Originally Posted by acidkhmer View Post

Hi all,
I'm going to be crazy about this issue!!!
I've bought 6 different brands of dvd-i dual link cables from 1.5m to 3m and impossible to have a display frown.gif monitor detected/blue led/back light on .
When i put the original 1.20m cable, all going ok smile.gif
Please users,
What type/brand of cables do you use on your monitor?
Regards.

I'm using the default cable but I should have another dual link dvi around and I'll give it later tonight when I get home.

Did I mention my monitor was paid by a pair of boots from Diablo 3 ?! bwhahahhahhaa
post #4156 of 4784
I had that problem too. It could be that the DVI-D cables you're getting aren't dual link (which is important, and it must be dvi-d).
post #4157 of 4784
Yah I've read the amazon reviews and a bunch of the dual link dvi cables are not actually dual link. They have the pins but not all the wiring inside.
550D
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-2700K Gigabyte Z77X-UD3H EVGA GTX 970 ACX 2.0+ SSC 4 x 4GB Samsung Green 
Hard DriveHard DriveCoolingOS
Crucial 240gb Samsung EVO 250gb Corsair H80 Win7 Ultimate 64 
MonitorKeyboardPowerCase
Qnix 2560x1440p Quickfire TK MX Brown XFX 750w Black Edition Corsair 550D 
MouseMouse Pad
Lefty Deathadder X Trac Ripper XXL 
  hide details  
Reply
550D
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-2700K Gigabyte Z77X-UD3H EVGA GTX 970 ACX 2.0+ SSC 4 x 4GB Samsung Green 
Hard DriveHard DriveCoolingOS
Crucial 240gb Samsung EVO 250gb Corsair H80 Win7 Ultimate 64 
MonitorKeyboardPowerCase
Qnix 2560x1440p Quickfire TK MX Brown XFX 750w Black Edition Corsair 550D 
MouseMouse Pad
Lefty Deathadder X Trac Ripper XXL 
  hide details  
Reply
post #4158 of 4784
Quote:
Originally Posted by acidkhmer View Post

Hi all,
I'm going to be crazy about this issue!!!
I've bought 6 different brands of dvd-i dual link cables from 1.5m to 3m and impossible to have a display frown.gif monitor detected/blue led/back light on .
When i put the original 1.20m cable, all going ok smile.gif
Please users,
What type/brand of cables do you use on your monitor?
Regards.

I got this one from Monoprice and it woeks great with my PCBANK.

http://www.monoprice.com/products/product.asp?c_id=102&cp_id=10209&cs_id=1020902&p_id=2408&seq=1&format=1#largeimage
post #4159 of 4784
Quote:
Originally Posted by acidkhmer View Post

Hi all,
I'm going to be crazy about this issue!!!
I've bought 6 different brands of dvd-i dual link cables from 1.5m to 3m and impossible to have a display frown.gif monitor detected/blue led/back light on .
When i put the original 1.20m cable, all going ok smile.gif
Please users,
What type/brand of cables do you use on your monitor?
Regards.
Although I would recommend checking cables first...
If that fails. it wouldnt surprise me if you have a loose wire inside your monitor.. (Though in this case the official cable should also give problems sometimes... (or possibly/eventually all the time) but perhaps you hardly used the official cable do to the size im guessing.
dont try that though unless you forsure cant get it to work.

if you use the official cable and sometimes only backlight will come on then thats most likely the problem from my understanding.
mine is doing the same thing i havent opened mine up yet but will soon.
post #4160 of 4784
Quote:
Originally Posted by bryceton View Post

Although I would recommend checking cables first...
If that fails. it wouldnt surprise me if you have a loose wire inside your monitor.. (Though in this case the official cable should also give problems sometimes... (or possibly/eventually all the time) but perhaps you hardly used the official cable do to the size im guessing.
dont try that though unless you forsure cant get it to work.
if you use the official cable and sometimes only backlight will come on then thats most likely the problem from my understanding.
mine is doing the same thing i havent opened mine up yet but will soon.


Hi,

Thanks for your help smile.gif

My cables issue is very strange,
With the 1.20m original cable, i've got display, with no issue,

the 3 meters one gave me a display only one time until reboot, after that nothing, monitor detected by G.C but the monitor is off/redlight frown.gif

the 1.5 and 1.8 meters, i ve got only the backlight on, but the screen is black.


Can you give me more info about the loose wire?


Regards.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › (Reviewed) $400 2560x1440 IPS no-AG 90hz+ Achieva Shimian QH270 and Catleap Q270