Overclock.net › Forums › Components › Monitors and Displays › (Reviewed) $400 2560x1440 IPS no-AG 90hz+ Achieva Shimian QH270 and Catleap Q270
New Posts  All Forums:Forum Nav:

(Reviewed) $400 2560x1440 IPS no-AG 90hz+ Achieva Shimian QH270 and Catleap Q270 - Page 469

Poll Results: Vote when your Achieva/Catleap monitor comes in.

 
  • 41% (232)
    Achieva QH270
  • 2% (12)
    Achieva QH270 (DOA / didn't recieve)
  • 8% (46)
    Achieva QH270 (Dead pixel(s) / flawed panel)
  • 40% (224)
    Catleap Q270
  • 1% (8)
    Catleap Q270 (DOA / didn't recieve)
  • 5% (33)
    Catleap Q270 (Dead pixel(s) / flawed panel)
555 Total Votes  
post #4681 of 4784
Quote:
Originally Posted by kevinsbane View Post

Don't do it. "Perfect Pixel" is marketing at its best. It hasn't resulted in a net benefit for the consumer. Just more profit for the sellers/manufacturers. The presence of so-called "perfect pixel" monitors has already reduced the general quality of monitors available.

This is completely bogus. Pixel perfect guarantees at most 1 dead pixel.
post #4682 of 4784
Quote:
Originally Posted by Koehler View Post

Source? Never heard of anything like that.
I don't recall where I saw it, but you can find that on some of the ebay seller's listings now. They state that if your perfect pixel version does have dead pixels they'll just refund you the difference between it and the non-perfect-pixel version.
post #4683 of 4784
Quote:
Originally Posted by hawkeye79 View Post

Well - I am testing with the cable that came with the Shimian - and also with this cable:
http://www.monoprice.com/products/product.asp?c_id=102&cp_id=10209&cs_id=1020901&p_id=2686&seq=1&format=2
Which says dual link on the cable so I think I am okay cable wise. The cable from ta_planet does not say dual link on it but it has all the pins of a dual-link cable on the connectors.
Well mine has not worked yet - but when I have it connected to the computer on the 8800GTS or GTX550Ti, I get a solid blue light and the backlight comes on. Windows 7 recognizes it as a monitor and says it has extended my desktop to it. I can move windows off the screen onto it, but can't see them on the monitor. The light will flash blue when I either set the resolution for the Shimian to some weird setting or when I plug it into my 6800GS card (which I do not think is compatible - may not be dual-link).

I got my monitor (QH270) on monday but have not been able to get it to work. I have been combing threads to try and find people with similar problems but have had only minimal luck so I figured I would try and post. Basically when I plug in the monitor windows recognizes it and the blue light turns solid. The backlight comes on but nothing appears on the screen. I tried booting with the monitor on 1st and with the shimian as the only monitor connected. I have a EVGA 580 GTXTi which has two DVI-I outputs. I tried buying several new dual-link DVI cables however the ones I ordered from monoprice http://www.monoprice.com/products/product.asp?c_id=102&cp_id=10209&cs_id=1020901&p_id=2686&seq=1&format=2 will not fit because the cable is too fat and runs into a protruding edge below the DVI input on the monitor. I bought a DL-DVI cable from frys and when I try using that the blue light blinks indicating it is not receiving any signal. I contacted the seller and he said make a video so he can review it. The only thing I have not tried is trying it on another computer because I do not have another computer that could run the monitor. I know I have read where some people have had to send their monitors back but that makes me nervous because it will be $100+ to send it back and how would I honestly know if they "test" my monitor and it "magically seems to work"? I guess I could try and discretely etch something into the monitor somewhere? Also the seller I bought from was dream-seller. Any help would be greatly appreciated.
post #4684 of 4784
I meant to say the GPU is a EVGA GTX 560Ti, but nevertheless it still has 2 DVI-I outputs.

Oh and also I have tried two different installs of windows and drivers are up to date.
post #4685 of 4784
Quote:
Originally Posted by conwa View Post

Im about to buy the Shimian from Green sum on e-bay...

I only have one question:

Do u guys recommend the pixel perfect version thats 40 bucks more?
http://www.ebay.nl/itm/Perfect-Pixel-New-ACHIEVA-Shimian-QH270-Lite-27-LED-S-IPS-2560x1440-HD-Monitor-/140886763636?pt=Computer_Monitors&hash=item20cd816874

Or is the chance i have stuck pixels that low, that i can just order a non pixel perfect..



Im from holland and sending the monitor back to S-Korea is as expensive as the monitor itself...

Just got mine from that seller was very good and delivery was 3 days Very Good thumb.gif
4690K
(14 items)
 
  
CPUMotherboardGraphicsRAM
4690K Gigerbyte Z97 ITX Zotac GTX 980 Amp Extreme Edition  corsair 2400 
Hard DriveCoolingOSMonitor
SSD 240  H60 Windows 8.1 64Bit Asus 4K 
PowerCase
Silverstone 450E Fractal Design 
  hide details  
Reply
4690K
(14 items)
 
  
CPUMotherboardGraphicsRAM
4690K Gigerbyte Z97 ITX Zotac GTX 980 Amp Extreme Edition  corsair 2400 
Hard DriveCoolingOSMonitor
SSD 240  H60 Windows 8.1 64Bit Asus 4K 
PowerCase
Silverstone 450E Fractal Design 
  hide details  
Reply
post #4686 of 4784
Quote:
Originally Posted by gaucho30 View Post

I meant to say the GPU is a EVGA GTX 560Ti, but nevertheless it still has 2 DVI-I outputs.

Oh and also I have tried two different installs of windows and drivers are up to date.

I have had this monitor running on EVGA gtx560 TI today so they do work on that GPU rolleyes.gif
4690K
(14 items)
 
  
CPUMotherboardGraphicsRAM
4690K Gigerbyte Z97 ITX Zotac GTX 980 Amp Extreme Edition  corsair 2400 
Hard DriveCoolingOSMonitor
SSD 240  H60 Windows 8.1 64Bit Asus 4K 
PowerCase
Silverstone 450E Fractal Design 
  hide details  
Reply
4690K
(14 items)
 
  
CPUMotherboardGraphicsRAM
4690K Gigerbyte Z97 ITX Zotac GTX 980 Amp Extreme Edition  corsair 2400 
Hard DriveCoolingOSMonitor
SSD 240  H60 Windows 8.1 64Bit Asus 4K 
PowerCase
Silverstone 450E Fractal Design 
  hide details  
Reply
post #4687 of 4784
Anyone have a link to the new 90hz+ Catleaps?

Can't seem to find any that aren't white or $400+
post #4688 of 4784
Quote:
Originally Posted by gaucho30 View Post

I got my monitor (QH270) on monday but have not been able to get it to work. I have been combing threads to try and find people with similar problems but have had only minimal luck so I figured I would try and post. Basically when I plug in the monitor windows recognizes it and the blue light turns solid. The backlight comes on but nothing appears on the screen. I tried booting with the monitor on 1st and with the shimian as the only monitor connected. I have a EVGA 580 GTXTi which has two DVI-I outputs. I tried buying several new dual-link DVI cables however the ones I ordered from monoprice http://www.monoprice.com/products/product.asp?c_id=102&cp_id=10209&cs_id=1020901&p_id=2686&seq=1&format=2 will not fit because the cable is too fat and runs into a protruding edge below the DVI input on the monitor. I bought a DL-DVI cable from frys and when I try using that the blue light blinks indicating it is not receiving any signal. I contacted the seller and he said make a video so he can review it. The only thing I have not tried is trying it on another computer because I do not have another computer that could run the monitor. I know I have read where some people have had to send their monitors back but that makes me nervous because it will be $100+ to send it back and how would I honestly know if they "test" my monitor and it "magically seems to work"? I guess I could try and discretely etch something into the monitor somewhere? Also the seller I bought from was dream-seller. Any help would be greatly appreciated.

I have an email from dream-seller where he confirms that you do not pay return shipping on an monitor that arrives defective. Did you make the video? I have a co-worker who had an issue with the monitor not turning on and after dealing with the seller (taking a video of it not working as requested) he had his replaced and did not pay for return shipping costs.
post #4689 of 4784
Quote:
Originally Posted by motokill36 View Post

Just got mine from that seller was very good and delivery was 3 days Very Good thumb.gif

Any dead pixels? (did you order the pixel perfect?)
post #4690 of 4784
Ya I sent him videos and he asked if I was using windows, if I was using a desktop, and whether or not I was using a 110V-220V converter which I was. I have not heard anything more. Will update as I find out more.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › (Reviewed) $400 2560x1440 IPS no-AG 90hz+ Achieva Shimian QH270 and Catleap Q270