post #1 of 1
Thread Starter 
Hey there

It took me almost a week now to find out how to get theese "best of the worst" class tablets rooted. I take no credits for this.. found it here:
http://www.slatedroid.com/topic/26372-need-help-with-mpman-mp827
I did not find anywhere such a detailed guide so i decieded to post it here, don´t hate pls.
If somebody here got a good knowledge about linux/android and rooting, pls tell me if this method will surely work on all devices (other tablets/mobiles), further feel free to join a discussion here. i will edit this thread after getting new info.

450

Specifications:
OS Android 2.3 / Gingerbread
RAM-Memory 512Mb (IGP) shared memory
Storage Mem 4Gb intergrated flash / up to 32Gb microSDHC-compatible card slot
CPU 1Ghz Cortex-A8
Outputs miniHdmi 1080p / 720p, Audio for headphones / Line
Display 8 Inch / 20.3 Cm WSVGA Multitouch / 800x600
Webcam 0.3Mp
Input 1 x Usb 2.0
WLan 802.11bg




Anyway, there are two faulty steps i´ve corrected. The guy forgot two signs and did not tell exactly to download
4 things you need to begín so i will post it here.. Get JavaSDK, AndroidSDK, SDKtools from AndroidSDK and
the google usb drivers. just read below and follow my instructions.


First Java JDK (needed for the Android-SDK)
http://www.oracle.com/technetwork/java/javase/downloads/index.html

Then Android-SDK (Software Development Kit)
http://developer.android.com/sdk/index.html
It will install AVD- and SDK-Manager

Open the SDK-Manager, in some cases it won´t connect to the server if you use a firewall.
I deactivated mine and it worked fine. It may take a while until you get to the file selection, so be patient pls.
When the program runs it shows you a huge list, check "Android SDK Platform-tools"
and hit the download/install button.

and at last download the Google USB driver
I Think there are to ways to obtain theese. One is shown in the SDK-Manager, but i did not see this
so i can not proof that it works but it says it´s the same thing so it should work, if not try this link to
download them seperately like i did.
http://www.file-upload.net/download-4001376/Google-USB-Driver--Huawei-Ideos-.exe.html



I`D RECOMMEND TO READ ALL STEPS AND MAKE YOU A PICTURE OF WHAT MUST BE DONE,
FURTHER I TAKE NO RESPONSIBILITY FOR ANY DAMAGE bla bla bla you sure understand smile.gif
one more thing, remove/uninstall all root applications like z4 and so on. i reseted my tablet completely before i startded.


OK, now we are ready to start:

1. Fully charge your tablet.
2. Download Gingerbrak.apk (google), save it to the root of you SD card
3. Make sure Unknown source and USB debugging is enabled
(on the tablet go to settings --> applications --> unknown sources and in that same menu go to development and check usb-debugging)
4. Open ApkInstall or any better file explorer and install gingerbreak.apk
5. Run Gingerbreak and click "root device", wait until your device powers off BY ITSELF
6. Press power button, let the devices start, go to applications if you see Superuser Icon there, you half work is done
7. If Superuser is not install (but it should be installed automatically with Gingerbreak!), manually install it from Applanet
(google Applanet.apk and do the steps 2 and 4 for Applanet, then install superuser.. or google the apk if you can find it)
8. Connect tab to your computer with OTG (usb cable provided with your tablet), wait until driver are installing
9. To check if the driver is install or not
Right click computer > Manage>Devices Management
And check for ADB Interface and android Composite ADB Interface if it is there that means your tab is ready for next step
10. Again on your tab click gingerbreak application and run "root device", wait until your mobile/tablet is off, let it be in off for now
11. Type CMD in search on your computer, Click and run as administrator ( its the command window in dos style )

12. Type "cd C:/" without the ""

13. Then use cd to navigate to your android sdk folder (example: "cd Program Files (x86)\Android\android-sdk\platform-tools")
14. Power on your device, wait until you see slide boot screen/android loading screen than quickly
15. type "adb devices" without the "" and press enter (before it gets into Android!!!) it will show you message and List of devices attached, don’t worry even if it doesn’t shows serial no of your device, if a message shows as “device not found” than you need to install OTG driver manually, everything else is fine.

16. Now enter "adb shell" again without the "" and press enter
17. Wait for few second and type "cd /system/bin" without "" and press enter, now you would see $ sign
(don´t forget the space between cd and /)
18. Wait till device is completely started, unlock screen
19. And type "./su" without "" and press enter ( don´t forget the point before / )
20. Now check the screen of your device/tablet, Superuser application should ask you for permission , Click allow
21. Back on your computer type "rm /system/busybox/bin/su" without "" and press enter.
22. Type exit , Exit again, and now you are rooted.

Tadaaa!

I needed some runs until i found out the missing spaces and reseted my device before it worked.
I´d recommend further using Droidwall (Firewall) because most applications wanna "phone home" what
is very annoying.

Wishing you good luck and a good time with your Android device!


EDIT: Sry if posting links is not permitted (anymore?!) , u can google all the software you need anyway.
Further there are some other great guides on the web to get Android Market running which will make
this 200$ tab worth its cash. I added an 16gb MicroSD card so it has 20gig now. You can also use
USB sticks up to 4gb and there are some applications that make it possible to plug in NTFS harddisks
and read files from there... for me a much better option than spending over 500$ for the 32gb or more tablets!

Cheers
Edited by smex - 2/18/12 at 5:02am