Overclock.net › Forums › Video Games › PC Gaming › Weird Problems with Battlefield 3 please help!
New Posts  All Forums:Forum Nav:

Weird Problems with Battlefield 3 please help!

post #1 of 9
Thread Starter 
I having some issues with Battlefield 3. I recently had to reinstall Windows and now my BF3 isn't working right. Before i reinstalled Windows i was getting 60+ fps out of Battlefield 3 with most settings on High and Medium, now since the reinstall i can barely maintain 30-50 fps with most setting on medium to low and some even off. Does anyone know what could be causing this? I have newest video drivers, all my motherboard drivers are up-to-date. This seems very weird to me considering 90% of the time a system wipe and reinstall is supposed to make things better tongue.gif. Well any help is appreciated, Thanks smile.gif
post #2 of 9
Will need more information on this to help you out. What kind of video card do you have? What version are your drivers? If nVidia GPU, do you have the latest BETA drivers? Was anything else in the computer changed when you completed a restore? Have you configured SLI settings if SLI is being used to take advantage of the dedicated Physx selection option or alternate frame rendering settings?
post #3 of 9
Thread Starter 
I have a 1Gig GDDR5 ATI Radeon HD 5670, driver version 12.2 beta drivers, don't use SLI so no need to configure SLI settings
post #4 of 9
Thread Starter 
anyone?
post #5 of 9
Have you adjusted your power options to max performance? Not sure if it'll make a difference or not, but worth a shot
post #6 of 9
Thread Starter 
i doubt adjusting power options is going to help my FPS in BF3 lol. but thx for advice. Anyone else please?
post #7 of 9
Did you disable something in the CCC before (i.e., disable AA/AF for all games, lower image/texture settings, etc.) that is now enabled?
Einstein
(12 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600k @ 4.5GHz (104.7*43, 1.296V) Gigabyte UD5 (Z68) Gigabyte GTX 560Ti 448 Cores 16GB (4x4GB) G.Skill Ripjaws X @ DDR3-1675MHz (... 
Hard DriveHard DriveOptical DriveCooling
64GB Crucial m4 6TB (4x1.5TB) Western Digital Caviar Black Lite-On DVD +/- R/RW Prolimatech Genesis w/ 2x140mm NZXT 140LBs 
OSPowerCaseAudio
Windows 7 Professional/Debian Squeeze Seasonic X650 Antec Three Hundred Creative Sound Blaster X-Fi Titanium Fatal1ty C... 
  hide details  
Reply
Einstein
(12 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600k @ 4.5GHz (104.7*43, 1.296V) Gigabyte UD5 (Z68) Gigabyte GTX 560Ti 448 Cores 16GB (4x4GB) G.Skill Ripjaws X @ DDR3-1675MHz (... 
Hard DriveHard DriveOptical DriveCooling
64GB Crucial m4 6TB (4x1.5TB) Western Digital Caviar Black Lite-On DVD +/- R/RW Prolimatech Genesis w/ 2x140mm NZXT 140LBs 
OSPowerCaseAudio
Windows 7 Professional/Debian Squeeze Seasonic X650 Antec Three Hundred Creative Sound Blaster X-Fi Titanium Fatal1ty C... 
  hide details  
Reply
post #8 of 9
Thread Starter 
i kept all settings on default as before
post #9 of 9
Thread Starter 
anyone else know something that might be able to help me or explain why this happened?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Weird Problems with Battlefield 3 please help!