Overclock.net › Forums › Software, Programming and Coding › Operating Systems › VMWare Ubuntu 11.10
New Posts  All Forums:Forum Nav:

VMWare Ubuntu 11.10

post #1 of 9
Thread Starter 
Kind of a newbie here to virtulization...

#1 Do I NEED Vmware tools?

If so there is an error installing them on ubuntu...

#2 trying to use aircrack but airmon will not pick up my adapter? It's just blank, no interface.

#3 Are there any other bumps in the road that I am likely to encounter, or any "vmware 101" tips and tricks I should know about?

#4 The screen resolution, is it supposed to be that small?
post #2 of 9
I haven't explored VMWare super-thoroughly, but I will tell you what I know.

1. Never heard of it, sorry.
2. VMWare has a local ethernet adapter. If you want to use the actual hardware on your machine, you would need a real install of Ubuntu. VMWare is just a made up computer that Ubuntu can't see outside of.
3. Doubt it, its usually super easy to setup. Make sure you install Guest Additions (I think that's what its called).
4. I believe Guest Additions adds support for higher resolution.
     
CPUMotherboardGraphicsRAM
2600K @ 5.0 ASUS Maximus IV Extreme Sapphire/Powercolor 7950 CF G.Skill Ripjaws X 4x4GB 
Hard DriveHard DriveCoolingCooling
OCZ Vertex 3 60GB's RAID 0 VelociRaptor 300GB EK Maximus IV Block EK FC-7950 Block x2 
CoolingCoolingCoolingCooling
EK Supreme HF Block D5 w/ BP Dress-up Kit XSPC EX240 Black Ice SR1 360 
CoolingCoolingOSMonitor
Primochill PrimoFlex 1/2" ID Black 14 NZXT Fans Windows 7 Professional x64 3x AOC 2436V 
KeyboardPowerCaseMouse
Razer BlackWidow Ultimate BF3 Edition Corsair HX1000 NZXT Switch 810 Black Razer Imperator BF3 Edition 
AudioAudio
Asus Xonar Essence STX Beyerdynamic DT770 250 Ohm 
CPUMotherboardGraphicsRAM
i5-2500K Asus Maximus IV Gene-Z AMD Radeon HD 5970 G.Skill Ripjaws X DDR3-1600 
Hard DriveHard DriveCoolingCooling
Vertex 3 60GB RAID 0 VelociRaptor 300GB XSPC EX240 Rad Black Ice GT 92MM Rad 
CoolingCoolingCoolingCooling
Black Ice GT 120MM Rad EK Supreme HF CPU Block EK 5970 Block XSPC 450 Pump/Res Combo 
OSMonitorKeyboardPower
Windows 7 Professional x64 3x AOC 2436vw Razer Black Widow Ultimate BF3 Edition Rosewill 750W HIVE 
CaseMouseMouse PadAudio
NZXT Vulcan Razer Imperator BF3 Edition Razer Scarab BF3 Edition ASUS Xonar Essence STX 
Audio
Beyerdynamic DT770 250 Ohm 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
2600K @ 5.0 ASUS Maximus IV Extreme Sapphire/Powercolor 7950 CF G.Skill Ripjaws X 4x4GB 
Hard DriveHard DriveCoolingCooling
OCZ Vertex 3 60GB's RAID 0 VelociRaptor 300GB EK Maximus IV Block EK FC-7950 Block x2 
CoolingCoolingCoolingCooling
EK Supreme HF Block D5 w/ BP Dress-up Kit XSPC EX240 Black Ice SR1 360 
CoolingCoolingOSMonitor
Primochill PrimoFlex 1/2" ID Black 14 NZXT Fans Windows 7 Professional x64 3x AOC 2436V 
KeyboardPowerCaseMouse
Razer BlackWidow Ultimate BF3 Edition Corsair HX1000 NZXT Switch 810 Black Razer Imperator BF3 Edition 
AudioAudio
Asus Xonar Essence STX Beyerdynamic DT770 250 Ohm 
CPUMotherboardGraphicsRAM
i5-2500K Asus Maximus IV Gene-Z AMD Radeon HD 5970 G.Skill Ripjaws X DDR3-1600 
Hard DriveHard DriveCoolingCooling
Vertex 3 60GB RAID 0 VelociRaptor 300GB XSPC EX240 Rad Black Ice GT 92MM Rad 
CoolingCoolingCoolingCooling
Black Ice GT 120MM Rad EK Supreme HF CPU Block EK 5970 Block XSPC 450 Pump/Res Combo 
OSMonitorKeyboardPower
Windows 7 Professional x64 3x AOC 2436vw Razer Black Widow Ultimate BF3 Edition Rosewill 750W HIVE 
CaseMouseMouse PadAudio
NZXT Vulcan Razer Imperator BF3 Edition Razer Scarab BF3 Edition ASUS Xonar Essence STX 
Audio
Beyerdynamic DT770 250 Ohm 
  hide details  
Reply
post #3 of 9
Thread Starter 
Ok so it appears I did make some mistake,

For whatever reason I am getting that VMWare tools error. I do not believe I did this in the right order.

I am operating windows 7 , and I downloaded VMWare for windows 7.

Then I downloaded the Ubuntu ISO, mounted it to a virtual drive with daemon tools, and installed the virtual machine.

Then I tried resetting the password, but still it would not work...

I am confused and am having a hard time finding the answer on google!
post #4 of 9
Newer versions of VMware Workstation may automatically install VMware Tools for supported Ubuntu versions. Since that did not happen, try this or this.

You can change the resolution under Display, Monitor or Resolution under System. The names are sometimes different depending upon the Linux distro.
post #5 of 9
Quote:
Originally Posted by Dive View Post

Kind of a newbie here to virtulization...
#1 Do I NEED Vmware tools?
If so there is an error installing them on ubuntu...
#2 trying to use aircrack but airmon will not pick up my adapter? It's just blank, no interface.
#3 Are there any other bumps in the road that I am likely to encounter, or any "vmware 101" tips and tricks I should know about?
#4 The screen resolution, is it supposed to be that small?

You need to install VMware tools if you want things to work correctly, yes. It's all the drivers and software needed to make the guest OS recognize the virtualized hardware and interact with the host.

This is why you are having issues, you have next to no drivers or support software without VMware tools.

VMware tools is not hard to install manually. I am a Linux novice and not familiar with Ubuntu and still managed to get things working fine.
Quote:
Originally Posted by Dive View Post

Ok so it appears I did make some mistake,
For whatever reason I am getting that VMWare tools error. I do not believe I did this in the right order.
I am operating windows 7 , and I downloaded VMWare for windows 7.
Then I downloaded the Ubuntu ISO, mounted it to a virtual drive with daemon tools, and installed the virtual machine.
Then I tried resetting the password, but still it would not work...
I am confused and am having a hard time finding the answer on google!

You should have installed VMware, setup a new virtual machine, installed Ubuntu on that virtual machine (you don't need DaemonTools, VMware can mount .iso), then installed VMware tools.
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
post #6 of 9
Thread Starter 
Hey OK so todays lesson was always use repositories....


For some reason I cannot seem to get the DVD image of VMwaretools onto my desktop. It seems as if all of the tutorials assume that it just works.

When I click install vmware tools from vmware player, it just stays in the "contacting update server" mode. I legit left it on over night!

when i tried the manueal heres an error

Setting up module-assistant (0.11.2ubuntu1) ...
Setting up quilt (0.48-5) ...
Setting up open-vm-source (2010.02.23-236320-1+ubuntu1) ...
Setting up open-vm-tools (2010.02.23-236320-1+ubuntu1) ...
update-initramfs: deferring update (trigger activated)
* Loading open-vm-tools modules FATAL: Module vmhgfs not found.
FATAL: Module vmmemctl not found.
FATAL: Module vmsync not found.
[ OK ]
* Starting open-vm daemon vmtoolsd [ OK ]


Does it matter if I switched to backtrack 5 at the last minute?
Setting up zerofree (1.0.1-2) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.38
Setting up open-vm-toolbox (2010.02.23-236320-1+ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
post #7 of 9
Quote:
Originally Posted by Dive View Post

For some reason I cannot seem to get the DVD image of VMwaretools onto my desktop. It seems as if all of the tutorials assume that it just works.

It is probably because Ubuntu's Unity UI is not very customizable at the moment. Try copying the VMware Tools folder to your /home folder instead.
post #8 of 9
Thread Starter 
apt-get install --no-install-recommends open-vm-dkms

Setting up linux-headers (1.1-bt3) ...
Setting up open-vm-dkms (2010.02.23-236320-1+ubuntu1) ...
Loading new open-vm-tools-2010.02.23 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.38
Building for architecture i686
Building initial module for 2.6.38

Error! Bad return status for module build on kernel: 2.6.38 (i686)
Consult the make.log in the build directory
/var/lib/dkms/open-vm-tools/2010.02.23/build/ for more information.
dpkg: error processing open-vm-dkms (--configure):
subprocess installed post-installation script returned error exit status 10
Errors were encountered while processing:
open-vm-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)
post #9 of 9
I have the same problem when trying to install VMWARE Tools with the current version of vmware player. I installed it on two separate machines and they both won’t install vmware tools for linux. I did a search and it seems it’s a known problem with the latest version of vmware player.

My fix, I installed the pervious release of VMWARE Player and it installed vmware tools without a problem. thumb.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Operating Systems
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › VMWare Ubuntu 11.10