Overclock.net › Forums › Graphics Cards › NVIDIA › Problems with GTX570
New Posts  All Forums:Forum Nav:

Problems with GTX570

post #1 of 7
Thread Starter 
Hi all. I've recently been having a bit of bother with my Asus GTX 570 (DCII version). Every time I boot up, I need to re-install my video card drivers before any of my Steam games or MC will run. At first I thought it was an isolated incident, but now it's just getting plain annoying.

Any thoughts? This has happened before, but was only every now and then. But this time, it's every time I shut down and boot back up.
Project: Vortex
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600 ASRock Z68 Extreme7  Asus GTX 570 DCII Corsair Vengeance 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda ST1000DM003 Sony 24xDVD RW Cooler Master V8 Windows 7 Pro x64 
MonitorKeyboardPowerCase
21.5" Asus VE228H LED Logitech Ultra Flat Corsair AX750 CM Storm Sniper (temporary) 
MouseMouse Pad
Razer Imperator Mousepad's are a PITA. 
  hide details  
Reply
Project: Vortex
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600 ASRock Z68 Extreme7  Asus GTX 570 DCII Corsair Vengeance 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda ST1000DM003 Sony 24xDVD RW Cooler Master V8 Windows 7 Pro x64 
MonitorKeyboardPowerCase
21.5" Asus VE228H LED Logitech Ultra Flat Corsair AX750 CM Storm Sniper (temporary) 
MouseMouse Pad
Razer Imperator Mousepad's are a PITA. 
  hide details  
Reply
post #2 of 7
well that is strange, how old is your windows install?
Easy V3
(17 items)
 
12 Pack
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7-4820k Asus Rampage IV BE evga 1080ti FE w/ hybrid kit 16 GB G.Skill Trident X 2400mhz  
Hard DriveHard DriveOptical DriveCooling
Samsung 840 EVO 120gb Samsung 840 EVO 1TB Samsung Blu-ray Corsair H110 
OSMonitorKeyboardPower
windows 10 Asus PG278Q Ducky Shine 3 - blue led - cherry mx browns Seasonic Platinum-1000 
CaseMouseMouse PadAudio
Dimastech Easy V3 Mionix NAOS 8200 Mionix Ensis 320 titanium HD  
Other
audio technica ATH-A900X 
  hide details  
Reply
Easy V3
(17 items)
 
12 Pack
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7-4820k Asus Rampage IV BE evga 1080ti FE w/ hybrid kit 16 GB G.Skill Trident X 2400mhz  
Hard DriveHard DriveOptical DriveCooling
Samsung 840 EVO 120gb Samsung 840 EVO 1TB Samsung Blu-ray Corsair H110 
OSMonitorKeyboardPower
windows 10 Asus PG278Q Ducky Shine 3 - blue led - cherry mx browns Seasonic Platinum-1000 
CaseMouseMouse PadAudio
Dimastech Easy V3 Mionix NAOS 8200 Mionix Ensis 320 titanium HD  
Other
audio technica ATH-A900X 
  hide details  
Reply
post #3 of 7
When installing the driver are you using an administrator account? You may want to try the drivers released today as well, make sure you select custom then perform clean install.
post #4 of 7
Thread Starter 
Quote:
Originally Posted by mtbiker033 View Post

well that is strange, how old is your windows install?

Less than a month old, reinstalled when I bought my SSD's.
Quote:
Originally Posted by EVGAMatthewH View Post

When installing the driver are you using an administrator account? You may want to try the drivers released today as well, make sure you select custom then perform clean install.

I never thought to do that, I always just saved it to the desktop and then just double clicked. I just checked on the right click menu and there is a Run as Admin option, so I'll try that out tomorrow, see if it helps. Thanks for the suggestion!
Project: Vortex
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600 ASRock Z68 Extreme7  Asus GTX 570 DCII Corsair Vengeance 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda ST1000DM003 Sony 24xDVD RW Cooler Master V8 Windows 7 Pro x64 
MonitorKeyboardPowerCase
21.5" Asus VE228H LED Logitech Ultra Flat Corsair AX750 CM Storm Sniper (temporary) 
MouseMouse Pad
Razer Imperator Mousepad's are a PITA. 
  hide details  
Reply
Project: Vortex
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600 ASRock Z68 Extreme7  Asus GTX 570 DCII Corsair Vengeance 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda ST1000DM003 Sony 24xDVD RW Cooler Master V8 Windows 7 Pro x64 
MonitorKeyboardPowerCase
21.5" Asus VE228H LED Logitech Ultra Flat Corsair AX750 CM Storm Sniper (temporary) 
MouseMouse Pad
Razer Imperator Mousepad's are a PITA. 
  hide details  
Reply
post #5 of 7
Thread Starter 
Alrighty, running as administrator made no difference.

Would installing the graphics card into a different PCIE slot make any difference? Since first installing it I have moved it to another slot, but made sure that the one I moved it to had the same speeds as the original.

At the moment I'm downloading the drivers from ASUS rather than nvidia, see if that makes a difference.
Project: Vortex
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600 ASRock Z68 Extreme7  Asus GTX 570 DCII Corsair Vengeance 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda ST1000DM003 Sony 24xDVD RW Cooler Master V8 Windows 7 Pro x64 
MonitorKeyboardPowerCase
21.5" Asus VE228H LED Logitech Ultra Flat Corsair AX750 CM Storm Sniper (temporary) 
MouseMouse Pad
Razer Imperator Mousepad's are a PITA. 
  hide details  
Reply
Project: Vortex
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600 ASRock Z68 Extreme7  Asus GTX 570 DCII Corsair Vengeance 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda ST1000DM003 Sony 24xDVD RW Cooler Master V8 Windows 7 Pro x64 
MonitorKeyboardPowerCase
21.5" Asus VE228H LED Logitech Ultra Flat Corsair AX750 CM Storm Sniper (temporary) 
MouseMouse Pad
Razer Imperator Mousepad's are a PITA. 
  hide details  
Reply
post #6 of 7
is their anyway you can get another card an see if the drivers work for them if it does than its the graphics card if not i would be another part
post #7 of 7
Thread Starter 
Quote:
Originally Posted by perfectnova View Post

is their anyway you can get another card an see if the drivers work for them if it does than its the graphics card if not i would be another part

'Fraid not, only card I have. The drivers from ASUS didn't make a difference either. I'll try moving the card back up to the original position later today.

Ok, got it back into the old PCIE slot and it's all working perfectly. Which is a big annoyance, because I moved it in the first place to make more of a gap between the GPU and CPU cooler, as well as allowing me access to the PCIE x1 slot.
Edited by evil_scotsman - 2/23/12 at 1:16pm
Project: Vortex
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600 ASRock Z68 Extreme7  Asus GTX 570 DCII Corsair Vengeance 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda ST1000DM003 Sony 24xDVD RW Cooler Master V8 Windows 7 Pro x64 
MonitorKeyboardPowerCase
21.5" Asus VE228H LED Logitech Ultra Flat Corsair AX750 CM Storm Sniper (temporary) 
MouseMouse Pad
Razer Imperator Mousepad's are a PITA. 
  hide details  
Reply
Project: Vortex
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600 ASRock Z68 Extreme7  Asus GTX 570 DCII Corsair Vengeance 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda ST1000DM003 Sony 24xDVD RW Cooler Master V8 Windows 7 Pro x64 
MonitorKeyboardPowerCase
21.5" Asus VE228H LED Logitech Ultra Flat Corsair AX750 CM Storm Sniper (temporary) 
MouseMouse Pad
Razer Imperator Mousepad's are a PITA. 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Problems with GTX570