Overclock.net › Forums › AMD › AMD Motherboards › AMD AHCI or Generic Win 7 one?
New Posts  All Forums:Forum Nav:

AMD AHCI or Generic Win 7 one? - Page 3

post #21 of 44
@phihalo66,

When you installed the AMD ACHI drivers it was giving you BSOD on loading bc you didnt had it turn on on your registry, the thing is that if you install windows on IDE and then you just tell him to install ACHI (because you enable it from the bios) it wont load up windows and dues the BSOD, there are guides like the one posted before where the right steps are to actually go to the registry change the value and then restart turn the ACHI from bios and then install the drivers in order to avoid BSOD.

You are not getting BSOD anymore bc you installed Win from zero and thats the same reason why in the registry you have already the value as needed.
4 GATE
(12 items)
 
  
CPUMotherboardGraphicsRAM
FX 8120 Asus Sabertooth 990FX ATI 6950 Corsair Vengeance LP 
Hard DriveHard DriveCoolingOS
Kingston SSDNOW 30 GB Seagate 7200rpm Corsair H100 Windows 7 Ultimate 64bits 
MonitorKeyboardPowerMouse
3x LG Flatron W2353v DasKeyboard Silent OCZ Silent 700w Logitech G3 
  hide details  
Reply
4 GATE
(12 items)
 
  
CPUMotherboardGraphicsRAM
FX 8120 Asus Sabertooth 990FX ATI 6950 Corsair Vengeance LP 
Hard DriveHard DriveCoolingOS
Kingston SSDNOW 30 GB Seagate 7200rpm Corsair H100 Windows 7 Ultimate 64bits 
MonitorKeyboardPowerMouse
3x LG Flatron W2353v DasKeyboard Silent OCZ Silent 700w Logitech G3 
  hide details  
Reply
post #22 of 44
Thread Starter 
well turns out i spoke too son instead of a BSOD the entire system looks up with ANY HHD activity so screw it I'll stick with IDE mode until amd learns how to make a driver that doesn't suck.
Tha Beast!
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K 4.4Ghz 1.25V ASUS Z87 Sabertooth EVGA GTX 1080 FTW2 iCX 2126/11GHz 16GB DDR3 2400Mhz 
Hard DriveHard DriveCoolingOS
Kingston 480GB SSD HGST 2TB Corsair H100i Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
AOC I2269VW-B 22" Razer BlackWidow Ultimate 2014 Corsair HX650 Corsair Vengance C70 Gunmetal 
MouseMouse PadAudio
Razer Deathadder 2013 Razer goliathus Sound Blaster X-FI Xtreme Audio PCIe 
  hide details  
Reply
Tha Beast!
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K 4.4Ghz 1.25V ASUS Z87 Sabertooth EVGA GTX 1080 FTW2 iCX 2126/11GHz 16GB DDR3 2400Mhz 
Hard DriveHard DriveCoolingOS
Kingston 480GB SSD HGST 2TB Corsair H100i Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
AOC I2269VW-B 22" Razer BlackWidow Ultimate 2014 Corsair HX650 Corsair Vengance C70 Gunmetal 
MouseMouse PadAudio
Razer Deathadder 2013 Razer goliathus Sound Blaster X-FI Xtreme Audio PCIe 
  hide details  
Reply
post #23 of 44
Quote:
Originally Posted by CDub07 View Post

achi is NOT included in windows 7 for AMD drivers just intel. So if u don't install the drivers from the mobo maker Windows 7 doesn't support ACHI. From what I could find.

Um.. when you install Windows 7 it uses a unified driver (WDM) for AHCI, compatible with Intel or AMD platforms.

confused.gif

It's not 'specifically' for Intel... where did you get that from?
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
post #24 of 44
Quote:
Originally Posted by philhalo66 View Post

well turns out i spoke too son instead of a BSOD the entire system looks up with ANY HHD activity so screw it I'll stick with IDE mode until amd learns how to make a driver that doesn't suck.

Sounds like a HDD problem, not your controller/driver.

Check your HDD for problems and if it is good (free and clear of signs of trouble) perhaps you have a bad SATA cable, or perhaps the controller is bugged.
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
post #25 of 44
Thread Starter 
Quote:
Originally Posted by GanjaSMK View Post

Sounds like a HDD problem, not your controller/driver.
Check your HDD for problems and if it is good (free and clear of signs of trouble) perhaps you have a bad SATA cable, or perhaps the controller is bugged.

the HDD is fine i ran a check last night how would i find out if the controller is bugged?
Tha Beast!
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K 4.4Ghz 1.25V ASUS Z87 Sabertooth EVGA GTX 1080 FTW2 iCX 2126/11GHz 16GB DDR3 2400Mhz 
Hard DriveHard DriveCoolingOS
Kingston 480GB SSD HGST 2TB Corsair H100i Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
AOC I2269VW-B 22" Razer BlackWidow Ultimate 2014 Corsair HX650 Corsair Vengance C70 Gunmetal 
MouseMouse PadAudio
Razer Deathadder 2013 Razer goliathus Sound Blaster X-FI Xtreme Audio PCIe 
  hide details  
Reply
Tha Beast!
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K 4.4Ghz 1.25V ASUS Z87 Sabertooth EVGA GTX 1080 FTW2 iCX 2126/11GHz 16GB DDR3 2400Mhz 
Hard DriveHard DriveCoolingOS
Kingston 480GB SSD HGST 2TB Corsair H100i Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
AOC I2269VW-B 22" Razer BlackWidow Ultimate 2014 Corsair HX650 Corsair Vengance C70 Gunmetal 
MouseMouse PadAudio
Razer Deathadder 2013 Razer goliathus Sound Blaster X-FI Xtreme Audio PCIe 
  hide details  
Reply
post #26 of 44
Quote:
Originally Posted by philhalo66 View Post

Quote:
Originally Posted by GanjaSMK View Post

Sounds like a HDD problem, not your controller/driver.
Check your HDD for problems and if it is good (free and clear of signs of trouble) perhaps you have a bad SATA cable, or perhaps the controller is bugged.

the HDD is fine i ran a check last night how would i find out if the controller is bugged?

Start by trying different SATA ports. Could just be a port. Unlikely your controller is bad but always a possibility there. For that you'd probably need a professional diagnostics system and those are expensive.
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
post #27 of 44
Thread Starter 
Quote:
Originally Posted by GanjaSMK View Post

Start by trying different SATA ports. Could just be a port. Unlikely your controller is bad but always a possibility there. For that you'd probably need a professional diagnostics system and those are expensive.

its very odd like 2 days ago my hard drive kept disappearing from my system till i did a reboot then a few hours later it would disappear again but on a clean install it hasn't done this once but it keeps either getting extremely slow (HDD LED lights up) and the system does nothing) i'm about to do a clean install ocne more and see if i can fix it by doing that, if not i'll post back here.
Tha Beast!
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K 4.4Ghz 1.25V ASUS Z87 Sabertooth EVGA GTX 1080 FTW2 iCX 2126/11GHz 16GB DDR3 2400Mhz 
Hard DriveHard DriveCoolingOS
Kingston 480GB SSD HGST 2TB Corsair H100i Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
AOC I2269VW-B 22" Razer BlackWidow Ultimate 2014 Corsair HX650 Corsair Vengance C70 Gunmetal 
MouseMouse PadAudio
Razer Deathadder 2013 Razer goliathus Sound Blaster X-FI Xtreme Audio PCIe 
  hide details  
Reply
Tha Beast!
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K 4.4Ghz 1.25V ASUS Z87 Sabertooth EVGA GTX 1080 FTW2 iCX 2126/11GHz 16GB DDR3 2400Mhz 
Hard DriveHard DriveCoolingOS
Kingston 480GB SSD HGST 2TB Corsair H100i Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
AOC I2269VW-B 22" Razer BlackWidow Ultimate 2014 Corsair HX650 Corsair Vengance C70 Gunmetal 
MouseMouse PadAudio
Razer Deathadder 2013 Razer goliathus Sound Blaster X-FI Xtreme Audio PCIe 
  hide details  
Reply
post #28 of 44
Quote:
Originally Posted by philhalo66 View Post

its very odd like 2 days ago my hard drive kept disappearing from my system till i did a reboot then a few hours later it would disappear again but on a clean install it hasn't done this once but it keeps either getting extremely slow (HDD LED lights up) and the system does nothing) i'm about to do a clean install ocne more and see if i can fix it by doing that, if not i'll post back here.

Check the Asrock site, there is (for my new board at least) a "floppy" version of the driver, download that, decompress it, store it on a USB stick, right at the beginning of Windows install, it gives the option to install 3rd party drivers for your storage, set AHCI mode in the beginning, and use that option to grab the driver from the USB stick, that should work for a straight to AHCI install.
Ryzen 5 1600
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD Ryzen 5 1600 MSI B350 Gaming Plus Gigabyte GeForce GTX 1060 WINDFORCE2 OC 16GB (2x8GB) Corsair DDR4 Vengeance LED, PC4-24... 
Hard DriveHard DriveCoolingOS
256GB Samsung PM961 Polaris M.2 NVMe  1TB Toshiba DT01ACA100 3.5" HDD, SATA III  Cooler Master Hyper 212 Evo Windows 10 64 
KeyboardPowerCaseMouse
Unicomp Model M 650W EVGA SuperNOVA G1, 80PLUS Gold, Full Modular Kolink Luminosity Cooler Master Reaper Aluminium 
  hide details  
Reply
Ryzen 5 1600
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD Ryzen 5 1600 MSI B350 Gaming Plus Gigabyte GeForce GTX 1060 WINDFORCE2 OC 16GB (2x8GB) Corsair DDR4 Vengeance LED, PC4-24... 
Hard DriveHard DriveCoolingOS
256GB Samsung PM961 Polaris M.2 NVMe  1TB Toshiba DT01ACA100 3.5" HDD, SATA III  Cooler Master Hyper 212 Evo Windows 10 64 
KeyboardPowerCaseMouse
Unicomp Model M 650W EVGA SuperNOVA G1, 80PLUS Gold, Full Modular Kolink Luminosity Cooler Master Reaper Aluminium 
  hide details  
Reply
post #29 of 44
Try a different Sata cable.
HAF H2
(16 items)
 
  
CPUMotherboardGraphicsRAM
AMD FX-4100 on Water SABERTOOTH 990FX Visiontek 6970 Mushkin  
RAMHard DriveHard DriveCooling
Mushkin  Samsung 830 WD Velociraptor  Custom Water Loop 
OSMonitorPowerCase
W7 64 Acer X223w 22" Corsair TX850 HAF932 Custom Paint 
  hide details  
Reply
HAF H2
(16 items)
 
  
CPUMotherboardGraphicsRAM
AMD FX-4100 on Water SABERTOOTH 990FX Visiontek 6970 Mushkin  
RAMHard DriveHard DriveCooling
Mushkin  Samsung 830 WD Velociraptor  Custom Water Loop 
OSMonitorPowerCase
W7 64 Acer X223w 22" Corsair TX850 HAF932 Custom Paint 
  hide details  
Reply
post #30 of 44
Quote:
Originally Posted by GanjaSMK View Post

Um.. when you install Windows 7 it uses a unified driver (WDM) for AHCI, compatible with Intel or AMD platforms.
confused.gif
It's not 'specifically' for Intel... where did you get that from?

My mistake. I was doing a lot of reading on the fly. Intel only defined the standard and the driver is included on both Vista and Windows 7 but is disabled my default. Looks like the best way to avoid any troubles is enable ACHI then install Windows 7 in that order.

The only time I have had any trouble with achi is when I had to enable it after installing Windows 7.

Quote:
Originally Posted by philhalo66 View Post

its very odd like 2 days ago my hard drive kept disappearing from my system till i did a reboot then a few hours later it would disappear again but on a clean install it hasn't done this once but it keeps either getting extremely slow (HDD LED lights up) and the system does nothing) i'm about to do a clean install ocne more and see if i can fix it by doing that, if not i'll post back here.


Might been something to bring up before. If your install is blank and your have nothing to loss a clean install with achi enabled in bios would be your best option.
Edited by CDub07 - 2/25/12 at 7:38am
White Lightning
(13 items)
 
   
CPUMotherboardGraphicsRAM
AMD Ryzen 7 1700X Processor  ASUS ROG Crosshair VI Hero (WI-FI AC) ASUS GeForce GTX 1060 6GB ROG STRIX  Corsair Vengeance 16GB DDR4 3200 White LED  
Hard DriveHard DriveOptical DriveCooling
Crucial MX300 525GB M.2 SSD  Toshiba X300 4TB Desktop 3.5  LG WH16NS40 Super Multi Blue 16x Blu-ray Disc  Corsair Hydro Series H110i Extreme Performance... 
CoolingOSMonitorPower
Corsair Corsair Air Series AF140 LED Quiet Edi... Windows 10 Pro AOC 2757 27" 1080p IPS Monitor  Seasonic SS-760XP2 Platinum 
Case
Cooler Master Mastercase Pro 5 
CPUMotherboardGraphicsRAM
AMD FX-8320E @ 4.1GHz Asrock 970M Pro3 mATX XFX Radeon RX 460 4 GB GDDR5 PCI Express 3.0 Gr... PNY Anarchy 16GB Kit (2x8GB) DDR3 1866MHz 
Hard DriveOptical DriveCoolingOS
SAMSUNG 850 EVO 2.5" 250GB SAMSUNG DVD Writer SH-224FB Scythe Samurai ZZ Rev.B CPU Cooler Windows 7 Pro SP1 
MonitorKeyboardPowerCase
AOC 27" I2757FH IPS LED HD Monitor Zalman ZM-K200M USB Keyboard EVGA 500W 80 PLUS Certified Power Supply Thermaltake Urban S1 Mini Tower Computer Case  
MouseMouse PadAudioOther
Zalman ZM-400M USB Mouse Jeecoo Mouse Pad 320x270x3mm Non-slip Rubber Ba... Z313 Multimedia Speaker System  AzureWave Broadcom BCM94352HMB/BCM94352 802.11/... 
CPUMotherboardRAMHard Drive
Marvell 6282 Processor( 1.60GHz 256KB) Marvell 88F6282 SoC 256MB DDR3 1600 MHz Seagate Barracuda Green 2TB SATA 6Gb/s 64MB  
OS
LenovoEMC LifeLine 4.0 
  hide details  
Reply
White Lightning
(13 items)
 
   
CPUMotherboardGraphicsRAM
AMD Ryzen 7 1700X Processor  ASUS ROG Crosshair VI Hero (WI-FI AC) ASUS GeForce GTX 1060 6GB ROG STRIX  Corsair Vengeance 16GB DDR4 3200 White LED  
Hard DriveHard DriveOptical DriveCooling
Crucial MX300 525GB M.2 SSD  Toshiba X300 4TB Desktop 3.5  LG WH16NS40 Super Multi Blue 16x Blu-ray Disc  Corsair Hydro Series H110i Extreme Performance... 
CoolingOSMonitorPower
Corsair Corsair Air Series AF140 LED Quiet Edi... Windows 10 Pro AOC 2757 27" 1080p IPS Monitor  Seasonic SS-760XP2 Platinum 
Case
Cooler Master Mastercase Pro 5 
CPUMotherboardGraphicsRAM
AMD FX-8320E @ 4.1GHz Asrock 970M Pro3 mATX XFX Radeon RX 460 4 GB GDDR5 PCI Express 3.0 Gr... PNY Anarchy 16GB Kit (2x8GB) DDR3 1866MHz 
Hard DriveOptical DriveCoolingOS
SAMSUNG 850 EVO 2.5" 250GB SAMSUNG DVD Writer SH-224FB Scythe Samurai ZZ Rev.B CPU Cooler Windows 7 Pro SP1 
MonitorKeyboardPowerCase
AOC 27" I2757FH IPS LED HD Monitor Zalman ZM-K200M USB Keyboard EVGA 500W 80 PLUS Certified Power Supply Thermaltake Urban S1 Mini Tower Computer Case  
MouseMouse PadAudioOther
Zalman ZM-400M USB Mouse Jeecoo Mouse Pad 320x270x3mm Non-slip Rubber Ba... Z313 Multimedia Speaker System  AzureWave Broadcom BCM94352HMB/BCM94352 802.11/... 
CPUMotherboardRAMHard Drive
Marvell 6282 Processor( 1.60GHz 256KB) Marvell 88F6282 SoC 256MB DDR3 1600 MHz Seagate Barracuda Green 2TB SATA 6Gb/s 64MB  
OS
LenovoEMC LifeLine 4.0 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › AMD AHCI or Generic Win 7 one?