Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › 8GB of RAM and memory hitting 80% usage with nothing running
New Posts  All Forums:Forum Nav:

8GB of RAM and memory hitting 80% usage with nothing running

post #1 of 17
Thread Starter 
So I think this is the right place to post this so here goes a little background first.

I usually leave my PC running 24/7 since I like to be able to access it around the house on my laptop and stream from it too my XBox. It is also my primary gaming rig.

Lately, I have been noticing that with 8GB of ram, my PC is sitting at 80% physical ram usage even though nothing is running. I started to notice this when games started to run slower than they used to and even to the point where firefox would take waaaaaay long to load a page. When I am on the PC the only things I may be running concurrently are Firefox, a game (either SWTOR or FFXIV or something else), ventrilo and sometimes spotify/zune.

I have checked several times the last few days and SWTOR at most uses 1.2GB ram, firefox can get up to 500MB and the others usually are below 50MB so what changed all a sudden that 6.2GB out of my 8 are in use? It used to sit at around 10% with nothing running.

Any suggestions on where to start would be greatly appreciated.
Luminescence v2.2
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 5820K 4.4Ghz @ 1.32v MSI X99S SLI Krait Edition GIGABYTE GeForce GTX 980Ti 6GB G1 GAMING OC EDI... 16GB Corsair Vengeance LPX DDR4 3000mhz @ 3200m... 
Hard DriveHard DriveCoolingOS
2x Spinpoint 1TB 240GB Patriot Blaze SSD Corsair H100i GTX Windows 10 Professional x64 
MonitorKeyboardPowerCase
Dell U2412M x2 - LG 34UM95 Razer Black Widow Ultimate Thermaltake TR2 RX 850w Phanteks P400 
MouseMouse PadAudioAudio
Razer Naga 2014 Razer Goliathus LG Soundbar Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
Luminescence v2.2
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 5820K 4.4Ghz @ 1.32v MSI X99S SLI Krait Edition GIGABYTE GeForce GTX 980Ti 6GB G1 GAMING OC EDI... 16GB Corsair Vengeance LPX DDR4 3000mhz @ 3200m... 
Hard DriveHard DriveCoolingOS
2x Spinpoint 1TB 240GB Patriot Blaze SSD Corsair H100i GTX Windows 10 Professional x64 
MonitorKeyboardPowerCase
Dell U2412M x2 - LG 34UM95 Razer Black Widow Ultimate Thermaltake TR2 RX 850w Phanteks P400 
MouseMouse PadAudioAudio
Razer Naga 2014 Razer Goliathus LG Soundbar Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
post #2 of 17
My brain has those also, it's a memory leak tongue.gif

Haven't used windows in a while, googling around for Windows 7 memory leak brings up some hotfixes and supposed updates.

Maybe try updating?
Neckpain
(12 items)
 
LAN rig
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7 4930k Sabertooth x79 Nvidia 650ti Corsair Vengeance 
CoolingOSMonitorKeyboard
H100 Linux Mint ASUS 21.5" CMSTORM Quick Fire 
PowerCaseMouseAudio
Enermax 1050W Corsair Vengeance Series C70 Logitech Performance MX Xonar DX 
CPUMotherboardGraphicsRAM
AMD A10 5800K ASRock FM2A75M-ITX AMD Radeon HD 7660D samsung wonder ram 
Optical DriveCoolingOSOS
None Stock Linux Mint 14 64bit Windows Server 2012 
  hide details  
Reply
Neckpain
(12 items)
 
LAN rig
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7 4930k Sabertooth x79 Nvidia 650ti Corsair Vengeance 
CoolingOSMonitorKeyboard
H100 Linux Mint ASUS 21.5" CMSTORM Quick Fire 
PowerCaseMouseAudio
Enermax 1050W Corsair Vengeance Series C70 Logitech Performance MX Xonar DX 
CPUMotherboardGraphicsRAM
AMD A10 5800K ASRock FM2A75M-ITX AMD Radeon HD 7660D samsung wonder ram 
Optical DriveCoolingOSOS
None Stock Linux Mint 14 64bit Windows Server 2012 
  hide details  
Reply
post #3 of 17
I had this once with iTunes I had backed up my phones earlier. Some how I think the entire iPhone backup never was flushed from the Ram a restart fixed it for me.
 
4x r290's
(9 items)
 
3x 7970's
(16 items)
 
CPUMotherboardGraphicsGraphics
i7 3930K 4.8Ghz offset ASUS X79 Rampage IV Extreme GTX 780 with EK waterblock GTX 780 with EK waterblock 
GraphicsRAMHard DriveHard Drive
GTX 780 with EK waterblock  Samsung 16GB (4x4gb) 2400Mhz 10-12-12-31-1t @ 1... 256GB Samsung 950 Pro 256GB Samsung 840 Pro 
CoolingCoolingOSMonitor
RX360, EX360, EX360, and 480 Rad's XSPC Raystorm CPU Block Dual boot (other unnamed OS) and Win8 Pro QNIX QX2710 27" 2560x1440 @ 112hz 
KeyboardPowerCase
Corsair K90 Corsair AX1200 Corsair 700D Modded w/ External Radiators 
CPUMotherboardGraphicsRAM
Intel i5 3570K GA-Z77X-UD3H 4x R9 290's 8GB 1600Mhz 
Hard DriveOSPowerCase
1TB Hard Drive Win8 Corsair Dual PSU - AX1200 and HX650 Open Case 
Other
Thee 16x Risers and One 1x Riser 
CPUMotherboardGraphicsRAM
i7 3930K 5Ghz Bench ASUS X79 Rampage IV Extreme 3x AMD 7970's w/ EK water blocks Samsung 16GB (4x4gb) 2400Mhz 10-12-12-31-1t @ 1... 
Hard DriveCoolingCoolingMonitor
128GB Samsung 830  RX360, RX240, EX360 XSPC Raystorm CPU Block QNIX QX2710 27" 2560x1440 @ 114hz 
KeyboardPowerCase
Corsair K90 Corsair AX760i Corsair 700D Modded w/ External Radiators 
  hide details  
Reply
 
4x r290's
(9 items)
 
3x 7970's
(16 items)
 
CPUMotherboardGraphicsGraphics
i7 3930K 4.8Ghz offset ASUS X79 Rampage IV Extreme GTX 780 with EK waterblock GTX 780 with EK waterblock 
GraphicsRAMHard DriveHard Drive
GTX 780 with EK waterblock  Samsung 16GB (4x4gb) 2400Mhz 10-12-12-31-1t @ 1... 256GB Samsung 950 Pro 256GB Samsung 840 Pro 
CoolingCoolingOSMonitor
RX360, EX360, EX360, and 480 Rad's XSPC Raystorm CPU Block Dual boot (other unnamed OS) and Win8 Pro QNIX QX2710 27" 2560x1440 @ 112hz 
KeyboardPowerCase
Corsair K90 Corsair AX1200 Corsair 700D Modded w/ External Radiators 
CPUMotherboardGraphicsRAM
Intel i5 3570K GA-Z77X-UD3H 4x R9 290's 8GB 1600Mhz 
Hard DriveOSPowerCase
1TB Hard Drive Win8 Corsair Dual PSU - AX1200 and HX650 Open Case 
Other
Thee 16x Risers and One 1x Riser 
CPUMotherboardGraphicsRAM
i7 3930K 5Ghz Bench ASUS X79 Rampage IV Extreme 3x AMD 7970's w/ EK water blocks Samsung 16GB (4x4gb) 2400Mhz 10-12-12-31-1t @ 1... 
Hard DriveCoolingCoolingMonitor
128GB Samsung 830  RX360, RX240, EX360 XSPC Raystorm CPU Block QNIX QX2710 27" 2560x1440 @ 114hz 
KeyboardPowerCase
Corsair K90 Corsair AX760i Corsair 700D Modded w/ External Radiators 
  hide details  
Reply
post #4 of 17
Take a screenshot of your Task Manager and make sure its its on the "Processes" tab and arranged by "Memory" highest usage on top.
post #5 of 17
Thread Starter 
Quote:
Originally Posted by Fir3Chi3f View Post

My brain has those also, it's a memory leak tongue.gif
Haven't used windows in a while, googling around for Windows 7 memory leak brings up some hotfixes and supposed updates.
Maybe try updating?

Windows is fully updated except the languages O_o.
Quote:
Originally Posted by armen16 View Post

Take a screenshot of your Task Manager and make sure its its on the "Processes" tab and arranged by "Memory" highest usage on top.

At the moment the PC is off because I didn't know what else to really do with it since it got so slow. I did look at task manager though and before closing them the highest item was 499MB and that was firefox, below that was dwm I believe at like 100MB. After closing firefox usage fell to 74% and by my math it didn't add up to the 6204MB in use even with Show processes from all users on.

If you'd like to see for yourself I can probably reproduce it tomorrow after work.
Luminescence v2.2
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 5820K 4.4Ghz @ 1.32v MSI X99S SLI Krait Edition GIGABYTE GeForce GTX 980Ti 6GB G1 GAMING OC EDI... 16GB Corsair Vengeance LPX DDR4 3000mhz @ 3200m... 
Hard DriveHard DriveCoolingOS
2x Spinpoint 1TB 240GB Patriot Blaze SSD Corsair H100i GTX Windows 10 Professional x64 
MonitorKeyboardPowerCase
Dell U2412M x2 - LG 34UM95 Razer Black Widow Ultimate Thermaltake TR2 RX 850w Phanteks P400 
MouseMouse PadAudioAudio
Razer Naga 2014 Razer Goliathus LG Soundbar Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
Luminescence v2.2
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 5820K 4.4Ghz @ 1.32v MSI X99S SLI Krait Edition GIGABYTE GeForce GTX 980Ti 6GB G1 GAMING OC EDI... 16GB Corsair Vengeance LPX DDR4 3000mhz @ 3200m... 
Hard DriveHard DriveCoolingOS
2x Spinpoint 1TB 240GB Patriot Blaze SSD Corsair H100i GTX Windows 10 Professional x64 
MonitorKeyboardPowerCase
Dell U2412M x2 - LG 34UM95 Razer Black Widow Ultimate Thermaltake TR2 RX 850w Phanteks P400 
MouseMouse PadAudioAudio
Razer Naga 2014 Razer Goliathus LG Soundbar Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
post #6 of 17
I've had faulty memory show up as in use in windows, may be worth running Memtest.

Otherwise make sure it is showing processes from all users. Then if thats not good enough, get Process Explorer so that you can see what files are running under each process. That will let you track down the threads which are stealing you memory!
RAH! v2
(20 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.5GHz v1.328 Asus P8Z68 Deluxe/GEN3 GTX 970 WindForce 4Gb Corsair Vengance DDR3 1600MHz 4x4GB (2 Blue 2 B... 
Hard DriveHard DriveHard DriveHard Drive
Samsung EVO Samsung Spinpoint Hitachi Micron C400 
CoolingCoolingCoolingCooling
Alphacool NexXxos UT60 240mm Alphacool NexXxos ST30 240mm EK FC970 GTX WF3 EK FC970 GTX WF3 Backplate 
CoolingOSMonitorPower
Heatkiller IV CPU Block Windows 8.1 Pro (With Start8) Samsung S23B300B Antec 650W TruePower Modular 
CaseMouseMouse PadAudio
Corsair Graphite 600t White Microsoft Wireless Mouse 5000 SteelSeries M-Audio BX-5 D2's 
  hide details  
Reply
RAH! v2
(20 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.5GHz v1.328 Asus P8Z68 Deluxe/GEN3 GTX 970 WindForce 4Gb Corsair Vengance DDR3 1600MHz 4x4GB (2 Blue 2 B... 
Hard DriveHard DriveHard DriveHard Drive
Samsung EVO Samsung Spinpoint Hitachi Micron C400 
CoolingCoolingCoolingCooling
Alphacool NexXxos UT60 240mm Alphacool NexXxos ST30 240mm EK FC970 GTX WF3 EK FC970 GTX WF3 Backplate 
CoolingOSMonitorPower
Heatkiller IV CPU Block Windows 8.1 Pro (With Start8) Samsung S23B300B Antec 650W TruePower Modular 
CaseMouseMouse PadAudio
Corsair Graphite 600t White Microsoft Wireless Mouse 5000 SteelSeries M-Audio BX-5 D2's 
  hide details  
Reply
post #7 of 17
Thread Starter 
Quote:
Originally Posted by Br0k3nLiNk View Post

I've had faulty memory show up as in use in windows, may be worth running Memtest.
Otherwise make sure it is showing processes from all users. Then if thats not good enough, get Process Explorer so that you can see what files are running under each process. That will let you track down the threads which are stealing you memory!

Alright, I'll try it tomorrow.

Could using two different kinda of RAM cause the problem? I am using Corsair XMS3 and Vengeance, both are 9-9-9-27 at 1600mhz, 1.5v. 4GB each.
Luminescence v2.2
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 5820K 4.4Ghz @ 1.32v MSI X99S SLI Krait Edition GIGABYTE GeForce GTX 980Ti 6GB G1 GAMING OC EDI... 16GB Corsair Vengeance LPX DDR4 3000mhz @ 3200m... 
Hard DriveHard DriveCoolingOS
2x Spinpoint 1TB 240GB Patriot Blaze SSD Corsair H100i GTX Windows 10 Professional x64 
MonitorKeyboardPowerCase
Dell U2412M x2 - LG 34UM95 Razer Black Widow Ultimate Thermaltake TR2 RX 850w Phanteks P400 
MouseMouse PadAudioAudio
Razer Naga 2014 Razer Goliathus LG Soundbar Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
Luminescence v2.2
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 5820K 4.4Ghz @ 1.32v MSI X99S SLI Krait Edition GIGABYTE GeForce GTX 980Ti 6GB G1 GAMING OC EDI... 16GB Corsair Vengeance LPX DDR4 3000mhz @ 3200m... 
Hard DriveHard DriveCoolingOS
2x Spinpoint 1TB 240GB Patriot Blaze SSD Corsair H100i GTX Windows 10 Professional x64 
MonitorKeyboardPowerCase
Dell U2412M x2 - LG 34UM95 Razer Black Widow Ultimate Thermaltake TR2 RX 850w Phanteks P400 
MouseMouse PadAudioAudio
Razer Naga 2014 Razer Goliathus LG Soundbar Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
post #8 of 17
Quote:
Originally Posted by Penryn View Post

Alright, I'll try it tomorrow.
Could using two different kinda of RAM cause the problem? I am using Corsair XMS3 and Vengeance, both are 9-9-9-27 at 1600mhz, 1.5v. 4GB each.

No. You should do as Armen16 requested and post that screen. Anything will be total guess work without looking at that.
Gizmoto
(18 items)
 
They beat me:(
(15 items)
 
Home Server V1.0
(17 items)
 
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1040t @2.7Ghz ASRock 880GM-LE FX  AMD Radeon HD 4250 integrated graphics Micro Center(ADATA) 8Gb (2x4) 1333 
Hard DriveHard DriveHard DriveHard Drive
Western Digital Caviar Blue 640Gb Samsung SpinPoint F4 2Tb Seagate Barracuda 7200.9 ST3500641AS-RK 500Gb Seagate Barracuda 7200.9 ST3500641AS-RK 500Gb 
Optical DriveOptical DriveCoolingOS
ASUS 24X DVD Burner ASUS 24X DVD Burner Stock AMD Cooler Windows 7 Home Premium 64 bit 
OSOSPowerCase
Linux Mint (VM) Linux Ubuntu (VM) Inland ILG-500R2 500w PSU DiabloTek Evo Mid-tower Case 
Other
Inland IL internal card reader 
  hide details  
Reply
Gizmoto
(18 items)
 
They beat me:(
(15 items)
 
Home Server V1.0
(17 items)
 
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1040t @2.7Ghz ASRock 880GM-LE FX  AMD Radeon HD 4250 integrated graphics Micro Center(ADATA) 8Gb (2x4) 1333 
Hard DriveHard DriveHard DriveHard Drive
Western Digital Caviar Blue 640Gb Samsung SpinPoint F4 2Tb Seagate Barracuda 7200.9 ST3500641AS-RK 500Gb Seagate Barracuda 7200.9 ST3500641AS-RK 500Gb 
Optical DriveOptical DriveCoolingOS
ASUS 24X DVD Burner ASUS 24X DVD Burner Stock AMD Cooler Windows 7 Home Premium 64 bit 
OSOSPowerCase
Linux Mint (VM) Linux Ubuntu (VM) Inland ILG-500R2 500w PSU DiabloTek Evo Mid-tower Case 
Other
Inland IL internal card reader 
  hide details  
Reply
post #9 of 17
Quote:
Originally Posted by Penryn View Post

Alright, I'll try it tomorrow.
Could using two different kinda of RAM cause the problem? I am using Corsair XMS3 and Vengeance, both are 9-9-9-27 at 1600mhz, 1.5v. 4GB each.

Multiple memory shouldn't be the issue, as long as the run the same voltage and speeds stable.

You know I bet Edward Elric could figure it out smile.gif
Main Rig
(21 items)
 
   
CPUMotherboardGraphicsRAM
i5 2500k @ 4.5ghz 24/7 MSI P67 GD55 Gigabyte GTX 1070 2x4GB Corsair Vengeance Blue 
Hard DriveOptical DriveOSMonitor
Crucial M4 128GB, 3TB HDD, 1TB HDD Samsung DVD-RW SATA Windows 10 64bit Hanns G 23" 1080p 60Hz 
MonitorMonitorMonitorKeyboard
Dell S2716DG 1440P 144hz Gsync TN Hanns G 23" 1080p 60Hz Epson Pro Cinema 9500UB 1080p Projector (110") Razer Black Widow Ultimate BF3 Edition (orange) 
PowerCaseMouseMouse Pad
Corsair TX750 Corsair 400R Steelseries Rival Steelseries QCK+ 
AudioAudioAudioAudio
Asus Xonar DG Astro A40 V Moda Crossfade LP Logitech Z5300 
Audio
Denon 1909 + 7.1 infinity surround 
CPUGraphicsRAMHard Drive
A6 3420 HD 6520G 8GB 500GB 5400RPM 
MonitorKeyboard
15.6" 1366x768 Generic with numberpad 
  hide details  
Reply
Main Rig
(21 items)
 
   
CPUMotherboardGraphicsRAM
i5 2500k @ 4.5ghz 24/7 MSI P67 GD55 Gigabyte GTX 1070 2x4GB Corsair Vengeance Blue 
Hard DriveOptical DriveOSMonitor
Crucial M4 128GB, 3TB HDD, 1TB HDD Samsung DVD-RW SATA Windows 10 64bit Hanns G 23" 1080p 60Hz 
MonitorMonitorMonitorKeyboard
Dell S2716DG 1440P 144hz Gsync TN Hanns G 23" 1080p 60Hz Epson Pro Cinema 9500UB 1080p Projector (110") Razer Black Widow Ultimate BF3 Edition (orange) 
PowerCaseMouseMouse Pad
Corsair TX750 Corsair 400R Steelseries Rival Steelseries QCK+ 
AudioAudioAudioAudio
Asus Xonar DG Astro A40 V Moda Crossfade LP Logitech Z5300 
Audio
Denon 1909 + 7.1 infinity surround 
CPUGraphicsRAMHard Drive
A6 3420 HD 6520G 8GB 500GB 5400RPM 
MonitorKeyboard
15.6" 1366x768 Generic with numberpad 
  hide details  
Reply
post #10 of 17
Quote:
Originally Posted by Penryn View Post

Alright, I'll try it tomorrow.
Could using two different kinda of RAM cause the problem? I am using Corsair XMS3 and Vengeance, both are 9-9-9-27 at 1600mhz, 1.5v. 4GB each.

So long as they have the same voltage they should be fine. I always tend to make mine run with the same timings too, as some BIOS's can run different speeds on each slot redface.gif
RAH! v2
(20 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.5GHz v1.328 Asus P8Z68 Deluxe/GEN3 GTX 970 WindForce 4Gb Corsair Vengance DDR3 1600MHz 4x4GB (2 Blue 2 B... 
Hard DriveHard DriveHard DriveHard Drive
Samsung EVO Samsung Spinpoint Hitachi Micron C400 
CoolingCoolingCoolingCooling
Alphacool NexXxos UT60 240mm Alphacool NexXxos ST30 240mm EK FC970 GTX WF3 EK FC970 GTX WF3 Backplate 
CoolingOSMonitorPower
Heatkiller IV CPU Block Windows 8.1 Pro (With Start8) Samsung S23B300B Antec 650W TruePower Modular 
CaseMouseMouse PadAudio
Corsair Graphite 600t White Microsoft Wireless Mouse 5000 SteelSeries M-Audio BX-5 D2's 
  hide details  
Reply
RAH! v2
(20 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.5GHz v1.328 Asus P8Z68 Deluxe/GEN3 GTX 970 WindForce 4Gb Corsair Vengance DDR3 1600MHz 4x4GB (2 Blue 2 B... 
Hard DriveHard DriveHard DriveHard Drive
Samsung EVO Samsung Spinpoint Hitachi Micron C400 
CoolingCoolingCoolingCooling
Alphacool NexXxos UT60 240mm Alphacool NexXxos ST30 240mm EK FC970 GTX WF3 EK FC970 GTX WF3 Backplate 
CoolingOSMonitorPower
Heatkiller IV CPU Block Windows 8.1 Pro (With Start8) Samsung S23B300B Antec 650W TruePower Modular 
CaseMouseMouse PadAudio
Corsair Graphite 600t White Microsoft Wireless Mouse 5000 SteelSeries M-Audio BX-5 D2's 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › 8GB of RAM and memory hitting 80% usage with nothing running