post #1 of 1
Thread Starter 
Hello Everybody,

It is my first time in this forum so I hope somebody can help me with my issues. I got my AMD 7970 over the weekend and ever since I didn't manage to make the card work correctly, I installed the last 12.2 drives and when I go to youtube and after I play a video my computer just hardlock after few seconds. I verify the volts and Temps of the card and everything alright (just 41 degrees), I try the 12.1 drivers and I get the same problem. (I use CCleaner after deleting the drivers)

I tried playing ME3 and after just 30 minutes, again, a hardlock so I'm oblige to reset my computer. I really don't know what else to do, but I'm almost sure is driver related because once I uninstall the drivers and I run a video on youtube (using microsoft generic one) everything is alright, no hardlock at all (of course I cannot test playing a game without drivers).

In overall, I run a youtube video and I got almost immediately a hardlock, on ME3, after 30 minutes, I tried playing a movie on windows media player and everything fine. I check different forums and it looks like people manage to solved the problem updating or rolling back drivers but for me neither works.
__________________
ASUS Sabertooth X79 --i7 3930k -- Sapphire 7970 -- crucial m4 256gb -- 8gb g.skill DDR3-1600 RAM -- WD Caviar Black 2TB FAEX