Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Cisco ADSL card - Home setup
New Posts  All Forums:Forum Nav:

Cisco ADSL card - Home setup

post #1 of 6
Thread Starter 
I am planning on using my cisco 1760 router as a home router, i have recently bought an ADSL card to connect to my ISP but i have not experience with them. Could anyone give me some guidance when configuring it? What information will i need in order to configure it? Has anyone else done this?
Skynet HQ
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X2 Dual Core 2.70GHz Asus M3N-78 PRO ATI XFX 5770 5GB Corsair DDR2 
OSMonitorKeyboardPower
Windows 7 Ultimate 2x 23" LG Flatrons Logitech MX3100 850w PSU 
CaseMouse
X-Blade Gaming Case Logitech MX1100 
  hide details  
Reply
Skynet HQ
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X2 Dual Core 2.70GHz Asus M3N-78 PRO ATI XFX 5770 5GB Corsair DDR2 
OSMonitorKeyboardPower
Windows 7 Ultimate 2x 23" LG Flatrons Logitech MX3100 850w PSU 
CaseMouse
X-Blade Gaming Case Logitech MX1100 
  hide details  
Reply
post #2 of 6
Did you want to use this bridged or have the 1760 manage the PPPoE session?

Here's what I used for a routed interface on my 3660 when I had Verizon using a WIC-1ADSL.
Some commands may or may not be applicable to your IOS version such as bba-group.
Code:
bba-group pppoe global
 mac-address 0011.2233.4455
!
interface ATM1/0
 mac-address 0011.2233.4455
 no ip address
 atm restart timer 300
 no atm ilmi-keepalive
 bundle-enable
 bundle ama-bundle12
 !
 dsl operating-mode auto
 clock rate aal5 5300000
 clock rate aal2 1300000
 hold-queue 224 in
!
interface ATM1/0.1 point-to-point
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
!
interface Dialer1
 ip address negotiated
 no ip redirects
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ipv6 address autoconfig
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname yourverizonusernamehere
 ppp chap password yourpasswordhere
 ppp pap sent-username yourverizonusernamehere yourpasswordhere
 ppp ipcp dns request
!

If you have something else to manage your PPPoE session and want a bridged interface, use this:
Code:
no ip routing
!
interface ATM0/0
 mac-address 0000.0000.0001
 no ip address
 no ip route-cache
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 bridge-group 1
 hold-queue 224 in
 pvc 0/35
  encapsulation aal5snap
 !
!
interface FastEthernet0/0
 description **DSL Bridge to WAN-FW**
 no ip address
 no ip route-cache
 no ip mroute-cache
 speed 100
 full-duplex
 bridge-group 1
!
interface Dialer1
 no ip address
 no ip redirects
 ip mtu 1492
 encapsulation ppp
 no ip route-cache
 ppp authentication chap callin
 ppp chap hostname yourverizonname
 ppp chap password yourpassword
 ppp pap sent-username yourverizonname password yourpassword
 ppp ipcp dns request
!
bridge 1 protocol ieee
Das Rig, Ja?
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD Ryzen 1700 Asus Crosshair VI EVGA 1080Ti SC2 2x16G GSkill RGB 3200 
Hard DriveCoolingOSMonitor
500 GB 960 EVO Enermax T50A-BVT Windows 10 Pro 27" Asus 
KeyboardPowerCaseMouse
Logitech K350 EVGA 1600G2 Fractal Define C Rosewill M55 RGB 
  hide details  
Reply
Das Rig, Ja?
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD Ryzen 1700 Asus Crosshair VI EVGA 1080Ti SC2 2x16G GSkill RGB 3200 
Hard DriveCoolingOSMonitor
500 GB 960 EVO Enermax T50A-BVT Windows 10 Pro 27" Asus 
KeyboardPowerCaseMouse
Logitech K350 EVGA 1600G2 Fractal Define C Rosewill M55 RGB 
  hide details  
Reply
post #3 of 6
Thread Starter 
I'm confused, what was your setup because you seem to have 2 ATM interfaces or is one virtual?

I have similar config on my router but it doesn't seem to be working. Are there any troubleshooting commands?
Skynet HQ
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X2 Dual Core 2.70GHz Asus M3N-78 PRO ATI XFX 5770 5GB Corsair DDR2 
OSMonitorKeyboardPower
Windows 7 Ultimate 2x 23" LG Flatrons Logitech MX3100 850w PSU 
CaseMouse
X-Blade Gaming Case Logitech MX1100 
  hide details  
Reply
Skynet HQ
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X2 Dual Core 2.70GHz Asus M3N-78 PRO ATI XFX 5770 5GB Corsair DDR2 
OSMonitorKeyboardPower
Windows 7 Ultimate 2x 23" LG Flatrons Logitech MX3100 850w PSU 
CaseMouse
X-Blade Gaming Case Logitech MX1100 
  hide details  
Reply
post #4 of 6
Those were from my 3660 as well as a 2621 to highlight both routed and bridge mode configs.

show dsl int atm0/0 I think was one of the larger ones.
You can also do pppoe debug as well as atm debugging to see the session being set up.

Gave my WIC away about a year ago though frown.gif
Das Rig, Ja?
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD Ryzen 1700 Asus Crosshair VI EVGA 1080Ti SC2 2x16G GSkill RGB 3200 
Hard DriveCoolingOSMonitor
500 GB 960 EVO Enermax T50A-BVT Windows 10 Pro 27" Asus 
KeyboardPowerCaseMouse
Logitech K350 EVGA 1600G2 Fractal Define C Rosewill M55 RGB 
  hide details  
Reply
Das Rig, Ja?
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD Ryzen 1700 Asus Crosshair VI EVGA 1080Ti SC2 2x16G GSkill RGB 3200 
Hard DriveCoolingOSMonitor
500 GB 960 EVO Enermax T50A-BVT Windows 10 Pro 27" Asus 
KeyboardPowerCaseMouse
Logitech K350 EVGA 1600G2 Fractal Define C Rosewill M55 RGB 
  hide details  
Reply
post #5 of 6
Thread Starter 
I cant seem to get anything using the debug commands . I was hoping there was someone on here who could give me a step by step or take a look at my config and tell me where i am going wrong frown.gif
Here's my config if it helps anyone.


Building configuration...

Current configuration : 1389 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Parkwood
!
boot-start-marker
boot system flash advsecurity.bin
boot-end-marker
!
enable password ****
!
no aaa new-model
ip cef
!
!
!
!
no ip domain lookup
ip domain name ****
ip ssh maxstartups 2
ip ssh version 2
!
!
!
!
username **** privilege 15 password 0 *****
!
!
!
!
!
interface ATM0/0
mac-address **************
no ip address
ip nat outside
ip virtual-reassembly
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 244 in
pvc 0/40
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0/0
ip address 192.168.0.33 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
!
interface Dialer1
ip address negotiated
ip access-group dialer-in in
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
no cdp enable
ppp pap sent-username ******** password 0 **********
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
!
ip access-list extended dialer-in
permit ip any any
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
line aux 0
line vty 0 1
access-class 1 in
password *****
login local
!
end
Skynet HQ
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X2 Dual Core 2.70GHz Asus M3N-78 PRO ATI XFX 5770 5GB Corsair DDR2 
OSMonitorKeyboardPower
Windows 7 Ultimate 2x 23" LG Flatrons Logitech MX3100 850w PSU 
CaseMouse
X-Blade Gaming Case Logitech MX1100 
  hide details  
Reply
Skynet HQ
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X2 Dual Core 2.70GHz Asus M3N-78 PRO ATI XFX 5770 5GB Corsair DDR2 
OSMonitorKeyboardPower
Windows 7 Ultimate 2x 23" LG Flatrons Logitech MX3100 850w PSU 
CaseMouse
X-Blade Gaming Case Logitech MX1100 
  hide details  
Reply
post #6 of 6
Thread Starter 
Could someone maybe explain the virtual dialer? that might help me understand the config better because at the moment i have just used the commands form online tutorials. Should i double check the username and password with another router first?

It seems to me if nobody really knows exactly how to configure these cards :S
Skynet HQ
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X2 Dual Core 2.70GHz Asus M3N-78 PRO ATI XFX 5770 5GB Corsair DDR2 
OSMonitorKeyboardPower
Windows 7 Ultimate 2x 23" LG Flatrons Logitech MX3100 850w PSU 
CaseMouse
X-Blade Gaming Case Logitech MX1100 
  hide details  
Reply
Skynet HQ
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X2 Dual Core 2.70GHz Asus M3N-78 PRO ATI XFX 5770 5GB Corsair DDR2 
OSMonitorKeyboardPower
Windows 7 Ultimate 2x 23" LG Flatrons Logitech MX3100 850w PSU 
CaseMouse
X-Blade Gaming Case Logitech MX1100 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Cisco ADSL card - Home setup