Overclock.net › Forums › AMD › AMD Motherboards › Case Power Switch Not Working - ASRock Fatal1ty 990FX
New Posts  All Forums:Forum Nav:

Case Power Switch Not Working - ASRock Fatal1ty 990FX

post #1 of 10
Thread Starter 
Hey guys,

After recent events and the failure of my MSI board (who wouldda guessed? lol) I decided to go all out and get the Fatal1ty 990fx board.

Everything in the swap went smoothly except I noticed that there was a screw missing that holds down the top of the Mosfet heatsync but I had a replacement for it in my toolbox.

the other issue is that my case's power switch won't work to turn the system on. it will turn it off but not back on.

It is connected properly and was working perfectly on my MSI board.

Any Ideas?

Thanks for lookin! thumb.gif
post #2 of 10
of course someone is going to ask if you have another mobo to test it on.
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8 ghz ASRock Z68 Extreme 3 GTX 680 SLI G Skill Ripjaws 1600 
Hard DriveCoolingMonitorPower
256GB M4 SSD Raystorm CPU block Asus VW246H Nvidia Surround Kingwin Lazer 1kw 
Case
NZXT Switch 810 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8 ghz ASRock Z68 Extreme 3 GTX 680 SLI G Skill Ripjaws 1600 
Hard DriveCoolingMonitorPower
256GB M4 SSD Raystorm CPU block Asus VW246H Nvidia Surround Kingwin Lazer 1kw 
Case
NZXT Switch 810 
  hide details  
Reply
post #3 of 10
Thread Starter 
Quote:
Originally Posted by Dwood View Post

of course someone is going to ask if you have another mobo to test it on.

Like I said in the post, it was working perfectly on the half dead MSI this morning
post #4 of 10
Thread Starter 
A little bit of an update.

So tried switching the reset and power buttons to see if it would make a difference and alas no, so my case power button won't work but the internal one on the board works perfect.

Also a side weird note. the system turns itself on randomly in the middle of the night.

only thing I can figure is that LAN boot is active (the board doesn't actually shut all the way off, the LAN lights are still flashing) but the problem is I can't find a setting for it in the ?UFEI? (whatever the new BIOS are called)
post #5 of 10
Its not going to sleep from not being used?
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8 ghz ASRock Z68 Extreme 3 GTX 680 SLI G Skill Ripjaws 1600 
Hard DriveCoolingMonitorPower
256GB M4 SSD Raystorm CPU block Asus VW246H Nvidia Surround Kingwin Lazer 1kw 
Case
NZXT Switch 810 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8 ghz ASRock Z68 Extreme 3 GTX 680 SLI G Skill Ripjaws 1600 
Hard DriveCoolingMonitorPower
256GB M4 SSD Raystorm CPU block Asus VW246H Nvidia Surround Kingwin Lazer 1kw 
Case
NZXT Switch 810 
  hide details  
Reply
post #6 of 10
make sure positive and negative are exact on the pins...
Ruby
(16 items)
 
  
CPUMotherboardGraphicsRAM
[Intel] i7 2700k HT - 5.0ghz; 1.42v [ASRock] Fatal1ity z68 Proffesional Gen3 [Sapphire] HD 7970's CrossfireX @ 1200/1700mhz ... [G.Skill] RipjawsX CL9D 2x4GB; XMP 2133mhz; 9-1... 
Hard DriveOptical DriveCoolingOS
[OCZ] Vertex 3 + [WD] VelociRaptor 600gb Gen3 +... [SONY] Optiarc DVD+RW Combo [EK] Res/Rad/Pump + [Koolance] CPU-360 block + ... [Microsoft] Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
[Samsung] 120hz 3D 27" LED 2ms -S27A950D- [Logitech] G19 [Antec] Quattro 1200w OC Edition [Antec] Dark Fleet 85 
MouseMouse PadAudioAudio
[Logitech] G500 [Razor] Vespula [Asus] Xonar HDAV 7.1 THX DTS [Logitech] Z-5500 speakers 
  hide details  
Reply
Ruby
(16 items)
 
  
CPUMotherboardGraphicsRAM
[Intel] i7 2700k HT - 5.0ghz; 1.42v [ASRock] Fatal1ity z68 Proffesional Gen3 [Sapphire] HD 7970's CrossfireX @ 1200/1700mhz ... [G.Skill] RipjawsX CL9D 2x4GB; XMP 2133mhz; 9-1... 
Hard DriveOptical DriveCoolingOS
[OCZ] Vertex 3 + [WD] VelociRaptor 600gb Gen3 +... [SONY] Optiarc DVD+RW Combo [EK] Res/Rad/Pump + [Koolance] CPU-360 block + ... [Microsoft] Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
[Samsung] 120hz 3D 27" LED 2ms -S27A950D- [Logitech] G19 [Antec] Quattro 1200w OC Edition [Antec] Dark Fleet 85 
MouseMouse PadAudioAudio
[Logitech] G500 [Razor] Vespula [Asus] Xonar HDAV 7.1 THX DTS [Logitech] Z-5500 speakers 
  hide details  
Reply
post #7 of 10
Thread Starter 
Quote:
Originally Posted by Dwood View Post

Its not going to sleep from not being used?
No, when I click "shutdown" in windows both LAN ports are still active and they are even active still after I hold the power button to shut it down manually.
Quote:
Originally Posted by Denim-187 View Post

make sure positive and negative are exact on the pins...
Have checked, double checked and triple checked, it is all plugged in perfectly, when I switched them the power button worked perfectly as a reset switch and the reset switch did the same thing as the power button, will turn the system off manually but will not re-power the board.
post #8 of 10
Quote:
Originally Posted by h0thead132 View Post

A little bit of an update.
So tried switching the reset and power buttons to see if it would make a difference and alas no, so my case power button won't work but the internal one on the board works perfect.
Also a side weird note. the system turns itself on randomly in the middle of the night.
only thing I can figure is that LAN boot is active (the board doesn't actually shut all the way off, the LAN lights are still flashing) but the problem is I can't find a setting for it in the ?UFEI? (whatever the new BIOS are called)

So the reset button didn't work on the power jumper either?
If so I'd contact ASRock, they are very promt with replies.

What is the "internal" power button?
Contender23
(15 items)
 
  
CPUMotherboardGraphicsRAM
FX 8150 ASRock 990FX Ex3 EVGA GeForce GTX 680 SC+ w/Backplate Mushkin Silverline 8GB (2 x 2GB) 240-Pin DDR3 S... 
Hard DriveOptical DriveCoolingOS
M4 128GB SSD LG Blu-Ray Rom Thermalright Archon Win 7 PRO 64bit 
MonitorKeyboardPowerCase
Asus VH236@1080p Filco Majestouch FKBN104M/EB Antec Earthwatt 650w Lian-Li PC-9F 
MouseMouse PadAudio
MS Sidewinder X8 Func 1030 Asus Xonar DX 
  hide details  
Reply
Contender23
(15 items)
 
  
CPUMotherboardGraphicsRAM
FX 8150 ASRock 990FX Ex3 EVGA GeForce GTX 680 SC+ w/Backplate Mushkin Silverline 8GB (2 x 2GB) 240-Pin DDR3 S... 
Hard DriveOptical DriveCoolingOS
M4 128GB SSD LG Blu-Ray Rom Thermalright Archon Win 7 PRO 64bit 
MonitorKeyboardPowerCase
Asus VH236@1080p Filco Majestouch FKBN104M/EB Antec Earthwatt 650w Lian-Li PC-9F 
MouseMouse PadAudio
MS Sidewinder X8 Func 1030 Asus Xonar DX 
  hide details  
Reply
post #9 of 10
Thread Starter 
Quote:
Originally Posted by DarthBaiter View Post

Quote:
Originally Posted by h0thead132 View Post

A little bit of an update.
So tried switching the reset and power buttons to see if it would make a difference and alas no, so my case power button won't work but the internal one on the board works perfect.
Also a side weird note. the system turns itself on randomly in the middle of the night.
only thing I can figure is that LAN boot is active (the board doesn't actually shut all the way off, the LAN lights are still flashing) but the problem is I can't find a setting for it in the ?UFEI? (whatever the new BIOS are called)

So the reset button didn't work on the power jumper either?
If so I'd contact ASRock, they are very promt with replies.

What is the "internal" power button?

the internal power is the one that is mounted on the board in the lower right corner

EDIT: just shot them a support request about it.
Edited by h0thead132 - 3/22/12 at 1:22pm
post #10 of 10
Thread Starter 
Well got another addition to the list of weird, now if I select shutdown in windows the system restarts? Only way I can get it to turn off is to turn off my PSU

Sent from my DROID2 using Tapatalk
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › Case Power Switch Not Working - ASRock Fatal1ty 990FX