Overclock.net › Forums › Components › Monitors and Displays › CrossOver 27Q LED/LED-P, 27M LED, & 2720MDP GOLD LED Monitor Club
New Posts  All Forums:Forum Nav:

CrossOver 27Q LED/LED-P, 27M LED, & 2720MDP GOLD LED Monitor Club - Page 310

post #3091 of 6483
Guys, any reason to look forward to the upcoming 2730MDP?

The only upgrade seems to be the 125hz refresh rate. That's all that I could make out anyway.
post #3092 of 6483
Quote:
Originally Posted by anmolkapoor View Post

Guys, any reason to look forward to the upcoming 2730MDP?
The only upgrade seems to be the 125hz refresh rate. That's all that I could make out anyway.

The max res on that page is still listed as 2560 × 1440 @ 60Hz; are you sure it'll be able to do 125?
SUPERPWN
(12 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 4670K Asus z87-Pro MSI GTX 1080 Aero 32GB DDR3 Gskill Ripjaws 
Hard DriveOSMonitorMonitor
4TB Seagate Windows 8 x64 Overlord x270 OC HP ZR27 
MonitorKeyboardPowerAudio
Asus PG279Q G-Tune Topre Realforce 800w Yulong D100 DAC with Denon D7000 headphones 
  hide details  
Reply
SUPERPWN
(12 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 4670K Asus z87-Pro MSI GTX 1080 Aero 32GB DDR3 Gskill Ripjaws 
Hard DriveOSMonitorMonitor
4TB Seagate Windows 8 x64 Overlord x270 OC HP ZR27 
MonitorKeyboardPowerAudio
Asus PG279Q G-Tune Topre Realforce 800w Yulong D100 DAC with Denon D7000 headphones 
  hide details  
Reply
post #3093 of 6483
Quote:
Originally Posted by binarysmacker View Post

Hey,
It was £34 I had to pay. It was stuck in customs just over a week. EMS changed from "invalid invoice" to "missing invoice" but apparently just ignore the EMS side of things once its in the UK. It updated twice while it was in the UK but when I called customs they told me my parcel hadn't even been looked at yet!
Anyway, the second it moved out of custom to parcel force I just rang them up to pay the charge. I didnt bother waiting for the letter.
The screen came today, along with the charges letter! ha.
Its just so weird how windows detects the monitor, detects its res but the screen says black with the red light as if its not plugged in.
I know this as im running a second screen at the same time. Incase that was the issue I tried booting several times just with the crossover. No dice!
I found a thread a few pages back, someone having the same issue but it was because they had it in the wrong DVI port. Ive tried both :/

I remember reading that a user on a another forum had the same symptoms with his yamakasi catleap. All he got was a red light when he put it on. Turns out it was a loose cable inside the monitor. He had taken apart the monitor to change the wobbly stand (you have to take apart the whole monitor to change the stand to a yamakasi catleap. This is not the case with crossover 27Q. I have no idea about the blade model though) and during the process one of the cables came loose.
post #3094 of 6483
Quote:
Originally Posted by Crazy9000 View Post

The max res on that page is still listed as 2560 × 1440 @ 60Hz; are you sure it'll be able to do 125?

In one of the graphic slides on the same page, it reads 125 Hz.. I don't know what they are trying to tell us with that though.
post #3095 of 6483
Quote:
Originally Posted by anmolkapoor View Post

In one of the graphic slides on the same page, it reads 125 Hz.. I don't know what they are trying to tell us with that though.

If you're referring to the specs, where it says max vertical frequency... back in the CRT days that would typically only apply to a really low resolution. Not sure with LCD though... it does seem too high for a screen that can only do 60hz.
SUPERPWN
(12 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 4670K Asus z87-Pro MSI GTX 1080 Aero 32GB DDR3 Gskill Ripjaws 
Hard DriveOSMonitorMonitor
4TB Seagate Windows 8 x64 Overlord x270 OC HP ZR27 
MonitorKeyboardPowerAudio
Asus PG279Q G-Tune Topre Realforce 800w Yulong D100 DAC with Denon D7000 headphones 
  hide details  
Reply
SUPERPWN
(12 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 4670K Asus z87-Pro MSI GTX 1080 Aero 32GB DDR3 Gskill Ripjaws 
Hard DriveOSMonitorMonitor
4TB Seagate Windows 8 x64 Overlord x270 OC HP ZR27 
MonitorKeyboardPowerAudio
Asus PG279Q G-Tune Topre Realforce 800w Yulong D100 DAC with Denon D7000 headphones 
  hide details  
Reply
post #3096 of 6483
Hmmm

Lets hope its that simple.

So im trying to take apart the screen, found all the screws on the back. For some reason theres no screws at the top, just the bottom.

It almost comes off but at the corners, even though the screws are out its still holding together. If I try any harder im scared I might snap the bezel.

Are there any teardown videos or images?
post #3097 of 6483
Quote:
Originally Posted by binarysmacker View Post

Hmmm
Lets hope its that simple.
So im trying to take apart the screen, found all the screws on the back. For some reason theres no screws at the top, just the bottom.
It almost comes off but at the corners, even though the screws are out its still holding together. If I try any harder im scared I might snap the bezel.
Are there any teardown videos or images?

Take your time and be careful. I'm afraid not many if anyone at all in here has taken apart the blade model. I found the post i was referring to (its not english speaking forum) and there was another user who had the same problem. At first it seemed all the cables were seated properly but he took them off and reseated them. The monitor worked fine after that. If you're comfortable with taking apart the monitor i guess it's worth a shot.
post #3098 of 6483
RIGHT EVERYONE.

ITS WORKING!!!!!!!!!!!!!!!!

I took Karails advice and decided to go for it, I slide my thumb along the bezel until it was painfull and then it just popped off (the bezel that is tongue.gif).

I just took everything apart and then put it all back together again.

As its the 27QD model. I took photos for everyone. Sorry for the quality, its pretty dark in here and im using my phone. Also its not the most techically and some people might not like some methods im using haha.

Heres the teardown photos.

https://plus.google.com/photos/100436332559084708570/albums/5797837097129401857

So after all that I plugged in in andd.......IT DIDNT WORK. I tried my other cable, the one that came with the screen. AND BINGO IT TURNED ON!!!!

So it looks like the "premium" cable I purchased (which I needed because this cable that came with it is a very tight fit, needs to be a bit longer) doesnt work!!

Anyway

ITS ALL UP AND RUNNING. So far from what I can see no stuck or dead pixels! smile.gif Back light bleed etc I havn't tested but it looks very uniform to me

I have yet to calibrate it. Thats next.

The only problem is......my desk and room feels really bare now. Ive got from 3 screens to 1. Hmmmmmm Does any 15 - 17" ips screens exist? For a small side monitor? tongue.gif
post #3099 of 6483
Quote:
Originally Posted by binarysmacker View Post

RIGHT EVERYONE.
ITS WORKING!!!!!!!!!!!!!!!!
I took Karails advice and decided to go for it, I slide my thumb along the bezel until it was painfull and then it just popped off (the bezel that is tongue.gif).
I just took everything apart and then put it all back together again.
As its the 27QD model. I took photos for everyone. Sorry for the quality, its pretty dark in here and im using my phone. Also its not the most techically and some people might not like some methods im using haha.
Heres the teardown photos.
https://plus.google.com/photos/100436332559084708570/albums/5797837097129401857
So after all that I plugged in in andd.......IT DIDNT WORK. I tried my other cable, the one that came with the screen. AND BINGO IT TURNED ON!!!!
So it looks like the "premium" cable I purchased (which I needed because this cable that came with it is a very tight fit, needs to be a bit longer) doesnt work!!
Anyway
ITS ALL UP AND RUNNING. So far from what I can see no stuck or dead pixels! smile.gif Back light bleed etc I havn't tested but it looks very uniform to me
I have yet to calibrate it. Thats next.
The only problem is......my desk and room feels really bare now. Ive got from 3 screens to 1. Hmmmmmm Does any 15 - 17" ips screens exist? For a small side monitor? tongue.gif
You could get a 21" monitor and put it in portrait; it would take up much less room.
post #3100 of 6483
Hmmm no thats going to be too big. I might get a 10" android chinese ips tablet. Its just to go on my wall next to it for PDFs and notifications and stuff.

Right one slight problem now.

Depending on whats on the screen, it seems like its the bright images that do this but it causes the screen to hum. If its all white it hums "loudly" but if its black its less.

If that anything that can be solved?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › CrossOver 27Q LED/LED-P, 27M LED, & 2720MDP GOLD LED Monitor Club