Overclock.net › Forums › Components › Monitors and Displays › CrossOver 27Q LED/LED-P, 27M LED, & 2720MDP GOLD LED Monitor Club
New Posts  All Forums:Forum Nav:

CrossOver 27Q LED/LED-P, 27M LED, & 2720MDP GOLD LED Monitor Club - Page 33

post #321 of 6485
Help! My crossover just arrived but it doesn't work! When I turn it on the front led turns blue for a moment, then the screens flashes white for a microsecond and then the led turns red! mad.gif

What to do??!?!

EDIT: Yes, I am using the included cables. No, I do not need another brick or step down transformer cause I live in Europe.
Edited by giecsar - 4/2/12 at 7:05am
post #322 of 6485
I'm debating on ordering a crossover but I've had my eye on the Samsung SA27850D monitor. You think this one out performs the Samsung for half the price?
post #323 of 6485
Mine has been sitting in customs since Saturday morning. I was hoping I would get it today but I lose confidence with every hour the status remains unchanged.
Gaming
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5-750 @ 4.0GHz eVGA P55 SLI 2 x GTX 570 Classified 900/1800/2000 2 x 4GB G.Skill Ripjaws X Series 1600MHz 
PowerCase
Antec HCG 750W Antec P183 
  hide details  
Reply
Gaming
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5-750 @ 4.0GHz eVGA P55 SLI 2 x GTX 570 Classified 900/1800/2000 2 x 4GB G.Skill Ripjaws X Series 1600MHz 
PowerCase
Antec HCG 750W Antec P183 
  hide details  
Reply
post #324 of 6485
It would be great to have some basic troubleshooting steps included in the OP. I've ordered three LED-Ps from dcsamsungmall and am hoping for the best. They're supposed to come with the 120V adapter so I don't expect to have power issues, but I'm not sure if there are any other minor issues I may come across.
Midi Station
(14 items)
 
   
CPUGraphicsHard DriveOS
Intel Xeon W3530 @ 2.80Ghz NVIDIA Quadro FX 580 WD Caviar Blue 320GB Windows 7 Professional 64-bit 
Monitor
Dell 2005FPW x 2 
  hide details  
Reply
Midi Station
(14 items)
 
   
CPUGraphicsHard DriveOS
Intel Xeon W3530 @ 2.80Ghz NVIDIA Quadro FX 580 WD Caviar Blue 320GB Windows 7 Professional 64-bit 
Monitor
Dell 2005FPW x 2 
  hide details  
Reply
post #325 of 6485
Quote:
Originally Posted by giecsar View Post

Help! My crossover just arrived but it doesn't work! When I turn it on the front led turns blue for a moment, then the screens flashes white for a microsecond and then the led turns red! mad.gif
What to do??!?!
EDIT: Yes, I am using the included cables. No, I do not need another brick or step down transformer cause I live in Europe.

I dont know man... Sure sounds like a power problem, but maybe something is not right within the monitor itself.
Who was your seller? I would contact him about it!
post #326 of 6485
Quote:
Originally Posted by giecsar View Post

Help! My crossover just arrived but it doesn't work! When I turn it on the front led turns blue for a moment, then the screens flashes white for a microsecond and then the led turns red! mad.gif
What to do??!?!
EDIT: Yes, I am using the included cables. No, I do not need another brick or step down transformer cause I live in Europe.

problem when the light from blue to red "NO SIGNAL"
maybe problem in your video card or try another computer/laptop
post #327 of 6485
Thread Starter 
Quote:
Originally Posted by giecsar View Post

Help! My crossover just arrived but it doesn't work! When I turn it on the front led turns blue for a moment, then the screens flashes white for a microsecond and then the led turns red! mad.gif
What to do??!?!
EDIT: Yes, I am using the included cables. No, I do not need another brick or step down transformer cause I live in Europe.

Make sure your computer is turned off and then turn on the monitor followed by turning on your computer.
post #328 of 6485
Quote:
Originally Posted by Stab View Post

Quote:
Originally Posted by giecsar View Post

Help! My crossover just arrived but it doesn't work! When I turn it on the front led turns blue for a moment, then the screens flashes white for a microsecond and then the led turns red! mad.gif
What to do??!?!
EDIT: Yes, I am using the included cables. No, I do not need another brick or step down transformer cause I live in Europe.

I dont know man... Sure sounds like a power problem, but maybe something is not right within the monitor itself.
Who was your seller? I would contact him about it!
Quote:
Originally Posted by fullhd99 View Post

Quote:
Originally Posted by giecsar View Post

Help! My crossover just arrived but it doesn't work! When I turn it on the front led turns blue for a moment, then the screens flashes white for a microsecond and then the led turns red! mad.gif
What to do??!?!
EDIT: Yes, I am using the included cables. No, I do not need another brick or step down transformer cause I live in Europe.

problem when the light from blue to red "NO SIGNAL"
maybe problem in your video card or try another computer/laptop
Quote:
Originally Posted by SimpleTech View Post

Quote:
Originally Posted by giecsar View Post

Help! My crossover just arrived but it doesn't work! When I turn it on the front led turns blue for a moment, then the screens flashes white for a microsecond and then the led turns red! mad.gif
What to do??!?!
EDIT: Yes, I am using the included cables. No, I do not need another brick or step down transformer cause I live in Europe.

Make sure your computer is turned off and then turn on the monitor followed by turning on your computer.

Thanks everyone! I've hooked it up to my brother's PC and it works perfectly! Moreover it's flawless!!! Very pleased biggrin.gif
It seems I cannot for some reason configure my GPU properly. I have the card in my sig, and it has 4 DP ports + 2 DVI ports, one of which is dual link. Then there is a litttle switch than switches between single link and dual link. I flipped it (and rebooted too) but it doesn't work!
post #329 of 6485
So which would you choose? The Samsung or the Crossover?

I've had my eye set on the samsung but now that the crossover is bad ass and half the price.. which would you recommend?
post #330 of 6485
UPDATE: rebooted my PC a few times more, then disconnected and reconnected the cable a few times more and now it works!

Wow, such an incredible monitor! Colors are amazing, great viewing angles and everything... well worth the price!! Very, very pleased. thumb.gif

Now if you'll excuse while I go play a few sick games biggrin.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › CrossOver 27Q LED/LED-P, 27M LED, & 2720MDP GOLD LED Monitor Club