Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Windows 8: Can't set chrome as default browser
New Posts  All Forums:Forum Nav:

Windows 8: Can't set chrome as default browser

post #1 of 2
Thread Starter 
I've been dealing with this for a while, but I'd like to fix it. I don't want all my links opening in Internet Explorer.

Chrome thinks it's my default browser. Under Wrench->Options chrome says it's my default browser. However, when trying to set default programs in control panel, chrome isn't even on the list as an option, and Internet Explorer has the .url default in a disabled checkbox, meaning I cannot uncheck it. Firefox is at least on that list, but it doesn't see itself as an option to open .url's either. Only HTML files.

Has anyone figured out a way to fix this?
    
CPUMotherboardGraphicsRAM
Phenom IIx4 955 @3.2ghz 1.285V Asus M4A79XTD EVO 6950 @ 850/1250 4x2GB DDR3 
Hard DriveOptical DriveOSMonitor
Hitachi 1Tb + Seagate 1.5Tb Samsung super speed Windows 7 Pro(games)/Linux Mint 10 (not games) LP2065 + 2x 2007FPb in IPS Eyefinity 4800*1200 
KeyboardPowerCaseMouse
Logitech Wave Corsair HX620 Azza Solano 1000 Logitech MX revolution 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Phenom IIx4 955 @3.2ghz 1.285V Asus M4A79XTD EVO 6950 @ 850/1250 4x2GB DDR3 
Hard DriveOptical DriveOSMonitor
Hitachi 1Tb + Seagate 1.5Tb Samsung super speed Windows 7 Pro(games)/Linux Mint 10 (not games) LP2065 + 2x 2007FPb in IPS Eyefinity 4800*1200 
KeyboardPowerCaseMouse
Logitech Wave Corsair HX620 Azza Solano 1000 Logitech MX revolution 
  hide details  
Reply
post #2 of 2
It's not my default browser and it's also not in the list, so that can't be the reason. You can add it to the list manually though by merging this into your Registry (this was gleaned from a Win7 machine that actually had Chrome listed by default).
Note: You need to substitute your actual profile name wherever you see "username" below. Also, if you're one of the few who installs Chrome under Program Files, you'll have to change the paths appropriately.

Good luck




Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\RegisteredApplications]
"Google Chrome"="Software\\Clients\\StartMenuInternet\\Google Chrome\\Capabilities"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome]
@="Google Chrome"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\Capabilities]
"ApplicationName"="Google Chrome"
"ApplicationIcon"="C:\\Users\\username\\AppData\\Local\\Google\\Chrome\\Application\\chrome.exe,0"
"ApplicationDescription"="Google Chrome is a web browser that runs webpages and applications with lightning speed. It's fast, stable, and easy to use. Browse the web more safely with malware and phishing protection built into Google Chrome."

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\Capabilities\FileAssociations]
".xhtml"="ChromeHTML"
".xht"="ChromeHTML"
".shtml"="ChromeHTML"
".html"="ChromeHTML"
".htm"="ChromeHTML"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\Capabilities\Startmenu]
"StartMenuInternet"="Google Chrome"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\Capabilities\URLAssociations]
"webcal"="ChromeHTML"
"urn"="ChromeHTML"
"tel"="ChromeHTML"
"smsto"="ChromeHTML"
"sms"="ChromeHTML"
"nntp"="ChromeHTML"
"news"="ChromeHTML"
"mms"="ChromeHTML"
"mailto"="ChromeHTML"
"irc"="ChromeHTML"
"https"="ChromeHTML"
"http"="ChromeHTML"
"ftp"="ChromeHTML"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\DefaultIcon]
@="C:\\Users\\username\\AppData\\Local\\Google\\Chrome\\Application\\chrome.exe,0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\InstallInfo]
"IconsVisible"=dword:00000001
"ShowIconsCommand"="\"C:\\Users\\username\\AppData\\Local\\Google\\Chrome\\Application\\chrome.exe\" --show-icons"
"HideIconsCommand"="\"C:\\Users\\username\\AppData\\Local\\Google\\Chrome\\Application\\chrome.exe\" --hide-icons"
"ReinstallCommand"="\"C:\\Users\\username\\AppData\\Local\\Google\\Chrome\\Application\\chrome.exe\" --make-default-browser"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\shell\open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\shell\open\command]
@="\"C:\\Users\\username\\AppData\\Local\\Google\\Chrome\\Application\\chrome.exe\""
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Windows 8: Can't set chrome as default browser