Overclock.net › Forums › Components › Power Supplies › Power supply failed in a weird way.
New Posts  All Forums:Forum Nav:

Power supply failed in a weird way.

post #1 of 7
Thread Starter 
So today, my Corsair TX750M failed. No pop, no sparks, no bad smell. Just stopped working. When its plugged into the wall and motherboard, it makes a high pitched whine. When the power button is pushed, the LED's come on for <.5 seconds, fans attempt to spin. There are no expanded caps, no burn marks that I can see. Only two solder points for red wires seem to be touching. I have literally zero ideas as to why this PSU failed. Failed the paper clip test.

I plugged a buddies PSU into my motherboard and fans spin. Just bought a tx650 to hold me over until I get a replacement, and just in case something like this happens again.

Does anyone have an idea, or had experience, with a power supply failing without so much as a hint as to why? I'll put pics up of said solder points later.

700
Edited by Marshmellow17 - 3/25/12 at 9:12pm
NoName
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 4.2Ghz@ 1.44v GA-990FXA-UD3 Saphire HD6950 unlocked shaders 930/1325 G.Skill ripjaw LV 1600Mhz Cas9 
RAMHard DriveHard DriveOptical Drive
G.Skill ripjaw LV 1600Mhz Cas9 Hitachi darkstar 750GB Corsair Force 3 120GB SSD Asus DVD burner 
CoolingOSKeyboardPower
Noctua NH-D14 Windows 7 Razor Arctosa Corsair TX750M 
CaseMouseMouse Pad
Corsair 600t SE Logitech G500 Masking Tap 
  hide details  
Reply
NoName
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 4.2Ghz@ 1.44v GA-990FXA-UD3 Saphire HD6950 unlocked shaders 930/1325 G.Skill ripjaw LV 1600Mhz Cas9 
RAMHard DriveHard DriveOptical Drive
G.Skill ripjaw LV 1600Mhz Cas9 Hitachi darkstar 750GB Corsair Force 3 120GB SSD Asus DVD burner 
CoolingOSKeyboardPower
Noctua NH-D14 Windows 7 Razor Arctosa Corsair TX750M 
CaseMouseMouse Pad
Corsair 600t SE Logitech G500 Masking Tap 
  hide details  
Reply
post #2 of 7
Should have just RMAd it.
post #3 of 7
Thread Starter 
I am RMA'ing it. Just curious if anyone has had one fail like this.
NoName
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 4.2Ghz@ 1.44v GA-990FXA-UD3 Saphire HD6950 unlocked shaders 930/1325 G.Skill ripjaw LV 1600Mhz Cas9 
RAMHard DriveHard DriveOptical Drive
G.Skill ripjaw LV 1600Mhz Cas9 Hitachi darkstar 750GB Corsair Force 3 120GB SSD Asus DVD burner 
CoolingOSKeyboardPower
Noctua NH-D14 Windows 7 Razor Arctosa Corsair TX750M 
CaseMouseMouse Pad
Corsair 600t SE Logitech G500 Masking Tap 
  hide details  
Reply
NoName
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 4.2Ghz@ 1.44v GA-990FXA-UD3 Saphire HD6950 unlocked shaders 930/1325 G.Skill ripjaw LV 1600Mhz Cas9 
RAMHard DriveHard DriveOptical Drive
G.Skill ripjaw LV 1600Mhz Cas9 Hitachi darkstar 750GB Corsair Force 3 120GB SSD Asus DVD burner 
CoolingOSKeyboardPower
Noctua NH-D14 Windows 7 Razor Arctosa Corsair TX750M 
CaseMouseMouse Pad
Corsair 600t SE Logitech G500 Masking Tap 
  hide details  
Reply
post #4 of 7
Stuff happens like this at times. I know someone that had a similar situation happen, but after the paper clip fix, it went back to working fine.
Ultrima RPX56
(13 items)
 
   
CPUMotherboardGraphicsRAM
AMD Ryzen R5 1600X @3.78GHz MSI X370 Gaming Pro Carbon v.1.71 Beta ZOTAC GeForce GTX 1070 AMP Edition 16GB (2x8GB) Team Dark Pro 3200MHz DDR4 
Hard DriveOptical DriveCoolingOS
256GB ADATA SX8000 NVMe SSD HP dvd1265i 24X Cryorig H7 Windows 10/Mageia 6 
MonitorKeyboardPowerCase
ASUS VH232H Logitech G510 EVGA SuperNOVA 650W G3 Sharkoon M25-W 
Mouse
Cougar Revenger 
CPUMotherboardGraphicsRAM
Intel Core i7 870 EVGA P55V EVGA Nvidia GeForce 1050 Ti 6GB 1333MHz DDR3 (4GB+2GB) 
Hard DriveOptical DriveOSMonitor
240GB SanDisk SSD Plus Lite-On iHAS124 DVD+/-RW Mageia 5.1 Compaq MV520 15" CRT 
KeyboardPowerCaseMouse
Compaq SK-2800C Diablotek PMD 650W Compaq Presario 7478 case from 2000 Corsair Gaming M45 
  hide details  
Reply
Ultrima RPX56
(13 items)
 
   
CPUMotherboardGraphicsRAM
AMD Ryzen R5 1600X @3.78GHz MSI X370 Gaming Pro Carbon v.1.71 Beta ZOTAC GeForce GTX 1070 AMP Edition 16GB (2x8GB) Team Dark Pro 3200MHz DDR4 
Hard DriveOptical DriveCoolingOS
256GB ADATA SX8000 NVMe SSD HP dvd1265i 24X Cryorig H7 Windows 10/Mageia 6 
MonitorKeyboardPowerCase
ASUS VH232H Logitech G510 EVGA SuperNOVA 650W G3 Sharkoon M25-W 
Mouse
Cougar Revenger 
CPUMotherboardGraphicsRAM
Intel Core i7 870 EVGA P55V EVGA Nvidia GeForce 1050 Ti 6GB 1333MHz DDR3 (4GB+2GB) 
Hard DriveOptical DriveOSMonitor
240GB SanDisk SSD Plus Lite-On iHAS124 DVD+/-RW Mageia 5.1 Compaq MV520 15" CRT 
KeyboardPowerCaseMouse
Compaq SK-2800C Diablotek PMD 650W Compaq Presario 7478 case from 2000 Corsair Gaming M45 
  hide details  
Reply
post #5 of 7
mine did that out of the box (brand new), just got a new one that worked straight away.
My System
(14 items)
 
  
CPUMotherboardGraphicsGraphics
Intel 3570K Asus Maximus Gene - V Gainward GTX 570 Goes like Hell Edition Gainward GTX 570 Phantom 
RAMHard DriveOSMonitor
Corsair Dominator Platinum 16Gb 1600Mzh OCZ Vertex 2 Windows 7 64bit Asus VG278H 
PowerCaseMouse
Corsair AX850 Corsair 600t se white Logitech G500 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsGraphics
Intel 3570K Asus Maximus Gene - V Gainward GTX 570 Goes like Hell Edition Gainward GTX 570 Phantom 
RAMHard DriveOSMonitor
Corsair Dominator Platinum 16Gb 1600Mzh OCZ Vertex 2 Windows 7 64bit Asus VG278H 
PowerCaseMouse
Corsair AX850 Corsair 600t se white Logitech G500 
  hide details  
Reply
post #6 of 7
If you opened the power supply then you probably broke the "warranty void if removed" sticker and Corsair will just send your PSU back to you without fixing it.
post #7 of 7
Thread Starter 
I didn't open it. the two wires are visible when looking at the fan.
NoName
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 4.2Ghz@ 1.44v GA-990FXA-UD3 Saphire HD6950 unlocked shaders 930/1325 G.Skill ripjaw LV 1600Mhz Cas9 
RAMHard DriveHard DriveOptical Drive
G.Skill ripjaw LV 1600Mhz Cas9 Hitachi darkstar 750GB Corsair Force 3 120GB SSD Asus DVD burner 
CoolingOSKeyboardPower
Noctua NH-D14 Windows 7 Razor Arctosa Corsair TX750M 
CaseMouseMouse Pad
Corsair 600t SE Logitech G500 Masking Tap 
  hide details  
Reply
NoName
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 4.2Ghz@ 1.44v GA-990FXA-UD3 Saphire HD6950 unlocked shaders 930/1325 G.Skill ripjaw LV 1600Mhz Cas9 
RAMHard DriveHard DriveOptical Drive
G.Skill ripjaw LV 1600Mhz Cas9 Hitachi darkstar 750GB Corsair Force 3 120GB SSD Asus DVD burner 
CoolingOSKeyboardPower
Noctua NH-D14 Windows 7 Razor Arctosa Corsair TX750M 
CaseMouseMouse Pad
Corsair 600t SE Logitech G500 Masking Tap 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Power supply failed in a weird way.