Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › echo "The `uname` Club" (NEW POLL)
New Posts  All Forums:Forum Nav:

echo "The `uname` Club" (NEW POLL) - Page 197

Poll Results: How long have you been using your current, main installation?

 
  • 24% (50)
    less then a month
  • 23% (47)
    less then six months
  • 14% (30)
    less then a year
  • 24% (49)
    less then three years
  • 13% (27)
    three years+
203 Total Votes  
post #1961 of 4043
Quote:
Originally Posted by Shrak View Post

Open up top and see what's hogging your memory then tongue.gif

Xorg is what is hogging the memory. But I'm trying to figure out what causes it to spike from 15-30MBs at start and then jumps up to 90-200MB after a while. I think it might be a kde-gtk issue as it seems to happen with GTK apps opened. I have only noticed this on my Nvidia systems. Seems there's a history with Xorg not liking Nvidia when I tried Googling it. I'll check if the xorg memory leak is a time based thing...or if it's a GTK related issue. Either way it doesn't really matter that much with me having 12GBs of RAM but it still annoys me as it sometimes slows things down slightly. Plus, it's just annoying knowing there's a bug.

Quote:
Originally Posted by cones View Post

Havent noticed anything. What version are you using?

Nvidia drive 331.4? I'll have to check when I get home to the desktop. No idea on xorg...how do I figure that out again? redface.gif
     
CPUGraphicsRAMHard Drive
Intel Core m3-6Y30 Intel HD515 8GB 1866DDR3L Micron M600 MTFDDAV256MBF M.2, 256 GB 
CoolingOSOSMonitor
Fanless Win10 Home x64 Kubuntu 16.04 (requires Linux kernel 4.5/4.6) 13.3 inch 16:9, 1920x1080 pixel, AU Optronics A... 
CPUMotherboardGraphicsRAM
AthlonIIX4 640 3.62GHz (250x14.5) 2.5GHz NB Asus M4A785TD-M EVO MSI GTX275 (Stock 666) 8GBs of GSkill 1600 
RAMHard DriveHard DriveHard Drive
4GBs of Adata 1333 Kingston HyperX 3k 120GB WD Caviar Black 500GB Hitachi Deskstar 1TB 
Optical DriveCoolingOSOS
LG 8X BDR (WHL08S20) Cooler Master Hyper 212+ Kubuntu x64 Windows 7 x64 
OSMonitorPowerCase
Bodhi Linux x64 Acer G215H (1920x1080) Seasonic 520 HAF912 
CPUMotherboardGraphicsRAM
N450 1.8GHz AC and 1.66GHz batt ASUS proprietary for 1001P GMA3150 (can play bluray now!?) 1GB DDR2 
Hard DriveOptical DriveOSOS
160GB LGLHDLBDRE32X Bodhi Linux Fedora LXDE 
OSOSMonitorKeyboard
Kubuntu SLAX 1280x600 + Dell 15inch Excellent! 
PowerCase
6 cells=6-12hrs and a charger 1001P MU17 Black 
  hide details  
Reply
     
CPUGraphicsRAMHard Drive
Intel Core m3-6Y30 Intel HD515 8GB 1866DDR3L Micron M600 MTFDDAV256MBF M.2, 256 GB 
CoolingOSOSMonitor
Fanless Win10 Home x64 Kubuntu 16.04 (requires Linux kernel 4.5/4.6) 13.3 inch 16:9, 1920x1080 pixel, AU Optronics A... 
CPUMotherboardGraphicsRAM
AthlonIIX4 640 3.62GHz (250x14.5) 2.5GHz NB Asus M4A785TD-M EVO MSI GTX275 (Stock 666) 8GBs of GSkill 1600 
RAMHard DriveHard DriveHard Drive
4GBs of Adata 1333 Kingston HyperX 3k 120GB WD Caviar Black 500GB Hitachi Deskstar 1TB 
Optical DriveCoolingOSOS
LG 8X BDR (WHL08S20) Cooler Master Hyper 212+ Kubuntu x64 Windows 7 x64 
OSMonitorPowerCase
Bodhi Linux x64 Acer G215H (1920x1080) Seasonic 520 HAF912 
CPUMotherboardGraphicsRAM
N450 1.8GHz AC and 1.66GHz batt ASUS proprietary for 1001P GMA3150 (can play bluray now!?) 1GB DDR2 
Hard DriveOptical DriveOSOS
160GB LGLHDLBDRE32X Bodhi Linux Fedora LXDE 
OSOSMonitorKeyboard
Kubuntu SLAX 1280x600 + Dell 15inch Excellent! 
PowerCase
6 cells=6-12hrs and a charger 1001P MU17 Black 
  hide details  
Reply
post #1962 of 4043
Quote:
Originally Posted by Rookie1337 View Post

Xorg is what is hogging the memory. But I'm trying to figure out what causes it to spike from 15-30MBs at start and then jumps up to 90-200MB after a while. I think it might be a kde-gtk issue as it seems to happen with GTK apps opened. I have only noticed this on my Nvidia systems. Seems there's a history with Xorg not liking Nvidia when I tried Googling it. I'll check if the xorg memory leak is a time based thing...or if it's a GTK related issue. Either way it doesn't really matter that much with me having 12GBs of RAM but it still annoys me as it sometimes slows things down slightly. Plus, it's just annoying knowing there's a bug.
Nvidia drive 331.4? I'll have to check when I get home to the desktop. No idea on xorg...how do I figure that out again? redface.gif

Your package manager or in the log file maybe.
My System
(21 items)
 
Server/HTPC
(11 items)
 
 
CPUMotherboardGraphicsRAM
AMD 8320 Asus m5a99fx pro EVGA 660ti  Gskill 8GB F3-1600C9-8GXM x2 
RAMHard DriveHard DriveHard Drive
4GB x2 OCZ Agility 3 Sasmsung 840 EVO Western Digital Caviar Blue 
Hard DriveOptical DriveOptical DriveCooling
Seagate 500gb Asus DRW-24B1ST Asus BC-12B1ST cool master hyper 212 evo 
OSOSMonitorMonitor
Windows 10 Pro x64 Arch  Asus 23" VH238 Asus 23" VH238H 
PowerCase
Corsair CX600M Fractal Design Define R5  
CPUMotherboardRAMHard Drive
i3 6100 Asus Z170M-Plus something 16gb DDR4 Western Digital 500GB 
Hard DriveHard DriveHard DriveOS
Samsung 2TB Western Digital Red 3TB HGST Deskter 4TB Unraid 6.x 
OSPowerCase
Ubuntu Server - VM Corsair CX430  Cooler Master HAF 912 
  hide details  
Reply
My System
(21 items)
 
Server/HTPC
(11 items)
 
 
CPUMotherboardGraphicsRAM
AMD 8320 Asus m5a99fx pro EVGA 660ti  Gskill 8GB F3-1600C9-8GXM x2 
RAMHard DriveHard DriveHard Drive
4GB x2 OCZ Agility 3 Sasmsung 840 EVO Western Digital Caviar Blue 
Hard DriveOptical DriveOptical DriveCooling
Seagate 500gb Asus DRW-24B1ST Asus BC-12B1ST cool master hyper 212 evo 
OSOSMonitorMonitor
Windows 10 Pro x64 Arch  Asus 23" VH238 Asus 23" VH238H 
PowerCase
Corsair CX600M Fractal Design Define R5  
CPUMotherboardRAMHard Drive
i3 6100 Asus Z170M-Plus something 16gb DDR4 Western Digital 500GB 
Hard DriveHard DriveHard DriveOS
Samsung 2TB Western Digital Red 3TB HGST Deskter 4TB Unraid 6.x 
OSPowerCase
Ubuntu Server - VM Corsair CX430  Cooler Master HAF 912 
  hide details  
Reply
post #1963 of 4043
Since this has tuned into a general conversation thread

dd if=/dev/cdrom of=/home/windows7pro.iso

why do I not have an iso in my home folder?
 
DD Portable
(12 items)
 
 
CPUMotherboardGraphicsRAM
i5 5675C Gigabyte GA-Z97X Gaming 5 XFX RX 480 GTR 32GB Corsair Vengeance 1600 
Hard DriveHard DriveHard DriveCooling
Samsung 840 Evo Western Digital Black RE4 2TB Western Digital Green 2TB bequiet! Silent Wings 2 140mm PWM 
CoolingCoolingCoolingOS
bequiet! Silent Wings 2 140mm PWM bequiet! Shadow Wings SW1 120mm PWM bequiet! Dark Rock Pro 3 Arch X64 / Gnome and OSX 10.11 
MonitorKeyboardPowerCase
Samsung 590D 4K KBC Poker II be quiet! Straight Power 10 400W bequiet! Silent Base 800 
MouseAudioAudio
Speedlink Omni VI  Sound Blaster Z  Bose Companion 2  
CPUMotherboardGraphicsRAM
i5 3427U The Googs HD4000 4GB DDR3 
Hard DriveOSMonitorKeyboard
32GB Flash / 128GB SanDisk Extreme SD card ChromeOS / Ubuntu 14.04 12" 2560x1700 bad 
PowerCaseMouseAudio
not much  Aluminium  Trackpad it makes noise I think  
  hide details  
Reply
 
DD Portable
(12 items)
 
 
CPUMotherboardGraphicsRAM
i5 5675C Gigabyte GA-Z97X Gaming 5 XFX RX 480 GTR 32GB Corsair Vengeance 1600 
Hard DriveHard DriveHard DriveCooling
Samsung 840 Evo Western Digital Black RE4 2TB Western Digital Green 2TB bequiet! Silent Wings 2 140mm PWM 
CoolingCoolingCoolingOS
bequiet! Silent Wings 2 140mm PWM bequiet! Shadow Wings SW1 120mm PWM bequiet! Dark Rock Pro 3 Arch X64 / Gnome and OSX 10.11 
MonitorKeyboardPowerCase
Samsung 590D 4K KBC Poker II be quiet! Straight Power 10 400W bequiet! Silent Base 800 
MouseAudioAudio
Speedlink Omni VI  Sound Blaster Z  Bose Companion 2  
CPUMotherboardGraphicsRAM
i5 3427U The Googs HD4000 4GB DDR3 
Hard DriveOSMonitorKeyboard
32GB Flash / 128GB SanDisk Extreme SD card ChromeOS / Ubuntu 14.04 12" 2560x1700 bad 
PowerCaseMouseAudio
not much  Aluminium  Trackpad it makes noise I think  
  hide details  
Reply
post #1964 of 4043
Quote:
Originally Posted by GermanyChris View Post

Since this has tuned into a general conversation thread

dd if=/dev/cdrom of=/home/windows7pro.iso

why do I not have an iso in my home folder?

try
Code:
dd if=/dev/cdrom of=$HOME/windows7pro.iso

/home contains user home directories. The path is normally /home/username

EDIT: screwed up the username string. fixed now
Edited by Nixalot - 1/16/14 at 12:41pm
post #1965 of 4043
Quote:
Originally Posted by Nixalot View Post

try
Code:
dd if=/dev/cdrom of=$HOME/windows7pro.iso

/home contains user home directories. The path is normally /home//

And there it is arrowheadsmiley.png

I re-did it to drop it into root then copied it where I wanted but....
 
DD Portable
(12 items)
 
 
CPUMotherboardGraphicsRAM
i5 5675C Gigabyte GA-Z97X Gaming 5 XFX RX 480 GTR 32GB Corsair Vengeance 1600 
Hard DriveHard DriveHard DriveCooling
Samsung 840 Evo Western Digital Black RE4 2TB Western Digital Green 2TB bequiet! Silent Wings 2 140mm PWM 
CoolingCoolingCoolingOS
bequiet! Silent Wings 2 140mm PWM bequiet! Shadow Wings SW1 120mm PWM bequiet! Dark Rock Pro 3 Arch X64 / Gnome and OSX 10.11 
MonitorKeyboardPowerCase
Samsung 590D 4K KBC Poker II be quiet! Straight Power 10 400W bequiet! Silent Base 800 
MouseAudioAudio
Speedlink Omni VI  Sound Blaster Z  Bose Companion 2  
CPUMotherboardGraphicsRAM
i5 3427U The Googs HD4000 4GB DDR3 
Hard DriveOSMonitorKeyboard
32GB Flash / 128GB SanDisk Extreme SD card ChromeOS / Ubuntu 14.04 12" 2560x1700 bad 
PowerCaseMouseAudio
not much  Aluminium  Trackpad it makes noise I think  
  hide details  
Reply
 
DD Portable
(12 items)
 
 
CPUMotherboardGraphicsRAM
i5 5675C Gigabyte GA-Z97X Gaming 5 XFX RX 480 GTR 32GB Corsair Vengeance 1600 
Hard DriveHard DriveHard DriveCooling
Samsung 840 Evo Western Digital Black RE4 2TB Western Digital Green 2TB bequiet! Silent Wings 2 140mm PWM 
CoolingCoolingCoolingOS
bequiet! Silent Wings 2 140mm PWM bequiet! Shadow Wings SW1 120mm PWM bequiet! Dark Rock Pro 3 Arch X64 / Gnome and OSX 10.11 
MonitorKeyboardPowerCase
Samsung 590D 4K KBC Poker II be quiet! Straight Power 10 400W bequiet! Silent Base 800 
MouseAudioAudio
Speedlink Omni VI  Sound Blaster Z  Bose Companion 2  
CPUMotherboardGraphicsRAM
i5 3427U The Googs HD4000 4GB DDR3 
Hard DriveOSMonitorKeyboard
32GB Flash / 128GB SanDisk Extreme SD card ChromeOS / Ubuntu 14.04 12" 2560x1700 bad 
PowerCaseMouseAudio
not much  Aluminium  Trackpad it makes noise I think  
  hide details  
Reply
post #1966 of 4043
Hmm, so I restarted and now can't get KDE to load again, still staring at the blinking _ in the upper left hand corner. Tried reentering "systemctl enable kdm.service" and "systemctl start kdm.service", but this time it didn't load. Figured it wouldn't help since enable should start it at boot, but didn't know what else to try, any ideas?
post #1967 of 4043
you should be at an actual command prompt not a blinky cursor that's why I added the last part to see if grub was pointed at you actual root partition. Without a desktop manager you should still see a console login.
 
DD Portable
(12 items)
 
 
CPUMotherboardGraphicsRAM
i5 5675C Gigabyte GA-Z97X Gaming 5 XFX RX 480 GTR 32GB Corsair Vengeance 1600 
Hard DriveHard DriveHard DriveCooling
Samsung 840 Evo Western Digital Black RE4 2TB Western Digital Green 2TB bequiet! Silent Wings 2 140mm PWM 
CoolingCoolingCoolingOS
bequiet! Silent Wings 2 140mm PWM bequiet! Shadow Wings SW1 120mm PWM bequiet! Dark Rock Pro 3 Arch X64 / Gnome and OSX 10.11 
MonitorKeyboardPowerCase
Samsung 590D 4K KBC Poker II be quiet! Straight Power 10 400W bequiet! Silent Base 800 
MouseAudioAudio
Speedlink Omni VI  Sound Blaster Z  Bose Companion 2  
CPUMotherboardGraphicsRAM
i5 3427U The Googs HD4000 4GB DDR3 
Hard DriveOSMonitorKeyboard
32GB Flash / 128GB SanDisk Extreme SD card ChromeOS / Ubuntu 14.04 12" 2560x1700 bad 
PowerCaseMouseAudio
not much  Aluminium  Trackpad it makes noise I think  
  hide details  
Reply
 
DD Portable
(12 items)
 
 
CPUMotherboardGraphicsRAM
i5 5675C Gigabyte GA-Z97X Gaming 5 XFX RX 480 GTR 32GB Corsair Vengeance 1600 
Hard DriveHard DriveHard DriveCooling
Samsung 840 Evo Western Digital Black RE4 2TB Western Digital Green 2TB bequiet! Silent Wings 2 140mm PWM 
CoolingCoolingCoolingOS
bequiet! Silent Wings 2 140mm PWM bequiet! Shadow Wings SW1 120mm PWM bequiet! Dark Rock Pro 3 Arch X64 / Gnome and OSX 10.11 
MonitorKeyboardPowerCase
Samsung 590D 4K KBC Poker II be quiet! Straight Power 10 400W bequiet! Silent Base 800 
MouseAudioAudio
Speedlink Omni VI  Sound Blaster Z  Bose Companion 2  
CPUMotherboardGraphicsRAM
i5 3427U The Googs HD4000 4GB DDR3 
Hard DriveOSMonitorKeyboard
32GB Flash / 128GB SanDisk Extreme SD card ChromeOS / Ubuntu 14.04 12" 2560x1700 bad 
PowerCaseMouseAudio
not much  Aluminium  Trackpad it makes noise I think  
  hide details  
Reply
post #1968 of 4043
It was going straight to tty1 before I put kde on. I'm using syslinux, not sure if that matters, but it's looking at sda2 which is where the root partition is installed.

Edit: Here is my Syslinux line:
Code:
.linux ../vmlinuz - linux root=/dev/sda2 rw initrd= ../initramfs-linux.img

Edited by thestraw0039 - 1/16/14 at 1:18pm
post #1969 of 4043
Quote:
Originally Posted by thestraw0039 View Post

Sometimes when I boot Arch I am getting an error message that says "BUG: Soft lockup - CPU #0 stuck for 22s". Anyone seen this before? It doesn't happen everytime I boot, but probalby half or so. Nothing sticks out in the logs.

Yes, I used to get it quite often. I never worked out what was causing it though and it seemed to only happen if I used a newer Arch ISO to install (even though a full pacman update would bring the two systems on a par regardless of the original ISO I used). I never made any sense of it.
post #1970 of 4043
Quote:
Originally Posted by Plan9 View Post

Yes, I used to get it quite often. I never worked out what was causing it though and it seemed to only happen if I used a newer Arch ISO to install (even though a full pacman update would bring the two systems on a par regardless of the original ISO I used). I never made any sense of it.

Did it ever go away or did you just reinstall with an older iso?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › echo "The `uname` Club" (NEW POLL)