Overclock.net › Forums › Intel › Intel Motherboards › Red CPU_Led / DRAM_Led - What parts to replace.
New Posts  All Forums:Forum Nav:

Red CPU_Led / DRAM_Led - What parts to replace.

post #1 of 4
Thread Starter 
What the title says.... I've had this issue before with fans not working correctly(not all fans starting on start-up) but it does work now. As we as my monitor not detecting any signal - Lights on keyboard/mouse not working as it should.

I have replaced my cpu cooler. however, it was a corsair h100 and it did not work. I might have broken something while installing it / uninstalling it, but I really doubt it, since this has red light has happend before..

Anyway.. im wondering, in order to fix this, what do I have to replace?
post #2 of 4
Quote:
Originally Posted by Flupa View Post

What the title says.... I've had this issue before with fans not working correctly(not all fans starting on start-up) but it does work now. As we as my monitor not detecting any signal - Lights on keyboard/mouse not working as it should.
I have replaced my cpu cooler. however, it was a corsair h100 and it did not work. I might have broken something while installing it / uninstalling it, but I really doubt it, since this has red light has happend before..
Anyway.. im wondering, in order to fix this, what do I have to replace?

if you could list your system specs it would help us help you smile.gif

but just off the top of my head, do you have your 8 pin cpu power cable plugged into the motherboard?

have you tried switching your ram to the other set of slots?
post #3 of 4
Thread Starter 
Quote:
Originally Posted by Bouf0010 View Post

if you could list your system specs it would help us help you smile.gif
but just off the top of my head, do you have your 8 pin cpu power cable plugged into the motherboard?
have you tried switching your ram to the other set of slots?

Hm, thought I already have done that...: http://www.overclock.net/lists/display/view/id/4053841

Yes, the power cable is plugged into the motherboard.

And yes to the Ram.
post #4 of 4
how do you have the 16gigs of ram set up on a triple channel mobo?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › Red CPU_Led / DRAM_Led - What parts to replace.