Overclock.net › Forums › Graphics Cards › AMD/ATI › Problems with new VisionTek HD 7970 please HELP!
New Posts  All Forums:Forum Nav:

Problems with new VisionTek HD 7970 please HELP!

post #1 of 4
Thread Starter 
Hi guys, I got my new VisionTek HD 7970 today on the mail. I am upgrading from crossfired HD5850's. The installation was easy and without problems. I got the latest drivers etc from AMD's website. I used CCleaner to remove anything that might have been left behind from my old cards. Anyways, here is the problem, I see alot of screen tearing/ freezes/ and crashes as soon as I overclock it. I have tried overclocking with CCC using Overdrive and also using Afterburner. I am not even messing with voltages, I am just trying for the CCC overclock which should be no problem for this card. The temps are around 80 while playing games, the games crash every time, if I don't mess with overclocking no problems. Please help, id appreciate any help. Thanks alot
post #2 of 4
Seems as though your new drivers install wasn't entirely "clean". There are probably still traces of the old drivers on your machine causing issues. You can use the guides below to properly remove drivers, then try reinstalling the latest drivers.

- Driver Sweeper Method

- Manual Method (note: only use this if you have an Intel mobo)
post #3 of 4
Thread Starter 
Hirolla,

Thanks for the advice, I did what you suggested and now the card overclocks...however I have to raise the fan speed to around 70% to be stable, and also now CCC will not launch no matter what I do. I have tried everything I found online short of reinstalling windows. Any ideas? Thanks
post #4 of 4
Just wondering, what clocks/voltage are you running your 7970 at?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Problems with new VisionTek HD 7970 please HELP!