Overclock.net › Forums › General Hardware › General Processor Discussions › 6950 driver issue
New Posts  All Forums:Forum Nav:

6950 driver issue

post #1 of 2
Thread Starter 
Hi guys I have this problem.

I how 2x6950 in crossfire, I'm downloading the new drivers available on a fresh reformatted system , for some reason once the driver are installed , a lot of garbage on the screen shows up and some times it doesn't pass the windows 7 loading screen.

But everything works perfectly when the drives are not installed

I've tried the latest 12.3 driver and 12.2 but no avail.

I need your help badly.


I have swapped the card place, used HDMI and DVI outputs


What else can I try.....
Trident
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD FX-6100 Asus Sabertooth 990FX Powercolor AMD 6950 Corsair Vengeance DDR3 8GB 1600mhz C9 
Hard DriveHard DriveCoolingOS
Corsair Force 3 90GB SATA III SSD Western Digital Caviar Black SATA III 1Tb Antec Kuhler H620 Windows 7 Professional 64bit 
KeyboardPowerCaseMouse
Razer Blackwidow Seasonci Xseries X850 Corsair Carbide 400R Razer Copperhead 
Mouse Pad
Razer Frag edition Goliathus 
  hide details  
Reply
Trident
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD FX-6100 Asus Sabertooth 990FX Powercolor AMD 6950 Corsair Vengeance DDR3 8GB 1600mhz C9 
Hard DriveHard DriveCoolingOS
Corsair Force 3 90GB SATA III SSD Western Digital Caviar Black SATA III 1Tb Antec Kuhler H620 Windows 7 Professional 64bit 
KeyboardPowerCaseMouse
Razer Blackwidow Seasonci Xseries X850 Corsair Carbide 400R Razer Copperhead 
Mouse Pad
Razer Frag edition Goliathus 
  hide details  
Reply
post #2 of 2
Try 12.1. Drivers after 12.2 have issues especially with 6000 series gpus. Mostly related to missing DLLs for overclocking software, but worth a try anyway as it messed up mine even without any OC programs. There is a fix for the later drivers available, but I'd try 12.1 first to confirm whether this is actually your issue.

To be sure you should do a complete uninstall and run driversweeper before installing 12.1.

Other than that, have you tried running just one card at a time to see if one is faulty or check for a bad crossfire bridge?


You posted this in the wrong forum BTW. Should be in Graphics Cards - AMD/ATI.
Edited by KinguBah - 4/12/12 at 3:36am
Mah baby
(10 items)
 
  
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1100T Crosshair IV Formula Sapphire Radeon HD 6950 Sapphire Radeon HD 6950 
RAMHard DriveHard DriveCooling
8gb G.skill Ripjaws cl7 1600mhz Corsair SSD Force Series 120gb WDC 2tb H50 
PowerCase
Corsair TX 850w CM HAF 932 Black Limited Edition 
  hide details  
Reply
Mah baby
(10 items)
 
  
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1100T Crosshair IV Formula Sapphire Radeon HD 6950 Sapphire Radeon HD 6950 
RAMHard DriveHard DriveCooling
8gb G.skill Ripjaws cl7 1600mhz Corsair SSD Force Series 120gb WDC 2tb H50 
PowerCase
Corsair TX 850w CM HAF 932 Black Limited Edition 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: General Processor Discussions
Overclock.net › Forums › General Hardware › General Processor Discussions › 6950 driver issue