Overclock.net › Forums › Video Games › PC Gaming › BF3, Possible VSYNC trick? No input lag + frame sync (no tearing).
New Posts  All Forums:Forum Nav:

BF3, Possible VSYNC trick? No input lag + frame sync (no tearing).

post #1 of 34
Thread Starter 
So I've been using MSI Afterburner (2.2) OSD's frame limiter at 58FPS for a while now with VSYNC turned off. 58 or 59FPS is just enough to offset 60FPS and help dissipate tearing, though never completely at any frame rate.

Just for giggles I turned VSYNC on while continuing to run the limiter at 58FPS. At first I wasn't sure that VSC was even turned on because there was absolutely no mouse lag, the type of input lag that is traditionally associated with VSC. After looking for tearing and toying with turning VSC on and off I noticed that tearing no longer happens with it turned on whilst having a frame limiter at anything below 60FPS (59, 58, 57, ect.). Even the small amount of tearing that happened with VSC off @ 58FPS was completely gone.
Using a frame limiter and locking the frame rate to 59 or 58, 57, ect. ect. FPS + turning VSC on is resulting in no input lag while completely ridding me of tearing - individual frames are absolutely aligned... though when the frame limiter is set to 60FPS (or above), it's as if traditional VSYNC re-appears with major input lag.

What I've found.
  • Using a frame limiter and locking frame rate to 59FPS or less with VSYNC turned on eliminated both input lag and completely removes tearing (basically VSYNC on + frame limiter set to 59FPS - GPU usage is not increased or decreased, can't find a drawback).
  • Using a frame limiter and locking frame rate to any frame rate with VSYNC turned off eliminates input lag but causes tearing (traditionally). Offsetting frame rate to 58, 59 or 61, 62FPS with a limiter will help make tearing less noticeable under this setup but will not completely remove it.
  • Using no frame limiter with VSYNC turned on causes input lag but eliminates tearing (traditionally).


I'm using Afterburner 2.2 beta 15 but my inclination is that it works with any frame limiting utility.
I'd like to know if it works for anyone else.
Update 9/10/2012
After using this for a while I have realized that this requires you have enough GPU power (or lower the graphical settings) to hold 60FPS consistently without maxing out the GPU(s). So this may not work for everyone.
When the GPU is at 99-100% (the wall), input lag will reappear.
Edited by pengs - 11/16/13 at 9:03pm
post #2 of 34
I also use AB's OSD to set limiter at 60 and I experience the same as you, except for all games. Using only vsync eliminates screen tearing, but induces enough input lag to be noticeable and unplayable for FPS. Setting AB's frame limiter to 60 almost totally removes input lag, but not FULLY. I can still feel a little bit input lag, but not as bad as without the frame limiter.

Why? I have no idea, I just know it works.
post #3 of 34
It's been commonly known that limiting your FPS to 1 FPS less than VSYNC is a traditional trick to removing input lag associated with VSYNC. smile.gif

It's good you figured it out though.
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
post #4 of 34
I notice when i limit my fps to 60 in BF3 there is huge amount of tearingin the middle of the screen in some areas

But when i limit the fps to 59 the tearing is gone and can mostly be seen towards the bottom or top if at all ever.

I tested this over and over.

Edit:

And when i dont limit the framrate i notices in some areas panning is not smooth (Areas with 70 or 100FPS and anything not a multiple of 30) like it is skipping frames, reminds me of 30FPS in these areas.

With frame limiter everywhere is smooth.
Edited by SIDWULF - 4/20/12 at 10:48am
Computer
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K / 4.5Ghz / 1.368v / 212 EVO+ ASUS P8Z77-V LK EVGA Geforce GTX 680 / 2GB / 1228MHz / 3479MHz Kingston HyperX Blu Black / 1600Mhz / 8GB (2x4GB) 
Hard DriveHard DriveHard DriveOS
OCZ Vertex 4 / SSD / 128GB Seagate ST500413AS / HDD / SATA / 500GB Seagate ST1000DM003 / HDD / SATA / 1000GB Windows 8.1 Pro / 64Bit / Full 
MonitorMonitorMonitorKeyboard
Samsung S23A700D / 120Hz / 23" Dell 2312HM / IPS / 23" LG IPS231 / IPS / 23" CMStorm Quick Fire Rapid 
PowerMouseMouse PadAudio
Seasonic X760 / 80 Plus Gold Zowie AM SteelSeries NP+ M-Audio Q40 with Beyerdynamic EDT 770 VB pads ... 
  hide details  
Reply
Computer
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K / 4.5Ghz / 1.368v / 212 EVO+ ASUS P8Z77-V LK EVGA Geforce GTX 680 / 2GB / 1228MHz / 3479MHz Kingston HyperX Blu Black / 1600Mhz / 8GB (2x4GB) 
Hard DriveHard DriveHard DriveOS
OCZ Vertex 4 / SSD / 128GB Seagate ST500413AS / HDD / SATA / 500GB Seagate ST1000DM003 / HDD / SATA / 1000GB Windows 8.1 Pro / 64Bit / Full 
MonitorMonitorMonitorKeyboard
Samsung S23A700D / 120Hz / 23" Dell 2312HM / IPS / 23" LG IPS231 / IPS / 23" CMStorm Quick Fire Rapid 
PowerMouseMouse PadAudio
Seasonic X760 / 80 Plus Gold Zowie AM SteelSeries NP+ M-Audio Q40 with Beyerdynamic EDT 770 VB pads ... 
  hide details  
Reply
post #5 of 34
Thread Starter 
Quote:
Originally Posted by WiL11o6 View Post

I also use AB's OSD to set limiter at 60 and I experience the same as you, except for all games. Using only vsync eliminates screen tearing, but induces enough input lag to be noticeable and unplayable for FPS. Setting AB's frame limiter to 60 almost totally removes input lag, but not FULLY. I can still feel a little bit input lag, but not as bad as without the frame limiter.

Try setting the limiter to 59FPS while keeping VSYNC on. If I set the FPS limiter to 60 (VSYNC on) I get traditional VSYNC input lag, but as soon as I set it to 59FPS (VSYNC still on), the input lag is gone and tearing is also non existent.
post #6 of 34
Thread Starter 
Quote:
Originally Posted by GanjaSMK View Post

It's been commonly known that limiting your FPS to 1 FPS less than VSYNC is a traditional trick to removing input lag associated with VSYNC. smile.gif
It's good you figured it out though.

I've always kept Vsync off in fear of input lag with a frame limiter set to either 58 or 62FPS and dealt with the tearing. Though 58 or 62FPS offset 60 enough to make tearing not as noticeable, it was still apparent.

Does it also remove tearing for you? Because it's removing both for me, input lag and tearing fully (even the small amount of tearing that happened at 58/59FPS with VSC off). The frames are completely aligned.
Edited by pengs - 4/20/12 at 11:40am
post #7 of 34
same thing for 1080i,set it at 29 hertz in gpu remove vsync.and it is smooth has butter ,if you set it at 30 hertz all kind of issue popup!the thing here is lets say you set it at 29 you look in gpu it still say 30 !dont touch it!
go in the window 7 resolution by there you can see the actual hertz and it is gona say 29!(ya a bug)it is the same for 1080p if i recall the actual number is 59.97 hertz so if you are there you are fully matched.people rarelly pair but if they did they would have a lot less issue!tip.if you ever plan to use 1080i dont forget to use windowed full screen or whatever it is called otherwise the game will probably try to force 1080p on your 1080i project!
post #8 of 34
@pengs

I get tearing no matter what in BF3. Other games no, like in Bulletstorm, no tearing. But in BF3 I can't get it not to tear no matter what I do.


( edit )

What version of MSI AB are you using that has the frame rate limiter? I just installed 2.2 the other day upon release, but I can't see it anywhere in the options?! thinking.gif
Edited by GanjaSMK - 4/20/12 at 11:04am
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
post #9 of 34
Thread Starter 
Quote:
Originally Posted by GanjaSMK View Post

@pengs
I get tearing no matter what in BF3. Other games no, like in Bulletstorm, no tearing. But in BF3 I can't get it not to tear no matter what I do.
( edit )
What version of MSI AB are you using that has the frame rate limiter? I just installed 2.2 the other day upon release, but I can't see it anywhere in the options?! thinking.gif

2.2 beta 15. You need to set up the AB OSD by going into properties and under monitoring, check 'show in tray' and 'show on-screen display'. The FPS limiter will be under the wrench in the OSD.

It may have something to do with NV cards. But try it. Set your frame limiter to 59FPS and turn VSC on.
Edited by pengs - 4/20/12 at 11:12am
post #10 of 34
Another solution: get a 120Hz monitor and turn off vsync

That costs $$$ though.
    
CPUMotherboardGraphicsRAM
2600K @ 4.7(1.416v load) Gigabyte P67 UD4 Diamond HD 7970 1250/1800 4 x 4GB Mushkin Blackline 1.35v 
Hard DriveOSMonitorPower
830 256GB & (3) Spinpoint F3's win7 x64 LG W2363D-PF Silverstone DA800 
Case
FT-02B 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
2600K @ 4.7(1.416v load) Gigabyte P67 UD4 Diamond HD 7970 1250/1800 4 x 4GB Mushkin Blackline 1.35v 
Hard DriveOSMonitorPower
830 256GB & (3) Spinpoint F3's win7 x64 LG W2363D-PF Silverstone DA800 
Case
FT-02B 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › BF3, Possible VSYNC trick? No input lag + frame sync (no tearing).