Overclock.net › Forums › Intel › Intel Motherboards › [Official] ASUS SABERTOOTH Z77 Owners Thread/Club
New Posts  All Forums:Forum Nav:

[Official] ASUS SABERTOOTH Z77 Owners Thread/Club - Page 186

post #1851 of 6915
Quote:
Originally Posted by Hanoverfist View Post

Yes it does support tri sli. Fitting three triple slot cooling solution cards no.
So it could handle three 670 ftws? They are only dual slot from what i see... I won't be doing water cooling.

Also the lowered bandwidth for each PCI Slot does it affect performance at a a noticable rate?
post #1852 of 6915
Quote:
Originally Posted by Trelga View Post

So it could handle three 670 ftws? They are only dual slot from what i see... I won't be doing water cooling.
Also the lowered bandwidth for each PCI Slot does it affect performance at a a noticable rate?
Yes that card is double slot so three will fit. I will look for review i only use 1 triple slot card and have no personal experience with trip sli. seems to me dual cards would be a sweet spot.
post #1853 of 6915
Anyone know why BIOS 1403 was removed from the ASUS website? I currently have it installed and am unable to flash an older BIOS (Warning about a change in BIOS framework).

Anyone know anything?
post #1854 of 6915
What's with the plastic cover on the mobo? Wouldn't it be cooler without? How would you blow off the dust bunnies collecting underneath?
post #1855 of 6915
Quote:
Originally Posted by Hanoverfist View Post

Yes that card is double slot so three will fit. I will look for review i only use 1 triple slot card and have no personal experience with trip sli. seems to me dual cards would be a sweet spot.

Yeah looking at reviews trial sli only gains on average 4 to 5 fps

Maybe if they can work some magic in drivers it will be worth it one day.
post #1856 of 6915
Quote:
Originally Posted by cab2 View Post

What's with the plastic cover on the mobo? Wouldn't it be cooler without? How would you blow off the dust bunnies collecting underneath?

Benchmarks I have seen show about 3C cooler with it on and assist fans in place, one of the features of it is to repel dust but it is removable if you chose.
Kaby Mullet
(27 items)
 
  
CPUMotherboardGraphicsRAM
intel i7 7700K ASUS Maximux IX Hero NVIDIA GeForce GTX 1080 Ti G.Skill TridentZ RGB Series 32GB DDR4 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 EVO M.2 500GB NVMe Crucial M500 240Gb SSD Crucial M500 960Gb SSD Seagate 3TB 
Hard DriveCoolingOSMonitor
WD MyCloud 4TB NAS Corsair Hydro Series H100i V2 Windows 10 Home x64 Acer Predator Z35P 
KeyboardPowerCaseMouse
Razer Blackwidow Chroma EVGA SuperNOVA 850 G2 Corsair 600C Razer Naga Epic Chroma 
Mouse PadAudioAudioOther
N/A Logitech Z506 Razer Man 'o War Chroma ButtKicker Gamer II 
OtherOtherOtherOther
Fanatec v2.5 Clubsport Pedals V3 Saitek X-52 Pro Saitek Pro Flight Rudder Pedals 
OtherOtherOther
Obutto R3volution Gaming Cockpit Oculus Rift  Blue Yeti Blackout 
  hide details  
Reply
Kaby Mullet
(27 items)
 
  
CPUMotherboardGraphicsRAM
intel i7 7700K ASUS Maximux IX Hero NVIDIA GeForce GTX 1080 Ti G.Skill TridentZ RGB Series 32GB DDR4 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 EVO M.2 500GB NVMe Crucial M500 240Gb SSD Crucial M500 960Gb SSD Seagate 3TB 
Hard DriveCoolingOSMonitor
WD MyCloud 4TB NAS Corsair Hydro Series H100i V2 Windows 10 Home x64 Acer Predator Z35P 
KeyboardPowerCaseMouse
Razer Blackwidow Chroma EVGA SuperNOVA 850 G2 Corsair 600C Razer Naga Epic Chroma 
Mouse PadAudioAudioOther
N/A Logitech Z506 Razer Man 'o War Chroma ButtKicker Gamer II 
OtherOtherOtherOther
Fanatec v2.5 Clubsport Pedals V3 Saitek X-52 Pro Saitek Pro Flight Rudder Pedals 
OtherOtherOther
Obutto R3volution Gaming Cockpit Oculus Rift  Blue Yeti Blackout 
  hide details  
Reply
post #1857 of 6915
Quote:
Originally Posted by jackbrennan2008 View Post

Anyone know why BIOS 1403 was removed from the ASUS website? I currently have it installed and am unable to flash an older BIOS (Warning about a change in BIOS framework).
Anyone know anything?

I was able to on mine. Used the USB Flashback method. Takes a few minutes bot works. Change the file to Z77ST. Then load onto a flash drive. Put in the marked Intel USB 3.0 port in the rear of the machine. Press the button for 5-6 seconds. It will begin flashing. In particular, mine blinked two or three times...stopped...then about 20 seconeds later...blinked two or three more times...then started blinking like crazy...once all the blinking stopped...bios was back flashed. I now have 1304 on my MB and seems to be working fine.

Make sure to set bios to default by hitting F5 Before you try to flash. You don't want to flash any bios while overclocked. Once you set defaults...just shut down and backflash. After flashing is complete...shut down...unplug the PSU for about 2 minutes...let everything clear. When you power back up...you will see the old spash screen and are told to hit F1 to setup the board
post #1858 of 6915
Im really curious why it was taken down, Im not having any issues with 1403, in fact boot is faster. i hope leaving it doesnt cause damage.
Kaby Mullet
(27 items)
 
  
CPUMotherboardGraphicsRAM
intel i7 7700K ASUS Maximux IX Hero NVIDIA GeForce GTX 1080 Ti G.Skill TridentZ RGB Series 32GB DDR4 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 EVO M.2 500GB NVMe Crucial M500 240Gb SSD Crucial M500 960Gb SSD Seagate 3TB 
Hard DriveCoolingOSMonitor
WD MyCloud 4TB NAS Corsair Hydro Series H100i V2 Windows 10 Home x64 Acer Predator Z35P 
KeyboardPowerCaseMouse
Razer Blackwidow Chroma EVGA SuperNOVA 850 G2 Corsair 600C Razer Naga Epic Chroma 
Mouse PadAudioAudioOther
N/A Logitech Z506 Razer Man 'o War Chroma ButtKicker Gamer II 
OtherOtherOtherOther
Fanatec v2.5 Clubsport Pedals V3 Saitek X-52 Pro Saitek Pro Flight Rudder Pedals 
OtherOtherOther
Obutto R3volution Gaming Cockpit Oculus Rift  Blue Yeti Blackout 
  hide details  
Reply
Kaby Mullet
(27 items)
 
  
CPUMotherboardGraphicsRAM
intel i7 7700K ASUS Maximux IX Hero NVIDIA GeForce GTX 1080 Ti G.Skill TridentZ RGB Series 32GB DDR4 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 EVO M.2 500GB NVMe Crucial M500 240Gb SSD Crucial M500 960Gb SSD Seagate 3TB 
Hard DriveCoolingOSMonitor
WD MyCloud 4TB NAS Corsair Hydro Series H100i V2 Windows 10 Home x64 Acer Predator Z35P 
KeyboardPowerCaseMouse
Razer Blackwidow Chroma EVGA SuperNOVA 850 G2 Corsair 600C Razer Naga Epic Chroma 
Mouse PadAudioAudioOther
N/A Logitech Z506 Razer Man 'o War Chroma ButtKicker Gamer II 
OtherOtherOtherOther
Fanatec v2.5 Clubsport Pedals V3 Saitek X-52 Pro Saitek Pro Flight Rudder Pedals 
OtherOtherOther
Obutto R3volution Gaming Cockpit Oculus Rift  Blue Yeti Blackout 
  hide details  
Reply
post #1859 of 6915
Quote:
Originally Posted by SPMOkc73 View Post

Im really curious why it was taken down, Im not having any issues with 1403, in fact boot is faster. i hope leaving it doesnt cause damage.

"Supposedly" It caused some RAID configurations to fail. Once flashed...RAID couldn't be enabled. I wouldn'k know, because I have an SSD as boot drive and 1 TB drive for data, etc. The only issues I experienced was that my USB 2.0 didn't always detect when a drive was inserted. I had to unplug and re-plug to get the board to initialize my USB flash drive or external HDD. Didn't happen all the time...was sporadic. Now that I am back to 1304...the USB issue is gone. I hope they release a new bios soon. My SSD's seemed to perform a bit better on 1403. Bootup time for me is minuscule because of SSD...

I don't suspect that using 1403 will cause damage. I expect the next bios release to fix whatever was truly wrong with 1403. I am now at 1304, because I no longer have a copy of 1403. I wouldn't worry. If need be, call Asus technical support and double check that.

Let us know if you find out anything more from them...
Edited by Bobmitch - 7/30/12 at 3:45pm
post #1860 of 6915
Quote:
Originally Posted by Bobmitch View Post

"Supposedly" It caused some RAID configurations to fail. Once flashed...RAID couldn't be enabled. I wouldn'k know, because I have an SSD as boot drive and 1 TB drive for data, etc. The only issues I experienced was that my USB 2.0 didn't always detect when a drive was inserted. I had to unplug and re-plug to get the board to initialize my USB flash drive or external HDD. Didn't happen all the time...was sporadic. Now that I am back to 1304...the USB issue is gone. I hope they release a new bios soon. My SSD's seemed to perform a bit better on 1403. Bootup time for me is minuscule because of SSD...
I don't suspect that using 1403 will cause damage. I expect the next bios release to fix whatever was truly wrong with 1403. I am now at 1304, because I no longer have a copy of 1403. I wouldn't worry. If need be, call Asus technical support and double check that.
Let us know if you find out anything more from them...

Same here using SSD, no raid so not an issue, and only usb plug in is my G27 that has been fine, guess Ill ride it out til the next update.
Kaby Mullet
(27 items)
 
  
CPUMotherboardGraphicsRAM
intel i7 7700K ASUS Maximux IX Hero NVIDIA GeForce GTX 1080 Ti G.Skill TridentZ RGB Series 32GB DDR4 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 EVO M.2 500GB NVMe Crucial M500 240Gb SSD Crucial M500 960Gb SSD Seagate 3TB 
Hard DriveCoolingOSMonitor
WD MyCloud 4TB NAS Corsair Hydro Series H100i V2 Windows 10 Home x64 Acer Predator Z35P 
KeyboardPowerCaseMouse
Razer Blackwidow Chroma EVGA SuperNOVA 850 G2 Corsair 600C Razer Naga Epic Chroma 
Mouse PadAudioAudioOther
N/A Logitech Z506 Razer Man 'o War Chroma ButtKicker Gamer II 
OtherOtherOtherOther
Fanatec v2.5 Clubsport Pedals V3 Saitek X-52 Pro Saitek Pro Flight Rudder Pedals 
OtherOtherOther
Obutto R3volution Gaming Cockpit Oculus Rift  Blue Yeti Blackout 
  hide details  
Reply
Kaby Mullet
(27 items)
 
  
CPUMotherboardGraphicsRAM
intel i7 7700K ASUS Maximux IX Hero NVIDIA GeForce GTX 1080 Ti G.Skill TridentZ RGB Series 32GB DDR4 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 EVO M.2 500GB NVMe Crucial M500 240Gb SSD Crucial M500 960Gb SSD Seagate 3TB 
Hard DriveCoolingOSMonitor
WD MyCloud 4TB NAS Corsair Hydro Series H100i V2 Windows 10 Home x64 Acer Predator Z35P 
KeyboardPowerCaseMouse
Razer Blackwidow Chroma EVGA SuperNOVA 850 G2 Corsair 600C Razer Naga Epic Chroma 
Mouse PadAudioAudioOther
N/A Logitech Z506 Razer Man 'o War Chroma ButtKicker Gamer II 
OtherOtherOtherOther
Fanatec v2.5 Clubsport Pedals V3 Saitek X-52 Pro Saitek Pro Flight Rudder Pedals 
OtherOtherOther
Obutto R3volution Gaming Cockpit Oculus Rift  Blue Yeti Blackout 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › [Official] ASUS SABERTOOTH Z77 Owners Thread/Club