Overclock.net › Forums › Overclock.net Forum › Bugs and Technical Issues › Resolved Issues › [Will fix] Error when submitting trader feedback without including link
New Posts  All Forums:Forum Nav:

[Will fix] Error when submitting trader feedback without including link

post #1 of 10
Thread Starter 
I kept getting this error when trying to submit a new trader feedback:
Fatal error:

Call to a member function first() on a non-object in /var/www/sites/huddler/releases/ebc7bab7c8ff596fdb94059e7555f22e7ccdc5ec/v2/system/application/libraries/objects/HuddlerObject.php on line 1335

Fixed by providing the link to a thread. I guess its not a terrible issue but a heads up reminder to include the URL would be a little better than a white page with an error on it that doesn't explain much.
Bavman's build
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k MSI z97-g45 GTX 970 16 GB samsung 
Hard DriveOSPowerCase
Crucial M4 128gb win7 corsair 650tx haf 922 
Mouse
mx518 
  hide details  
Reply
Bavman's build
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k MSI z97-g45 GTX 970 16 GB samsung 
Hard DriveOSPowerCase
Crucial M4 128gb win7 corsair 650tx haf 922 
Mouse
mx518 
  hide details  
Reply
post #2 of 10
Its not an issue. Its a way to prevent Trader feedback boosting. thumb.gif
     
CPUGraphicsRAMHard Drive
Intel i7 6700HQ Nvidia GTX 970m 8GB's Micron DDR4 2133 Samsung SM951 256GB m.2 SSD 
Hard DriveOSAudio
Seagate 500GB SHDD Windows 10 Enterprise x64 Soundblaster X-Fi 5 
  hide details  
Reply
     
CPUGraphicsRAMHard Drive
Intel i7 6700HQ Nvidia GTX 970m 8GB's Micron DDR4 2133 Samsung SM951 256GB m.2 SSD 
Hard DriveOSAudio
Seagate 500GB SHDD Windows 10 Enterprise x64 Soundblaster X-Fi 5 
  hide details  
Reply
post #3 of 10
Thread Starter 
Well I understand it now, but when it happened it was puzzled for a couple minutes because I didn't know what was wrong. It is a good idea to require a URL, but the reminder should be more friendly than a fatal error with no explanation smile.gif
Bavman's build
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k MSI z97-g45 GTX 970 16 GB samsung 
Hard DriveOSPowerCase
Crucial M4 128gb win7 corsair 650tx haf 922 
Mouse
mx518 
  hide details  
Reply
Bavman's build
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k MSI z97-g45 GTX 970 16 GB samsung 
Hard DriveOSPowerCase
Crucial M4 128gb win7 corsair 650tx haf 922 
Mouse
mx518 
  hide details  
Reply
post #4 of 10
I'm not able to reproduce this one. To confirm, you had all information filled in with the exception of the thread link?

Capture.PNG 18k .PNG file
Morpheus Mini
(7 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700T SN970 GTX 960 Crucial CT102464BF160B 
Hard DriveOSAudio
Samsung 850 Evo M.2 Windows 10 Pro MOTU Audio Express 
  hide details  
Reply
Morpheus Mini
(7 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700T SN970 GTX 960 Crucial CT102464BF160B 
Hard DriveOSAudio
Samsung 850 Evo M.2 Windows 10 Pro MOTU Audio Express 
  hide details  
Reply
post #5 of 10
Thread Starter 
Quote:
Originally Posted by Chipp View Post

I'm not able to reproduce this one. To confirm, you had all information filled in with the exception of the thread link?
Capture.PNG 18k .PNG file

Yes, I reproduced the error by trying to submit feedback to you filling everything except the URL. I guess it might be a browser thing. I am using firefox 11.0
Bavman's build
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k MSI z97-g45 GTX 970 16 GB samsung 
Hard DriveOSPowerCase
Crucial M4 128gb win7 corsair 650tx haf 922 
Mouse
mx518 
  hide details  
Reply
Bavman's build
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-4770k MSI z97-g45 GTX 970 16 GB samsung 
Hard DriveOSPowerCase
Crucial M4 128gb win7 corsair 650tx haf 922 
Mouse
mx518 
  hide details  
Reply
post #6 of 10
I get the same as Chipp with IE9 64 bit, waterfox 10.0.2 and Chrome 18
post #7 of 10
Quote:
Originally Posted by bavman View Post

Quote:
Originally Posted by Chipp View Post

I'm not able to reproduce this one. To confirm, you had all information filled in with the exception of the thread link?
Capture.PNG 18k .PNG file

Yes, I reproduced the error by trying to submit feedback to you filling everything except the URL. I guess it might be a browser thing. I am using firefox 11.0

Interesting - it actually seems to be account-dependent. I can reproduce it a regular member account, but the expected notification appears when I'm logged in as an administrator. Confirmed!
Morpheus Mini
(7 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700T SN970 GTX 960 Crucial CT102464BF160B 
Hard DriveOSAudio
Samsung 850 Evo M.2 Windows 10 Pro MOTU Audio Express 
  hide details  
Reply
Morpheus Mini
(7 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700T SN970 GTX 960 Crucial CT102464BF160B 
Hard DriveOSAudio
Samsung 850 Evo M.2 Windows 10 Pro MOTU Audio Express 
  hide details  
Reply
post #8 of 10

So bavman is getting this error due to being a normal user, but Bitemarks and you are not, correct?  Can I get actual repro steps, here?

post #9 of 10
Quote:
Originally Posted by SJHuddler View Post

So bavman is getting this error due to being a normal user, but Bitemarks and you are not, correct?  Can I get actual repro steps, here?

As a regular user, head to any other member's trader rating page and select "leave feedback". On the feedback submission page, fill in all fields except the URL for the deal thread. Submit the form, (in theory) observe the PHP error. The same process on an administrator account will reload the form and display the proper form validation error inline.
Morpheus Mini
(7 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700T SN970 GTX 960 Crucial CT102464BF160B 
Hard DriveOSAudio
Samsung 850 Evo M.2 Windows 10 Pro MOTU Audio Express 
  hide details  
Reply
Morpheus Mini
(7 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700T SN970 GTX 960 Crucial CT102464BF160B 
Hard DriveOSAudio
Samsung 850 Evo M.2 Windows 10 Pro MOTU Audio Express 
  hide details  
Reply
post #10 of 10

Verified, #9149.


Edited by SJHuddler - 5/1/12 at 4:30pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Resolved Issues
Overclock.net › Forums › Overclock.net Forum › Bugs and Technical Issues › Resolved Issues › [Will fix] Error when submitting trader feedback without including link