Overclock.net › Forums › Graphics Cards › AMD/ATI › Just bought a 6870 double D, First boot up is fine.. anything boot up following that results in no display. help please?
New Posts  All Forums:Forum Nav:

Just bought a 6870 double D, First boot up is fine.. anything boot up following that results in no display. help please?

post #1 of 6
Thread Starter 
Hey everyone.. I was wondering if anyone can help me out with my problem. I just bought an XFX 6870 double D. I installed it yesterday and it booted up just fine. I cleared out my old drivers and installed the new ones. The problem happened when it went to restart. There was no longer any signal coming from the graphics card. I tried switching to the other DVI input and even the HDMI input. Nothing worked. I switched off the psu and waited for my mobo to discharge and then tried starting it back up. This would work and I would be able to use it just fine until i restart or shut down again. No monitor would not receive any signal again and the only way I would be able to get the signal back is by turning the psu off for a min and switching it back on. Any clue what my problem is?

I tried resetting my cmos and my bios has the latest update. I tried disabling the integrated gfx and that didn't work either. I previously owned a 4890 and everything worked flawlessly. Any help would be appreciated.
My first intel
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asrock z77 Extreme4 ASUS GTX 670 CUII TOP G-skill RipJaw Z series 2400mhz 
Hard DriveOptical DriveCoolingOS
Intel x-25m g2 Lite-on CM 212+ Windows 7 Pro 64 
MonitorKeyboardPowerCase
westinghouse l2410nm logitech Corsair 650tx antec 300 
MouseMouse PadAudio
MX revolution generic Creative Xi-FI Extreme Music 
  hide details  
Reply
My first intel
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asrock z77 Extreme4 ASUS GTX 670 CUII TOP G-skill RipJaw Z series 2400mhz 
Hard DriveOptical DriveCoolingOS
Intel x-25m g2 Lite-on CM 212+ Windows 7 Pro 64 
MonitorKeyboardPowerCase
westinghouse l2410nm logitech Corsair 650tx antec 300 
MouseMouse PadAudio
MX revolution generic Creative Xi-FI Extreme Music 
  hide details  
Reply
post #2 of 6
Sorry to say this, but looks like card just killed it self.
EDIT: Now somethign came to my mind, one my friend killed his Gigabyte HD 5870 SoC in the similar way.
After driver install, his bios became corrupted.
Edited by sena - 4/24/12 at 9:08am
Green Hell
(16 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i7 6950X @ 4.3 GHz 1.35V Asus Rampage V Extreme Edition 10  GTX 1080 @ 2.1 GHz GTX 1080 @ 2.1 GHz 
RAMHard DriveHard DriveHard Drive
Corsair LPX 128 GB 3200 MHz Samsung 950 Pro 512 GB Samsung 850 Pro 1 TB Samsung 850 Pro 1 TB 
CoolingOSMonitorKeyboard
Fully custom watercooling system Windows 10 Pro Acer Predator XB321HK Razer BlackWidow Ultimate Stealth 2013 Edition 
PowerCaseMouseAudio
Corsair AXi 1500W Corsair 900D Razer Mamba Asus ROG Strix Wireless 
  hide details  
Reply
Green Hell
(16 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i7 6950X @ 4.3 GHz 1.35V Asus Rampage V Extreme Edition 10  GTX 1080 @ 2.1 GHz GTX 1080 @ 2.1 GHz 
RAMHard DriveHard DriveHard Drive
Corsair LPX 128 GB 3200 MHz Samsung 950 Pro 512 GB Samsung 850 Pro 1 TB Samsung 850 Pro 1 TB 
CoolingOSMonitorKeyboard
Fully custom watercooling system Windows 10 Pro Acer Predator XB321HK Razer BlackWidow Ultimate Stealth 2013 Edition 
PowerCaseMouseAudio
Corsair AXi 1500W Corsair 900D Razer Mamba Asus ROG Strix Wireless 
  hide details  
Reply
post #3 of 6
Thread Starter 
I dont think the bios is corrupted because when i reset my psu all of my bios settings are still intact. The card works fine again after i reset the psu. I can be on it for hours at a time and game with no problems. I just have to reset the psu after every shut down or restart.
My first intel
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asrock z77 Extreme4 ASUS GTX 670 CUII TOP G-skill RipJaw Z series 2400mhz 
Hard DriveOptical DriveCoolingOS
Intel x-25m g2 Lite-on CM 212+ Windows 7 Pro 64 
MonitorKeyboardPowerCase
westinghouse l2410nm logitech Corsair 650tx antec 300 
MouseMouse PadAudio
MX revolution generic Creative Xi-FI Extreme Music 
  hide details  
Reply
My first intel
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asrock z77 Extreme4 ASUS GTX 670 CUII TOP G-skill RipJaw Z series 2400mhz 
Hard DriveOptical DriveCoolingOS
Intel x-25m g2 Lite-on CM 212+ Windows 7 Pro 64 
MonitorKeyboardPowerCase
westinghouse l2410nm logitech Corsair 650tx antec 300 
MouseMouse PadAudio
MX revolution generic Creative Xi-FI Extreme Music 
  hide details  
Reply
post #4 of 6
Quote:
Originally Posted by xbanhxbaox View Post

I dont think the bios is corrupted because when i reset my psu all of my bios settings are still intact. The card works fine again after i reset the psu. I can be on it for hours at a time and game with no problems. I just have to reset the psu after every shut down or restart.

I was talkig about GPU bios, but nevermind, now i see that you problem is most likely PSU.
Green Hell
(16 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i7 6950X @ 4.3 GHz 1.35V Asus Rampage V Extreme Edition 10  GTX 1080 @ 2.1 GHz GTX 1080 @ 2.1 GHz 
RAMHard DriveHard DriveHard Drive
Corsair LPX 128 GB 3200 MHz Samsung 950 Pro 512 GB Samsung 850 Pro 1 TB Samsung 850 Pro 1 TB 
CoolingOSMonitorKeyboard
Fully custom watercooling system Windows 10 Pro Acer Predator XB321HK Razer BlackWidow Ultimate Stealth 2013 Edition 
PowerCaseMouseAudio
Corsair AXi 1500W Corsair 900D Razer Mamba Asus ROG Strix Wireless 
  hide details  
Reply
Green Hell
(16 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i7 6950X @ 4.3 GHz 1.35V Asus Rampage V Extreme Edition 10  GTX 1080 @ 2.1 GHz GTX 1080 @ 2.1 GHz 
RAMHard DriveHard DriveHard Drive
Corsair LPX 128 GB 3200 MHz Samsung 950 Pro 512 GB Samsung 850 Pro 1 TB Samsung 850 Pro 1 TB 
CoolingOSMonitorKeyboard
Fully custom watercooling system Windows 10 Pro Acer Predator XB321HK Razer BlackWidow Ultimate Stealth 2013 Edition 
PowerCaseMouseAudio
Corsair AXi 1500W Corsair 900D Razer Mamba Asus ROG Strix Wireless 
  hide details  
Reply
post #5 of 6
Thread Starter 
Oh sorry. My mistake. It's not the psu either. The 4890 works fine with my psu and it draws more power than the 6870. I'm going to try to contact xfx to see if I can work something out with them. Thanks for the help!
My first intel
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asrock z77 Extreme4 ASUS GTX 670 CUII TOP G-skill RipJaw Z series 2400mhz 
Hard DriveOptical DriveCoolingOS
Intel x-25m g2 Lite-on CM 212+ Windows 7 Pro 64 
MonitorKeyboardPowerCase
westinghouse l2410nm logitech Corsair 650tx antec 300 
MouseMouse PadAudio
MX revolution generic Creative Xi-FI Extreme Music 
  hide details  
Reply
My first intel
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asrock z77 Extreme4 ASUS GTX 670 CUII TOP G-skill RipJaw Z series 2400mhz 
Hard DriveOptical DriveCoolingOS
Intel x-25m g2 Lite-on CM 212+ Windows 7 Pro 64 
MonitorKeyboardPowerCase
westinghouse l2410nm logitech Corsair 650tx antec 300 
MouseMouse PadAudio
MX revolution generic Creative Xi-FI Extreme Music 
  hide details  
Reply
post #6 of 6
Sorry for not replying, was busy in HD 7900 thread.
That is bad to hear, good luck mate.
Green Hell
(16 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i7 6950X @ 4.3 GHz 1.35V Asus Rampage V Extreme Edition 10  GTX 1080 @ 2.1 GHz GTX 1080 @ 2.1 GHz 
RAMHard DriveHard DriveHard Drive
Corsair LPX 128 GB 3200 MHz Samsung 950 Pro 512 GB Samsung 850 Pro 1 TB Samsung 850 Pro 1 TB 
CoolingOSMonitorKeyboard
Fully custom watercooling system Windows 10 Pro Acer Predator XB321HK Razer BlackWidow Ultimate Stealth 2013 Edition 
PowerCaseMouseAudio
Corsair AXi 1500W Corsair 900D Razer Mamba Asus ROG Strix Wireless 
  hide details  
Reply
Green Hell
(16 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i7 6950X @ 4.3 GHz 1.35V Asus Rampage V Extreme Edition 10  GTX 1080 @ 2.1 GHz GTX 1080 @ 2.1 GHz 
RAMHard DriveHard DriveHard Drive
Corsair LPX 128 GB 3200 MHz Samsung 950 Pro 512 GB Samsung 850 Pro 1 TB Samsung 850 Pro 1 TB 
CoolingOSMonitorKeyboard
Fully custom watercooling system Windows 10 Pro Acer Predator XB321HK Razer BlackWidow Ultimate Stealth 2013 Edition 
PowerCaseMouseAudio
Corsair AXi 1500W Corsair 900D Razer Mamba Asus ROG Strix Wireless 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
  • Just bought a 6870 double D, First boot up is fine.. anything boot up following that results in no display. help please?
Overclock.net › Forums › Graphics Cards › AMD/ATI › Just bought a 6870 double D, First boot up is fine.. anything boot up following that results in no display. help please?