Overclock.net › Forums › Cooling › Water Cooling › Rust on pump :(
New Posts  All Forums:Forum Nav:

Rust on pump :(

post #1 of 7
Thread Starter 
So I'm working on my Ivy build and when I pull my pump off its mount and I find this....

450

Should I be worried and any idea on a fix or how long it will last?
MOAR FANS
(10 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77 UD5H HD 7950 G skill Ripjaws X 
CoolingOSKeyboardPower
EK supreme HF Win 7 Logitech G15 Thermaltake TR2 850W 
CaseMouse
switch 810 Logitech MX620 
  hide details  
Reply
MOAR FANS
(10 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77 UD5H HD 7950 G skill Ripjaws X 
CoolingOSKeyboardPower
EK supreme HF Win 7 Logitech G15 Thermaltake TR2 850W 
CaseMouse
switch 810 Logitech MX620 
  hide details  
Reply
post #2 of 7
ooh yeah i dont know about that. It just all depends on how deep that rust goes. It might just be on the one opening or god forbid there might be rust developing on the motor itself. you might be able to get away with like a silicone lubricant to spray in there. but i would do more research before making any attempt. possibly even send a picture to the manufacture.
MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
post #3 of 7
Thread Starter 
It's a MCP 355 pump. It's also on the inside when the impeller is near the ceramic bearing piece. Not sure how long it's been that way either, last time I pulled my loop apart was when I cleaned it maybe 2 months ago.
MOAR FANS
(10 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77 UD5H HD 7950 G skill Ripjaws X 
CoolingOSKeyboardPower
EK supreme HF Win 7 Logitech G15 Thermaltake TR2 850W 
CaseMouse
switch 810 Logitech MX620 
  hide details  
Reply
MOAR FANS
(10 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77 UD5H HD 7950 G skill Ripjaws X 
CoolingOSKeyboardPower
EK supreme HF Win 7 Logitech G15 Thermaltake TR2 850W 
CaseMouse
switch 810 Logitech MX620 
  hide details  
Reply
post #4 of 7
Dang... If this happened to me, I would definitely toss that and get a new pump. It would be hard to prove both ways, but better safe than sorry. Especially with your shiny new CPU and board smile.gif
    
CPUMotherboardGraphicsRAM
Intel i7-3930K Asus Rampage IV Extreme EVGA GTX 690 Corsair Dominator GT 16 GB (4 x 4 GB) DDR3 2133... 
Hard DriveHard DriveHard DriveCooling
Samsung 840 Pro 256GB x 2 (RAID 0) Western Digital VelociRaptor 300GB Seagate Barracuda 3TB x 2 Koolance CPU-380i 
CoolingCoolingCoolingMonitor
HEATKILLER® GPU-X³ GTX 690 Hole Edition Noiseblocker NB-BlackSilentPro PK-3 x 12 Black Ice® GTX Gen Two Xtreme 560 x 3 Asus VG278HE 
KeyboardPowerCaseMouse
Corsair Vengeance K60 SeaSonic Platinum-1000 CaseLabs STH-10 Corsair Vengeance M60 
Audio
Asus Xonar Phoebus 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i7-3930K Asus Rampage IV Extreme EVGA GTX 690 Corsair Dominator GT 16 GB (4 x 4 GB) DDR3 2133... 
Hard DriveHard DriveHard DriveCooling
Samsung 840 Pro 256GB x 2 (RAID 0) Western Digital VelociRaptor 300GB Seagate Barracuda 3TB x 2 Koolance CPU-380i 
CoolingCoolingCoolingMonitor
HEATKILLER® GPU-X³ GTX 690 Hole Edition Noiseblocker NB-BlackSilentPro PK-3 x 12 Black Ice® GTX Gen Two Xtreme 560 x 3 Asus VG278HE 
KeyboardPowerCaseMouse
Corsair Vengeance K60 SeaSonic Platinum-1000 CaseLabs STH-10 Corsair Vengeance M60 
Audio
Asus Xonar Phoebus 
  hide details  
Reply
post #5 of 7
looks like minor surface rust to me, you should be ok. if it makes crazy noises or stops working all together just get a new one. but like i said it looks very minor. just use a brush and a dab of silicon and scrub it off.
    
CPUMotherboardGraphicsRAM
Intel i7 4930k Asus Rampage IV Extreme MSI 7970 Lightning quad gskill trident 2400mhz 
Hard DriveHard DriveHard DriveOptical Drive
OCZ agility 2 Samsung spinpoint 3 1tb raid 0 sandisk extreme ultra  ASUS OEM DVD writer 
CoolingCoolingCoolingCooling
EK Supreme HF dual Laing D5 pump  XSPC dual D5 Dual bay reservoir XSPC 240 RX Rad 
CoolingCoolingCoolingOS
XSPC 360 RX Rad Ek XTX 480 ek 7970 lightning blocks x4 Windows 7 Ultimate 64b 
MonitorMonitorMonitorKeyboard
SAMSUNG BX2335 23" ACER S230HLAbii ACER S230HLAbii Das Keyboard 
PowerCaseMouse
Corsair AX1500I Corsair 900d Logitech G9 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i7 4930k Asus Rampage IV Extreme MSI 7970 Lightning quad gskill trident 2400mhz 
Hard DriveHard DriveHard DriveOptical Drive
OCZ agility 2 Samsung spinpoint 3 1tb raid 0 sandisk extreme ultra  ASUS OEM DVD writer 
CoolingCoolingCoolingCooling
EK Supreme HF dual Laing D5 pump  XSPC dual D5 Dual bay reservoir XSPC 240 RX Rad 
CoolingCoolingCoolingOS
XSPC 360 RX Rad Ek XTX 480 ek 7970 lightning blocks x4 Windows 7 Ultimate 64b 
MonitorMonitorMonitorKeyboard
SAMSUNG BX2335 23" ACER S230HLAbii ACER S230HLAbii Das Keyboard 
PowerCaseMouse
Corsair AX1500I Corsair 900d Logitech G9 
  hide details  
Reply
post #6 of 7
Looks as if the tiny pressed on clip that holds the main pin of the pump has rusted. That clip in your photo is on the outside of the pump. Just clen it off really good and use a clear coat finger nail polish over the exposed metal.

As for the other comments, indeed, unscrew the four base screws pop the top off and look inside.
NOTE: Drain you loop first if you need to take the pump apart. The good thing is, the DDC pump can come apart without removing the cover from the loop. wink.gif

All of the DDC and D5 pumps use a low grade of stainless steel for the impellers. People today mainly use just kill-coil and water. A few years back it was propylene glycol 10% and 90% distilled water that kept the pump happy, well lubricated and no issues with oxidation showing rust.

If the impeller shows signs of surface oxidation looking like rust, wipe it off till it's smooth and again use clear nail polish on the impeller. Just make sure it's as smooth a coating that you can get.

Hope this helps.

BMaverick, meeting your DDC pump needs
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon 64 x2 5000 Black 2.6Ghz OC 3.3Ghz GigaByte GA-MA78GM-S2H Full Radeon 780G HD 3200 4GB Corsair DDR2 6400C4 
Hard DriveOSPowerCase
Seagate Barracuda 750GB 7200 RPM 32MB Cache Windows 7 Pro x64 Corsair HX620W Meridian XClio High Tower I 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon 64 x2 5000 Black 2.6Ghz OC 3.3Ghz GigaByte GA-MA78GM-S2H Full Radeon 780G HD 3200 4GB Corsair DDR2 6400C4 
Hard DriveOSPowerCase
Seagate Barracuda 750GB 7200 RPM 32MB Cache Windows 7 Pro x64 Corsair HX620W Meridian XClio High Tower I 
  hide details  
Reply
post #7 of 7
Thread Starter 
Thanks Bmaverick, the pump has been of great service to me with no issues. I have to take the loop apart here again soon so ill be sure to coat the bottom and the pinhole in the top of the ceramic bearing with clear nail polish. It hasn't leaked (knock on wood).
MOAR FANS
(10 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77 UD5H HD 7950 G skill Ripjaws X 
CoolingOSKeyboardPower
EK supreme HF Win 7 Logitech G15 Thermaltake TR2 850W 
CaseMouse
switch 810 Logitech MX620 
  hide details  
Reply
MOAR FANS
(10 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77 UD5H HD 7950 G skill Ripjaws X 
CoolingOSKeyboardPower
EK supreme HF Win 7 Logitech G15 Thermaltake TR2 850W 
CaseMouse
switch 810 Logitech MX620 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Rust on pump :(