Overclock.net › Forums › Components › Monitors and Displays › Screen is Getting NO signal. NEED HELP!
New Posts  All Forums:Forum Nav:

Screen is Getting NO signal. NEED HELP!

post #1 of 11
Thread Starter 
So, yet another No screen signal problem.

When I turn on the PC, everything works, the fans spin and everything's dandy. It was working fine yesterday.

So far I have tried...


1. I've made sure the CPU and 24PIN Power are in.

2. The screen does work, and so does the cable (I've tried them both and they are fine)

3. I've tried both the inbuilt and the HD 4870. (And the GPU power was in too)

4. I've tried two different power supplies, and get the same problem with both.

5. I've taken out the CMOS battery for about a minutes to Clear CMOS. Still nothing.

6. I've taken the mobo out of the case and onto a Anti-Static bag to see if it's a short circuit.

7. I've tried some different RAM. Still getting the same error.

All I can think of is that the graphics card or Motherboard has fried. Please Help What do you guys think it is?
Defiance
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6600K Asus ROG Maximum VIII Ranger Powercolor R9 280x Turbo Duo Corsair Vengeance LPX 3200mhz 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 EVO 250GB Western Digital 3TB Black 1TB External HDD External Optical Drive 
CoolingOSKeyboardPower
Noctua NH-D15 Windows 10 Microsoft Sidewinder X4 Corsair HX750i 
CaseMouseMouse Pad
NZXT H440 Black/Red Deathadder Chrome Turtlebeach Drift  
  hide details  
Reply
Defiance
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6600K Asus ROG Maximum VIII Ranger Powercolor R9 280x Turbo Duo Corsair Vengeance LPX 3200mhz 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 EVO 250GB Western Digital 3TB Black 1TB External HDD External Optical Drive 
CoolingOSKeyboardPower
Noctua NH-D15 Windows 10 Microsoft Sidewinder X4 Corsair HX750i 
CaseMouseMouse Pad
NZXT H440 Black/Red Deathadder Chrome Turtlebeach Drift  
  hide details  
Reply
post #2 of 11
Thread Starter 
Ok, so it's not the Graphics card, cause it's working fine in my main rig. I'm going to test the Hard drives now and if it isn't them, it must be the motherboard, so I'll get a replacement.
Defiance
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6600K Asus ROG Maximum VIII Ranger Powercolor R9 280x Turbo Duo Corsair Vengeance LPX 3200mhz 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 EVO 250GB Western Digital 3TB Black 1TB External HDD External Optical Drive 
CoolingOSKeyboardPower
Noctua NH-D15 Windows 10 Microsoft Sidewinder X4 Corsair HX750i 
CaseMouseMouse Pad
NZXT H440 Black/Red Deathadder Chrome Turtlebeach Drift  
  hide details  
Reply
Defiance
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6600K Asus ROG Maximum VIII Ranger Powercolor R9 280x Turbo Duo Corsair Vengeance LPX 3200mhz 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 EVO 250GB Western Digital 3TB Black 1TB External HDD External Optical Drive 
CoolingOSKeyboardPower
Noctua NH-D15 Windows 10 Microsoft Sidewinder X4 Corsair HX750i 
CaseMouseMouse Pad
NZXT H440 Black/Red Deathadder Chrome Turtlebeach Drift  
  hide details  
Reply
post #3 of 11
Quote:
Originally Posted by snipekill2445 View Post

Ok, so it's not the Graphics card, cause it's working fine in my main rig. I'm going to test the Hard drives now and if it isn't them, it must be the motherboard, so I'll get a replacement.

I think the problem is the Rams,this happened to me before,after I cleaned my pc and turned it on the display had no signal so I removed 3 GB of rams and left 1 GB inside of it and the pc booted up.
I think you should get your rams out and put 1GB one by one till you get signal.,If not try to remove your mobo battery,let it out for 5 minutes or clear Cmos with a jumper.
Hope this helps.
Cheers!
Tk
(15 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.2 Ghz (1.5v) Washer Mod Gigabyte GA-P35-DS3 Evga GTX 480 6 GB DDR 2 Kingmax 800 Mhz (stock) 1000 Mhz (OC) 
Hard DriveOptical DriveCoolingOS
WD 1000 GB (Raid-0) & WD 200 GB & Hitachi 160 GB LG DVD-RW ThermalRight Extreme 120 Windows 10 Pro x64 
MonitorKeyboardPowerCase
AOC 24"' Full HD Serioux Corsair HX 520 W SAGITTA Raidmax 
MouseMouse PadAudio
bloody Gun3v3 Gaming X 7 Realtek HD 
  hide details  
Reply
Tk
(15 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.2 Ghz (1.5v) Washer Mod Gigabyte GA-P35-DS3 Evga GTX 480 6 GB DDR 2 Kingmax 800 Mhz (stock) 1000 Mhz (OC) 
Hard DriveOptical DriveCoolingOS
WD 1000 GB (Raid-0) & WD 200 GB & Hitachi 160 GB LG DVD-RW ThermalRight Extreme 120 Windows 10 Pro x64 
MonitorKeyboardPowerCase
AOC 24"' Full HD Serioux Corsair HX 520 W SAGITTA Raidmax 
MouseMouse PadAudio
bloody Gun3v3 Gaming X 7 Realtek HD 
  hide details  
Reply
post #4 of 11
have you check the 4 pin power cable for the cpu. ive seen where that sometimes comes loose and causes a no boot issue
Home
(17 items)
 
Server
(15 items)
 
 
CPUCPUMotherboardGraphics
intel Xeon 2670 intel xeon 2670 Intel S2600CP Evga 980ti 
RAMHard DriveHard DriveOptical Drive
64gb Ecc 24x 128gb ssds  Crucial Mx1000 Asus 
OSMonitorMonitorKeyboard
Windows 10 Pro Sony XBR43X830C 43" 4K Monoprice 28" 4k Max Keyboards NightHawk X8 Custom 
PowerCaseMouseMouse Pad
Evga Supernova 850w  Norco Rpc-4224 Logitech G900 Chaos Steelseries QCK 
Audio
FIIO E7/E9 combo 
CPUCPUMotherboardRAM
Intel L5640 Intel L5640  Supermicro - X8DT3 24Gb ECC 
Hard DriveHard DriveHard DriveOS
4x 128gb ssd's raid 0 - Cache Wd Red 3tb Seagate 8tb smr - parity Unriad 6.2 
PowerCaseOtherOther
ThermalTake 700 watt  Norco 4220 HP sas expander Lsi 9211-8i 
  hide details  
Reply
Home
(17 items)
 
Server
(15 items)
 
 
CPUCPUMotherboardGraphics
intel Xeon 2670 intel xeon 2670 Intel S2600CP Evga 980ti 
RAMHard DriveHard DriveOptical Drive
64gb Ecc 24x 128gb ssds  Crucial Mx1000 Asus 
OSMonitorMonitorKeyboard
Windows 10 Pro Sony XBR43X830C 43" 4K Monoprice 28" 4k Max Keyboards NightHawk X8 Custom 
PowerCaseMouseMouse Pad
Evga Supernova 850w  Norco Rpc-4224 Logitech G900 Chaos Steelseries QCK 
Audio
FIIO E7/E9 combo 
CPUCPUMotherboardRAM
Intel L5640 Intel L5640  Supermicro - X8DT3 24Gb ECC 
Hard DriveHard DriveHard DriveOS
4x 128gb ssd's raid 0 - Cache Wd Red 3tb Seagate 8tb smr - parity Unriad 6.2 
PowerCaseOtherOther
ThermalTake 700 watt  Norco 4220 HP sas expander Lsi 9211-8i 
  hide details  
Reply
post #5 of 11
Not directly related to your problem but it isn't a good idea to place a motherboard on those anti-static bags because they can conduct. Best is just place it on the cardboard box if you want to test it outside of your case.

Do you get a lank screen or does the screen say: No signal (or something along those lines)?
Have you tried the screen on an other rig?

How did it start? Did you change something to your computer lately?

My brother has an LG Flatron W2453TQ and he has been complaining about lost signal as well, long waits before the monitor started etc. as well. So, I'm not entirely convinced it's your motherboard or anything hardware-related.
Black Betty
(16 items)
 
  
Reply
Black Betty
(16 items)
 
  
Reply
post #6 of 11
Thread Starter 
It's not the Ram, I've tested it, And there is only one 4GB Module. It's not the screen cause it works fine on my main rig. It's not the Power cable cause it's definitely in (checked about 5 times now)

I'll try taking out the CMOS Battery again for about 10 minutes this time, and see what happens then.

Of coarse IF it is the motherboard, It's still under warranty, so that would be fine biggrin.gif
Defiance
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6600K Asus ROG Maximum VIII Ranger Powercolor R9 280x Turbo Duo Corsair Vengeance LPX 3200mhz 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 EVO 250GB Western Digital 3TB Black 1TB External HDD External Optical Drive 
CoolingOSKeyboardPower
Noctua NH-D15 Windows 10 Microsoft Sidewinder X4 Corsair HX750i 
CaseMouseMouse Pad
NZXT H440 Black/Red Deathadder Chrome Turtlebeach Drift  
  hide details  
Reply
Defiance
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6600K Asus ROG Maximum VIII Ranger Powercolor R9 280x Turbo Duo Corsair Vengeance LPX 3200mhz 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 EVO 250GB Western Digital 3TB Black 1TB External HDD External Optical Drive 
CoolingOSKeyboardPower
Noctua NH-D15 Windows 10 Microsoft Sidewinder X4 Corsair HX750i 
CaseMouseMouse Pad
NZXT H440 Black/Red Deathadder Chrome Turtlebeach Drift  
  hide details  
Reply
post #7 of 11
Just throwing a few idea's in here! Hope you find the problem, I know how frustration these things can be!
Have you tried another (different) screen and cable, I know you said screen is good but have you tried.
Have you checked the pins at the DVI connection.
When does the screen go blank, ei always, after post, welcome screen.
I have a Viewsonic that is very tempermental, on that note have you tried a different connection, ie HDMI, Display Port, DVI. This thing always works on VGA but will only work with certain gc.
Good luck!!!thumb.gif
Gunsrunner
(28 items)
 
Mobile Gaming
(10 items)
 
Serving It Up
(13 items)
 
CPUMotherboardGraphicsRAM
I7 3770K ASRock Z77 Extreme 4 Evga 680gtx FTW 4gb G.Skill Ripjaws X DDR3-2133 CL9 16G 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force 3 SSD 240G Corsair Force 3 SSD 120G WD Raptor 150G WD 500G 
Optical DriveOptical DriveCoolingCooling
LG Blueray Burner Asus DVD Burner EK Supremacy CSQ EK FC680 FTW CSQ 
CoolingCoolingCoolingCooling
EK RES X3 EK 360 XT EK 240 XT Swiftech MP655 
CoolingOSMonitorMonitor
Gentle Typhoon AP15 x 10 Windows 7 Home Premium 64bit Samsung S24A450BW 24" 1920x1200  Samsung S24A450BW 24" 1920x1200 
MonitorKeyboardPowerCase
Samsung S24A450BW 24" 1920x1200 Logitech G510 Corsair TX850w NZXT Switch 810 Matt Black 
MouseMouse PadAudioAudio
Logitech G700 Razer Mantis Logitech 5.1 Sennheiser  
CPUMotherboardGraphicsRAM
i7 3610 H77M Nvidia 670M 3gig 16gig DDR3 1600 
Hard DriveHard DriveOptical DriveCooling
256gig SSD 1Terra HDD 5400rpm Blueray Burner ASUS G Series 
OSMonitor
Windows 7 HP 1920x1080 17.3" 
CPUMotherboardGraphicsRAM
Intel I5 750 Asus P7P55D-R Pro XFX HD-6870 DD Corsair Vengeance DDR3-1600 CL9 8G 
Hard DriveOptical DriveOSMonitor
Samsung 4x2tb, WD 2x1tb, WD 1x500gb LG DVD Burner Windows Home Server 2012 Samsung Syncmaster 226BW 
KeyboardPowerCaseMouse
Logitech MX3000 CM 650w Fractual Design R3 Logitech 
Audio
Logitech R2.1 
  hide details  
Reply
Gunsrunner
(28 items)
 
Mobile Gaming
(10 items)
 
Serving It Up
(13 items)
 
CPUMotherboardGraphicsRAM
I7 3770K ASRock Z77 Extreme 4 Evga 680gtx FTW 4gb G.Skill Ripjaws X DDR3-2133 CL9 16G 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force 3 SSD 240G Corsair Force 3 SSD 120G WD Raptor 150G WD 500G 
Optical DriveOptical DriveCoolingCooling
LG Blueray Burner Asus DVD Burner EK Supremacy CSQ EK FC680 FTW CSQ 
CoolingCoolingCoolingCooling
EK RES X3 EK 360 XT EK 240 XT Swiftech MP655 
CoolingOSMonitorMonitor
Gentle Typhoon AP15 x 10 Windows 7 Home Premium 64bit Samsung S24A450BW 24" 1920x1200  Samsung S24A450BW 24" 1920x1200 
MonitorKeyboardPowerCase
Samsung S24A450BW 24" 1920x1200 Logitech G510 Corsair TX850w NZXT Switch 810 Matt Black 
MouseMouse PadAudioAudio
Logitech G700 Razer Mantis Logitech 5.1 Sennheiser  
CPUMotherboardGraphicsRAM
i7 3610 H77M Nvidia 670M 3gig 16gig DDR3 1600 
Hard DriveHard DriveOptical DriveCooling
256gig SSD 1Terra HDD 5400rpm Blueray Burner ASUS G Series 
OSMonitor
Windows 7 HP 1920x1080 17.3" 
CPUMotherboardGraphicsRAM
Intel I5 750 Asus P7P55D-R Pro XFX HD-6870 DD Corsair Vengeance DDR3-1600 CL9 8G 
Hard DriveOptical DriveOSMonitor
Samsung 4x2tb, WD 2x1tb, WD 1x500gb LG DVD Burner Windows Home Server 2012 Samsung Syncmaster 226BW 
KeyboardPowerCaseMouse
Logitech MX3000 CM 650w Fractual Design R3 Logitech 
Audio
Logitech R2.1 
  hide details  
Reply
post #8 of 11
Could it be the CPU cooler spilled some liquid on your MoBo?
I don't know what CPU cooler you have, but that's how I personally got my "no-display" error.
 
BloodFury Build
(30 items)
 
 
CPUMotherboardGraphicsGraphics
i7 3930K @ 4.7GHz ASUS Rampage IV Extreme ASUS Radeon HD7970 ASUS Radeon HD7970 
RAMHard DriveHard DriveHard Drive
Corsair 32GB 2133MHz DDR3 RAM WD Caviar Green 3TB x4 - 12TB WD My Book 3TB WD My Book 2TB x2 - 4TB 
Hard DriveOptical DriveCoolingCooling
Crucial M4 512GB External optical drive Swiftech MCR420-QP 480 Radiator Yate Loon D12SL-12 1350RPM x15 
CoolingCoolingCoolingCooling
Alphacool VPP655 -T12 x2 Alphacool Repack - Dual Laing D5 - Dual 5,25 Ba... DangerDen Delrin 90° G1/4 connector EK-FB KIT RE4 - Acetal+Nickel EN 
CoolingCoolingCoolingCooling
EK-FC Bridge DUAL Parallel EK-FC7970 - Nickel EN Acetal x2 EK-FC7970 Backplate - Black x2 EK-VGA I/O bracket HD7970 x2 
CoolingCoolingOSMonitor
Feser Tube UV - HighFlow - 3/8 ID - 1/2 OD - BLACK Lamptron FC9 Fan Controller 4-channel 50W FC-9-... Windows 7 Ultimate x64 Samsung Syncmaster S27A750D x2 
MonitorMonitorKeyboardPower
IIYAMA G2773HDS-GB1 LG 37LF2500 Razer Blackwidow Ultimate Corsair AX1200W 
CaseMouseMouse PadAudio
Mountain Mods Ascension Razer Mamba Razer Goliathus Extended Control Edition ASUS ROG Phoebus 9.1 Soundcard 
AudioAudioOther
CM Storm Sirus 5.1 Headset Teufel Concept E 400 Digital Media 5.1 Surround... Canon MG6250 MultiFunctional Printer 
CPUMotherboardGraphicsRAM
i7 3930K C2 @4.7GHz ASUS Rampage IV Extreme/BF3 ASUS Radeon HD 7970 12GB Corsair Dominator 1600MHz memory 
Hard DriveHard DriveHard DriveCooling
Crucial M4 128GB 7 TB External HDDs 2.2 TB HDDs in Raid0 Black Ice GT Stealth 360 
CoolingCoolingCoolingCooling
Swiftech Apogee HD 7x Yate Loon D12SL-12 XSPC X2O 750 Dual Bay Reservoir+Pump Phobya Nano-G 14 Silent Waterproof 140mm - 1000rpm 
CoolingCoolingOSMonitor
10MM (3/8) Compression Fitting Gripz Style - G1... PVC Tube 3/8 ID (10mm ID -13 mm OD ) - 2 meter ... Windows 7 Ultimate LG 37LF2500 
KeyboardPowerCaseMouse
Logitech G15 Corsair HW 750W Cooler Master Cosmos II Razer Naga 
Mouse PadAudioOtherOther
Steelseries SK Gaming Mouse Pad Creative HS 1200 NZXT 12x Red LED Sleeve - 1M NZXT 12x Red LED Sleeve - 1M 
OtherOtherOtherOther
BitFenix PCIe 6-Pin to 6-Pin Cable - 45 cm - Pr... BitFenix USB 2.0 internal extension - 30 cm - P... BitFenix PCIe 8-Pin to 8-Pin Cable - 45 cm - Pr... Sweex US011 4-poorts USB Hub 
OtherOther
3-Pin Splitter naar 4x 3-Pin Fan - Sleeved UVRe... BitFenix Molex to 3x Molex 55cm - Premium Sleev... 
  hide details  
Reply
 
BloodFury Build
(30 items)
 
 
CPUMotherboardGraphicsGraphics
i7 3930K @ 4.7GHz ASUS Rampage IV Extreme ASUS Radeon HD7970 ASUS Radeon HD7970 
RAMHard DriveHard DriveHard Drive
Corsair 32GB 2133MHz DDR3 RAM WD Caviar Green 3TB x4 - 12TB WD My Book 3TB WD My Book 2TB x2 - 4TB 
Hard DriveOptical DriveCoolingCooling
Crucial M4 512GB External optical drive Swiftech MCR420-QP 480 Radiator Yate Loon D12SL-12 1350RPM x15 
CoolingCoolingCoolingCooling
Alphacool VPP655 -T12 x2 Alphacool Repack - Dual Laing D5 - Dual 5,25 Ba... DangerDen Delrin 90° G1/4 connector EK-FB KIT RE4 - Acetal+Nickel EN 
CoolingCoolingCoolingCooling
EK-FC Bridge DUAL Parallel EK-FC7970 - Nickel EN Acetal x2 EK-FC7970 Backplate - Black x2 EK-VGA I/O bracket HD7970 x2 
CoolingCoolingOSMonitor
Feser Tube UV - HighFlow - 3/8 ID - 1/2 OD - BLACK Lamptron FC9 Fan Controller 4-channel 50W FC-9-... Windows 7 Ultimate x64 Samsung Syncmaster S27A750D x2 
MonitorMonitorKeyboardPower
IIYAMA G2773HDS-GB1 LG 37LF2500 Razer Blackwidow Ultimate Corsair AX1200W 
CaseMouseMouse PadAudio
Mountain Mods Ascension Razer Mamba Razer Goliathus Extended Control Edition ASUS ROG Phoebus 9.1 Soundcard 
AudioAudioOther
CM Storm Sirus 5.1 Headset Teufel Concept E 400 Digital Media 5.1 Surround... Canon MG6250 MultiFunctional Printer 
CPUMotherboardGraphicsRAM
i7 3930K C2 @4.7GHz ASUS Rampage IV Extreme/BF3 ASUS Radeon HD 7970 12GB Corsair Dominator 1600MHz memory 
Hard DriveHard DriveHard DriveCooling
Crucial M4 128GB 7 TB External HDDs 2.2 TB HDDs in Raid0 Black Ice GT Stealth 360 
CoolingCoolingCoolingCooling
Swiftech Apogee HD 7x Yate Loon D12SL-12 XSPC X2O 750 Dual Bay Reservoir+Pump Phobya Nano-G 14 Silent Waterproof 140mm - 1000rpm 
CoolingCoolingOSMonitor
10MM (3/8) Compression Fitting Gripz Style - G1... PVC Tube 3/8 ID (10mm ID -13 mm OD ) - 2 meter ... Windows 7 Ultimate LG 37LF2500 
KeyboardPowerCaseMouse
Logitech G15 Corsair HW 750W Cooler Master Cosmos II Razer Naga 
Mouse PadAudioOtherOther
Steelseries SK Gaming Mouse Pad Creative HS 1200 NZXT 12x Red LED Sleeve - 1M NZXT 12x Red LED Sleeve - 1M 
OtherOtherOtherOther
BitFenix PCIe 6-Pin to 6-Pin Cable - 45 cm - Pr... BitFenix USB 2.0 internal extension - 30 cm - P... BitFenix PCIe 8-Pin to 8-Pin Cable - 45 cm - Pr... Sweex US011 4-poorts USB Hub 
OtherOther
3-Pin Splitter naar 4x 3-Pin Fan - Sleeved UVRe... BitFenix Molex to 3x Molex 55cm - Premium Sleev... 
  hide details  
Reply
post #9 of 11
Thread Starter 
I'm not sure what you mean by "Spilled liquid on Mobo" But there is no thermal paste on the CPU or socket. The cooler is just a simple Zalman cooler, and it works fine.

I'll try another screen, and I'm gonna leave the CMOS Battery out for all of tonight. I'll also try Re-installing the OS, and if nothing works, I'll ring the shop and get a replacement smile.gif

Thanks for the help so far.
Defiance
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6600K Asus ROG Maximum VIII Ranger Powercolor R9 280x Turbo Duo Corsair Vengeance LPX 3200mhz 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 EVO 250GB Western Digital 3TB Black 1TB External HDD External Optical Drive 
CoolingOSKeyboardPower
Noctua NH-D15 Windows 10 Microsoft Sidewinder X4 Corsair HX750i 
CaseMouseMouse Pad
NZXT H440 Black/Red Deathadder Chrome Turtlebeach Drift  
  hide details  
Reply
Defiance
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6600K Asus ROG Maximum VIII Ranger Powercolor R9 280x Turbo Duo Corsair Vengeance LPX 3200mhz 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 EVO 250GB Western Digital 3TB Black 1TB External HDD External Optical Drive 
CoolingOSKeyboardPower
Noctua NH-D15 Windows 10 Microsoft Sidewinder X4 Corsair HX750i 
CaseMouseMouse Pad
NZXT H440 Black/Red Deathadder Chrome Turtlebeach Drift  
  hide details  
Reply
post #10 of 11
Thread Starter 
I FIXED IT!

I just left the CMOS Battery out over night, cleared the CMOS and now it works! I'm so happy biggrin.gifbiggrin.gifbiggrin.gif

Thanks for the help guys, REP for everyone biggrin.gif
Defiance
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6600K Asus ROG Maximum VIII Ranger Powercolor R9 280x Turbo Duo Corsair Vengeance LPX 3200mhz 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 EVO 250GB Western Digital 3TB Black 1TB External HDD External Optical Drive 
CoolingOSKeyboardPower
Noctua NH-D15 Windows 10 Microsoft Sidewinder X4 Corsair HX750i 
CaseMouseMouse Pad
NZXT H440 Black/Red Deathadder Chrome Turtlebeach Drift  
  hide details  
Reply
Defiance
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 6600K Asus ROG Maximum VIII Ranger Powercolor R9 280x Turbo Duo Corsair Vengeance LPX 3200mhz 16GB 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 840 EVO 250GB Western Digital 3TB Black 1TB External HDD External Optical Drive 
CoolingOSKeyboardPower
Noctua NH-D15 Windows 10 Microsoft Sidewinder X4 Corsair HX750i 
CaseMouseMouse Pad
NZXT H440 Black/Red Deathadder Chrome Turtlebeach Drift  
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › Screen is Getting NO signal. NEED HELP!